Remove a couple extra newlines in output formatting.
[pykickstart.git] / pykickstart.spec
blob66638d63c4ed84a575430d6becf9e07e6092a406
1 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Url: http://fedoraproject.org/wiki/pykickstart
6 Version: 1.49
7 Release: 1%{?dist}
8 # This is a Red Hat maintained package which is specific to
9 # our distribution. Thus the source is only available from
10 # within this srpm.
11 Source0: %{name}-%{version}.tar.gz
13 License: GPLv2
14 Group: System Environment/Libraries
15 BuildArch: noarch
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17 BuildRequires: python-devel, gettext, python-setuptools-devel
18 Requires: python, python-urlgrabber
20 %description
21 The pykickstart package is a python library for manipulating kickstart
22 files.
24 %prep
25 %setup -q
26 make
28 %build
30 %install
31 rm -rf %{buildroot}
32 make DESTDIR=%{buildroot} install
33 %find_lang %{name}
35 %clean
36 rm -rf %{buildroot}
38 %files -f %{name}.lang
39 %defattr(-,root,root,-)
40 %doc README ChangeLog COPYING docs/programmers-guide
41 %doc docs/kickstart-docs.txt
42 %{python_sitelib}/*
43 %{_bindir}/ksvalidator
44 %{_bindir}/ksflatten
46 %changelog
47 * Thu Jan 08 2009 Chris Lumens <clumens@redhat.com> - 1.49-1
48 - Add upgrade --root-device (atodorov, #471232).
49 - Use python's builtin set rather than the Sets module (#477836, dcantrell).
51 * Tue Dec 23 2008 Chris Lumens <clumens@redhat.com> - 1.48-1
52 - Allow ignoring group metadata from repos, using a '--ignoregroups'
53 boolean. (notting)
54 - Add initial support for F11.
55 - Specify the command versions in the handlers instead of making copies.
56 - Remove empty and pointless __init__ methods.
57 - Pass arguments to superclasses via *args and **kwargs, all the way up.
58 - Add removedKeywords and removedAttrs lists on Commands and Data.
59 - Fix version regexes to handle double digits and minor releases (jlaska).
61 * Thu Oct 30 2008 Chris Lumens <clumens@redhat.com> - 1.47-1
62 - Fix enabling services we specify by specific options.
64 * Mon Oct 27 2008 Chris Lumens <clumens@redhat.com> - 1.46-1
65 - Add support for firewall --service (#467005).
67 * Tue Oct 14 2008 Chris Lumens <clumens@redhat.com> - 1.45-1
68 - Lots of translation updates.
69 - Remove use of string.partition for python2.4 (atodorov).
71 * Mon Sep 22 2008 Chris Lumens <clumens@redhat.com> - 1.44-1
72 - Add support for reverse CHAP to the kickstart iscsi command (hans)
73 - Fix typo (katzj)
75 * Wed Sep 03 2008 Chris Lumens <clumens@redhat.com> - 1.43-1
76 - Revert "Do not include passphrases for encrypted block devices in
77 anaconda-ks.cfg." (dlehman)
78 - yum doesn't like when mirrorlist is "". (clumens)
80 * Mon Aug 11 2008 Chris Lumens <clumens@redhat.com> - 1.42-1
81 - Add rescue command to pykickstart (atodorov)
82 - Sort %packages output (katzj)
83 - Fix a typo (atodorov).
85 * Fri Aug 01 2008 Chris Lumens <clumens@redhat.com> - 1.41-1
86 - RHEL5 supports ignoredisk --only-use now too. (clumens)
87 - Do not include passphrases for encrypted block devices in
88 anaconda-ks.cfg. (dlehman)
89 - Fix F9,F10,RHEL5 "part" commands to use the same class as
90 "partition". (dlehman)
91 - Add an apply method() for commands and implement for lang (katzj)
93 * Tue Jul 15 2008 Chris Lumens <clumens@redhat.com> - 1.40-1
94 - RHEL5_LogVolData should inherit from FC4, not FC3.
95 Also fix FC9->F9 typo. (dlehman)
96 - Support creation of encrypted block devices in RHEL5. (#449830) (dlehman)
97 - Use the right LogVolData objects for RHEL3 and 4 (jlaska). (clumens)
98 - We no longer use rhpl for translations. (clumens)
99 - All the base classes should derive from object. (clumens)
101 * Fri Jun 13 2008 Chris Lumens <clumens@redhat.com> - 1.39-1
102 - It's helpful to return the parser object. (clumens)
104 * Tue Jun 10 2008 Chris Lumens <clumens@redhat.com> - 1.38-1
105 - Fix loading the Handler object by looking for a more specific
106 name (#450740). (clumens)
108 * Sun Jun 08 2008 Chris Lumens <clumens@redhat.com> - 1.37-1
109 - XConfig is still used by other projects, so just deprecate some
110 options. (clumens)
112 * Thu May 29 2008 Chris Lumens <clumens@redhat.com> - 1.36-1
113 - It should be repo --cost, not repo --priority. (clumens)
115 * Fri May 23 2008 Chris Lumens <clumens@redhat.com> - 1.35-1
116 - Bring driverdisk command in line with the docs. (clumens)
117 - Change RAID command print priorities (jlaska).
118 - According to docs, physvols are space delimited. (jlaska)
119 - Don't write the label out twice (jlaska).
120 - Deprecate monitor and xconfig commands. (clumens)
122 * Wed May 07 2008 Chris Lumens <clumens@redhat.com> - 1.34-1
123 - Load the handler module automatically. (clumens)
124 - Add support for F10. (clumens)
125 - Initialize cmd.handler earlier; fixes repo.methodToRepo() (markmc)
126 - Don't shadow builtin function names. (clumens)
127 - Running check is now required before pykickstart can be packaged. (clumens)
128 - Reorganize code a little bit to pass pychecker. (clumens)
130 * Tue Apr 08 2008 Chris Lumens <clumens@redhat.com> - 1.33-1
131 - Fix whitespace when printing out the bootloader command (pmeyers).
132 - Fix the type on bootloader --timeout processing. (clumens)
134 * Wed Apr 02 2008 Chris Lumens <clumens@redhat.com> - 1.32-1
135 - Make the string reader act like the file reader upon EOF. (clumens)
136 - Add syntax for encrypted logical volumes. (clumens)
138 * Tue Mar 25 2008 Chris Lumens <clumens@redhat.com> - 1.31-1
139 - Support end-of-line comments. (clumens)
140 - Lots of translation updates.
142 * Tue Feb 26 2008 Chris Lumens <clumens@redhat.com> - 1.30-1
143 - Reverse writePriorities of iscsi and iscsname (#434965, jlaska).
144 - Fix printing of iscsiname command (#434945, jlaska).
145 - Don't traceback on ENOENT. (pnasrat)
146 - Store the mouse name as a string, not a list. (clumens)
147 - Update translations.
149 * Wed Jan 30 2008 Chris Lumens <clumens@redhat.com> - 1.29-1
150 - Renamed bootproto=ask to bootproto=query, add to RHEL5 as well. (clumens)
152 * Wed Jan 23 2008 Chris Lumens <clumens@redhat.com> - 1.28-1
153 - Fix traceback on volgroup command. (clumens)
155 * Thu Jan 17 2008 Chris Lumens <clumens@redhat.com> - 1.27-1
156 - The bootprotoList needs to be defined before it's used. (clumens)
158 * Thu Jan 17 2008 Chris Lumens <clumens@redhat.com> - 1.26-1
159 - Add support for network --bootproto=ask. (clumens)
161 * Tue Jan 15 2008 Chris Lumens <clumens@redhat.com> - 1.25-1
162 - Add the version to the output ks file. (clumens)
163 - Add syntax for encrypted partitions and raid devices. (clumens)
165 * Thu Jan 10 2008 Chris Lumens <clumens@redhat.com> - 1.24-1
166 - Make inheritance and overriding of %packages work (#427768). (clumens)
167 - Add an option for which languages should be installed. (katzj)
168 - Use the right name for the iscsi --target variable (#418781). (clumens)
170 * Mon Dec 10 2007 Chris Lumens <clumens@redhat.com> - 1.23-1
171 - Take Makefile improvements from anaconda.
172 - Fix a traceback on F9 zerombr command (#395431).
173 - Update to handle new Python eggs packaging.
175 * Tue Nov 20 2007 Chris Lumens <clumens@redhat.com> 1.22-1
176 - Don't process or write out vnc --enabled (jlaska AT redhat DOT com).
177 - Fix a traceback in the clearpart command.
179 * Tue Nov 06 2007 Chris Lumens <clumens@redhat.com> 1.21-1
180 - Save script line numbers for debugging.
181 - More internal cleanups.
183 * Wed Oct 31 2007 Chris Lumens <clumens@redhat.com> 1.20-1
184 - Pull wiki docs from the new location.
185 - Fix error messages for options that have been removed after having been
186 previously deprecated.
187 - zerombr no longer takes any arguments.
188 - %packages --ignoredeps --resolvedeps have been removed.
189 - firewall --high --medium have been removed.
190 - vnc --connect has been removed.
191 - xconfig options from monitor have now been removed.
192 - --bytes-per-inode has been marked as deprecated.
193 - Fix typos.
194 - Add --fsprofile option to disk commands (pjones).
195 - Add F9 support (pjones).
196 - Lots of internal fixes (clumens, pjones).
198 * Tue Oct 23 2007 Chris Lumens <clumens@redhat.com> 1.19-1
199 - Fix a traceback on the cdrom method.
201 * Thu Oct 18 2007 Chris Lumens <clumens@redhat.com> 1.18-1
202 - Don't write out %end to packages and scripts if the syntax version doesn't
203 support it.
204 - Remove obsolete translation (#332221).
206 * Thu Oct 04 2007 Chris Lumens <clumens@redhat.com> 1.17-1
207 - Simplify argument processing and printing.
209 * Wed Oct 03 2007 Chris Lumens <clumens@redhat.com> 1.16-1
210 - Undeprecate %packages --excludedocs.
211 - Fix a traceback in the device command handling.
212 - Add bootloader --timeout (katzj).
214 * Tue Oct 02 2007 Chris Lumens <clumens@redhat.com> 1.15-1
215 - Update translations (#259121).
216 - The device command no longer takes a type argument.
218 * Fri Sep 28 2007 Chris Lumens <clumens@redhat.com> 1.14-1
219 - Fix output formatting for packages section header (#310211).
220 - Add a script to flatten kickstart files containing includes (katzj).
222 * Wed Sep 12 2007 Chris Lumens <clumens@redhat.com> 1.13-1
223 - Add a function to convert URL method strings into repo objects
224 (jkeating).
225 - Writer formatting fixes.
226 - Add kickstart documentation from the Fedora Wiki.
228 * Tue Sep 04 2007 Chris Lumens <clumens@redhat.com> 1.12-1
229 - Fix lots of problems in processing the bootloader, device, network, and
230 raid commands.
231 - Add %end when writing out scripts and packages.
232 - Add a makefile target to run pychecker to cut down on errors in
233 releases.
235 * Mon Sep 3 2007 Jeremy Katz <katzj@redhat.com> - 1.11-1
236 - fix a few tracebacks
238 * Fri Aug 31 2007 Chris Lumens <clumens@redhat.com> 1.10-1
239 - Add network --ipv6=.
241 * Fri Aug 24 2007 Chris Lumens <clumens@redhat.com> 1.9-1
242 - Add support for the %end directive to be placed at the end of scripts
243 and packages sections. Deprecate old syntax.
244 - Clean up after ksvalidator if pykickstart issues a traceback.
245 - Add support for repo --priority --includepkgs --excludepkgs.
246 - Fix newline at end of reboot --eject output (#253562).
248 * Mon Aug 13 2007 Chris Lumens <clumens@redhat.com> 1.8-1
249 - Fix type checking of string values.
251 * Thu Aug 09 2007 Chris Lumens <clumens@redhat.com> 1.7-1
252 - Clarify license in spec file and all source files.
253 - Check string values to options to make sure they're not other options
254 (#251318).
256 * Thu Aug 02 2007 Chris Lumens <clumens@redhat.com> 1.6-1
257 - Fix a couple tracebacks in ksvalidator.
258 - Change --class to --dhcpclass (#248912).
260 * Thu Jul 19 2007 Chris Lumens <clumens@redhat.com> 1.5-2
261 - Require rhpl (#248953).
263 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.5-1
264 - Fix traceback when calling preprocessKickstart.
266 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.4-1
267 - Add methods to handle the %ksappend directive.
268 - Fix ignoredisk --disks.
270 * Wed Jul 11 2007 Chris Lumens <clumens@redhat.com> - 1.3-1
271 - Add support for ignoredisk --only-use.
272 - Fix traceback in raid command printing method (#246709).
274 * Fri Jun 08 2007 Chris Lumens <clumens@redhat.com> - 1.2-2
275 - Fix package review problems (#226334).
277 * Mon Jun 04 2007 Chris Lumens <clumens@redhat.com> - 1.2-1
278 - Fix harddrive install method error checking (#232492).
279 - Set authentication information from the input line to preserve quoting
280 (#241657).
281 - Allow included files to be given by URL.
282 - Fix typo in user --iscrypted option.
284 * Mon May 14 2007 Chris Lumens <clumens@redhat.com> - 1.1-1
285 - Better regexes for splitting version strings into family and version.
286 - Add basic support for RHEL3.
287 - Update translations.
289 * Fri Apr 13 2007 Chris Lumens <clumens@redhat.com> - 1.0-1
290 - Update documentation.
291 - Update translations.
293 * Mon Mar 19 2007 Chris Lumens <clumens@redhat.com> - 0.100-1
294 - bootloader should be written out after upgrade/install.
295 - Treat class names as unicode strings (#231053).
297 * Wed Mar 07 2007 Chris Lumens <clumens@redhat.com> - 0.99-1
298 - The timezone command didn't recognize --isUtc before FC6 (#231189).
299 - Recognize %ksappend lines in ksvalidator.
300 - Don't set default values in some command __init__ methods.
301 - Added an updates command.
302 - Add support for RAID10.
304 * Mon Feb 26 2007 Chris Lumens <clumens@redhat.com> - 0.98-1
305 - Fix device command syntax to match anaconda.
306 - Fix __call__ on method command.
308 * Wed Feb 21 2007 Chris Lumens <clumens@redhat.com> - 0.97-1
309 - Fix traceback when not overriding default mappings (#229505).
311 * Tue Feb 20 2007 Chris Lumens <clumens@redhat.com> - 0.96-1
312 - Fix __str__ methods for langsupport and reboot commands.
313 - Renamed BaseHandler.empty to BaseHandler.maskAllExcept.
314 - Split command objects out into their own files in commands/.
315 - Rename command objects to start with Version_.
316 - Support extended group selection syntax.
318 * Wed Feb 14 2007 Chris Lumens <clumens@redhat.com> - 0.95-1
319 - KickstartParser no longer takes a version argument.
320 - Be more lenient in what strings stringToVersion accepts.
321 - Allow setting state on one data object from multiple files.
323 * Wed Feb 07 2007 Chris Lumens <clumens@redhat.com> - 0.94-1
324 - Add a newline to the end of the key command output.
325 - Use network bootproto constants (#197694).
326 - Fix tracebacks in subclass __str__ methods (#226734).
328 * Wed Jan 31 2007 Chris Lumens <clumens@redhat.com> - 0.93-2
329 - Make some minor spec file changes to get closer to the extras guidelines.
331 * Thu Jan 25 2007 Chris Lumens <clumens@redhat.com> - 0.93-1
332 - Add support for FC3, RHEL4, and RHEL5.
333 - The key command was not supported until after FC6.
334 - Accept more strings in stringToVersion.
336 * Fri Jan 19 2007 Chris Lumens <clumens@redhat.com> - 0.92-1
337 - Fix KickstartVersionError reporting.
338 - Add a version attribute to handler objects.
339 - Fix line number reporting on lots of commands.
340 - Add initial support for Fedora 7 and remove deprecated commands.
341 - Accept a --default argument to the %%packages header (#221305).
343 * Wed Jan 17 2007 Chris Lumens <clumens@redhat.com> - 0.91-1
344 - Add a method to read kickstart files from strings.
346 * Tue Jan 16 2007 Chris Lumens <clumens@redhat.com> - 0.90-1
347 - Support multiple versions of kickstart syntax from one code base
348 (#189348).
349 - Fix inconsistency between Script parser and writer (#222877).
351 * Fri Dec 15 2006 Chris Lumens <clumens@redhat.com> - 0.43-1
352 - Pull in new translations (#216620).
354 * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.42-2
355 - rebuild against python 2.5
357 * Tue Dec 05 2006 Chris Lumens <clumens@redhat.com> - 0.42-1
358 - Fix traceback when writing out repo command (#218274).
360 * Fri Dec 01 2006 Chris Lumens <clumens@redhat.com> - 0.41-1
361 - Fix traceback when using deprecated commands (#218047, #218059).
363 * Thu Nov 30 2006 Chris Lumens <clumens@redhat.com> - 0.40-1
364 - Pull in new translations (#216620).
365 - Add --level argument to logging command writer.
367 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-2
368 - Fix release number.
370 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-1
371 - Add writer for --key (#211997).
373 * Tue Oct 17 2006 Jeremy Katz <katzj@redhat.com> - 0.38-1
374 - allow --skip for installation number as well (#207029)
376 * Mon Oct 16 2006 Jeremy Katz <katzj@redhat.com> - 0.37-1
377 - support for installation numbers (#207029)
379 * Fri Oct 13 2006 Bill Nottingham <notting@redhat.com> - 0.36-1
380 - use valid charsets in translations (#210720)
382 * Fri Sep 29 2006 Chris Lumens <clumens@redhat.com> - 0.35-1
383 - Fix traceback in harddrive command (#208557).
385 * Mon Sep 25 2006 Chris Lumens <clumens@redhat.com> - 0.34-1
386 - Add support for --biospart option to harddrive (#207585).
387 - Update writer for syntax changes.
389 * Wed Sep 20 2006 Jeremy Katz <katzj@redhat.com> - 0.33-1
390 - improved iscsi syntax
391 - allow multiple zfcp devs
393 * Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 0.32-1
394 - Limit --bootproto to what anaconda supports.
395 - Add --noipv4 and --noipv6 network options.
397 * Tue Jun 20 2006 Chris Lumens <clumens@redhat.com> 0.31-1
398 - Handle nfs --opts (katzj).
399 - RAID devices should be integers instead of strings (#176537).
400 - Add initial support for iscsi (katzj).
402 * Tue Jun 06 2006 Chris Lumens <clumens@redhat.com> 0.30-2
403 - Add BuildRequires to fix building under mock (#194156, Joost Soeterbroek
404 <fedora AT soeterbroek.com>).
406 * Thu May 25 2006 Chris Lumens <clumens@redhat.com> 0.30-1
407 - Change order of LVM-related writing functions (#193073).
408 - Require urlgrabber.
409 - Return a more useful error message on unknown commands.
410 - Fix logvol writing typo.
411 - Make ksvalidator validate from a URL in addition to a file.
412 - Don't write out an empty packages section (#192851).
414 * Tue May 23 2006 Chris Lumens <clumens@redhat.com> 0.29-1
415 - Add multipath command, handlers, and data objects (pjones).
416 - Rename --ports to --port in writer.
418 * Mon May 15 2006 Chris Lumens <clumens@redhat.com> 0.28-1
419 - Support --mtu for the network command (#191328).
420 - Accept --isUtc for backwards compatibility.
422 * Wed May 04 2006 Chris Lumens <clumens@redhat.com> 0.27-1
423 - Output formatting fixes.
424 - Added commands for managing users and services.
426 * Mon Apr 17 2006 Chris Lumens <clumens@redhat.com> 0.26-1
427 - Ignore spaces before group names (#188095).
428 - Added some translations.
429 - Add options for repo command.
430 - Reorder %%packages section output.
431 - Output %%packages header options.
432 - Initialize RAID and volume group members to empty lists.
434 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.25-1
435 - Add support for the logging command.
437 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.24-1
438 - Don't write out a blank xconfig line.
439 - Reorder output handlers to group like commands together.
440 - Mark strings for translation.
442 * Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 0.23-1
443 - Backwards compatibility support for options to zerombr.
445 * Fri Feb 24 2006 Chris Lumens <clumens@redhat.com> 0.22-1
446 - Get ignoredisk working again (#182934).
448 * Fri Feb 17 2006 Chris Lumens <clumens@redhat.com> 0.21-1
449 - Provide an option to not traceback on missing include files (#181760).
450 - Update programming documentation.
452 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.20-1
453 - Correctly set --noformat and --useexisting on lvm and raid.
455 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.19-1
456 - --onboot requires a value (#180987).
457 - Be more strict about commands that don't take arguments.
459 * Thu Feb 09 2006 Chris Lumens <clumens@redhat.com> 0.18-1
460 - Fix some errors pychecker caught.
461 - Allow exceptions to not be fatal so ksvalidator can spot more errors in
462 a single pass (#179894).
464 * Wed Feb 01 2006 Chris Lumens <clumens@redhat.com> 0.17-1
465 - Don't set a default port for vnc.
467 * Tue Jan 31 2006 Chris Lumens <clumens@redhat.com> 0.16-1
468 - Give dmraid string an initial value.
469 - Handle None on partition size.
471 * Tue Jan 31 2006 Peter Jones <pjones@redhat.com> 0.15-1
472 - Add dmraid support
474 * Mon Jan 30 2006 Chris Lumens <clumens@redhat.com> 0.14-1
475 - Fix VNC parameter parsing (#179209).
476 - Deprecate --connect. Add --host and --port instead.
478 * Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 0.13-1
479 - Recognize the --eject parameter to shutdown/halt.
480 - Store the exact post-installation action in ksdata.
482 * Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 0.12-1
483 - Clean up output quoting.
484 - Finish removing monitor-related stuff from xconfig.
486 * Mon Dec 12 2005 Chris Lumens <clumens@redhat.com> 0.11-1
487 - Deprecate monitor-related options to xconfig.
489 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
490 - Support --bytes-per-inode on raid
491 (Curtis Doty <Curtis at GreenKey.net> #175288).
493 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
494 - fixup network --onboot
496 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
497 - Default to SELINUX_ENFORCING.
498 - Default partition sizes to None for anaconda (#172378).
499 - Don't call shlex.split on anything inside a script (#172313).
501 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
502 - Fix clearpart --all.
503 - vnc command does not require --connect option (#172192).
504 - network --onboot does not take any option.
505 - Remove extra spaces from firewall --ports and --trust.
506 - Write out network --<service> options.
508 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
509 - Add --resolvedeps and --ignoredeps as deprecated options.
510 - Pass line number to header functions.
512 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
513 - Add line numbers to exception reporting.
514 - Added ksvalidator.
516 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
517 - Correct deprecated attribute on options.
518 - Added programming documentation.
520 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
521 - Correct python lib directory on 64-bit archs (#170621).
523 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
524 - Add a deprecated attribute to options.
525 - Add --card option back to xconfig and mark as deprecated.
526 - Throw a deprecation warning on mouse and langsupport commands.
527 - Rename Writer to KickstartWriter for consistency.
528 - Collapse scripts into a single list and add an attribute on Script to
529 differentiate.
531 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
532 - Rename module to pykickstart to avoid conflicts in anaconda.
533 - Rename data classes for consistency.
534 - Add default bytesPerInode settings.
536 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
537 - Created package from anaconda.