Yet more output fixes.
[pykickstart.git] / pykickstart.spec
blob0859cfed737ef728c3c9992b139aea7e15940ed8
1 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Version: 0.26
6 Release: 1
7 Source0: %{name}-%{version}.tar.gz
8 License: GPL
9 Group: System Environment/Libraries
10 BuildArch: noarch
11 BuildRoot: %{_tmppath}/%{name}-root
12 BuildRequires: python-devel
13 Requires: python >= %(%{__python} -c "import sys; print sys.version[:3]")
15 %description
16 The pykickstart package is a python library for manipulating kickstart
17 files.
19 %prep
20 %setup -q
21 make
23 %build
25 %install
26 rm -rf $RPM_BUILD_ROOT
27 make DESTDIR=${RPM_BUILD_ROOT} install
29 %clean
30 rm -rf $RPM_BUILD_ROOT
32 %files
33 %defattr(-,root,root)
34 %doc README ChangeLog COPYING docs/programmers-guide
35 %{python_sitelib}/pykickstart
36 /usr/bin/ksvalidator
37 /usr/share/locale/*/*/*
39 %changelog
40 * Mon Apr 17 2006 Chris Lumens <clumens@redhat.com> 0.26-1
41 - Ignore spaces before group names (#188095).
42 - Added some translations.
43 - Add options for repo command.
44 - Reorder %packages section output.
45 - Output %packages header options.
46 - Initialize RAID and volume group members to empty lists.
48 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.25-1
49 - Add support for the logging command.
51 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.24-1
52 - Don't write out a blank xconfig line.
53 - Reorder output handlers to group like commands together.
54 - Mark strings for translation.
56 * Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 0.23-1
57 - Backwards compatibility support for options to zerombr.
59 * Fri Feb 24 2006 Chris Lumens <clumens@redhat.com> 0.22-1
60 - Get ignoredisk working again (#182934).
62 * Fri Feb 17 2006 Chris Lumens <clumens@redhat.com> 0.21-1
63 - Provide an option to not traceback on missing include files (#181760).
64 - Update programming documentation.
66 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.20-1
67 - Correctly set --noformat and --useexisting on lvm and raid.
69 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.19-1
70 - --onboot requires a value (#180987).
71 - Be more strict about commands that don't take arguments.
73 * Thu Feb 09 2006 Chris Lumens <clumens@redhat.com> 0.18-1
74 - Fix some errors pychecker caught.
75 - Allow exceptions to not be fatal so ksvalidator can spot more errors in
76 a single pass (#179894).
78 * Wed Feb 01 2006 Chris Lumens <clumens@redhat.com> 0.17-1
79 - Don't set a default port for vnc.
81 * Tue Jan 31 2006 Chris Lumens <clumens@redhat.com> 0.16-1
82 - Give dmraid string an initial value.
83 - Handle None on partition size.
85 * Tue Jan 31 2006 Peter Jones <pjones@redhat.com> 0.15-1
86 - Add dmraid support
88 * Mon Jan 30 2006 Chris Lumens <clumens@redhat.com> 0.14-1
89 - Fix VNC parameter parsing (#179209).
90 - Deprecate --connect. Add --host and --port instead.
92 * Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 0.13-1
93 - Recognize the --eject parameter to shutdown/halt.
94 - Store the exact post-installation action in ksdata.
96 * Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 0.12-1
97 - Clean up output quoting.
98 - Finish removing monitor-related stuff from xconfig.
100 * Mon Dec 12 2005 Chris Lumens <clumens@redhat.com> 0.11-1
101 - Deprecate monitor-related options to xconfig.
103 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
104 - Support --bytes-per-inode on raid
105 (Curtis Doty <Curtis at GreenKey.net> #175288).
107 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
108 - fixup network --onboot
110 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
111 - Default to SELINUX_ENFORCING.
112 - Default partition sizes to None for anaconda (#172378).
113 - Don't call shlex.split on anything inside a script (#172313).
115 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
116 - Fix clearpart --all.
117 - vnc command does not require --connect option (#172192).
118 - network --onboot does not take any option.
119 - Remove extra spaces from firewall --ports and --trust.
120 - Write out network --<service> options.
122 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
123 - Add --resolvedeps and --ignoredeps as deprecated options.
124 - Pass line number to header functions.
126 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
127 - Add line numbers to exception reporting.
128 - Added ksvalidator.
130 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
131 - Correct deprecated attribute on options.
132 - Added programming documentation.
134 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
135 - Correct python lib directory on 64-bit archs (#170621).
137 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
138 - Add a deprecated attribute to options.
139 - Add --card option back to xconfig and mark as deprecated.
140 - Throw a deprecation warning on mouse and langsupport commands.
141 - Rename Writer to KickstartWriter for consistency.
142 - Collapse scripts into a single list and add an attribute on Script to
143 differentiate.
145 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
146 - Rename module to pykickstart to avoid conflicts in anaconda.
147 - Rename data classes for consistency.
148 - Add default bytesPerInode settings.
150 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
151 - Created package from anaconda.