Add a device unit test
[pykickstart.git] / pykickstart.spec
blobc19415495d38a33c5577915ef70235a1c1291bc5
1 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Url: http://fedoraproject.org/wiki/pykickstart
6 Version: 1.50
7 Release: 1%{?dist}
8 # This is a Red Hat maintained package which is specific to
9 # our distribution. Thus the source is only available from
10 # within this srpm.
11 Source0: %{name}-%{version}.tar.gz
13 License: GPLv2
14 Group: System Environment/Libraries
15 BuildArch: noarch
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17 BuildRequires: python-devel, gettext, python-setuptools-devel
18 Requires: python, python-urlgrabber
20 %description
21 The pykickstart package is a python library for manipulating kickstart
22 files.
24 %prep
25 %setup -q
26 make
28 %build
30 %install
31 rm -rf %{buildroot}
32 make DESTDIR=%{buildroot} install
33 %find_lang %{name}
35 %clean
36 rm -rf %{buildroot}
38 %files -f %{name}.lang
39 %defattr(-,root,root,-)
40 %doc README ChangeLog COPYING docs/programmers-guide
41 %doc docs/kickstart-docs.txt
42 %{python_sitelib}/*
43 %{_bindir}/ksvalidator
44 %{_bindir}/ksflatten
45 %{_bindir}/ksverdiff
47 %changelog
48 * Sat Jan 10 2009 Chris Lumens <clumens@redhat.com> - 1.50-1
49 - Add a script to diff two versions of kickstart syntax.
50 - Add an option to ksvalidator to list all available syntax versions.
51 - Remove a couple extra newlines in output formatting.
52 - Add documentation for the new %include representation.
53 - Add support %include to the pykickstart data objects.
55 * Thu Jan 08 2009 Chris Lumens <clumens@redhat.com> - 1.49-1
56 - Add upgrade --root-device (atodorov, #471232).
57 - Use python's builtin set rather than the Sets module (#477836, dcantrell).
59 * Tue Dec 23 2008 Chris Lumens <clumens@redhat.com> - 1.48-1
60 - Allow ignoring group metadata from repos, using a '--ignoregroups'
61 boolean. (notting)
62 - Add initial support for F11.
63 - Specify the command versions in the handlers instead of making copies.
64 - Remove empty and pointless __init__ methods.
65 - Pass arguments to superclasses via *args and **kwargs, all the way up.
66 - Add removedKeywords and removedAttrs lists on Commands and Data.
67 - Fix version regexes to handle double digits and minor releases (jlaska).
69 * Thu Oct 30 2008 Chris Lumens <clumens@redhat.com> - 1.47-1
70 - Fix enabling services we specify by specific options.
72 * Mon Oct 27 2008 Chris Lumens <clumens@redhat.com> - 1.46-1
73 - Add support for firewall --service (#467005).
75 * Tue Oct 14 2008 Chris Lumens <clumens@redhat.com> - 1.45-1
76 - Lots of translation updates.
77 - Remove use of string.partition for python2.4 (atodorov).
79 * Mon Sep 22 2008 Chris Lumens <clumens@redhat.com> - 1.44-1
80 - Add support for reverse CHAP to the kickstart iscsi command (hans)
81 - Fix typo (katzj)
83 * Wed Sep 03 2008 Chris Lumens <clumens@redhat.com> - 1.43-1
84 - Revert "Do not include passphrases for encrypted block devices in
85 anaconda-ks.cfg." (dlehman)
86 - yum doesn't like when mirrorlist is "". (clumens)
88 * Mon Aug 11 2008 Chris Lumens <clumens@redhat.com> - 1.42-1
89 - Add rescue command to pykickstart (atodorov)
90 - Sort %packages output (katzj)
91 - Fix a typo (atodorov).
93 * Fri Aug 01 2008 Chris Lumens <clumens@redhat.com> - 1.41-1
94 - RHEL5 supports ignoredisk --only-use now too. (clumens)
95 - Do not include passphrases for encrypted block devices in
96 anaconda-ks.cfg. (dlehman)
97 - Fix F9,F10,RHEL5 "part" commands to use the same class as
98 "partition". (dlehman)
99 - Add an apply method() for commands and implement for lang (katzj)
101 * Tue Jul 15 2008 Chris Lumens <clumens@redhat.com> - 1.40-1
102 - RHEL5_LogVolData should inherit from FC4, not FC3.
103 Also fix FC9->F9 typo. (dlehman)
104 - Support creation of encrypted block devices in RHEL5. (#449830) (dlehman)
105 - Use the right LogVolData objects for RHEL3 and 4 (jlaska). (clumens)
106 - We no longer use rhpl for translations. (clumens)
107 - All the base classes should derive from object. (clumens)
109 * Fri Jun 13 2008 Chris Lumens <clumens@redhat.com> - 1.39-1
110 - It's helpful to return the parser object. (clumens)
112 * Tue Jun 10 2008 Chris Lumens <clumens@redhat.com> - 1.38-1
113 - Fix loading the Handler object by looking for a more specific
114 name (#450740). (clumens)
116 * Sun Jun 08 2008 Chris Lumens <clumens@redhat.com> - 1.37-1
117 - XConfig is still used by other projects, so just deprecate some
118 options. (clumens)
120 * Thu May 29 2008 Chris Lumens <clumens@redhat.com> - 1.36-1
121 - It should be repo --cost, not repo --priority. (clumens)
123 * Fri May 23 2008 Chris Lumens <clumens@redhat.com> - 1.35-1
124 - Bring driverdisk command in line with the docs. (clumens)
125 - Change RAID command print priorities (jlaska).
126 - According to docs, physvols are space delimited. (jlaska)
127 - Don't write the label out twice (jlaska).
128 - Deprecate monitor and xconfig commands. (clumens)
130 * Wed May 07 2008 Chris Lumens <clumens@redhat.com> - 1.34-1
131 - Load the handler module automatically. (clumens)
132 - Add support for F10. (clumens)
133 - Initialize cmd.handler earlier; fixes repo.methodToRepo() (markmc)
134 - Don't shadow builtin function names. (clumens)
135 - Running check is now required before pykickstart can be packaged. (clumens)
136 - Reorganize code a little bit to pass pychecker. (clumens)
138 * Tue Apr 08 2008 Chris Lumens <clumens@redhat.com> - 1.33-1
139 - Fix whitespace when printing out the bootloader command (pmeyers).
140 - Fix the type on bootloader --timeout processing. (clumens)
142 * Wed Apr 02 2008 Chris Lumens <clumens@redhat.com> - 1.32-1
143 - Make the string reader act like the file reader upon EOF. (clumens)
144 - Add syntax for encrypted logical volumes. (clumens)
146 * Tue Mar 25 2008 Chris Lumens <clumens@redhat.com> - 1.31-1
147 - Support end-of-line comments. (clumens)
148 - Lots of translation updates.
150 * Tue Feb 26 2008 Chris Lumens <clumens@redhat.com> - 1.30-1
151 - Reverse writePriorities of iscsi and iscsname (#434965, jlaska).
152 - Fix printing of iscsiname command (#434945, jlaska).
153 - Don't traceback on ENOENT. (pnasrat)
154 - Store the mouse name as a string, not a list. (clumens)
155 - Update translations.
157 * Wed Jan 30 2008 Chris Lumens <clumens@redhat.com> - 1.29-1
158 - Renamed bootproto=ask to bootproto=query, add to RHEL5 as well. (clumens)
160 * Wed Jan 23 2008 Chris Lumens <clumens@redhat.com> - 1.28-1
161 - Fix traceback on volgroup command. (clumens)
163 * Thu Jan 17 2008 Chris Lumens <clumens@redhat.com> - 1.27-1
164 - The bootprotoList needs to be defined before it's used. (clumens)
166 * Thu Jan 17 2008 Chris Lumens <clumens@redhat.com> - 1.26-1
167 - Add support for network --bootproto=ask. (clumens)
169 * Tue Jan 15 2008 Chris Lumens <clumens@redhat.com> - 1.25-1
170 - Add the version to the output ks file. (clumens)
171 - Add syntax for encrypted partitions and raid devices. (clumens)
173 * Thu Jan 10 2008 Chris Lumens <clumens@redhat.com> - 1.24-1
174 - Make inheritance and overriding of %packages work (#427768). (clumens)
175 - Add an option for which languages should be installed. (katzj)
176 - Use the right name for the iscsi --target variable (#418781). (clumens)
178 * Mon Dec 10 2007 Chris Lumens <clumens@redhat.com> - 1.23-1
179 - Take Makefile improvements from anaconda.
180 - Fix a traceback on F9 zerombr command (#395431).
181 - Update to handle new Python eggs packaging.
183 * Tue Nov 20 2007 Chris Lumens <clumens@redhat.com> 1.22-1
184 - Don't process or write out vnc --enabled (jlaska AT redhat DOT com).
185 - Fix a traceback in the clearpart command.
187 * Tue Nov 06 2007 Chris Lumens <clumens@redhat.com> 1.21-1
188 - Save script line numbers for debugging.
189 - More internal cleanups.
191 * Wed Oct 31 2007 Chris Lumens <clumens@redhat.com> 1.20-1
192 - Pull wiki docs from the new location.
193 - Fix error messages for options that have been removed after having been
194 previously deprecated.
195 - zerombr no longer takes any arguments.
196 - %packages --ignoredeps --resolvedeps have been removed.
197 - firewall --high --medium have been removed.
198 - vnc --connect has been removed.
199 - xconfig options from monitor have now been removed.
200 - --bytes-per-inode has been marked as deprecated.
201 - Fix typos.
202 - Add --fsprofile option to disk commands (pjones).
203 - Add F9 support (pjones).
204 - Lots of internal fixes (clumens, pjones).
206 * Tue Oct 23 2007 Chris Lumens <clumens@redhat.com> 1.19-1
207 - Fix a traceback on the cdrom method.
209 * Thu Oct 18 2007 Chris Lumens <clumens@redhat.com> 1.18-1
210 - Don't write out %end to packages and scripts if the syntax version doesn't
211 support it.
212 - Remove obsolete translation (#332221).
214 * Thu Oct 04 2007 Chris Lumens <clumens@redhat.com> 1.17-1
215 - Simplify argument processing and printing.
217 * Wed Oct 03 2007 Chris Lumens <clumens@redhat.com> 1.16-1
218 - Undeprecate %packages --excludedocs.
219 - Fix a traceback in the device command handling.
220 - Add bootloader --timeout (katzj).
222 * Tue Oct 02 2007 Chris Lumens <clumens@redhat.com> 1.15-1
223 - Update translations (#259121).
224 - The device command no longer takes a type argument.
226 * Fri Sep 28 2007 Chris Lumens <clumens@redhat.com> 1.14-1
227 - Fix output formatting for packages section header (#310211).
228 - Add a script to flatten kickstart files containing includes (katzj).
230 * Wed Sep 12 2007 Chris Lumens <clumens@redhat.com> 1.13-1
231 - Add a function to convert URL method strings into repo objects
232 (jkeating).
233 - Writer formatting fixes.
234 - Add kickstart documentation from the Fedora Wiki.
236 * Tue Sep 04 2007 Chris Lumens <clumens@redhat.com> 1.12-1
237 - Fix lots of problems in processing the bootloader, device, network, and
238 raid commands.
239 - Add %end when writing out scripts and packages.
240 - Add a makefile target to run pychecker to cut down on errors in
241 releases.
243 * Mon Sep 3 2007 Jeremy Katz <katzj@redhat.com> - 1.11-1
244 - fix a few tracebacks
246 * Fri Aug 31 2007 Chris Lumens <clumens@redhat.com> 1.10-1
247 - Add network --ipv6=.
249 * Fri Aug 24 2007 Chris Lumens <clumens@redhat.com> 1.9-1
250 - Add support for the %end directive to be placed at the end of scripts
251 and packages sections. Deprecate old syntax.
252 - Clean up after ksvalidator if pykickstart issues a traceback.
253 - Add support for repo --priority --includepkgs --excludepkgs.
254 - Fix newline at end of reboot --eject output (#253562).
256 * Mon Aug 13 2007 Chris Lumens <clumens@redhat.com> 1.8-1
257 - Fix type checking of string values.
259 * Thu Aug 09 2007 Chris Lumens <clumens@redhat.com> 1.7-1
260 - Clarify license in spec file and all source files.
261 - Check string values to options to make sure they're not other options
262 (#251318).
264 * Thu Aug 02 2007 Chris Lumens <clumens@redhat.com> 1.6-1
265 - Fix a couple tracebacks in ksvalidator.
266 - Change --class to --dhcpclass (#248912).
268 * Thu Jul 19 2007 Chris Lumens <clumens@redhat.com> 1.5-2
269 - Require rhpl (#248953).
271 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.5-1
272 - Fix traceback when calling preprocessKickstart.
274 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.4-1
275 - Add methods to handle the %ksappend directive.
276 - Fix ignoredisk --disks.
278 * Wed Jul 11 2007 Chris Lumens <clumens@redhat.com> - 1.3-1
279 - Add support for ignoredisk --only-use.
280 - Fix traceback in raid command printing method (#246709).
282 * Fri Jun 08 2007 Chris Lumens <clumens@redhat.com> - 1.2-2
283 - Fix package review problems (#226334).
285 * Mon Jun 04 2007 Chris Lumens <clumens@redhat.com> - 1.2-1
286 - Fix harddrive install method error checking (#232492).
287 - Set authentication information from the input line to preserve quoting
288 (#241657).
289 - Allow included files to be given by URL.
290 - Fix typo in user --iscrypted option.
292 * Mon May 14 2007 Chris Lumens <clumens@redhat.com> - 1.1-1
293 - Better regexes for splitting version strings into family and version.
294 - Add basic support for RHEL3.
295 - Update translations.
297 * Fri Apr 13 2007 Chris Lumens <clumens@redhat.com> - 1.0-1
298 - Update documentation.
299 - Update translations.
301 * Mon Mar 19 2007 Chris Lumens <clumens@redhat.com> - 0.100-1
302 - bootloader should be written out after upgrade/install.
303 - Treat class names as unicode strings (#231053).
305 * Wed Mar 07 2007 Chris Lumens <clumens@redhat.com> - 0.99-1
306 - The timezone command didn't recognize --isUtc before FC6 (#231189).
307 - Recognize %ksappend lines in ksvalidator.
308 - Don't set default values in some command __init__ methods.
309 - Added an updates command.
310 - Add support for RAID10.
312 * Mon Feb 26 2007 Chris Lumens <clumens@redhat.com> - 0.98-1
313 - Fix device command syntax to match anaconda.
314 - Fix __call__ on method command.
316 * Wed Feb 21 2007 Chris Lumens <clumens@redhat.com> - 0.97-1
317 - Fix traceback when not overriding default mappings (#229505).
319 * Tue Feb 20 2007 Chris Lumens <clumens@redhat.com> - 0.96-1
320 - Fix __str__ methods for langsupport and reboot commands.
321 - Renamed BaseHandler.empty to BaseHandler.maskAllExcept.
322 - Split command objects out into their own files in commands/.
323 - Rename command objects to start with Version_.
324 - Support extended group selection syntax.
326 * Wed Feb 14 2007 Chris Lumens <clumens@redhat.com> - 0.95-1
327 - KickstartParser no longer takes a version argument.
328 - Be more lenient in what strings stringToVersion accepts.
329 - Allow setting state on one data object from multiple files.
331 * Wed Feb 07 2007 Chris Lumens <clumens@redhat.com> - 0.94-1
332 - Add a newline to the end of the key command output.
333 - Use network bootproto constants (#197694).
334 - Fix tracebacks in subclass __str__ methods (#226734).
336 * Wed Jan 31 2007 Chris Lumens <clumens@redhat.com> - 0.93-2
337 - Make some minor spec file changes to get closer to the extras guidelines.
339 * Thu Jan 25 2007 Chris Lumens <clumens@redhat.com> - 0.93-1
340 - Add support for FC3, RHEL4, and RHEL5.
341 - The key command was not supported until after FC6.
342 - Accept more strings in stringToVersion.
344 * Fri Jan 19 2007 Chris Lumens <clumens@redhat.com> - 0.92-1
345 - Fix KickstartVersionError reporting.
346 - Add a version attribute to handler objects.
347 - Fix line number reporting on lots of commands.
348 - Add initial support for Fedora 7 and remove deprecated commands.
349 - Accept a --default argument to the %%packages header (#221305).
351 * Wed Jan 17 2007 Chris Lumens <clumens@redhat.com> - 0.91-1
352 - Add a method to read kickstart files from strings.
354 * Tue Jan 16 2007 Chris Lumens <clumens@redhat.com> - 0.90-1
355 - Support multiple versions of kickstart syntax from one code base
356 (#189348).
357 - Fix inconsistency between Script parser and writer (#222877).
359 * Fri Dec 15 2006 Chris Lumens <clumens@redhat.com> - 0.43-1
360 - Pull in new translations (#216620).
362 * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.42-2
363 - rebuild against python 2.5
365 * Tue Dec 05 2006 Chris Lumens <clumens@redhat.com> - 0.42-1
366 - Fix traceback when writing out repo command (#218274).
368 * Fri Dec 01 2006 Chris Lumens <clumens@redhat.com> - 0.41-1
369 - Fix traceback when using deprecated commands (#218047, #218059).
371 * Thu Nov 30 2006 Chris Lumens <clumens@redhat.com> - 0.40-1
372 - Pull in new translations (#216620).
373 - Add --level argument to logging command writer.
375 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-2
376 - Fix release number.
378 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-1
379 - Add writer for --key (#211997).
381 * Tue Oct 17 2006 Jeremy Katz <katzj@redhat.com> - 0.38-1
382 - allow --skip for installation number as well (#207029)
384 * Mon Oct 16 2006 Jeremy Katz <katzj@redhat.com> - 0.37-1
385 - support for installation numbers (#207029)
387 * Fri Oct 13 2006 Bill Nottingham <notting@redhat.com> - 0.36-1
388 - use valid charsets in translations (#210720)
390 * Fri Sep 29 2006 Chris Lumens <clumens@redhat.com> - 0.35-1
391 - Fix traceback in harddrive command (#208557).
393 * Mon Sep 25 2006 Chris Lumens <clumens@redhat.com> - 0.34-1
394 - Add support for --biospart option to harddrive (#207585).
395 - Update writer for syntax changes.
397 * Wed Sep 20 2006 Jeremy Katz <katzj@redhat.com> - 0.33-1
398 - improved iscsi syntax
399 - allow multiple zfcp devs
401 * Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 0.32-1
402 - Limit --bootproto to what anaconda supports.
403 - Add --noipv4 and --noipv6 network options.
405 * Tue Jun 20 2006 Chris Lumens <clumens@redhat.com> 0.31-1
406 - Handle nfs --opts (katzj).
407 - RAID devices should be integers instead of strings (#176537).
408 - Add initial support for iscsi (katzj).
410 * Tue Jun 06 2006 Chris Lumens <clumens@redhat.com> 0.30-2
411 - Add BuildRequires to fix building under mock (#194156, Joost Soeterbroek
412 <fedora AT soeterbroek.com>).
414 * Thu May 25 2006 Chris Lumens <clumens@redhat.com> 0.30-1
415 - Change order of LVM-related writing functions (#193073).
416 - Require urlgrabber.
417 - Return a more useful error message on unknown commands.
418 - Fix logvol writing typo.
419 - Make ksvalidator validate from a URL in addition to a file.
420 - Don't write out an empty packages section (#192851).
422 * Tue May 23 2006 Chris Lumens <clumens@redhat.com> 0.29-1
423 - Add multipath command, handlers, and data objects (pjones).
424 - Rename --ports to --port in writer.
426 * Mon May 15 2006 Chris Lumens <clumens@redhat.com> 0.28-1
427 - Support --mtu for the network command (#191328).
428 - Accept --isUtc for backwards compatibility.
430 * Wed May 04 2006 Chris Lumens <clumens@redhat.com> 0.27-1
431 - Output formatting fixes.
432 - Added commands for managing users and services.
434 * Mon Apr 17 2006 Chris Lumens <clumens@redhat.com> 0.26-1
435 - Ignore spaces before group names (#188095).
436 - Added some translations.
437 - Add options for repo command.
438 - Reorder %%packages section output.
439 - Output %%packages header options.
440 - Initialize RAID and volume group members to empty lists.
442 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.25-1
443 - Add support for the logging command.
445 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.24-1
446 - Don't write out a blank xconfig line.
447 - Reorder output handlers to group like commands together.
448 - Mark strings for translation.
450 * Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 0.23-1
451 - Backwards compatibility support for options to zerombr.
453 * Fri Feb 24 2006 Chris Lumens <clumens@redhat.com> 0.22-1
454 - Get ignoredisk working again (#182934).
456 * Fri Feb 17 2006 Chris Lumens <clumens@redhat.com> 0.21-1
457 - Provide an option to not traceback on missing include files (#181760).
458 - Update programming documentation.
460 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.20-1
461 - Correctly set --noformat and --useexisting on lvm and raid.
463 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.19-1
464 - --onboot requires a value (#180987).
465 - Be more strict about commands that don't take arguments.
467 * Thu Feb 09 2006 Chris Lumens <clumens@redhat.com> 0.18-1
468 - Fix some errors pychecker caught.
469 - Allow exceptions to not be fatal so ksvalidator can spot more errors in
470 a single pass (#179894).
472 * Wed Feb 01 2006 Chris Lumens <clumens@redhat.com> 0.17-1
473 - Don't set a default port for vnc.
475 * Tue Jan 31 2006 Chris Lumens <clumens@redhat.com> 0.16-1
476 - Give dmraid string an initial value.
477 - Handle None on partition size.
479 * Tue Jan 31 2006 Peter Jones <pjones@redhat.com> 0.15-1
480 - Add dmraid support
482 * Mon Jan 30 2006 Chris Lumens <clumens@redhat.com> 0.14-1
483 - Fix VNC parameter parsing (#179209).
484 - Deprecate --connect. Add --host and --port instead.
486 * Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 0.13-1
487 - Recognize the --eject parameter to shutdown/halt.
488 - Store the exact post-installation action in ksdata.
490 * Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 0.12-1
491 - Clean up output quoting.
492 - Finish removing monitor-related stuff from xconfig.
494 * Mon Dec 12 2005 Chris Lumens <clumens@redhat.com> 0.11-1
495 - Deprecate monitor-related options to xconfig.
497 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
498 - Support --bytes-per-inode on raid
499 (Curtis Doty <Curtis at GreenKey.net> #175288).
501 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
502 - fixup network --onboot
504 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
505 - Default to SELINUX_ENFORCING.
506 - Default partition sizes to None for anaconda (#172378).
507 - Don't call shlex.split on anything inside a script (#172313).
509 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
510 - Fix clearpart --all.
511 - vnc command does not require --connect option (#172192).
512 - network --onboot does not take any option.
513 - Remove extra spaces from firewall --ports and --trust.
514 - Write out network --<service> options.
516 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
517 - Add --resolvedeps and --ignoredeps as deprecated options.
518 - Pass line number to header functions.
520 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
521 - Add line numbers to exception reporting.
522 - Added ksvalidator.
524 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
525 - Correct deprecated attribute on options.
526 - Added programming documentation.
528 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
529 - Correct python lib directory on 64-bit archs (#170621).
531 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
532 - Add a deprecated attribute to options.
533 - Add --card option back to xconfig and mark as deprecated.
534 - Throw a deprecation warning on mouse and langsupport commands.
535 - Rename Writer to KickstartWriter for consistency.
536 - Collapse scripts into a single list and add an attribute on Script to
537 differentiate.
539 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
540 - Rename module to pykickstart to avoid conflicts in anaconda.
541 - Rename data classes for consistency.
542 - Add default bytesPerInode settings.
544 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
545 - Created package from anaconda.