Add the kickstart documentation from the Fedora wiki.
[pykickstart.git] / pykickstart.spec
blobcceb15d47540b052506ffd9e521f9c1cf01b275f
1 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Url: http://fedoraproject.org/wiki/pykickstart
6 Version: 1.12
7 Release: 1%{?dist}
8 # This is a Red Hat maintained package which is specific to
9 # our distribution. Thus the source is only available from
10 # within this srpm.
11 Source0: %{name}-%{version}.tar.gz
13 License: GPLv2
14 Group: System Environment/Libraries
15 BuildArch: noarch
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17 BuildRequires: python-devel, gettext
18 Requires: python, python-urlgrabber, rhpl
20 %description
21 The pykickstart package is a python library for manipulating kickstart
22 files.
24 %prep
25 %setup -q
26 make
28 %build
30 %install
31 rm -rf %{buildroot}
32 make DESTDIR=%{buildroot} install
33 %find_lang %{name}
35 %clean
36 rm -rf %{buildroot}
38 %files -f %{name}.lang
39 %defattr(-,root,root,-)
40 %doc README ChangeLog COPYING docs/programmers-guide
41 %doc docs/kickstart-docs.txt
42 %{python_sitelib}/pykickstart
43 %{_bindir}/ksvalidator
45 %changelog
46 * Tue Sep 04 2007 Chris Lumens <clumens@redhat.com> 1.12-1
47 - Fix lots of problems in processing the bootloader, device, network, and
48 raid commands.
49 - Add %end when writing out scripts and packages.
50 - Add a makefile target to run pychecker to cut down on errors in
51 releases.
53 * Mon Sep 3 2007 Jeremy Katz <katzj@redhat.com> - 1.11-1
54 - fix a few tracebacks
56 * Fri Aug 31 2007 Chris Lumens <clumens@redhat.com> 1.10-1
57 - Add network --ipv6=.
59 * Fri Aug 24 2007 Chris Lumens <clumens@redhat.com> 1.9-1
60 - Add support for the %end directive to be placed at the end of scripts
61 and packages sections. Deprecate old syntax.
62 - Clean up after ksvalidator if pykickstart issues a traceback.
63 - Add support for repo --priority --includepkgs --excludepkgs.
64 - Fix newline at end of reboot --eject output (#253562).
66 * Mon Aug 13 2007 Chris Lumens <clumens@redhat.com> 1.8-1
67 - Fix type checking of string values.
69 * Thu Aug 09 2007 Chris Lumens <clumens@redhat.com> 1.7-1
70 - Clarify license in spec file and all source files.
71 - Check string values to options to make sure they're not other options
72 (#251318).
74 * Thu Aug 02 2007 Chris Lumens <clumens@redhat.com> 1.6-1
75 - Fix a couple tracebacks in ksvalidator.
76 - Change --class to --dhcpclass (#248912).
78 * Thu Jul 19 2007 Chris Lumens <clumens@redhat.com> 1.5-2
79 - Require rhpl (#248953).
81 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.5-1
82 - Fix traceback when calling preprocessKickstart.
84 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.4-1
85 - Add methods to handle the %ksappend directive.
86 - Fix ignoredisk --disks.
88 * Wed Jul 11 2007 Chris Lumens <clumens@redhat.com> - 1.3-1
89 - Add support for ignoredisk --only-use.
90 - Fix traceback in raid command printing method (#246709).
92 * Fri Jun 08 2007 Chris Lumens <clumens@redhat.com> - 1.2-2
93 - Fix package review problems (#226334).
95 * Mon Jun 04 2007 Chris Lumens <clumens@redhat.com> - 1.2-1
96 - Fix harddrive install method error checking (#232492).
97 - Set authentication information from the input line to preserve quoting
98 (#241657).
99 - Allow included files to be given by URL.
100 - Fix typo in user --iscrypted option.
102 * Mon May 14 2007 Chris Lumens <clumens@redhat.com> - 1.1-1
103 - Better regexes for splitting version strings into family and version.
104 - Add basic support for RHEL3.
105 - Update translations.
107 * Fri Apr 13 2007 Chris Lumens <clumens@redhat.com> - 1.0-1
108 - Update documentation.
109 - Update translations.
111 * Mon Mar 19 2007 Chris Lumens <clumens@redhat.com> - 0.100-1
112 - bootloader should be written out after upgrade/install.
113 - Treat class names as unicode strings (#231053).
115 * Wed Mar 07 2007 Chris Lumens <clumens@redhat.com> - 0.99-1
116 - The timezone command didn't recognize --isUtc before FC6 (#231189).
117 - Recognize %ksappend lines in ksvalidator.
118 - Don't set default values in some command __init__ methods.
119 - Added an updates command.
120 - Add support for RAID10.
122 * Mon Feb 26 2007 Chris Lumens <clumens@redhat.com> - 0.98-1
123 - Fix device command syntax to match anaconda.
124 - Fix __call__ on method command.
126 * Wed Feb 21 2007 Chris Lumens <clumens@redhat.com> - 0.97-1
127 - Fix traceback when not overriding default mappings (#229505).
129 * Tue Feb 20 2007 Chris Lumens <clumens@redhat.com> - 0.96-1
130 - Fix __str__ methods for langsupport and reboot commands.
131 - Renamed BaseHandler.empty to BaseHandler.maskAllExcept.
132 - Split command objects out into their own files in commands/.
133 - Rename command objects to start with Version_.
134 - Support extended group selection syntax.
136 * Wed Feb 14 2007 Chris Lumens <clumens@redhat.com> - 0.95-1
137 - KickstartParser no longer takes a version argument.
138 - Be more lenient in what strings stringToVersion accepts.
139 - Allow setting state on one data object from multiple files.
141 * Wed Feb 07 2007 Chris Lumens <clumens@redhat.com> - 0.94-1
142 - Add a newline to the end of the key command output.
143 - Use network bootproto constants (#197694).
144 - Fix tracebacks in subclass __str__ methods (#226734).
146 * Wed Jan 31 2007 Chris Lumens <clumens@redhat.com> - 0.93-2
147 - Make some minor spec file changes to get closer to the extras guidelines.
149 * Thu Jan 25 2007 Chris Lumens <clumens@redhat.com> - 0.93-1
150 - Add support for FC3, RHEL4, and RHEL5.
151 - The key command was not supported until after FC6.
152 - Accept more strings in stringToVersion.
154 * Fri Jan 19 2007 Chris Lumens <clumens@redhat.com> - 0.92-1
155 - Fix KickstartVersionError reporting.
156 - Add a version attribute to handler objects.
157 - Fix line number reporting on lots of commands.
158 - Add initial support for Fedora 7 and remove deprecated commands.
159 - Accept a --default argument to the %%packages header (#221305).
161 * Wed Jan 17 2007 Chris Lumens <clumens@redhat.com> - 0.91-1
162 - Add a method to read kickstart files from strings.
164 * Tue Jan 16 2007 Chris Lumens <clumens@redhat.com> - 0.90-1
165 - Support multiple versions of kickstart syntax from one code base
166 (#189348).
167 - Fix inconsistency between Script parser and writer (#222877).
169 * Fri Dec 15 2006 Chris Lumens <clumens@redhat.com> - 0.43-1
170 - Pull in new translations (#216620).
172 * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.42-2
173 - rebuild against python 2.5
175 * Tue Dec 05 2006 Chris Lumens <clumens@redhat.com> - 0.42-1
176 - Fix traceback when writing out repo command (#218274).
178 * Fri Dec 01 2006 Chris Lumens <clumens@redhat.com> - 0.41-1
179 - Fix traceback when using deprecated commands (#218047, #218059).
181 * Thu Nov 30 2006 Chris Lumens <clumens@redhat.com> - 0.40-1
182 - Pull in new translations (#216620).
183 - Add --level argument to logging command writer.
185 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-2
186 - Fix release number.
188 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-1
189 - Add writer for --key (#211997).
191 * Tue Oct 17 2006 Jeremy Katz <katzj@redhat.com> - 0.38-1
192 - allow --skip for installation number as well (#207029)
194 * Mon Oct 16 2006 Jeremy Katz <katzj@redhat.com> - 0.37-1
195 - support for installation numbers (#207029)
197 * Fri Oct 13 2006 Bill Nottingham <notting@redhat.com> - 0.36-1
198 - use valid charsets in translations (#210720)
200 * Fri Sep 29 2006 Chris Lumens <clumens@redhat.com> - 0.35-1
201 - Fix traceback in harddrive command (#208557).
203 * Mon Sep 25 2006 Chris Lumens <clumens@redhat.com> - 0.34-1
204 - Add support for --biospart option to harddrive (#207585).
205 - Update writer for syntax changes.
207 * Wed Sep 20 2006 Jeremy Katz <katzj@redhat.com> - 0.33-1
208 - improved iscsi syntax
209 - allow multiple zfcp devs
211 * Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 0.32-1
212 - Limit --bootproto to what anaconda supports.
213 - Add --noipv4 and --noipv6 network options.
215 * Tue Jun 20 2006 Chris Lumens <clumens@redhat.com> 0.31-1
216 - Handle nfs --opts (katzj).
217 - RAID devices should be integers instead of strings (#176537).
218 - Add initial support for iscsi (katzj).
220 * Tue Jun 06 2006 Chris Lumens <clumens@redhat.com> 0.30-2
221 - Add BuildRequires to fix building under mock (#194156, Joost Soeterbroek
222 <fedora AT soeterbroek.com>).
224 * Thu May 25 2006 Chris Lumens <clumens@redhat.com> 0.30-1
225 - Change order of LVM-related writing functions (#193073).
226 - Require urlgrabber.
227 - Return a more useful error message on unknown commands.
228 - Fix logvol writing typo.
229 - Make ksvalidator validate from a URL in addition to a file.
230 - Don't write out an empty packages section (#192851).
232 * Tue May 23 2006 Chris Lumens <clumens@redhat.com> 0.29-1
233 - Add multipath command, handlers, and data objects (pjones).
234 - Rename --ports to --port in writer.
236 * Mon May 15 2006 Chris Lumens <clumens@redhat.com> 0.28-1
237 - Support --mtu for the network command (#191328).
238 - Accept --isUtc for backwards compatibility.
240 * Wed May 04 2006 Chris Lumens <clumens@redhat.com> 0.27-1
241 - Output formatting fixes.
242 - Added commands for managing users and services.
244 * Mon Apr 17 2006 Chris Lumens <clumens@redhat.com> 0.26-1
245 - Ignore spaces before group names (#188095).
246 - Added some translations.
247 - Add options for repo command.
248 - Reorder %%packages section output.
249 - Output %%packages header options.
250 - Initialize RAID and volume group members to empty lists.
252 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.25-1
253 - Add support for the logging command.
255 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.24-1
256 - Don't write out a blank xconfig line.
257 - Reorder output handlers to group like commands together.
258 - Mark strings for translation.
260 * Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 0.23-1
261 - Backwards compatibility support for options to zerombr.
263 * Fri Feb 24 2006 Chris Lumens <clumens@redhat.com> 0.22-1
264 - Get ignoredisk working again (#182934).
266 * Fri Feb 17 2006 Chris Lumens <clumens@redhat.com> 0.21-1
267 - Provide an option to not traceback on missing include files (#181760).
268 - Update programming documentation.
270 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.20-1
271 - Correctly set --noformat and --useexisting on lvm and raid.
273 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.19-1
274 - --onboot requires a value (#180987).
275 - Be more strict about commands that don't take arguments.
277 * Thu Feb 09 2006 Chris Lumens <clumens@redhat.com> 0.18-1
278 - Fix some errors pychecker caught.
279 - Allow exceptions to not be fatal so ksvalidator can spot more errors in
280 a single pass (#179894).
282 * Wed Feb 01 2006 Chris Lumens <clumens@redhat.com> 0.17-1
283 - Don't set a default port for vnc.
285 * Tue Jan 31 2006 Chris Lumens <clumens@redhat.com> 0.16-1
286 - Give dmraid string an initial value.
287 - Handle None on partition size.
289 * Tue Jan 31 2006 Peter Jones <pjones@redhat.com> 0.15-1
290 - Add dmraid support
292 * Mon Jan 30 2006 Chris Lumens <clumens@redhat.com> 0.14-1
293 - Fix VNC parameter parsing (#179209).
294 - Deprecate --connect. Add --host and --port instead.
296 * Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 0.13-1
297 - Recognize the --eject parameter to shutdown/halt.
298 - Store the exact post-installation action in ksdata.
300 * Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 0.12-1
301 - Clean up output quoting.
302 - Finish removing monitor-related stuff from xconfig.
304 * Mon Dec 12 2005 Chris Lumens <clumens@redhat.com> 0.11-1
305 - Deprecate monitor-related options to xconfig.
307 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
308 - Support --bytes-per-inode on raid
309 (Curtis Doty <Curtis at GreenKey.net> #175288).
311 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
312 - fixup network --onboot
314 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
315 - Default to SELINUX_ENFORCING.
316 - Default partition sizes to None for anaconda (#172378).
317 - Don't call shlex.split on anything inside a script (#172313).
319 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
320 - Fix clearpart --all.
321 - vnc command does not require --connect option (#172192).
322 - network --onboot does not take any option.
323 - Remove extra spaces from firewall --ports and --trust.
324 - Write out network --<service> options.
326 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
327 - Add --resolvedeps and --ignoredeps as deprecated options.
328 - Pass line number to header functions.
330 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
331 - Add line numbers to exception reporting.
332 - Added ksvalidator.
334 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
335 - Correct deprecated attribute on options.
336 - Added programming documentation.
338 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
339 - Correct python lib directory on 64-bit archs (#170621).
341 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
342 - Add a deprecated attribute to options.
343 - Add --card option back to xconfig and mark as deprecated.
344 - Throw a deprecation warning on mouse and langsupport commands.
345 - Rename Writer to KickstartWriter for consistency.
346 - Collapse scripts into a single list and add an attribute on Script to
347 differentiate.
349 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
350 - Rename module to pykickstart to avoid conflicts in anaconda.
351 - Rename data classes for consistency.
352 - Add default bytesPerInode settings.
354 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
355 - Created package from anaconda.