Add a devicemode test case (alindebe).
[pykickstart.git] / pykickstart.spec
bloba5b585c3a2a49a7a390c7036c53312c24b0c3f50
1 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Url: http://fedoraproject.org/wiki/pykickstart
6 Version: 1.51
7 Release: 1%{?dist}
8 # This is a Red Hat maintained package which is specific to
9 # our distribution. Thus the source is only available from
10 # within this srpm.
11 Source0: %{name}-%{version}.tar.gz
13 License: GPLv2
14 Group: System Environment/Libraries
15 BuildArch: noarch
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17 BuildRequires: python-devel, gettext, python-setuptools-devel
18 Requires: python, python-urlgrabber
20 %description
21 The pykickstart package is a python library for manipulating kickstart
22 files.
24 %prep
25 %setup -q
26 make
28 %build
30 %install
31 rm -rf %{buildroot}
32 make DESTDIR=%{buildroot} install
33 %find_lang %{name}
35 %clean
36 rm -rf %{buildroot}
38 %files -f %{name}.lang
39 %defattr(-,root,root,-)
40 %doc README ChangeLog COPYING docs/programmers-guide
41 %doc docs/kickstart-docs.txt
42 %{python_sitelib}/*
43 %{_bindir}/ksvalidator
44 %{_bindir}/ksflatten
45 %{_bindir}/ksverdiff
47 %changelog
48 * Thu Jan 29 2009 Chris Lumens <clumens@redhat.com> - 1.51-1
49 - Make a couple changes to how the logging command is handled.
50 - Add a lot of test cases (clumens, alindebe, jlaska, fcami, adamwill, pfrields).
51 - Fix output formatting for the rootpw command.
52 - For commands that take exactly one argument, check and error correctly.
53 - Surround module options in quotes on the output side (jlaska).
54 - Set module opts in the FC3 handler correctly.
55 - Fix newlines on the device command output (jlaska).
56 - If --autoscreenshot is not specified, still output "autostep".
57 - Move the currentCmd and currentLine into getParser(). (jlaska)
58 - Write out an selinux line if set to disabled, but not if None.
59 - F9_LogVolData should inherit from FC4_LogVolData, not FC3_LogVolData (jlaska).
60 - Add unittest framework along with logvol and vnc unittests. (jlaska)
61 - Don't set the KSOption.required attribute in the constructor (jlaska).
63 * Sat Jan 10 2009 Chris Lumens <clumens@redhat.com> - 1.50-1
64 - Add a script to diff two versions of kickstart syntax.
65 - Add an option to ksvalidator to list all available syntax versions.
66 - Remove a couple extra newlines in output formatting.
67 - Add documentation for the new %include representation.
68 - Add support %include to the pykickstart data objects.
70 * Thu Jan 08 2009 Chris Lumens <clumens@redhat.com> - 1.49-1
71 - Add upgrade --root-device (atodorov, #471232).
72 - Use python's builtin set rather than the Sets module (#477836, dcantrell).
74 * Tue Dec 23 2008 Chris Lumens <clumens@redhat.com> - 1.48-1
75 - Allow ignoring group metadata from repos, using a '--ignoregroups'
76 boolean. (notting)
77 - Add initial support for F11.
78 - Specify the command versions in the handlers instead of making copies.
79 - Remove empty and pointless __init__ methods.
80 - Pass arguments to superclasses via *args and **kwargs, all the way up.
81 - Add removedKeywords and removedAttrs lists on Commands and Data.
82 - Fix version regexes to handle double digits and minor releases (jlaska).
84 * Thu Oct 30 2008 Chris Lumens <clumens@redhat.com> - 1.47-1
85 - Fix enabling services we specify by specific options.
87 * Mon Oct 27 2008 Chris Lumens <clumens@redhat.com> - 1.46-1
88 - Add support for firewall --service (#467005).
90 * Tue Oct 14 2008 Chris Lumens <clumens@redhat.com> - 1.45-1
91 - Lots of translation updates.
92 - Remove use of string.partition for python2.4 (atodorov).
94 * Mon Sep 22 2008 Chris Lumens <clumens@redhat.com> - 1.44-1
95 - Add support for reverse CHAP to the kickstart iscsi command (hans)
96 - Fix typo (katzj)
98 * Wed Sep 03 2008 Chris Lumens <clumens@redhat.com> - 1.43-1
99 - Revert "Do not include passphrases for encrypted block devices in
100 anaconda-ks.cfg." (dlehman)
101 - yum doesn't like when mirrorlist is "". (clumens)
103 * Mon Aug 11 2008 Chris Lumens <clumens@redhat.com> - 1.42-1
104 - Add rescue command to pykickstart (atodorov)
105 - Sort %packages output (katzj)
106 - Fix a typo (atodorov).
108 * Fri Aug 01 2008 Chris Lumens <clumens@redhat.com> - 1.41-1
109 - RHEL5 supports ignoredisk --only-use now too. (clumens)
110 - Do not include passphrases for encrypted block devices in
111 anaconda-ks.cfg. (dlehman)
112 - Fix F9,F10,RHEL5 "part" commands to use the same class as
113 "partition". (dlehman)
114 - Add an apply method() for commands and implement for lang (katzj)
116 * Tue Jul 15 2008 Chris Lumens <clumens@redhat.com> - 1.40-1
117 - RHEL5_LogVolData should inherit from FC4, not FC3.
118 Also fix FC9->F9 typo. (dlehman)
119 - Support creation of encrypted block devices in RHEL5. (#449830) (dlehman)
120 - Use the right LogVolData objects for RHEL3 and 4 (jlaska). (clumens)
121 - We no longer use rhpl for translations. (clumens)
122 - All the base classes should derive from object. (clumens)
124 * Fri Jun 13 2008 Chris Lumens <clumens@redhat.com> - 1.39-1
125 - It's helpful to return the parser object. (clumens)
127 * Tue Jun 10 2008 Chris Lumens <clumens@redhat.com> - 1.38-1
128 - Fix loading the Handler object by looking for a more specific
129 name (#450740). (clumens)
131 * Sun Jun 08 2008 Chris Lumens <clumens@redhat.com> - 1.37-1
132 - XConfig is still used by other projects, so just deprecate some
133 options. (clumens)
135 * Thu May 29 2008 Chris Lumens <clumens@redhat.com> - 1.36-1
136 - It should be repo --cost, not repo --priority. (clumens)
138 * Fri May 23 2008 Chris Lumens <clumens@redhat.com> - 1.35-1
139 - Bring driverdisk command in line with the docs. (clumens)
140 - Change RAID command print priorities (jlaska).
141 - According to docs, physvols are space delimited. (jlaska)
142 - Don't write the label out twice (jlaska).
143 - Deprecate monitor and xconfig commands. (clumens)
145 * Wed May 07 2008 Chris Lumens <clumens@redhat.com> - 1.34-1
146 - Load the handler module automatically. (clumens)
147 - Add support for F10. (clumens)
148 - Initialize cmd.handler earlier; fixes repo.methodToRepo() (markmc)
149 - Don't shadow builtin function names. (clumens)
150 - Running check is now required before pykickstart can be packaged. (clumens)
151 - Reorganize code a little bit to pass pychecker. (clumens)
153 * Tue Apr 08 2008 Chris Lumens <clumens@redhat.com> - 1.33-1
154 - Fix whitespace when printing out the bootloader command (pmeyers).
155 - Fix the type on bootloader --timeout processing. (clumens)
157 * Wed Apr 02 2008 Chris Lumens <clumens@redhat.com> - 1.32-1
158 - Make the string reader act like the file reader upon EOF. (clumens)
159 - Add syntax for encrypted logical volumes. (clumens)
161 * Tue Mar 25 2008 Chris Lumens <clumens@redhat.com> - 1.31-1
162 - Support end-of-line comments. (clumens)
163 - Lots of translation updates.
165 * Tue Feb 26 2008 Chris Lumens <clumens@redhat.com> - 1.30-1
166 - Reverse writePriorities of iscsi and iscsname (#434965, jlaska).
167 - Fix printing of iscsiname command (#434945, jlaska).
168 - Don't traceback on ENOENT. (pnasrat)
169 - Store the mouse name as a string, not a list. (clumens)
170 - Update translations.
172 * Wed Jan 30 2008 Chris Lumens <clumens@redhat.com> - 1.29-1
173 - Renamed bootproto=ask to bootproto=query, add to RHEL5 as well. (clumens)
175 * Wed Jan 23 2008 Chris Lumens <clumens@redhat.com> - 1.28-1
176 - Fix traceback on volgroup command. (clumens)
178 * Thu Jan 17 2008 Chris Lumens <clumens@redhat.com> - 1.27-1
179 - The bootprotoList needs to be defined before it's used. (clumens)
181 * Thu Jan 17 2008 Chris Lumens <clumens@redhat.com> - 1.26-1
182 - Add support for network --bootproto=ask. (clumens)
184 * Tue Jan 15 2008 Chris Lumens <clumens@redhat.com> - 1.25-1
185 - Add the version to the output ks file. (clumens)
186 - Add syntax for encrypted partitions and raid devices. (clumens)
188 * Thu Jan 10 2008 Chris Lumens <clumens@redhat.com> - 1.24-1
189 - Make inheritance and overriding of %packages work (#427768). (clumens)
190 - Add an option for which languages should be installed. (katzj)
191 - Use the right name for the iscsi --target variable (#418781). (clumens)
193 * Mon Dec 10 2007 Chris Lumens <clumens@redhat.com> - 1.23-1
194 - Take Makefile improvements from anaconda.
195 - Fix a traceback on F9 zerombr command (#395431).
196 - Update to handle new Python eggs packaging.
198 * Tue Nov 20 2007 Chris Lumens <clumens@redhat.com> 1.22-1
199 - Don't process or write out vnc --enabled (jlaska AT redhat DOT com).
200 - Fix a traceback in the clearpart command.
202 * Tue Nov 06 2007 Chris Lumens <clumens@redhat.com> 1.21-1
203 - Save script line numbers for debugging.
204 - More internal cleanups.
206 * Wed Oct 31 2007 Chris Lumens <clumens@redhat.com> 1.20-1
207 - Pull wiki docs from the new location.
208 - Fix error messages for options that have been removed after having been
209 previously deprecated.
210 - zerombr no longer takes any arguments.
211 - %packages --ignoredeps --resolvedeps have been removed.
212 - firewall --high --medium have been removed.
213 - vnc --connect has been removed.
214 - xconfig options from monitor have now been removed.
215 - --bytes-per-inode has been marked as deprecated.
216 - Fix typos.
217 - Add --fsprofile option to disk commands (pjones).
218 - Add F9 support (pjones).
219 - Lots of internal fixes (clumens, pjones).
221 * Tue Oct 23 2007 Chris Lumens <clumens@redhat.com> 1.19-1
222 - Fix a traceback on the cdrom method.
224 * Thu Oct 18 2007 Chris Lumens <clumens@redhat.com> 1.18-1
225 - Don't write out %end to packages and scripts if the syntax version doesn't
226 support it.
227 - Remove obsolete translation (#332221).
229 * Thu Oct 04 2007 Chris Lumens <clumens@redhat.com> 1.17-1
230 - Simplify argument processing and printing.
232 * Wed Oct 03 2007 Chris Lumens <clumens@redhat.com> 1.16-1
233 - Undeprecate %packages --excludedocs.
234 - Fix a traceback in the device command handling.
235 - Add bootloader --timeout (katzj).
237 * Tue Oct 02 2007 Chris Lumens <clumens@redhat.com> 1.15-1
238 - Update translations (#259121).
239 - The device command no longer takes a type argument.
241 * Fri Sep 28 2007 Chris Lumens <clumens@redhat.com> 1.14-1
242 - Fix output formatting for packages section header (#310211).
243 - Add a script to flatten kickstart files containing includes (katzj).
245 * Wed Sep 12 2007 Chris Lumens <clumens@redhat.com> 1.13-1
246 - Add a function to convert URL method strings into repo objects
247 (jkeating).
248 - Writer formatting fixes.
249 - Add kickstart documentation from the Fedora Wiki.
251 * Tue Sep 04 2007 Chris Lumens <clumens@redhat.com> 1.12-1
252 - Fix lots of problems in processing the bootloader, device, network, and
253 raid commands.
254 - Add %end when writing out scripts and packages.
255 - Add a makefile target to run pychecker to cut down on errors in
256 releases.
258 * Mon Sep 3 2007 Jeremy Katz <katzj@redhat.com> - 1.11-1
259 - fix a few tracebacks
261 * Fri Aug 31 2007 Chris Lumens <clumens@redhat.com> 1.10-1
262 - Add network --ipv6=.
264 * Fri Aug 24 2007 Chris Lumens <clumens@redhat.com> 1.9-1
265 - Add support for the %end directive to be placed at the end of scripts
266 and packages sections. Deprecate old syntax.
267 - Clean up after ksvalidator if pykickstart issues a traceback.
268 - Add support for repo --priority --includepkgs --excludepkgs.
269 - Fix newline at end of reboot --eject output (#253562).
271 * Mon Aug 13 2007 Chris Lumens <clumens@redhat.com> 1.8-1
272 - Fix type checking of string values.
274 * Thu Aug 09 2007 Chris Lumens <clumens@redhat.com> 1.7-1
275 - Clarify license in spec file and all source files.
276 - Check string values to options to make sure they're not other options
277 (#251318).
279 * Thu Aug 02 2007 Chris Lumens <clumens@redhat.com> 1.6-1
280 - Fix a couple tracebacks in ksvalidator.
281 - Change --class to --dhcpclass (#248912).
283 * Thu Jul 19 2007 Chris Lumens <clumens@redhat.com> 1.5-2
284 - Require rhpl (#248953).
286 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.5-1
287 - Fix traceback when calling preprocessKickstart.
289 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.4-1
290 - Add methods to handle the %ksappend directive.
291 - Fix ignoredisk --disks.
293 * Wed Jul 11 2007 Chris Lumens <clumens@redhat.com> - 1.3-1
294 - Add support for ignoredisk --only-use.
295 - Fix traceback in raid command printing method (#246709).
297 * Fri Jun 08 2007 Chris Lumens <clumens@redhat.com> - 1.2-2
298 - Fix package review problems (#226334).
300 * Mon Jun 04 2007 Chris Lumens <clumens@redhat.com> - 1.2-1
301 - Fix harddrive install method error checking (#232492).
302 - Set authentication information from the input line to preserve quoting
303 (#241657).
304 - Allow included files to be given by URL.
305 - Fix typo in user --iscrypted option.
307 * Mon May 14 2007 Chris Lumens <clumens@redhat.com> - 1.1-1
308 - Better regexes for splitting version strings into family and version.
309 - Add basic support for RHEL3.
310 - Update translations.
312 * Fri Apr 13 2007 Chris Lumens <clumens@redhat.com> - 1.0-1
313 - Update documentation.
314 - Update translations.
316 * Mon Mar 19 2007 Chris Lumens <clumens@redhat.com> - 0.100-1
317 - bootloader should be written out after upgrade/install.
318 - Treat class names as unicode strings (#231053).
320 * Wed Mar 07 2007 Chris Lumens <clumens@redhat.com> - 0.99-1
321 - The timezone command didn't recognize --isUtc before FC6 (#231189).
322 - Recognize %ksappend lines in ksvalidator.
323 - Don't set default values in some command __init__ methods.
324 - Added an updates command.
325 - Add support for RAID10.
327 * Mon Feb 26 2007 Chris Lumens <clumens@redhat.com> - 0.98-1
328 - Fix device command syntax to match anaconda.
329 - Fix __call__ on method command.
331 * Wed Feb 21 2007 Chris Lumens <clumens@redhat.com> - 0.97-1
332 - Fix traceback when not overriding default mappings (#229505).
334 * Tue Feb 20 2007 Chris Lumens <clumens@redhat.com> - 0.96-1
335 - Fix __str__ methods for langsupport and reboot commands.
336 - Renamed BaseHandler.empty to BaseHandler.maskAllExcept.
337 - Split command objects out into their own files in commands/.
338 - Rename command objects to start with Version_.
339 - Support extended group selection syntax.
341 * Wed Feb 14 2007 Chris Lumens <clumens@redhat.com> - 0.95-1
342 - KickstartParser no longer takes a version argument.
343 - Be more lenient in what strings stringToVersion accepts.
344 - Allow setting state on one data object from multiple files.
346 * Wed Feb 07 2007 Chris Lumens <clumens@redhat.com> - 0.94-1
347 - Add a newline to the end of the key command output.
348 - Use network bootproto constants (#197694).
349 - Fix tracebacks in subclass __str__ methods (#226734).
351 * Wed Jan 31 2007 Chris Lumens <clumens@redhat.com> - 0.93-2
352 - Make some minor spec file changes to get closer to the extras guidelines.
354 * Thu Jan 25 2007 Chris Lumens <clumens@redhat.com> - 0.93-1
355 - Add support for FC3, RHEL4, and RHEL5.
356 - The key command was not supported until after FC6.
357 - Accept more strings in stringToVersion.
359 * Fri Jan 19 2007 Chris Lumens <clumens@redhat.com> - 0.92-1
360 - Fix KickstartVersionError reporting.
361 - Add a version attribute to handler objects.
362 - Fix line number reporting on lots of commands.
363 - Add initial support for Fedora 7 and remove deprecated commands.
364 - Accept a --default argument to the %%packages header (#221305).
366 * Wed Jan 17 2007 Chris Lumens <clumens@redhat.com> - 0.91-1
367 - Add a method to read kickstart files from strings.
369 * Tue Jan 16 2007 Chris Lumens <clumens@redhat.com> - 0.90-1
370 - Support multiple versions of kickstart syntax from one code base
371 (#189348).
372 - Fix inconsistency between Script parser and writer (#222877).
374 * Fri Dec 15 2006 Chris Lumens <clumens@redhat.com> - 0.43-1
375 - Pull in new translations (#216620).
377 * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.42-2
378 - rebuild against python 2.5
380 * Tue Dec 05 2006 Chris Lumens <clumens@redhat.com> - 0.42-1
381 - Fix traceback when writing out repo command (#218274).
383 * Fri Dec 01 2006 Chris Lumens <clumens@redhat.com> - 0.41-1
384 - Fix traceback when using deprecated commands (#218047, #218059).
386 * Thu Nov 30 2006 Chris Lumens <clumens@redhat.com> - 0.40-1
387 - Pull in new translations (#216620).
388 - Add --level argument to logging command writer.
390 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-2
391 - Fix release number.
393 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-1
394 - Add writer for --key (#211997).
396 * Tue Oct 17 2006 Jeremy Katz <katzj@redhat.com> - 0.38-1
397 - allow --skip for installation number as well (#207029)
399 * Mon Oct 16 2006 Jeremy Katz <katzj@redhat.com> - 0.37-1
400 - support for installation numbers (#207029)
402 * Fri Oct 13 2006 Bill Nottingham <notting@redhat.com> - 0.36-1
403 - use valid charsets in translations (#210720)
405 * Fri Sep 29 2006 Chris Lumens <clumens@redhat.com> - 0.35-1
406 - Fix traceback in harddrive command (#208557).
408 * Mon Sep 25 2006 Chris Lumens <clumens@redhat.com> - 0.34-1
409 - Add support for --biospart option to harddrive (#207585).
410 - Update writer for syntax changes.
412 * Wed Sep 20 2006 Jeremy Katz <katzj@redhat.com> - 0.33-1
413 - improved iscsi syntax
414 - allow multiple zfcp devs
416 * Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 0.32-1
417 - Limit --bootproto to what anaconda supports.
418 - Add --noipv4 and --noipv6 network options.
420 * Tue Jun 20 2006 Chris Lumens <clumens@redhat.com> 0.31-1
421 - Handle nfs --opts (katzj).
422 - RAID devices should be integers instead of strings (#176537).
423 - Add initial support for iscsi (katzj).
425 * Tue Jun 06 2006 Chris Lumens <clumens@redhat.com> 0.30-2
426 - Add BuildRequires to fix building under mock (#194156, Joost Soeterbroek
427 <fedora AT soeterbroek.com>).
429 * Thu May 25 2006 Chris Lumens <clumens@redhat.com> 0.30-1
430 - Change order of LVM-related writing functions (#193073).
431 - Require urlgrabber.
432 - Return a more useful error message on unknown commands.
433 - Fix logvol writing typo.
434 - Make ksvalidator validate from a URL in addition to a file.
435 - Don't write out an empty packages section (#192851).
437 * Tue May 23 2006 Chris Lumens <clumens@redhat.com> 0.29-1
438 - Add multipath command, handlers, and data objects (pjones).
439 - Rename --ports to --port in writer.
441 * Mon May 15 2006 Chris Lumens <clumens@redhat.com> 0.28-1
442 - Support --mtu for the network command (#191328).
443 - Accept --isUtc for backwards compatibility.
445 * Wed May 04 2006 Chris Lumens <clumens@redhat.com> 0.27-1
446 - Output formatting fixes.
447 - Added commands for managing users and services.
449 * Mon Apr 17 2006 Chris Lumens <clumens@redhat.com> 0.26-1
450 - Ignore spaces before group names (#188095).
451 - Added some translations.
452 - Add options for repo command.
453 - Reorder %%packages section output.
454 - Output %%packages header options.
455 - Initialize RAID and volume group members to empty lists.
457 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.25-1
458 - Add support for the logging command.
460 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.24-1
461 - Don't write out a blank xconfig line.
462 - Reorder output handlers to group like commands together.
463 - Mark strings for translation.
465 * Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 0.23-1
466 - Backwards compatibility support for options to zerombr.
468 * Fri Feb 24 2006 Chris Lumens <clumens@redhat.com> 0.22-1
469 - Get ignoredisk working again (#182934).
471 * Fri Feb 17 2006 Chris Lumens <clumens@redhat.com> 0.21-1
472 - Provide an option to not traceback on missing include files (#181760).
473 - Update programming documentation.
475 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.20-1
476 - Correctly set --noformat and --useexisting on lvm and raid.
478 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.19-1
479 - --onboot requires a value (#180987).
480 - Be more strict about commands that don't take arguments.
482 * Thu Feb 09 2006 Chris Lumens <clumens@redhat.com> 0.18-1
483 - Fix some errors pychecker caught.
484 - Allow exceptions to not be fatal so ksvalidator can spot more errors in
485 a single pass (#179894).
487 * Wed Feb 01 2006 Chris Lumens <clumens@redhat.com> 0.17-1
488 - Don't set a default port for vnc.
490 * Tue Jan 31 2006 Chris Lumens <clumens@redhat.com> 0.16-1
491 - Give dmraid string an initial value.
492 - Handle None on partition size.
494 * Tue Jan 31 2006 Peter Jones <pjones@redhat.com> 0.15-1
495 - Add dmraid support
497 * Mon Jan 30 2006 Chris Lumens <clumens@redhat.com> 0.14-1
498 - Fix VNC parameter parsing (#179209).
499 - Deprecate --connect. Add --host and --port instead.
501 * Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 0.13-1
502 - Recognize the --eject parameter to shutdown/halt.
503 - Store the exact post-installation action in ksdata.
505 * Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 0.12-1
506 - Clean up output quoting.
507 - Finish removing monitor-related stuff from xconfig.
509 * Mon Dec 12 2005 Chris Lumens <clumens@redhat.com> 0.11-1
510 - Deprecate monitor-related options to xconfig.
512 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
513 - Support --bytes-per-inode on raid
514 (Curtis Doty <Curtis at GreenKey.net> #175288).
516 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
517 - fixup network --onboot
519 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
520 - Default to SELINUX_ENFORCING.
521 - Default partition sizes to None for anaconda (#172378).
522 - Don't call shlex.split on anything inside a script (#172313).
524 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
525 - Fix clearpart --all.
526 - vnc command does not require --connect option (#172192).
527 - network --onboot does not take any option.
528 - Remove extra spaces from firewall --ports and --trust.
529 - Write out network --<service> options.
531 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
532 - Add --resolvedeps and --ignoredeps as deprecated options.
533 - Pass line number to header functions.
535 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
536 - Add line numbers to exception reporting.
537 - Added ksvalidator.
539 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
540 - Correct deprecated attribute on options.
541 - Added programming documentation.
543 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
544 - Correct python lib directory on 64-bit archs (#170621).
546 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
547 - Add a deprecated attribute to options.
548 - Add --card option back to xconfig and mark as deprecated.
549 - Throw a deprecation warning on mouse and langsupport commands.
550 - Rename Writer to KickstartWriter for consistency.
551 - Collapse scripts into a single list and add an attribute on Script to
552 differentiate.
554 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
555 - Rename module to pykickstart to avoid conflicts in anaconda.
556 - Rename data classes for consistency.
557 - Add default bytesPerInode settings.
559 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
560 - Created package from anaconda.