Make sure the F11 handler gets used for "partition" and "part" (#501020).
[pykickstart.git] / pykickstart.spec
blob471113cdd9e48a3ec216e4fe8e224b7422ac47e2
1 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Url: http://fedoraproject.org/wiki/pykickstart
6 Version: 1.53
7 Release: 1%{?dist}
8 # This is a Red Hat maintained package which is specific to
9 # our distribution. Thus the source is only available from
10 # within this srpm.
11 Source0: %{name}-%{version}.tar.gz
13 License: GPLv2
14 Group: System Environment/Libraries
15 BuildArch: noarch
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17 BuildRequires: python-devel, gettext, python-setuptools-devel
18 Requires: python, python-urlgrabber
20 %description
21 The pykickstart package is a python library for manipulating kickstart
22 files.
24 %prep
25 %setup -q
26 make
28 %build
30 %install
31 rm -rf %{buildroot}
32 make DESTDIR=%{buildroot} install
33 %find_lang %{name}
35 %clean
36 rm -rf %{buildroot}
38 %files -f %{name}.lang
39 %defattr(-,root,root,-)
40 %doc README ChangeLog COPYING docs/programmers-guide
41 %doc docs/kickstart-docs.txt
42 %{python_sitelib}/*
43 %{_bindir}/ksvalidator
44 %{_bindir}/ksflatten
45 %{_bindir}/ksverdiff
47 %changelog
48 * Wed Apr 29 2009 Chris Lumens <clumens@redhat.com> - 1.53-1
49 - Move lineno= from KSOptionParser.__init__ to parse_args (#497149). (clumens)
50 - Use the F11 version of the partition command. (clumens)
51 - Remove the --start and --end options since anaconda no longer uses them. (clumens)
52 - Remove a broken test case. (clumens)
54 * Wed Feb 18 2009 Chris Lumens <clumens@redhat.com> - 1.52-1
55 - Add lots more test cases (alindebe, mgracik, stickster).
56 - Add a skip attribute on key to shut up pychecker.
57 - Only show autostep command when requested (jlaska)
58 - Strip spaces from service names, and require an option to be provided.
59 - Surround services lists in double quotes.
60 - Remove the extra space from the services __str__ method.
61 - Fix output formatting bugs in firewall, partition, and repo (mgracik).
62 - Specifying both or neither of --drives and --only-use should be an error.
63 - Corrected newline char in return value of FC6_Method. (mgracik)
64 - Make --drives a required option for FC3, and catch no args on F8.
65 - Fix final printing of the rescue command (mgracik).
66 - Surround output strings in double quotes.
67 - Fix a typo in the deviceprobe command.
68 - Revert the more strict option processing on displaymode.
69 - Properly handle erroring on extra args, not just extra options.
70 - Don't use the logging class since it interferes with the logging test.
71 - port without host should raise KickstartParseError, not kickstartValueError.
72 - Add the --key option to option processing, since it's a valid argument.
73 - Fix test cases that were failing due to the new use of KSOptionParser.
74 - Teach driverdisk.py command to reject extra partitions (stickster).
75 - Add KSOptionParser to all commands ... enables more strick option checking (jlaska).
76 - Use KSOptionParser so we can catch bad command options (jlaska).
78 * Thu Jan 29 2009 Chris Lumens <clumens@redhat.com> - 1.51-1
79 - Make a couple changes to how the logging command is handled.
80 - Add a lot of test cases (clumens, alindebe, jlaska, fcami, adamwill, pfrields).
81 - Fix output formatting for the rootpw command.
82 - For commands that take exactly one argument, check and error correctly.
83 - Surround module options in quotes on the output side (jlaska).
84 - Set module opts in the FC3 handler correctly.
85 - Fix newlines on the device command output (jlaska).
86 - If --autoscreenshot is not specified, still output "autostep".
87 - Move the currentCmd and currentLine into getParser(). (jlaska)
88 - Write out an selinux line if set to disabled, but not if None.
89 - F9_LogVolData should inherit from FC4_LogVolData, not FC3_LogVolData (jlaska).
90 - Add unittest framework along with logvol and vnc unittests. (jlaska)
91 - Don't set the KSOption.required attribute in the constructor (jlaska).
93 * Sat Jan 10 2009 Chris Lumens <clumens@redhat.com> - 1.50-1
94 - Add a script to diff two versions of kickstart syntax.
95 - Add an option to ksvalidator to list all available syntax versions.
96 - Remove a couple extra newlines in output formatting.
97 - Add documentation for the new %include representation.
98 - Add support %include to the pykickstart data objects.
100 * Thu Jan 08 2009 Chris Lumens <clumens@redhat.com> - 1.49-1
101 - Add upgrade --root-device (atodorov, #471232).
102 - Use python's builtin set rather than the Sets module (#477836, dcantrell).
104 * Tue Dec 23 2008 Chris Lumens <clumens@redhat.com> - 1.48-1
105 - Allow ignoring group metadata from repos, using a '--ignoregroups'
106 boolean. (notting)
107 - Add initial support for F11.
108 - Specify the command versions in the handlers instead of making copies.
109 - Remove empty and pointless __init__ methods.
110 - Pass arguments to superclasses via *args and **kwargs, all the way up.
111 - Add removedKeywords and removedAttrs lists on Commands and Data.
112 - Fix version regexes to handle double digits and minor releases (jlaska).
114 * Thu Oct 30 2008 Chris Lumens <clumens@redhat.com> - 1.47-1
115 - Fix enabling services we specify by specific options.
117 * Mon Oct 27 2008 Chris Lumens <clumens@redhat.com> - 1.46-1
118 - Add support for firewall --service (#467005).
120 * Tue Oct 14 2008 Chris Lumens <clumens@redhat.com> - 1.45-1
121 - Lots of translation updates.
122 - Remove use of string.partition for python2.4 (atodorov).
124 * Mon Sep 22 2008 Chris Lumens <clumens@redhat.com> - 1.44-1
125 - Add support for reverse CHAP to the kickstart iscsi command (hans)
126 - Fix typo (katzj)
128 * Wed Sep 03 2008 Chris Lumens <clumens@redhat.com> - 1.43-1
129 - Revert "Do not include passphrases for encrypted block devices in
130 anaconda-ks.cfg." (dlehman)
131 - yum doesn't like when mirrorlist is "". (clumens)
133 * Mon Aug 11 2008 Chris Lumens <clumens@redhat.com> - 1.42-1
134 - Add rescue command to pykickstart (atodorov)
135 - Sort %packages output (katzj)
136 - Fix a typo (atodorov).
138 * Fri Aug 01 2008 Chris Lumens <clumens@redhat.com> - 1.41-1
139 - RHEL5 supports ignoredisk --only-use now too. (clumens)
140 - Do not include passphrases for encrypted block devices in
141 anaconda-ks.cfg. (dlehman)
142 - Fix F9,F10,RHEL5 "part" commands to use the same class as
143 "partition". (dlehman)
144 - Add an apply method() for commands and implement for lang (katzj)
146 * Tue Jul 15 2008 Chris Lumens <clumens@redhat.com> - 1.40-1
147 - RHEL5_LogVolData should inherit from FC4, not FC3.
148 Also fix FC9->F9 typo. (dlehman)
149 - Support creation of encrypted block devices in RHEL5. (#449830) (dlehman)
150 - Use the right LogVolData objects for RHEL3 and 4 (jlaska). (clumens)
151 - We no longer use rhpl for translations. (clumens)
152 - All the base classes should derive from object. (clumens)
154 * Fri Jun 13 2008 Chris Lumens <clumens@redhat.com> - 1.39-1
155 - It's helpful to return the parser object. (clumens)
157 * Tue Jun 10 2008 Chris Lumens <clumens@redhat.com> - 1.38-1
158 - Fix loading the Handler object by looking for a more specific
159 name (#450740). (clumens)
161 * Sun Jun 08 2008 Chris Lumens <clumens@redhat.com> - 1.37-1
162 - XConfig is still used by other projects, so just deprecate some
163 options. (clumens)
165 * Thu May 29 2008 Chris Lumens <clumens@redhat.com> - 1.36-1
166 - It should be repo --cost, not repo --priority. (clumens)
168 * Fri May 23 2008 Chris Lumens <clumens@redhat.com> - 1.35-1
169 - Bring driverdisk command in line with the docs. (clumens)
170 - Change RAID command print priorities (jlaska).
171 - According to docs, physvols are space delimited. (jlaska)
172 - Don't write the label out twice (jlaska).
173 - Deprecate monitor and xconfig commands. (clumens)
175 * Wed May 07 2008 Chris Lumens <clumens@redhat.com> - 1.34-1
176 - Load the handler module automatically. (clumens)
177 - Add support for F10. (clumens)
178 - Initialize cmd.handler earlier; fixes repo.methodToRepo() (markmc)
179 - Don't shadow builtin function names. (clumens)
180 - Running check is now required before pykickstart can be packaged. (clumens)
181 - Reorganize code a little bit to pass pychecker. (clumens)
183 * Tue Apr 08 2008 Chris Lumens <clumens@redhat.com> - 1.33-1
184 - Fix whitespace when printing out the bootloader command (pmeyers).
185 - Fix the type on bootloader --timeout processing. (clumens)
187 * Wed Apr 02 2008 Chris Lumens <clumens@redhat.com> - 1.32-1
188 - Make the string reader act like the file reader upon EOF. (clumens)
189 - Add syntax for encrypted logical volumes. (clumens)
191 * Tue Mar 25 2008 Chris Lumens <clumens@redhat.com> - 1.31-1
192 - Support end-of-line comments. (clumens)
193 - Lots of translation updates.
195 * Tue Feb 26 2008 Chris Lumens <clumens@redhat.com> - 1.30-1
196 - Reverse writePriorities of iscsi and iscsname (#434965, jlaska).
197 - Fix printing of iscsiname command (#434945, jlaska).
198 - Don't traceback on ENOENT. (pnasrat)
199 - Store the mouse name as a string, not a list. (clumens)
200 - Update translations.
202 * Wed Jan 30 2008 Chris Lumens <clumens@redhat.com> - 1.29-1
203 - Renamed bootproto=ask to bootproto=query, add to RHEL5 as well. (clumens)
205 * Wed Jan 23 2008 Chris Lumens <clumens@redhat.com> - 1.28-1
206 - Fix traceback on volgroup command. (clumens)
208 * Thu Jan 17 2008 Chris Lumens <clumens@redhat.com> - 1.27-1
209 - The bootprotoList needs to be defined before it's used. (clumens)
211 * Thu Jan 17 2008 Chris Lumens <clumens@redhat.com> - 1.26-1
212 - Add support for network --bootproto=ask. (clumens)
214 * Tue Jan 15 2008 Chris Lumens <clumens@redhat.com> - 1.25-1
215 - Add the version to the output ks file. (clumens)
216 - Add syntax for encrypted partitions and raid devices. (clumens)
218 * Thu Jan 10 2008 Chris Lumens <clumens@redhat.com> - 1.24-1
219 - Make inheritance and overriding of %packages work (#427768). (clumens)
220 - Add an option for which languages should be installed. (katzj)
221 - Use the right name for the iscsi --target variable (#418781). (clumens)
223 * Mon Dec 10 2007 Chris Lumens <clumens@redhat.com> - 1.23-1
224 - Take Makefile improvements from anaconda.
225 - Fix a traceback on F9 zerombr command (#395431).
226 - Update to handle new Python eggs packaging.
228 * Tue Nov 20 2007 Chris Lumens <clumens@redhat.com> 1.22-1
229 - Don't process or write out vnc --enabled (jlaska AT redhat DOT com).
230 - Fix a traceback in the clearpart command.
232 * Tue Nov 06 2007 Chris Lumens <clumens@redhat.com> 1.21-1
233 - Save script line numbers for debugging.
234 - More internal cleanups.
236 * Wed Oct 31 2007 Chris Lumens <clumens@redhat.com> 1.20-1
237 - Pull wiki docs from the new location.
238 - Fix error messages for options that have been removed after having been
239 previously deprecated.
240 - zerombr no longer takes any arguments.
241 - %packages --ignoredeps --resolvedeps have been removed.
242 - firewall --high --medium have been removed.
243 - vnc --connect has been removed.
244 - xconfig options from monitor have now been removed.
245 - --bytes-per-inode has been marked as deprecated.
246 - Fix typos.
247 - Add --fsprofile option to disk commands (pjones).
248 - Add F9 support (pjones).
249 - Lots of internal fixes (clumens, pjones).
251 * Tue Oct 23 2007 Chris Lumens <clumens@redhat.com> 1.19-1
252 - Fix a traceback on the cdrom method.
254 * Thu Oct 18 2007 Chris Lumens <clumens@redhat.com> 1.18-1
255 - Don't write out %end to packages and scripts if the syntax version doesn't
256 support it.
257 - Remove obsolete translation (#332221).
259 * Thu Oct 04 2007 Chris Lumens <clumens@redhat.com> 1.17-1
260 - Simplify argument processing and printing.
262 * Wed Oct 03 2007 Chris Lumens <clumens@redhat.com> 1.16-1
263 - Undeprecate %packages --excludedocs.
264 - Fix a traceback in the device command handling.
265 - Add bootloader --timeout (katzj).
267 * Tue Oct 02 2007 Chris Lumens <clumens@redhat.com> 1.15-1
268 - Update translations (#259121).
269 - The device command no longer takes a type argument.
271 * Fri Sep 28 2007 Chris Lumens <clumens@redhat.com> 1.14-1
272 - Fix output formatting for packages section header (#310211).
273 - Add a script to flatten kickstart files containing includes (katzj).
275 * Wed Sep 12 2007 Chris Lumens <clumens@redhat.com> 1.13-1
276 - Add a function to convert URL method strings into repo objects
277 (jkeating).
278 - Writer formatting fixes.
279 - Add kickstart documentation from the Fedora Wiki.
281 * Tue Sep 04 2007 Chris Lumens <clumens@redhat.com> 1.12-1
282 - Fix lots of problems in processing the bootloader, device, network, and
283 raid commands.
284 - Add %end when writing out scripts and packages.
285 - Add a makefile target to run pychecker to cut down on errors in
286 releases.
288 * Mon Sep 3 2007 Jeremy Katz <katzj@redhat.com> - 1.11-1
289 - fix a few tracebacks
291 * Fri Aug 31 2007 Chris Lumens <clumens@redhat.com> 1.10-1
292 - Add network --ipv6=.
294 * Fri Aug 24 2007 Chris Lumens <clumens@redhat.com> 1.9-1
295 - Add support for the %end directive to be placed at the end of scripts
296 and packages sections. Deprecate old syntax.
297 - Clean up after ksvalidator if pykickstart issues a traceback.
298 - Add support for repo --priority --includepkgs --excludepkgs.
299 - Fix newline at end of reboot --eject output (#253562).
301 * Mon Aug 13 2007 Chris Lumens <clumens@redhat.com> 1.8-1
302 - Fix type checking of string values.
304 * Thu Aug 09 2007 Chris Lumens <clumens@redhat.com> 1.7-1
305 - Clarify license in spec file and all source files.
306 - Check string values to options to make sure they're not other options
307 (#251318).
309 * Thu Aug 02 2007 Chris Lumens <clumens@redhat.com> 1.6-1
310 - Fix a couple tracebacks in ksvalidator.
311 - Change --class to --dhcpclass (#248912).
313 * Thu Jul 19 2007 Chris Lumens <clumens@redhat.com> 1.5-2
314 - Require rhpl (#248953).
316 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.5-1
317 - Fix traceback when calling preprocessKickstart.
319 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.4-1
320 - Add methods to handle the %ksappend directive.
321 - Fix ignoredisk --disks.
323 * Wed Jul 11 2007 Chris Lumens <clumens@redhat.com> - 1.3-1
324 - Add support for ignoredisk --only-use.
325 - Fix traceback in raid command printing method (#246709).
327 * Fri Jun 08 2007 Chris Lumens <clumens@redhat.com> - 1.2-2
328 - Fix package review problems (#226334).
330 * Mon Jun 04 2007 Chris Lumens <clumens@redhat.com> - 1.2-1
331 - Fix harddrive install method error checking (#232492).
332 - Set authentication information from the input line to preserve quoting
333 (#241657).
334 - Allow included files to be given by URL.
335 - Fix typo in user --iscrypted option.
337 * Mon May 14 2007 Chris Lumens <clumens@redhat.com> - 1.1-1
338 - Better regexes for splitting version strings into family and version.
339 - Add basic support for RHEL3.
340 - Update translations.
342 * Fri Apr 13 2007 Chris Lumens <clumens@redhat.com> - 1.0-1
343 - Update documentation.
344 - Update translations.
346 * Mon Mar 19 2007 Chris Lumens <clumens@redhat.com> - 0.100-1
347 - bootloader should be written out after upgrade/install.
348 - Treat class names as unicode strings (#231053).
350 * Wed Mar 07 2007 Chris Lumens <clumens@redhat.com> - 0.99-1
351 - The timezone command didn't recognize --isUtc before FC6 (#231189).
352 - Recognize %ksappend lines in ksvalidator.
353 - Don't set default values in some command __init__ methods.
354 - Added an updates command.
355 - Add support for RAID10.
357 * Mon Feb 26 2007 Chris Lumens <clumens@redhat.com> - 0.98-1
358 - Fix device command syntax to match anaconda.
359 - Fix __call__ on method command.
361 * Wed Feb 21 2007 Chris Lumens <clumens@redhat.com> - 0.97-1
362 - Fix traceback when not overriding default mappings (#229505).
364 * Tue Feb 20 2007 Chris Lumens <clumens@redhat.com> - 0.96-1
365 - Fix __str__ methods for langsupport and reboot commands.
366 - Renamed BaseHandler.empty to BaseHandler.maskAllExcept.
367 - Split command objects out into their own files in commands/.
368 - Rename command objects to start with Version_.
369 - Support extended group selection syntax.
371 * Wed Feb 14 2007 Chris Lumens <clumens@redhat.com> - 0.95-1
372 - KickstartParser no longer takes a version argument.
373 - Be more lenient in what strings stringToVersion accepts.
374 - Allow setting state on one data object from multiple files.
376 * Wed Feb 07 2007 Chris Lumens <clumens@redhat.com> - 0.94-1
377 - Add a newline to the end of the key command output.
378 - Use network bootproto constants (#197694).
379 - Fix tracebacks in subclass __str__ methods (#226734).
381 * Wed Jan 31 2007 Chris Lumens <clumens@redhat.com> - 0.93-2
382 - Make some minor spec file changes to get closer to the extras guidelines.
384 * Thu Jan 25 2007 Chris Lumens <clumens@redhat.com> - 0.93-1
385 - Add support for FC3, RHEL4, and RHEL5.
386 - The key command was not supported until after FC6.
387 - Accept more strings in stringToVersion.
389 * Fri Jan 19 2007 Chris Lumens <clumens@redhat.com> - 0.92-1
390 - Fix KickstartVersionError reporting.
391 - Add a version attribute to handler objects.
392 - Fix line number reporting on lots of commands.
393 - Add initial support for Fedora 7 and remove deprecated commands.
394 - Accept a --default argument to the %%packages header (#221305).
396 * Wed Jan 17 2007 Chris Lumens <clumens@redhat.com> - 0.91-1
397 - Add a method to read kickstart files from strings.
399 * Tue Jan 16 2007 Chris Lumens <clumens@redhat.com> - 0.90-1
400 - Support multiple versions of kickstart syntax from one code base
401 (#189348).
402 - Fix inconsistency between Script parser and writer (#222877).
404 * Fri Dec 15 2006 Chris Lumens <clumens@redhat.com> - 0.43-1
405 - Pull in new translations (#216620).
407 * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.42-2
408 - rebuild against python 2.5
410 * Tue Dec 05 2006 Chris Lumens <clumens@redhat.com> - 0.42-1
411 - Fix traceback when writing out repo command (#218274).
413 * Fri Dec 01 2006 Chris Lumens <clumens@redhat.com> - 0.41-1
414 - Fix traceback when using deprecated commands (#218047, #218059).
416 * Thu Nov 30 2006 Chris Lumens <clumens@redhat.com> - 0.40-1
417 - Pull in new translations (#216620).
418 - Add --level argument to logging command writer.
420 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-2
421 - Fix release number.
423 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-1
424 - Add writer for --key (#211997).
426 * Tue Oct 17 2006 Jeremy Katz <katzj@redhat.com> - 0.38-1
427 - allow --skip for installation number as well (#207029)
429 * Mon Oct 16 2006 Jeremy Katz <katzj@redhat.com> - 0.37-1
430 - support for installation numbers (#207029)
432 * Fri Oct 13 2006 Bill Nottingham <notting@redhat.com> - 0.36-1
433 - use valid charsets in translations (#210720)
435 * Fri Sep 29 2006 Chris Lumens <clumens@redhat.com> - 0.35-1
436 - Fix traceback in harddrive command (#208557).
438 * Mon Sep 25 2006 Chris Lumens <clumens@redhat.com> - 0.34-1
439 - Add support for --biospart option to harddrive (#207585).
440 - Update writer for syntax changes.
442 * Wed Sep 20 2006 Jeremy Katz <katzj@redhat.com> - 0.33-1
443 - improved iscsi syntax
444 - allow multiple zfcp devs
446 * Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 0.32-1
447 - Limit --bootproto to what anaconda supports.
448 - Add --noipv4 and --noipv6 network options.
450 * Tue Jun 20 2006 Chris Lumens <clumens@redhat.com> 0.31-1
451 - Handle nfs --opts (katzj).
452 - RAID devices should be integers instead of strings (#176537).
453 - Add initial support for iscsi (katzj).
455 * Tue Jun 06 2006 Chris Lumens <clumens@redhat.com> 0.30-2
456 - Add BuildRequires to fix building under mock (#194156, Joost Soeterbroek
457 <fedora AT soeterbroek.com>).
459 * Thu May 25 2006 Chris Lumens <clumens@redhat.com> 0.30-1
460 - Change order of LVM-related writing functions (#193073).
461 - Require urlgrabber.
462 - Return a more useful error message on unknown commands.
463 - Fix logvol writing typo.
464 - Make ksvalidator validate from a URL in addition to a file.
465 - Don't write out an empty packages section (#192851).
467 * Tue May 23 2006 Chris Lumens <clumens@redhat.com> 0.29-1
468 - Add multipath command, handlers, and data objects (pjones).
469 - Rename --ports to --port in writer.
471 * Mon May 15 2006 Chris Lumens <clumens@redhat.com> 0.28-1
472 - Support --mtu for the network command (#191328).
473 - Accept --isUtc for backwards compatibility.
475 * Wed May 04 2006 Chris Lumens <clumens@redhat.com> 0.27-1
476 - Output formatting fixes.
477 - Added commands for managing users and services.
479 * Mon Apr 17 2006 Chris Lumens <clumens@redhat.com> 0.26-1
480 - Ignore spaces before group names (#188095).
481 - Added some translations.
482 - Add options for repo command.
483 - Reorder %%packages section output.
484 - Output %%packages header options.
485 - Initialize RAID and volume group members to empty lists.
487 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.25-1
488 - Add support for the logging command.
490 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.24-1
491 - Don't write out a blank xconfig line.
492 - Reorder output handlers to group like commands together.
493 - Mark strings for translation.
495 * Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 0.23-1
496 - Backwards compatibility support for options to zerombr.
498 * Fri Feb 24 2006 Chris Lumens <clumens@redhat.com> 0.22-1
499 - Get ignoredisk working again (#182934).
501 * Fri Feb 17 2006 Chris Lumens <clumens@redhat.com> 0.21-1
502 - Provide an option to not traceback on missing include files (#181760).
503 - Update programming documentation.
505 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.20-1
506 - Correctly set --noformat and --useexisting on lvm and raid.
508 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.19-1
509 - --onboot requires a value (#180987).
510 - Be more strict about commands that don't take arguments.
512 * Thu Feb 09 2006 Chris Lumens <clumens@redhat.com> 0.18-1
513 - Fix some errors pychecker caught.
514 - Allow exceptions to not be fatal so ksvalidator can spot more errors in
515 a single pass (#179894).
517 * Wed Feb 01 2006 Chris Lumens <clumens@redhat.com> 0.17-1
518 - Don't set a default port for vnc.
520 * Tue Jan 31 2006 Chris Lumens <clumens@redhat.com> 0.16-1
521 - Give dmraid string an initial value.
522 - Handle None on partition size.
524 * Tue Jan 31 2006 Peter Jones <pjones@redhat.com> 0.15-1
525 - Add dmraid support
527 * Mon Jan 30 2006 Chris Lumens <clumens@redhat.com> 0.14-1
528 - Fix VNC parameter parsing (#179209).
529 - Deprecate --connect. Add --host and --port instead.
531 * Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 0.13-1
532 - Recognize the --eject parameter to shutdown/halt.
533 - Store the exact post-installation action in ksdata.
535 * Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 0.12-1
536 - Clean up output quoting.
537 - Finish removing monitor-related stuff from xconfig.
539 * Mon Dec 12 2005 Chris Lumens <clumens@redhat.com> 0.11-1
540 - Deprecate monitor-related options to xconfig.
542 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
543 - Support --bytes-per-inode on raid
544 (Curtis Doty <Curtis at GreenKey.net> #175288).
546 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
547 - fixup network --onboot
549 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
550 - Default to SELINUX_ENFORCING.
551 - Default partition sizes to None for anaconda (#172378).
552 - Don't call shlex.split on anything inside a script (#172313).
554 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
555 - Fix clearpart --all.
556 - vnc command does not require --connect option (#172192).
557 - network --onboot does not take any option.
558 - Remove extra spaces from firewall --ports and --trust.
559 - Write out network --<service> options.
561 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
562 - Add --resolvedeps and --ignoredeps as deprecated options.
563 - Pass line number to header functions.
565 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
566 - Add line numbers to exception reporting.
567 - Added ksvalidator.
569 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
570 - Correct deprecated attribute on options.
571 - Added programming documentation.
573 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
574 - Correct python lib directory on 64-bit archs (#170621).
576 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
577 - Add a deprecated attribute to options.
578 - Add --card option back to xconfig and mark as deprecated.
579 - Throw a deprecation warning on mouse and langsupport commands.
580 - Rename Writer to KickstartWriter for consistency.
581 - Collapse scripts into a single list and add an attribute on Script to
582 differentiate.
584 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
585 - Rename module to pykickstart to avoid conflicts in anaconda.
586 - Rename data classes for consistency.
587 - Add default bytesPerInode settings.
589 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
590 - Created package from anaconda.