New version.
[pykickstart.git] / pykickstart.spec
blobf99ea817ab48d5d8711a3ad8b45d8e39a9cf0116
1 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Url: http://fedoraproject.org/wiki/pykickstart
6 Version: 1.2
7 Release: 1%{?dist}
8 Source0: %{name}-%{version}.tar.gz
9 License: GPL
10 Group: System Environment/Libraries
11 BuildArch: noarch
12 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13 BuildRequires: python-devel, gettext
14 Requires: python, python-urlgrabber
16 %description
17 The pykickstart package is a python library for manipulating kickstart
18 files.
20 %prep
21 %setup -q
22 make
24 %build
26 %install
27 rm -rf %{buildroot}
28 make DESTDIR=%{buildroot} install
29 %find_lang %{name}
31 %clean
32 rm -rf %{buildroot}
34 %files -f %{name}.lang
35 %defattr(-,root,root,-)
36 %doc README ChangeLog COPYING docs/programmers-guide
37 %{python_sitelib}/pykickstart
38 %{_bindir}/ksvalidator
40 %changelog
41 * Mon Jun 04 2007 Chris Lumens <clumens@redhat.com> - 1.2-1
42 - Fix harddrive install method error checking (#232492).
43 - Set authentication information from the input line to preserve quoting
44 (#241657).
45 - Allow included files to be given by URL.
46 - Fix typo in user --iscrypted option.
48 * Mon May 14 2007 Chris Lumens <clumens@redhat.com> - 1.1-1
49 - Better regexes for splitting version strings into family and version.
50 - Add basic support for RHEL3.
51 - Update translations.
53 * Fri Apr 13 2007 Chris Lumens <clumens@redhat.com> - 1.0-1
54 - Update documentation.
55 - Update translations.
57 * Mon Mar 19 2007 Chris Lumens <clumens@redhat.com> - 0.100-1
58 - bootloader should be written out after upgrade/install.
59 - Treat class names as unicode strings (#231053).
61 * Wed Mar 07 2007 Chris Lumens <clumens@redhat.com> - 0.99-1
62 - The timezone command didn't recognize --isUtc before FC6 (#231189).
63 - Recognize %ksappend lines in ksvalidator.
64 - Don't set default values in some command __init__ methods.
65 - Added an updates command.
66 - Add support for RAID10.
68 * Mon Feb 26 2007 Chris Lumens <clumens@redhat.com> - 0.98-1
69 - Fix device command syntax to match anaconda.
70 - Fix __call__ on method command.
72 * Wed Feb 21 2007 Chris Lumens <clumens@redhat.com> - 0.97-1
73 - Fix traceback when not overriding default mappings (#229505).
75 * Tue Feb 20 2007 Chris Lumens <clumens@redhat.com> - 0.96-1
76 - Fix __str__ methods for langsupport and reboot commands.
77 - Renamed BaseHandler.empty to BaseHandler.maskAllExcept.
78 - Split command objects out into their own files in commands/.
79 - Rename command objects to start with Version_.
80 - Support extended group selection syntax.
82 * Wed Feb 14 2007 Chris Lumens <clumens@redhat.com> - 0.95-1
83 - KickstartParser no longer takes a version argument.
84 - Be more lenient in what strings stringToVersion accepts.
85 - Allow setting state on one data object from multiple files.
87 * Wed Feb 07 2007 Chris Lumens <clumens@redhat.com> - 0.94-1
88 - Add a newline to the end of the key command output.
89 - Use network bootproto constants (#197694).
90 - Fix tracebacks in subclass __str__ methods (#226734).
92 * Wed Jan 31 2007 Chris Lumens <clumens@redhat.com> - 0.93-2
93 - Make some minor spec file changes to get closer to the extras guidelines.
95 * Thu Jan 25 2007 Chris Lumens <clumens@redhat.com> - 0.93-1
96 - Add support for FC3, RHEL4, and RHEL5.
97 - The key command was not supported until after FC6.
98 - Accept more strings in stringToVersion.
100 * Fri Jan 19 2007 Chris Lumens <clumens@redhat.com> - 0.92-1
101 - Fix KickstartVersionError reporting.
102 - Add a version attribute to handler objects.
103 - Fix line number reporting on lots of commands.
104 - Add initial support for Fedora 7 and remove deprecated commands.
105 - Accept a --default argument to the %%packages header (#221305).
107 * Wed Jan 17 2007 Chris Lumens <clumens@redhat.com> - 0.91-1
108 - Add a method to read kickstart files from strings.
110 * Tue Jan 16 2007 Chris Lumens <clumens@redhat.com> - 0.90-1
111 - Support multiple versions of kickstart syntax from one code base
112 (#189348).
113 - Fix inconsistency between Script parser and writer (#222877).
115 * Fri Dec 15 2006 Chris Lumens <clumens@redhat.com> - 0.43-1
116 - Pull in new translations (#216620).
118 * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.42-2
119 - rebuild against python 2.5
121 * Tue Dec 05 2006 Chris Lumens <clumens@redhat.com> - 0.42-1
122 - Fix traceback when writing out repo command (#218274).
124 * Fri Dec 01 2006 Chris Lumens <clumens@redhat.com> - 0.41-1
125 - Fix traceback when using deprecated commands (#218047, #218059).
127 * Thu Nov 30 2006 Chris Lumens <clumens@redhat.com> - 0.40-1
128 - Pull in new translations (#216620).
129 - Add --level argument to logging command writer.
131 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-2
132 - Fix release number.
134 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-1
135 - Add writer for --key (#211997).
137 * Tue Oct 17 2006 Jeremy Katz <katzj@redhat.com> - 0.38-1
138 - allow --skip for installation number as well (#207029)
140 * Mon Oct 16 2006 Jeremy Katz <katzj@redhat.com> - 0.37-1
141 - support for installation numbers (#207029)
143 * Fri Oct 13 2006 Bill Nottingham <notting@redhat.com> - 0.36-1
144 - use valid charsets in translations (#210720)
146 * Fri Sep 29 2006 Chris Lumens <clumens@redhat.com> - 0.35-1
147 - Fix traceback in harddrive command (#208557).
149 * Mon Sep 25 2006 Chris Lumens <clumens@redhat.com> - 0.34-1
150 - Add support for --biospart option to harddrive (#207585).
151 - Update writer for syntax changes.
153 * Wed Sep 20 2006 Jeremy Katz <katzj@redhat.com> - 0.33-1
154 - improved iscsi syntax
155 - allow multiple zfcp devs
157 * Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 0.32-1
158 - Limit --bootproto to what anaconda supports.
159 - Add --noipv4 and --noipv6 network options.
161 * Tue Jun 20 2006 Chris Lumens <clumens@redhat.com> 0.31-1
162 - Handle nfs --opts (katzj).
163 - RAID devices should be integers instead of strings (#176537).
164 - Add initial support for iscsi (katzj).
166 * Tue Jun 06 2006 Chris Lumens <clumens@redhat.com> 0.30-2
167 - Add BuildRequires to fix building under mock (#194156, Joost Soeterbroek
168 <fedora AT soeterbroek.com>).
170 * Thu May 25 2006 Chris Lumens <clumens@redhat.com> 0.30-1
171 - Change order of LVM-related writing functions (#193073).
172 - Require urlgrabber.
173 - Return a more useful error message on unknown commands.
174 - Fix logvol writing typo.
175 - Make ksvalidator validate from a URL in addition to a file.
176 - Don't write out an empty packages section (#192851).
178 * Tue May 23 2006 Chris Lumens <clumens@redhat.com> 0.29-1
179 - Add multipath command, handlers, and data objects (pjones).
180 - Rename --ports to --port in writer.
182 * Mon May 15 2006 Chris Lumens <clumens@redhat.com> 0.28-1
183 - Support --mtu for the network command (#191328).
184 - Accept --isUtc for backwards compatibility.
186 * Wed May 04 2006 Chris Lumens <clumens@redhat.com> 0.27-1
187 - Output formatting fixes.
188 - Added commands for managing users and services.
190 * Mon Apr 17 2006 Chris Lumens <clumens@redhat.com> 0.26-1
191 - Ignore spaces before group names (#188095).
192 - Added some translations.
193 - Add options for repo command.
194 - Reorder %%packages section output.
195 - Output %%packages header options.
196 - Initialize RAID and volume group members to empty lists.
198 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.25-1
199 - Add support for the logging command.
201 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.24-1
202 - Don't write out a blank xconfig line.
203 - Reorder output handlers to group like commands together.
204 - Mark strings for translation.
206 * Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 0.23-1
207 - Backwards compatibility support for options to zerombr.
209 * Fri Feb 24 2006 Chris Lumens <clumens@redhat.com> 0.22-1
210 - Get ignoredisk working again (#182934).
212 * Fri Feb 17 2006 Chris Lumens <clumens@redhat.com> 0.21-1
213 - Provide an option to not traceback on missing include files (#181760).
214 - Update programming documentation.
216 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.20-1
217 - Correctly set --noformat and --useexisting on lvm and raid.
219 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.19-1
220 - --onboot requires a value (#180987).
221 - Be more strict about commands that don't take arguments.
223 * Thu Feb 09 2006 Chris Lumens <clumens@redhat.com> 0.18-1
224 - Fix some errors pychecker caught.
225 - Allow exceptions to not be fatal so ksvalidator can spot more errors in
226 a single pass (#179894).
228 * Wed Feb 01 2006 Chris Lumens <clumens@redhat.com> 0.17-1
229 - Don't set a default port for vnc.
231 * Tue Jan 31 2006 Chris Lumens <clumens@redhat.com> 0.16-1
232 - Give dmraid string an initial value.
233 - Handle None on partition size.
235 * Tue Jan 31 2006 Peter Jones <pjones@redhat.com> 0.15-1
236 - Add dmraid support
238 * Mon Jan 30 2006 Chris Lumens <clumens@redhat.com> 0.14-1
239 - Fix VNC parameter parsing (#179209).
240 - Deprecate --connect. Add --host and --port instead.
242 * Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 0.13-1
243 - Recognize the --eject parameter to shutdown/halt.
244 - Store the exact post-installation action in ksdata.
246 * Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 0.12-1
247 - Clean up output quoting.
248 - Finish removing monitor-related stuff from xconfig.
250 * Mon Dec 12 2005 Chris Lumens <clumens@redhat.com> 0.11-1
251 - Deprecate monitor-related options to xconfig.
253 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
254 - Support --bytes-per-inode on raid
255 (Curtis Doty <Curtis at GreenKey.net> #175288).
257 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
258 - fixup network --onboot
260 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
261 - Default to SELINUX_ENFORCING.
262 - Default partition sizes to None for anaconda (#172378).
263 - Don't call shlex.split on anything inside a script (#172313).
265 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
266 - Fix clearpart --all.
267 - vnc command does not require --connect option (#172192).
268 - network --onboot does not take any option.
269 - Remove extra spaces from firewall --ports and --trust.
270 - Write out network --<service> options.
272 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
273 - Add --resolvedeps and --ignoredeps as deprecated options.
274 - Pass line number to header functions.
276 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
277 - Add line numbers to exception reporting.
278 - Added ksvalidator.
280 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
281 - Correct deprecated attribute on options.
282 - Added programming documentation.
284 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
285 - Correct python lib directory on 64-bit archs (#170621).
287 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
288 - Add a deprecated attribute to options.
289 - Add --card option back to xconfig and mark as deprecated.
290 - Throw a deprecation warning on mouse and langsupport commands.
291 - Rename Writer to KickstartWriter for consistency.
292 - Collapse scripts into a single list and add an attribute on Script to
293 differentiate.
295 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
296 - Rename module to pykickstart to avoid conflicts in anaconda.
297 - Rename data classes for consistency.
298 - Add default bytesPerInode settings.
300 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
301 - Created package from anaconda.