If an option parser object has the same option added twice, allow the later one
[pykickstart.git] / pykickstart.spec
blob41b5684ddb723340e9fa7c02c31600cad3094fe6
1 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Url: http://fedoraproject.org/wiki/pykickstart
6 Version: 1.15
7 Release: 1%{?dist}
8 # This is a Red Hat maintained package which is specific to
9 # our distribution. Thus the source is only available from
10 # within this srpm.
11 Source0: %{name}-%{version}.tar.gz
13 License: GPLv2
14 Group: System Environment/Libraries
15 BuildArch: noarch
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17 BuildRequires: python-devel, gettext
18 Requires: python, python-urlgrabber, rhpl
20 %description
21 The pykickstart package is a python library for manipulating kickstart
22 files.
24 %prep
25 %setup -q
26 make
28 %build
30 %install
31 rm -rf %{buildroot}
32 make DESTDIR=%{buildroot} install
33 %find_lang %{name}
35 %clean
36 rm -rf %{buildroot}
38 %files -f %{name}.lang
39 %defattr(-,root,root,-)
40 %doc README ChangeLog COPYING docs/programmers-guide
41 %doc docs/kickstart-docs.txt
42 %{python_sitelib}/pykickstart
43 %{_bindir}/ksvalidator
44 %{_bindir}/ksflatten
46 %changelog
47 * Tue Oct 02 2007 Chris Lumens <clumens@redhat.com> 1.15-1
48 - Update translations (#259121).
49 - The device command no longer takes a type argument.
51 * Fri Sep 28 2007 Chris Lumens <clumens@redhat.com> 1.14-1
52 - Fix output formatting for packages section header (#310211).
53 - Add a script to flatten kickstart files containing includes (katzj).
55 * Wed Sep 12 2007 Chris Lumens <clumens@redhat.com> 1.13-1
56 - Add a function to convert URL method strings into repo objects
57 (jkeating).
58 - Writer formatting fixes.
59 - Add kickstart documentation from the Fedora Wiki.
61 * Tue Sep 04 2007 Chris Lumens <clumens@redhat.com> 1.12-1
62 - Fix lots of problems in processing the bootloader, device, network, and
63 raid commands.
64 - Add %end when writing out scripts and packages.
65 - Add a makefile target to run pychecker to cut down on errors in
66 releases.
68 * Mon Sep 3 2007 Jeremy Katz <katzj@redhat.com> - 1.11-1
69 - fix a few tracebacks
71 * Fri Aug 31 2007 Chris Lumens <clumens@redhat.com> 1.10-1
72 - Add network --ipv6=.
74 * Fri Aug 24 2007 Chris Lumens <clumens@redhat.com> 1.9-1
75 - Add support for the %end directive to be placed at the end of scripts
76 and packages sections. Deprecate old syntax.
77 - Clean up after ksvalidator if pykickstart issues a traceback.
78 - Add support for repo --priority --includepkgs --excludepkgs.
79 - Fix newline at end of reboot --eject output (#253562).
81 * Mon Aug 13 2007 Chris Lumens <clumens@redhat.com> 1.8-1
82 - Fix type checking of string values.
84 * Thu Aug 09 2007 Chris Lumens <clumens@redhat.com> 1.7-1
85 - Clarify license in spec file and all source files.
86 - Check string values to options to make sure they're not other options
87 (#251318).
89 * Thu Aug 02 2007 Chris Lumens <clumens@redhat.com> 1.6-1
90 - Fix a couple tracebacks in ksvalidator.
91 - Change --class to --dhcpclass (#248912).
93 * Thu Jul 19 2007 Chris Lumens <clumens@redhat.com> 1.5-2
94 - Require rhpl (#248953).
96 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.5-1
97 - Fix traceback when calling preprocessKickstart.
99 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.4-1
100 - Add methods to handle the %ksappend directive.
101 - Fix ignoredisk --disks.
103 * Wed Jul 11 2007 Chris Lumens <clumens@redhat.com> - 1.3-1
104 - Add support for ignoredisk --only-use.
105 - Fix traceback in raid command printing method (#246709).
107 * Fri Jun 08 2007 Chris Lumens <clumens@redhat.com> - 1.2-2
108 - Fix package review problems (#226334).
110 * Mon Jun 04 2007 Chris Lumens <clumens@redhat.com> - 1.2-1
111 - Fix harddrive install method error checking (#232492).
112 - Set authentication information from the input line to preserve quoting
113 (#241657).
114 - Allow included files to be given by URL.
115 - Fix typo in user --iscrypted option.
117 * Mon May 14 2007 Chris Lumens <clumens@redhat.com> - 1.1-1
118 - Better regexes for splitting version strings into family and version.
119 - Add basic support for RHEL3.
120 - Update translations.
122 * Fri Apr 13 2007 Chris Lumens <clumens@redhat.com> - 1.0-1
123 - Update documentation.
124 - Update translations.
126 * Mon Mar 19 2007 Chris Lumens <clumens@redhat.com> - 0.100-1
127 - bootloader should be written out after upgrade/install.
128 - Treat class names as unicode strings (#231053).
130 * Wed Mar 07 2007 Chris Lumens <clumens@redhat.com> - 0.99-1
131 - The timezone command didn't recognize --isUtc before FC6 (#231189).
132 - Recognize %ksappend lines in ksvalidator.
133 - Don't set default values in some command __init__ methods.
134 - Added an updates command.
135 - Add support for RAID10.
137 * Mon Feb 26 2007 Chris Lumens <clumens@redhat.com> - 0.98-1
138 - Fix device command syntax to match anaconda.
139 - Fix __call__ on method command.
141 * Wed Feb 21 2007 Chris Lumens <clumens@redhat.com> - 0.97-1
142 - Fix traceback when not overriding default mappings (#229505).
144 * Tue Feb 20 2007 Chris Lumens <clumens@redhat.com> - 0.96-1
145 - Fix __str__ methods for langsupport and reboot commands.
146 - Renamed BaseHandler.empty to BaseHandler.maskAllExcept.
147 - Split command objects out into their own files in commands/.
148 - Rename command objects to start with Version_.
149 - Support extended group selection syntax.
151 * Wed Feb 14 2007 Chris Lumens <clumens@redhat.com> - 0.95-1
152 - KickstartParser no longer takes a version argument.
153 - Be more lenient in what strings stringToVersion accepts.
154 - Allow setting state on one data object from multiple files.
156 * Wed Feb 07 2007 Chris Lumens <clumens@redhat.com> - 0.94-1
157 - Add a newline to the end of the key command output.
158 - Use network bootproto constants (#197694).
159 - Fix tracebacks in subclass __str__ methods (#226734).
161 * Wed Jan 31 2007 Chris Lumens <clumens@redhat.com> - 0.93-2
162 - Make some minor spec file changes to get closer to the extras guidelines.
164 * Thu Jan 25 2007 Chris Lumens <clumens@redhat.com> - 0.93-1
165 - Add support for FC3, RHEL4, and RHEL5.
166 - The key command was not supported until after FC6.
167 - Accept more strings in stringToVersion.
169 * Fri Jan 19 2007 Chris Lumens <clumens@redhat.com> - 0.92-1
170 - Fix KickstartVersionError reporting.
171 - Add a version attribute to handler objects.
172 - Fix line number reporting on lots of commands.
173 - Add initial support for Fedora 7 and remove deprecated commands.
174 - Accept a --default argument to the %%packages header (#221305).
176 * Wed Jan 17 2007 Chris Lumens <clumens@redhat.com> - 0.91-1
177 - Add a method to read kickstart files from strings.
179 * Tue Jan 16 2007 Chris Lumens <clumens@redhat.com> - 0.90-1
180 - Support multiple versions of kickstart syntax from one code base
181 (#189348).
182 - Fix inconsistency between Script parser and writer (#222877).
184 * Fri Dec 15 2006 Chris Lumens <clumens@redhat.com> - 0.43-1
185 - Pull in new translations (#216620).
187 * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.42-2
188 - rebuild against python 2.5
190 * Tue Dec 05 2006 Chris Lumens <clumens@redhat.com> - 0.42-1
191 - Fix traceback when writing out repo command (#218274).
193 * Fri Dec 01 2006 Chris Lumens <clumens@redhat.com> - 0.41-1
194 - Fix traceback when using deprecated commands (#218047, #218059).
196 * Thu Nov 30 2006 Chris Lumens <clumens@redhat.com> - 0.40-1
197 - Pull in new translations (#216620).
198 - Add --level argument to logging command writer.
200 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-2
201 - Fix release number.
203 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-1
204 - Add writer for --key (#211997).
206 * Tue Oct 17 2006 Jeremy Katz <katzj@redhat.com> - 0.38-1
207 - allow --skip for installation number as well (#207029)
209 * Mon Oct 16 2006 Jeremy Katz <katzj@redhat.com> - 0.37-1
210 - support for installation numbers (#207029)
212 * Fri Oct 13 2006 Bill Nottingham <notting@redhat.com> - 0.36-1
213 - use valid charsets in translations (#210720)
215 * Fri Sep 29 2006 Chris Lumens <clumens@redhat.com> - 0.35-1
216 - Fix traceback in harddrive command (#208557).
218 * Mon Sep 25 2006 Chris Lumens <clumens@redhat.com> - 0.34-1
219 - Add support for --biospart option to harddrive (#207585).
220 - Update writer for syntax changes.
222 * Wed Sep 20 2006 Jeremy Katz <katzj@redhat.com> - 0.33-1
223 - improved iscsi syntax
224 - allow multiple zfcp devs
226 * Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 0.32-1
227 - Limit --bootproto to what anaconda supports.
228 - Add --noipv4 and --noipv6 network options.
230 * Tue Jun 20 2006 Chris Lumens <clumens@redhat.com> 0.31-1
231 - Handle nfs --opts (katzj).
232 - RAID devices should be integers instead of strings (#176537).
233 - Add initial support for iscsi (katzj).
235 * Tue Jun 06 2006 Chris Lumens <clumens@redhat.com> 0.30-2
236 - Add BuildRequires to fix building under mock (#194156, Joost Soeterbroek
237 <fedora AT soeterbroek.com>).
239 * Thu May 25 2006 Chris Lumens <clumens@redhat.com> 0.30-1
240 - Change order of LVM-related writing functions (#193073).
241 - Require urlgrabber.
242 - Return a more useful error message on unknown commands.
243 - Fix logvol writing typo.
244 - Make ksvalidator validate from a URL in addition to a file.
245 - Don't write out an empty packages section (#192851).
247 * Tue May 23 2006 Chris Lumens <clumens@redhat.com> 0.29-1
248 - Add multipath command, handlers, and data objects (pjones).
249 - Rename --ports to --port in writer.
251 * Mon May 15 2006 Chris Lumens <clumens@redhat.com> 0.28-1
252 - Support --mtu for the network command (#191328).
253 - Accept --isUtc for backwards compatibility.
255 * Wed May 04 2006 Chris Lumens <clumens@redhat.com> 0.27-1
256 - Output formatting fixes.
257 - Added commands for managing users and services.
259 * Mon Apr 17 2006 Chris Lumens <clumens@redhat.com> 0.26-1
260 - Ignore spaces before group names (#188095).
261 - Added some translations.
262 - Add options for repo command.
263 - Reorder %%packages section output.
264 - Output %%packages header options.
265 - Initialize RAID and volume group members to empty lists.
267 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.25-1
268 - Add support for the logging command.
270 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.24-1
271 - Don't write out a blank xconfig line.
272 - Reorder output handlers to group like commands together.
273 - Mark strings for translation.
275 * Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 0.23-1
276 - Backwards compatibility support for options to zerombr.
278 * Fri Feb 24 2006 Chris Lumens <clumens@redhat.com> 0.22-1
279 - Get ignoredisk working again (#182934).
281 * Fri Feb 17 2006 Chris Lumens <clumens@redhat.com> 0.21-1
282 - Provide an option to not traceback on missing include files (#181760).
283 - Update programming documentation.
285 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.20-1
286 - Correctly set --noformat and --useexisting on lvm and raid.
288 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.19-1
289 - --onboot requires a value (#180987).
290 - Be more strict about commands that don't take arguments.
292 * Thu Feb 09 2006 Chris Lumens <clumens@redhat.com> 0.18-1
293 - Fix some errors pychecker caught.
294 - Allow exceptions to not be fatal so ksvalidator can spot more errors in
295 a single pass (#179894).
297 * Wed Feb 01 2006 Chris Lumens <clumens@redhat.com> 0.17-1
298 - Don't set a default port for vnc.
300 * Tue Jan 31 2006 Chris Lumens <clumens@redhat.com> 0.16-1
301 - Give dmraid string an initial value.
302 - Handle None on partition size.
304 * Tue Jan 31 2006 Peter Jones <pjones@redhat.com> 0.15-1
305 - Add dmraid support
307 * Mon Jan 30 2006 Chris Lumens <clumens@redhat.com> 0.14-1
308 - Fix VNC parameter parsing (#179209).
309 - Deprecate --connect. Add --host and --port instead.
311 * Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 0.13-1
312 - Recognize the --eject parameter to shutdown/halt.
313 - Store the exact post-installation action in ksdata.
315 * Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 0.12-1
316 - Clean up output quoting.
317 - Finish removing monitor-related stuff from xconfig.
319 * Mon Dec 12 2005 Chris Lumens <clumens@redhat.com> 0.11-1
320 - Deprecate monitor-related options to xconfig.
322 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
323 - Support --bytes-per-inode on raid
324 (Curtis Doty <Curtis at GreenKey.net> #175288).
326 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
327 - fixup network --onboot
329 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
330 - Default to SELINUX_ENFORCING.
331 - Default partition sizes to None for anaconda (#172378).
332 - Don't call shlex.split on anything inside a script (#172313).
334 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
335 - Fix clearpart --all.
336 - vnc command does not require --connect option (#172192).
337 - network --onboot does not take any option.
338 - Remove extra spaces from firewall --ports and --trust.
339 - Write out network --<service> options.
341 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
342 - Add --resolvedeps and --ignoredeps as deprecated options.
343 - Pass line number to header functions.
345 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
346 - Add line numbers to exception reporting.
347 - Added ksvalidator.
349 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
350 - Correct deprecated attribute on options.
351 - Added programming documentation.
353 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
354 - Correct python lib directory on 64-bit archs (#170621).
356 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
357 - Add a deprecated attribute to options.
358 - Add --card option back to xconfig and mark as deprecated.
359 - Throw a deprecation warning on mouse and langsupport commands.
360 - Rename Writer to KickstartWriter for consistency.
361 - Collapse scripts into a single list and add an attribute on Script to
362 differentiate.
364 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
365 - Rename module to pykickstart to avoid conflicts in anaconda.
366 - Rename data classes for consistency.
367 - Add default bytesPerInode settings.
369 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
370 - Created package from anaconda.