Reorder output handlers.
[pykickstart.git] / pykickstart.spec
blob0077edbd2ee0e8b42ba2ec395704bc0f644c430d
1 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Version: 0.23
6 Release: 1
7 Source0: %{name}-%{version}.tar.gz
8 License: GPL
9 Group: System Environment/Libraries
10 BuildArch: noarch
11 BuildRoot: %{_tmppath}/%{name}-root
12 BuildRequires: python-devel
13 Requires: python >= %(%{__python} -c "import sys; print sys.version[:3]")
15 %description
16 The pykickstart package is a python library for manipulating kickstart
17 files.
19 %prep
20 %setup -q
21 make
23 %build
25 %install
26 rm -rf $RPM_BUILD_ROOT
27 python setup.py install --root=${RPM_BUILD_ROOT}
29 %clean
30 rm -rf $RPM_BUILD_ROOT
32 %files
33 %defattr(-,root,root)
34 %doc README ChangeLog COPYING docs/programmers-guide
35 %{python_sitelib}/pykickstart
36 /usr/bin/ksvalidator
38 %changelog
39 * Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 0.23-1
40 - Backwards compatibility support for options to zerombr.
42 * Fri Feb 24 2006 Chris Lumens <clumens@redhat.com> 0.22-1
43 - Get ignoredisk working again (#182934).
45 * Fri Feb 17 2006 Chris Lumens <clumens@redhat.com> 0.21-1
46 - Provide an option to not traceback on missing include files (#181760).
47 - Update programming documentation.
49 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.20-1
50 - Correctly set --noformat and --useexisting on lvm and raid.
52 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.19-1
53 - --onboot requires a value (#180987).
54 - Be more strict about commands that don't take arguments.
56 * Thu Feb 09 2006 Chris Lumens <clumens@redhat.com> 0.18-1
57 - Fix some errors pychecker caught.
58 - Allow exceptions to not be fatal so ksvalidator can spot more errors in
59 a single pass (#179894).
61 * Wed Feb 01 2006 Chris Lumens <clumens@redhat.com> 0.17-1
62 - Don't set a default port for vnc.
64 * Tue Jan 31 2006 Chris Lumens <clumens@redhat.com> 0.16-1
65 - Give dmraid string an initial value.
66 - Handle None on partition size.
68 * Tue Jan 31 2006 Peter Jones <pjones@redhat.com> 0.15-1
69 - Add dmraid support
71 * Mon Jan 30 2006 Chris Lumens <clumens@redhat.com> 0.14-1
72 - Fix VNC parameter parsing (#179209).
73 - Deprecate --connect. Add --host and --port instead.
75 * Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 0.13-1
76 - Recognize the --eject parameter to shutdown/halt.
77 - Store the exact post-installation action in ksdata.
79 * Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 0.12-1
80 - Clean up output quoting.
81 - Finish removing monitor-related stuff from xconfig.
83 * Mon Dec 12 2005 Chris Lumens <clumens@redhat.com> 0.11-1
84 - Deprecate monitor-related options to xconfig.
86 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
87 - Support --bytes-per-inode on raid
88 (Curtis Doty <Curtis at GreenKey.net> #175288).
90 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
91 - fixup network --onboot
93 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
94 - Default to SELINUX_ENFORCING.
95 - Default partition sizes to None for anaconda (#172378).
96 - Don't call shlex.split on anything inside a script (#172313).
98 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
99 - Fix clearpart --all.
100 - vnc command does not require --connect option (#172192).
101 - network --onboot does not take any option.
102 - Remove extra spaces from firewall --ports and --trust.
103 - Write out network --<service> options.
105 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
106 - Add --resolvedeps and --ignoredeps as deprecated options.
107 - Pass line number to header functions.
109 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
110 - Add line numbers to exception reporting.
111 - Added ksvalidator.
113 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
114 - Correct deprecated attribute on options.
115 - Added programming documentation.
117 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
118 - Correct python lib directory on 64-bit archs (#170621).
120 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
121 - Add a deprecated attribute to options.
122 - Add --card option back to xconfig and mark as deprecated.
123 - Throw a deprecation warning on mouse and langsupport commands.
124 - Rename Writer to KickstartWriter for consistency.
125 - Collapse scripts into a single list and add an attribute on Script to
126 differentiate.
128 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
129 - Rename module to pykickstart to avoid conflicts in anaconda.
130 - Rename data classes for consistency.
131 - Add default bytesPerInode settings.
133 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
134 - Created package from anaconda.