Add bootloader --iscrypted (#554870).
[pykickstart.git] / pykickstart.spec
blob5f5c3c68a99f253e8c16fcf536437935ae20297f
1 %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Url: http://fedoraproject.org/wiki/pykickstart
6 Version: 1.78
7 Release: 1%{?dist}
8 # This is a Red Hat maintained package which is specific to
9 # our distribution. Thus the source is only available from
10 # within this srpm.
11 Source0: %{name}-%{version}.tar.gz
13 License: GPLv2
14 Group: System Environment/Libraries
15 BuildArch: noarch
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17 BuildRequires: python-devel, gettext, python-setuptools-devel
18 Requires: python, python-urlgrabber
20 %description
21 The pykickstart package is a python library for manipulating kickstart
22 files.
24 %prep
25 %setup -q
27 %build
28 make
30 %install
31 rm -rf %{buildroot}
32 make DESTDIR=%{buildroot} install
33 %find_lang %{name}
35 %clean
36 rm -rf %{buildroot}
38 %files -f %{name}.lang
39 %defattr(-,root,root,-)
40 %doc README ChangeLog COPYING docs/programmers-guide
41 %doc docs/kickstart-docs.txt
42 %{python_sitelib}/*
43 %{_bindir}/ksvalidator
44 %{_bindir}/ksflatten
45 %{_bindir}/ksverdiff
47 %changelog
48 * Fri Sep 10 2010 Chris Lumens <clumens@redhat.com> - 1.78-1
49 - Raise KickstartError instead of IOError (#618002). (clumens)
50 - It's --biospart, not --biosdisk (#620855). (clumens)
51 - Translation updates.
53 * Tue Jul 20 2010 Chris Lumens <clumens@redhat.com> - 1.77-1
54 - Send the key command down the memory hole. (clumens)
55 - Deprecate interactive kickstart mode. (clumens)
57 * Thu Jul 08 2010 Chris Lumens <clumens@redhat.com> - 1.76-1
58 - method: new parameter '--noverifyssl' after --url. (akozumpl)
59 - repo: new parameter '--noverifyssl'. (akozumpl)
61 * Tue Jun 22 2010 Chris Lumens <clumens@redhat.com> - 1.75-1
62 - Update translation files. (clumens)
63 - Remove everything from pykickstart that's been deprecated forever. (clumens)
64 - Using the knowledge of what command supports what option, condense test cases. (clumens)
65 - Add a method to list all supported options for a command being tested. (clumens)
66 - Add support for F14. (clumens)
67 - The %end at the end of a section is now required. (clumens)
69 * Thu Jun 10 2010 Chris Lumens <clumens@redhat.com> - 1.74-1
70 - If an option is deprecated, do not care if it takes a value (#602303). (clumens)
71 - Don't compare the dest ("telnet") with the option string ("--telnet"). (clumens)
72 - The --connect= parameter wasn't really deprecated in FC6. (clumens)
74 * Tue Jun 01 2010 Chris Lumens <clumens@redhat.com> - 1.73-1
75 - Allow "ignoredisk" to explicitly specify interactive usage (#596804) (pjones)
77 * Fri Apr 23 2010 Chris Lumens <clumens@redhat.com> - 1.72-1
78 - Return non-zero on error from ksvalidator (#585284). (clumens)
80 * Wed Apr 14 2010 Chris Lumens <clumens@redhat.com> - 1.71-1
81 - Don't overwrite the excluded group list after every %packages line (#577334). (clumens)
82 - Add a bunch of test cases for the packages section. (clumens)
84 * Wed Mar 31 2010 Chris Lumens <clumens@redhat.com> - 1.70-1
85 - Add support for RAID4 (#578514). (clumens)
86 - Escape percent signs in the changelog. (clumens)
88 * Wed Mar 10 2010 Chris Lumens <clumens@redhat.com> - 1.69-1
89 - Add driverdisk --biospart= (#570437). (clumens)
90 - Fix IOError catching in ksflatten (jgregusk, #558650).
92 * Thu Jan 14 2010 Chris Lumens <clumens@redhat.com> - 1.68-1
93 - Support removing groups that were included by a glob (#554717). (clumens)
94 - Make sure that everything in version.versionMap has a handler. (clumens)
95 - Add support for RHEL6 (#552230). (clumens)
96 - Don't consider RHEL versions as developmental even if they're latest. (clumens)
97 - Add lineno to BaseData and derived classes (version 2) (hdegoede)
98 - Give the non mandatory iscsi --port argument a sane default (hdegoede)
99 - Change python_sitelib macro to use %%global for new rpm (hdegoede)
100 - Fix typo in iscsi parsing error message (hdegoede)
102 * Thu Dec 03 2009 Chris Lumens <clumens@redhat.com> - 1.67-1
103 - Don't use action="append_const" in firewall.py.
104 - Make "make archive" depend on test and check passing again.
105 - versionToString now works in all cases we test for.
106 - Fix the few pychecker errors outstanding in options.py.
107 - Fix make docs to make docs dir before trying to download files there (hdegoede)
109 * Wed Nov 25 2009 Hans de Goede <hdgoede@redhat.com> - 1.66-1
110 - Add --dcb option to fcoe command (#513011)
111 - Remove rhpl from tests
112 - Port bootloader --hvargs option added in rhel5
113 - Ignore comments when looking for %%ksappend lines (#525676)
114 - Use python 2.x exception syntax
116 * Thu Nov 12 2009 Chris Lumens <clumens@redhat.com> - 1.65-1
117 - Add additional arguments to BaseHandler.__init__ for better map control.
118 - Return the KickstartCommand/KickstartData object from dispatcher.
119 - Add an "sshpw" command for changing the passwords in anaconda's env.
120 - Add --proxy support to the url and repo commands.
121 - Add support for F13. Is it really that time already?
123 * Wed Sep 30 2009 Chris Lumens <clumens@redhat.com> - 1.64-1
124 - Update the zfcp command for F12 (#526360).
125 - Move "make" to %%build (#524215).
127 * Wed Sep 16 2009 Chris Lumens <clumens@redhat.com> - 1.63-1
128 - Add encryption key escrow support (mitr, #508963).
129 - Fix the repo test cases to expect quotes around the repo's name.
131 * Thu Sep 10 2009 Chris Lumens <clumens@redhat.com> - 1.62-1
132 - Support translated help text in optparse (#479519).
133 - If the input kickstart file cannot be read, raise IOError (#519477).
135 * Thu Aug 27 2009 Chris Lumens <clumens@redhat.com> - 1.61-1
136 - Include the error messages from URLGrabError in the exception (#518443).
138 * Tue Aug 11 2009 Chris Lumens <clumens@redhat.com> - 1.60-1
139 - Put quotes around the repo's name (Marc.Herbert@gmail.com).
140 - Make duplicate entries warnings, not errors (#516338).
142 * Tue Jul 28 2009 Chris Lumens <clumens@redhat.com> - 1.59-1
143 - Handle a few more places where a urlgrabber error could happen (#512951).
144 - Error out if the same partition/repo/network is defined twice (#512956).
145 - Call parent class tests first. (jlaska)
146 - Add KSOptionParser to FC3 upgrade command. (jlaska)
147 - Correct missing return stmt in _getArgsAsStr() (jlaska)
149 * Fri Jul 17 2009 Chris Lumens <clumens@redhat.com> - 1.58-1
150 - Adjust writePriority to fix lvm-on-raid0 test cases (jlaska).
151 - Add F12 to the version number tests. (clumens)
152 - F12_User test case. (dcantrell)
153 - Add --gecos argument to the 'user' command (dcantrell)
154 - Convert user.py to use _getArgsAsStr() (dcantrell)
156 * Fri Jul 10 2009 Chris Lumens <clumens@redhat.com> - 1.57-1
157 - Another patch to make the bootloader test work (jlaska).
159 * Thu Jul 09 2009 Chris Lumens <clumens@redhat.com> - 1.56-1
160 - Make sure to import the gettext stuff in fcoe. (clumens)
161 - Correctly deprecate bootloader --lba32 (jlaska).
162 - pykickstart: fix zfcp command writepriority (hdegoede)
163 - pykickstart: Add fcoe command (take 2) (hdegoede)
164 - Add a test case for RAID (jlaska).
166 * Thu Jul 02 2009 Chris Lumens <clumens@redhat.com> - 1.55-1
167 - Add support for the group command to F12 (#509119).
168 - RHEL5 now supports RAID 10.
169 - The f12 hander class should be called F12Handler. (jgranado)
170 - Remove bootloader --lba32.
171 - Add a new version of the driverdisk command without --type=.
172 - Add initial support for F12.
173 - Fetch the programmers-guide from the wiki now.
175 * Mon May 18 2009 Chris Lumens <clumens@redhat.com> - 1.54-1
176 - Make sure the F11 handler gets used for "partition" and "part" (#501020).
178 * Wed Apr 29 2009 Chris Lumens <clumens@redhat.com> - 1.53-1
179 - Move lineno= from KSOptionParser.__init__ to parse_args (#497149). (clumens)
180 - Use the F11 version of the partition command. (clumens)
181 - Remove the --start and --end options since anaconda no longer uses them. (clumens)
182 - Remove a broken test case. (clumens)
184 * Wed Feb 18 2009 Chris Lumens <clumens@redhat.com> - 1.52-1
185 - Add lots more test cases (alindebe, mgracik, stickster).
186 - Add a skip attribute on key to shut up pychecker.
187 - Only show autostep command when requested (jlaska)
188 - Strip spaces from service names, and require an option to be provided.
189 - Surround services lists in double quotes.
190 - Remove the extra space from the services __str__ method.
191 - Fix output formatting bugs in firewall, partition, and repo (mgracik).
192 - Specifying both or neither of --drives and --only-use should be an error.
193 - Corrected newline char in return value of FC6_Method. (mgracik)
194 - Make --drives a required option for FC3, and catch no args on F8.
195 - Fix final printing of the rescue command (mgracik).
196 - Surround output strings in double quotes.
197 - Fix a typo in the deviceprobe command.
198 - Revert the more strict option processing on displaymode.
199 - Properly handle erroring on extra args, not just extra options.
200 - Don't use the logging class since it interferes with the logging test.
201 - port without host should raise KickstartParseError, not kickstartValueError.
202 - Add the --key option to option processing, since it's a valid argument.
203 - Fix test cases that were failing due to the new use of KSOptionParser.
204 - Teach driverdisk.py command to reject extra partitions (stickster).
205 - Add KSOptionParser to all commands ... enables more strick option checking (jlaska).
206 - Use KSOptionParser so we can catch bad command options (jlaska).
208 * Thu Jan 29 2009 Chris Lumens <clumens@redhat.com> - 1.51-1
209 - Make a couple changes to how the logging command is handled.
210 - Add a lot of test cases (clumens, alindebe, jlaska, fcami, adamwill, pfrields).
211 - Fix output formatting for the rootpw command.
212 - For commands that take exactly one argument, check and error correctly.
213 - Surround module options in quotes on the output side (jlaska).
214 - Set module opts in the FC3 handler correctly.
215 - Fix newlines on the device command output (jlaska).
216 - If --autoscreenshot is not specified, still output "autostep".
217 - Move the currentCmd and currentLine into getParser(). (jlaska)
218 - Write out an selinux line if set to disabled, but not if None.
219 - F9_LogVolData should inherit from FC4_LogVolData, not FC3_LogVolData (jlaska).
220 - Add unittest framework along with logvol and vnc unittests. (jlaska)
221 - Don't set the KSOption.required attribute in the constructor (jlaska).
223 * Sat Jan 10 2009 Chris Lumens <clumens@redhat.com> - 1.50-1
224 - Add a script to diff two versions of kickstart syntax.
225 - Add an option to ksvalidator to list all available syntax versions.
226 - Remove a couple extra newlines in output formatting.
227 - Add documentation for the new %%include representation.
228 - Add support %include to the pykickstart data objects.
230 * Thu Jan 08 2009 Chris Lumens <clumens@redhat.com> - 1.49-1
231 - Add upgrade --root-device (atodorov, #471232).
232 - Use python's builtin set rather than the Sets module (#477836, dcantrell).
234 * Tue Dec 23 2008 Chris Lumens <clumens@redhat.com> - 1.48-1
235 - Allow ignoring group metadata from repos, using a '--ignoregroups'
236 boolean. (notting)
237 - Add initial support for F11.
238 - Specify the command versions in the handlers instead of making copies.
239 - Remove empty and pointless __init__ methods.
240 - Pass arguments to superclasses via *args and **kwargs, all the way up.
241 - Add removedKeywords and removedAttrs lists on Commands and Data.
242 - Fix version regexes to handle double digits and minor releases (jlaska).
244 * Thu Oct 30 2008 Chris Lumens <clumens@redhat.com> - 1.47-1
245 - Fix enabling services we specify by specific options.
247 * Mon Oct 27 2008 Chris Lumens <clumens@redhat.com> - 1.46-1
248 - Add support for firewall --service (#467005).
250 * Tue Oct 14 2008 Chris Lumens <clumens@redhat.com> - 1.45-1
251 - Lots of translation updates.
252 - Remove use of string.partition for python2.4 (atodorov).
254 * Mon Sep 22 2008 Chris Lumens <clumens@redhat.com> - 1.44-1
255 - Add support for reverse CHAP to the kickstart iscsi command (hans)
256 - Fix typo (katzj)
258 * Wed Sep 03 2008 Chris Lumens <clumens@redhat.com> - 1.43-1
259 - Revert "Do not include passphrases for encrypted block devices in
260 anaconda-ks.cfg." (dlehman)
261 - yum doesn't like when mirrorlist is "". (clumens)
263 * Mon Aug 11 2008 Chris Lumens <clumens@redhat.com> - 1.42-1
264 - Add rescue command to pykickstart (atodorov)
265 - Sort %%packages output (katzj)
266 - Fix a typo (atodorov).
268 * Fri Aug 01 2008 Chris Lumens <clumens@redhat.com> - 1.41-1
269 - RHEL5 supports ignoredisk --only-use now too. (clumens)
270 - Do not include passphrases for encrypted block devices in
271 anaconda-ks.cfg. (dlehman)
272 - Fix F9,F10,RHEL5 "part" commands to use the same class as
273 "partition". (dlehman)
274 - Add an apply method() for commands and implement for lang (katzj)
276 * Tue Jul 15 2008 Chris Lumens <clumens@redhat.com> - 1.40-1
277 - RHEL5_LogVolData should inherit from FC4, not FC3.
278 Also fix FC9->F9 typo. (dlehman)
279 - Support creation of encrypted block devices in RHEL5. (#449830) (dlehman)
280 - Use the right LogVolData objects for RHEL3 and 4 (jlaska). (clumens)
281 - We no longer use rhpl for translations. (clumens)
282 - All the base classes should derive from object. (clumens)
284 * Fri Jun 13 2008 Chris Lumens <clumens@redhat.com> - 1.39-1
285 - It's helpful to return the parser object. (clumens)
287 * Tue Jun 10 2008 Chris Lumens <clumens@redhat.com> - 1.38-1
288 - Fix loading the Handler object by looking for a more specific
289 name (#450740). (clumens)
291 * Sun Jun 08 2008 Chris Lumens <clumens@redhat.com> - 1.37-1
292 - XConfig is still used by other projects, so just deprecate some
293 options. (clumens)
295 * Thu May 29 2008 Chris Lumens <clumens@redhat.com> - 1.36-1
296 - It should be repo --cost, not repo --priority. (clumens)
298 * Fri May 23 2008 Chris Lumens <clumens@redhat.com> - 1.35-1
299 - Bring driverdisk command in line with the docs. (clumens)
300 - Change RAID command print priorities (jlaska).
301 - According to docs, physvols are space delimited. (jlaska)
302 - Don't write the label out twice (jlaska).
303 - Deprecate monitor and xconfig commands. (clumens)
305 * Wed May 07 2008 Chris Lumens <clumens@redhat.com> - 1.34-1
306 - Load the handler module automatically. (clumens)
307 - Add support for F10. (clumens)
308 - Initialize cmd.handler earlier; fixes repo.methodToRepo() (markmc)
309 - Don't shadow builtin function names. (clumens)
310 - Running check is now required before pykickstart can be packaged. (clumens)
311 - Reorganize code a little bit to pass pychecker. (clumens)
313 * Tue Apr 08 2008 Chris Lumens <clumens@redhat.com> - 1.33-1
314 - Fix whitespace when printing out the bootloader command (pmeyers).
315 - Fix the type on bootloader --timeout processing. (clumens)
317 * Wed Apr 02 2008 Chris Lumens <clumens@redhat.com> - 1.32-1
318 - Make the string reader act like the file reader upon EOF. (clumens)
319 - Add syntax for encrypted logical volumes. (clumens)
321 * Tue Mar 25 2008 Chris Lumens <clumens@redhat.com> - 1.31-1
322 - Support end-of-line comments. (clumens)
323 - Lots of translation updates.
325 * Tue Feb 26 2008 Chris Lumens <clumens@redhat.com> - 1.30-1
326 - Reverse writePriorities of iscsi and iscsname (#434965, jlaska).
327 - Fix printing of iscsiname command (#434945, jlaska).
328 - Don't traceback on ENOENT. (pnasrat)
329 - Store the mouse name as a string, not a list. (clumens)
330 - Update translations.
332 * Wed Jan 30 2008 Chris Lumens <clumens@redhat.com> - 1.29-1
333 - Renamed bootproto=ask to bootproto=query, add to RHEL5 as well. (clumens)
335 * Wed Jan 23 2008 Chris Lumens <clumens@redhat.com> - 1.28-1
336 - Fix traceback on volgroup command. (clumens)
338 * Thu Jan 17 2008 Chris Lumens <clumens@redhat.com> - 1.27-1
339 - The bootprotoList needs to be defined before it's used. (clumens)
341 * Thu Jan 17 2008 Chris Lumens <clumens@redhat.com> - 1.26-1
342 - Add support for network --bootproto=ask. (clumens)
344 * Tue Jan 15 2008 Chris Lumens <clumens@redhat.com> - 1.25-1
345 - Add the version to the output ks file. (clumens)
346 - Add syntax for encrypted partitions and raid devices. (clumens)
348 * Thu Jan 10 2008 Chris Lumens <clumens@redhat.com> - 1.24-1
349 - Make inheritance and overriding of %%packages work (#427768). (clumens)
350 - Add an option for which languages should be installed. (katzj)
351 - Use the right name for the iscsi --target variable (#418781). (clumens)
353 * Mon Dec 10 2007 Chris Lumens <clumens@redhat.com> - 1.23-1
354 - Take Makefile improvements from anaconda.
355 - Fix a traceback on F9 zerombr command (#395431).
356 - Update to handle new Python eggs packaging.
358 * Tue Nov 20 2007 Chris Lumens <clumens@redhat.com> 1.22-1
359 - Don't process or write out vnc --enabled (jlaska AT redhat DOT com).
360 - Fix a traceback in the clearpart command.
362 * Tue Nov 06 2007 Chris Lumens <clumens@redhat.com> 1.21-1
363 - Save script line numbers for debugging.
364 - More internal cleanups.
366 * Wed Oct 31 2007 Chris Lumens <clumens@redhat.com> 1.20-1
367 - Pull wiki docs from the new location.
368 - Fix error messages for options that have been removed after having been
369 previously deprecated.
370 - zerombr no longer takes any arguments.
371 - %%packages --ignoredeps --resolvedeps have been removed.
372 - firewall --high --medium have been removed.
373 - vnc --connect has been removed.
374 - xconfig options from monitor have now been removed.
375 - --bytes-per-inode has been marked as deprecated.
376 - Fix typos.
377 - Add --fsprofile option to disk commands (pjones).
378 - Add F9 support (pjones).
379 - Lots of internal fixes (clumens, pjones).
381 * Tue Oct 23 2007 Chris Lumens <clumens@redhat.com> 1.19-1
382 - Fix a traceback on the cdrom method.
384 * Thu Oct 18 2007 Chris Lumens <clumens@redhat.com> 1.18-1
385 - Don't write out %%end to packages and scripts if the syntax version doesn't
386 support it.
387 - Remove obsolete translation (#332221).
389 * Thu Oct 04 2007 Chris Lumens <clumens@redhat.com> 1.17-1
390 - Simplify argument processing and printing.
392 * Wed Oct 03 2007 Chris Lumens <clumens@redhat.com> 1.16-1
393 - Undeprecate %%packages --excludedocs.
394 - Fix a traceback in the device command handling.
395 - Add bootloader --timeout (katzj).
397 * Tue Oct 02 2007 Chris Lumens <clumens@redhat.com> 1.15-1
398 - Update translations (#259121).
399 - The device command no longer takes a type argument.
401 * Fri Sep 28 2007 Chris Lumens <clumens@redhat.com> 1.14-1
402 - Fix output formatting for packages section header (#310211).
403 - Add a script to flatten kickstart files containing includes (katzj).
405 * Wed Sep 12 2007 Chris Lumens <clumens@redhat.com> 1.13-1
406 - Add a function to convert URL method strings into repo objects
407 (jkeating).
408 - Writer formatting fixes.
409 - Add kickstart documentation from the Fedora Wiki.
411 * Tue Sep 04 2007 Chris Lumens <clumens@redhat.com> 1.12-1
412 - Fix lots of problems in processing the bootloader, device, network, and
413 raid commands.
414 - Add %%end when writing out scripts and packages.
415 - Add a makefile target to run pychecker to cut down on errors in
416 releases.
418 * Mon Sep 3 2007 Jeremy Katz <katzj@redhat.com> - 1.11-1
419 - fix a few tracebacks
421 * Fri Aug 31 2007 Chris Lumens <clumens@redhat.com> 1.10-1
422 - Add network --ipv6=.
424 * Fri Aug 24 2007 Chris Lumens <clumens@redhat.com> 1.9-1
425 - Add support for the %%end directive to be placed at the end of scripts
426 and packages sections. Deprecate old syntax.
427 - Clean up after ksvalidator if pykickstart issues a traceback.
428 - Add support for repo --priority --includepkgs --excludepkgs.
429 - Fix newline at end of reboot --eject output (#253562).
431 * Mon Aug 13 2007 Chris Lumens <clumens@redhat.com> 1.8-1
432 - Fix type checking of string values.
434 * Thu Aug 09 2007 Chris Lumens <clumens@redhat.com> 1.7-1
435 - Clarify license in spec file and all source files.
436 - Check string values to options to make sure they're not other options
437 (#251318).
439 * Thu Aug 02 2007 Chris Lumens <clumens@redhat.com> 1.6-1
440 - Fix a couple tracebacks in ksvalidator.
441 - Change --class to --dhcpclass (#248912).
443 * Thu Jul 19 2007 Chris Lumens <clumens@redhat.com> 1.5-2
444 - Require rhpl (#248953).
446 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.5-1
447 - Fix traceback when calling preprocessKickstart.
449 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.4-1
450 - Add methods to handle the %%ksappend directive.
451 - Fix ignoredisk --disks.
453 * Wed Jul 11 2007 Chris Lumens <clumens@redhat.com> - 1.3-1
454 - Add support for ignoredisk --only-use.
455 - Fix traceback in raid command printing method (#246709).
457 * Fri Jun 08 2007 Chris Lumens <clumens@redhat.com> - 1.2-2
458 - Fix package review problems (#226334).
460 * Mon Jun 04 2007 Chris Lumens <clumens@redhat.com> - 1.2-1
461 - Fix harddrive install method error checking (#232492).
462 - Set authentication information from the input line to preserve quoting
463 (#241657).
464 - Allow included files to be given by URL.
465 - Fix typo in user --iscrypted option.
467 * Mon May 14 2007 Chris Lumens <clumens@redhat.com> - 1.1-1
468 - Better regexes for splitting version strings into family and version.
469 - Add basic support for RHEL3.
470 - Update translations.
472 * Fri Apr 13 2007 Chris Lumens <clumens@redhat.com> - 1.0-1
473 - Update documentation.
474 - Update translations.
476 * Mon Mar 19 2007 Chris Lumens <clumens@redhat.com> - 0.100-1
477 - bootloader should be written out after upgrade/install.
478 - Treat class names as unicode strings (#231053).
480 * Wed Mar 07 2007 Chris Lumens <clumens@redhat.com> - 0.99-1
481 - The timezone command didn't recognize --isUtc before FC6 (#231189).
482 - Recognize %%ksappend lines in ksvalidator.
483 - Don't set default values in some command __init__ methods.
484 - Added an updates command.
485 - Add support for RAID10.
487 * Mon Feb 26 2007 Chris Lumens <clumens@redhat.com> - 0.98-1
488 - Fix device command syntax to match anaconda.
489 - Fix __call__ on method command.
491 * Wed Feb 21 2007 Chris Lumens <clumens@redhat.com> - 0.97-1
492 - Fix traceback when not overriding default mappings (#229505).
494 * Tue Feb 20 2007 Chris Lumens <clumens@redhat.com> - 0.96-1
495 - Fix __str__ methods for langsupport and reboot commands.
496 - Renamed BaseHandler.empty to BaseHandler.maskAllExcept.
497 - Split command objects out into their own files in commands/.
498 - Rename command objects to start with Version_.
499 - Support extended group selection syntax.
501 * Wed Feb 14 2007 Chris Lumens <clumens@redhat.com> - 0.95-1
502 - KickstartParser no longer takes a version argument.
503 - Be more lenient in what strings stringToVersion accepts.
504 - Allow setting state on one data object from multiple files.
506 * Wed Feb 07 2007 Chris Lumens <clumens@redhat.com> - 0.94-1
507 - Add a newline to the end of the key command output.
508 - Use network bootproto constants (#197694).
509 - Fix tracebacks in subclass __str__ methods (#226734).
511 * Wed Jan 31 2007 Chris Lumens <clumens@redhat.com> - 0.93-2
512 - Make some minor spec file changes to get closer to the extras guidelines.
514 * Thu Jan 25 2007 Chris Lumens <clumens@redhat.com> - 0.93-1
515 - Add support for FC3, RHEL4, and RHEL5.
516 - The key command was not supported until after FC6.
517 - Accept more strings in stringToVersion.
519 * Fri Jan 19 2007 Chris Lumens <clumens@redhat.com> - 0.92-1
520 - Fix KickstartVersionError reporting.
521 - Add a version attribute to handler objects.
522 - Fix line number reporting on lots of commands.
523 - Add initial support for Fedora 7 and remove deprecated commands.
524 - Accept a --default argument to the %%packages header (#221305).
526 * Wed Jan 17 2007 Chris Lumens <clumens@redhat.com> - 0.91-1
527 - Add a method to read kickstart files from strings.
529 * Tue Jan 16 2007 Chris Lumens <clumens@redhat.com> - 0.90-1
530 - Support multiple versions of kickstart syntax from one code base
531 (#189348).
532 - Fix inconsistency between Script parser and writer (#222877).
534 * Fri Dec 15 2006 Chris Lumens <clumens@redhat.com> - 0.43-1
535 - Pull in new translations (#216620).
537 * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.42-2
538 - rebuild against python 2.5
540 * Tue Dec 05 2006 Chris Lumens <clumens@redhat.com> - 0.42-1
541 - Fix traceback when writing out repo command (#218274).
543 * Fri Dec 01 2006 Chris Lumens <clumens@redhat.com> - 0.41-1
544 - Fix traceback when using deprecated commands (#218047, #218059).
546 * Thu Nov 30 2006 Chris Lumens <clumens@redhat.com> - 0.40-1
547 - Pull in new translations (#216620).
548 - Add --level argument to logging command writer.
550 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-2
551 - Fix release number.
553 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-1
554 - Add writer for --key (#211997).
556 * Tue Oct 17 2006 Jeremy Katz <katzj@redhat.com> - 0.38-1
557 - allow --skip for installation number as well (#207029)
559 * Mon Oct 16 2006 Jeremy Katz <katzj@redhat.com> - 0.37-1
560 - support for installation numbers (#207029)
562 * Fri Oct 13 2006 Bill Nottingham <notting@redhat.com> - 0.36-1
563 - use valid charsets in translations (#210720)
565 * Fri Sep 29 2006 Chris Lumens <clumens@redhat.com> - 0.35-1
566 - Fix traceback in harddrive command (#208557).
568 * Mon Sep 25 2006 Chris Lumens <clumens@redhat.com> - 0.34-1
569 - Add support for --biospart option to harddrive (#207585).
570 - Update writer for syntax changes.
572 * Wed Sep 20 2006 Jeremy Katz <katzj@redhat.com> - 0.33-1
573 - improved iscsi syntax
574 - allow multiple zfcp devs
576 * Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 0.32-1
577 - Limit --bootproto to what anaconda supports.
578 - Add --noipv4 and --noipv6 network options.
580 * Tue Jun 20 2006 Chris Lumens <clumens@redhat.com> 0.31-1
581 - Handle nfs --opts (katzj).
582 - RAID devices should be integers instead of strings (#176537).
583 - Add initial support for iscsi (katzj).
585 * Tue Jun 06 2006 Chris Lumens <clumens@redhat.com> 0.30-2
586 - Add BuildRequires to fix building under mock (#194156, Joost Soeterbroek
587 <fedora AT soeterbroek.com>).
589 * Thu May 25 2006 Chris Lumens <clumens@redhat.com> 0.30-1
590 - Change order of LVM-related writing functions (#193073).
591 - Require urlgrabber.
592 - Return a more useful error message on unknown commands.
593 - Fix logvol writing typo.
594 - Make ksvalidator validate from a URL in addition to a file.
595 - Don't write out an empty packages section (#192851).
597 * Tue May 23 2006 Chris Lumens <clumens@redhat.com> 0.29-1
598 - Add multipath command, handlers, and data objects (pjones).
599 - Rename --ports to --port in writer.
601 * Mon May 15 2006 Chris Lumens <clumens@redhat.com> 0.28-1
602 - Support --mtu for the network command (#191328).
603 - Accept --isUtc for backwards compatibility.
605 * Wed May 04 2006 Chris Lumens <clumens@redhat.com> 0.27-1
606 - Output formatting fixes.
607 - Added commands for managing users and services.
609 * Mon Apr 17 2006 Chris Lumens <clumens@redhat.com> 0.26-1
610 - Ignore spaces before group names (#188095).
611 - Added some translations.
612 - Add options for repo command.
613 - Reorder %%packages section output.
614 - Output %%packages header options.
615 - Initialize RAID and volume group members to empty lists.
617 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.25-1
618 - Add support for the logging command.
620 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.24-1
621 - Don't write out a blank xconfig line.
622 - Reorder output handlers to group like commands together.
623 - Mark strings for translation.
625 * Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 0.23-1
626 - Backwards compatibility support for options to zerombr.
628 * Fri Feb 24 2006 Chris Lumens <clumens@redhat.com> 0.22-1
629 - Get ignoredisk working again (#182934).
631 * Fri Feb 17 2006 Chris Lumens <clumens@redhat.com> 0.21-1
632 - Provide an option to not traceback on missing include files (#181760).
633 - Update programming documentation.
635 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.20-1
636 - Correctly set --noformat and --useexisting on lvm and raid.
638 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.19-1
639 - --onboot requires a value (#180987).
640 - Be more strict about commands that don't take arguments.
642 * Thu Feb 09 2006 Chris Lumens <clumens@redhat.com> 0.18-1
643 - Fix some errors pychecker caught.
644 - Allow exceptions to not be fatal so ksvalidator can spot more errors in
645 a single pass (#179894).
647 * Wed Feb 01 2006 Chris Lumens <clumens@redhat.com> 0.17-1
648 - Don't set a default port for vnc.
650 * Tue Jan 31 2006 Chris Lumens <clumens@redhat.com> 0.16-1
651 - Give dmraid string an initial value.
652 - Handle None on partition size.
654 * Tue Jan 31 2006 Peter Jones <pjones@redhat.com> 0.15-1
655 - Add dmraid support
657 * Mon Jan 30 2006 Chris Lumens <clumens@redhat.com> 0.14-1
658 - Fix VNC parameter parsing (#179209).
659 - Deprecate --connect. Add --host and --port instead.
661 * Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 0.13-1
662 - Recognize the --eject parameter to shutdown/halt.
663 - Store the exact post-installation action in ksdata.
665 * Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 0.12-1
666 - Clean up output quoting.
667 - Finish removing monitor-related stuff from xconfig.
669 * Mon Dec 12 2005 Chris Lumens <clumens@redhat.com> 0.11-1
670 - Deprecate monitor-related options to xconfig.
672 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
673 - Support --bytes-per-inode on raid
674 (Curtis Doty <Curtis at GreenKey.net> #175288).
676 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
677 - fixup network --onboot
679 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
680 - Default to SELINUX_ENFORCING.
681 - Default partition sizes to None for anaconda (#172378).
682 - Don't call shlex.split on anything inside a script (#172313).
684 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
685 - Fix clearpart --all.
686 - vnc command does not require --connect option (#172192).
687 - network --onboot does not take any option.
688 - Remove extra spaces from firewall --ports and --trust.
689 - Write out network --<service> options.
691 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
692 - Add --resolvedeps and --ignoredeps as deprecated options.
693 - Pass line number to header functions.
695 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
696 - Add line numbers to exception reporting.
697 - Added ksvalidator.
699 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
700 - Correct deprecated attribute on options.
701 - Added programming documentation.
703 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
704 - Correct python lib directory on 64-bit archs (#170621).
706 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
707 - Add a deprecated attribute to options.
708 - Add --card option back to xconfig and mark as deprecated.
709 - Throw a deprecation warning on mouse and langsupport commands.
710 - Rename Writer to KickstartWriter for consistency.
711 - Collapse scripts into a single list and add an attribute on Script to
712 differentiate.
714 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
715 - Rename module to pykickstart to avoid conflicts in anaconda.
716 - Rename data classes for consistency.
717 - Add default bytesPerInode settings.
719 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
720 - Created package from anaconda.