Remove duplicate monitor config options from xconfig keyword, add --noprobe
[pykickstart.git] / pykickstart.spec
blob73d8472eda1f67e4462ae0377567e5ac08e46433
1 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Version: 0.10
6 Release: 1
7 Source0: %{name}-%{version}.tar.gz
8 License: GPL
9 Group: System Environment/Libraries
10 BuildArch: noarch
11 BuildRoot: %{_tmppath}/%{name}-root
12 BuildRequires: python-devel
13 Requires: python >= %(%{__python} -c "import sys; print sys.version[:3]")
15 %description
16 The pykickstart package is a python library for manipulating kickstart
17 files.
19 %prep
20 %setup -q
21 make
23 %build
25 %install
26 rm -rf $RPM_BUILD_ROOT
27 python setup.py install --root=${RPM_BUILD_ROOT}
29 %clean
30 rm -rf $RPM_BUILD_ROOT
32 %files
33 %defattr(-,root,root)
34 %doc README ChangeLog COPYING docs/programmers-guide
35 %{python_sitelib}/pykickstart
36 /usr/bin/ksvalidator
38 %changelog
39 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
40 - Support --bytes-per-inode on raid
41 (Curtis Doty <Curtis at GreenKey.net> #175288).
43 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
44 - fixup network --onboot
46 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
47 - Default to SELINUX_ENFORCING.
48 - Default partition sizes to None for anaconda (#172378).
49 - Don't call shlex.split on anything inside a script (#172313).
51 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
52 - Fix clearpart --all.
53 - vnc command does not require --connect option (#172192).
54 - network --onboot does not take any option.
55 - Remove extra spaces from firewall --ports and --trust.
56 - Write out network --<service> options.
58 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
59 - Add --resolvedeps and --ignoredeps as deprecated options.
60 - Pass line number to header functions.
62 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
63 - Add line numbers to exception reporting.
64 - Added ksvalidator.
66 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
67 - Correct deprecated attribute on options.
68 - Added programming documentation.
70 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
71 - Correct python lib directory on 64-bit archs (#170621).
73 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
74 - Add a deprecated attribute to options.
75 - Add --card option back to xconfig and mark as deprecated.
76 - Throw a deprecation warning on mouse and langsupport commands.
77 - Rename Writer to KickstartWriter for consistency.
78 - Collapse scripts into a single list and add an attribute on Script to
79 differentiate.
81 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
82 - Rename module to pykickstart to avoid conflicts in anaconda.
83 - Rename data classes for consistency.
84 - Add default bytesPerInode settings.
86 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
87 - Created package from anaconda.