Add %end token to the end of packages and scripts that get written out.
[pykickstart.git] / pykickstart.spec
blob7c0d2797968f986b2c112ab7cae4e44826706a9a
1 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Url: http://fedoraproject.org/wiki/pykickstart
6 Version: 1.11
7 Release: 1%{?dist}
8 # This is a Red Hat maintained package which is specific to
9 # our distribution. Thus the source is only available from
10 # within this srpm.
11 Source0: %{name}-%{version}.tar.gz
13 License: GPLv2
14 Group: System Environment/Libraries
15 BuildArch: noarch
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17 BuildRequires: python-devel, gettext
18 Requires: python, python-urlgrabber, rhpl
20 %description
21 The pykickstart package is a python library for manipulating kickstart
22 files.
24 %prep
25 %setup -q
26 make
28 %build
30 %install
31 rm -rf %{buildroot}
32 make DESTDIR=%{buildroot} install
33 %find_lang %{name}
35 %clean
36 rm -rf %{buildroot}
38 %files -f %{name}.lang
39 %defattr(-,root,root,-)
40 %doc README ChangeLog COPYING docs/programmers-guide
41 %{python_sitelib}/pykickstart
42 %{_bindir}/ksvalidator
44 %changelog
45 * Mon Sep 3 2007 Jeremy Katz <katzj@redhat.com> - 1.11-1
46 - fix a few tracebacks
48 * Fri Aug 31 2007 Chris Lumens <clumens@redhat.com> 1.10-1
49 - Add network --ipv6=.
51 * Fri Aug 24 2007 Chris Lumens <clumens@redhat.com> 1.9-1
52 - Add support for the %end directive to be placed at the end of scripts
53 and packages sections. Deprecate old syntax.
54 - Clean up after ksvalidator if pykickstart issues a traceback.
55 - Add support for repo --priority --includepkgs --excludepkgs.
56 - Fix newline at end of reboot --eject output (#253562).
58 * Mon Aug 13 2007 Chris Lumens <clumens@redhat.com> 1.8-1
59 - Fix type checking of string values.
61 * Thu Aug 09 2007 Chris Lumens <clumens@redhat.com> 1.7-1
62 - Clarify license in spec file and all source files.
63 - Check string values to options to make sure they're not other options
64 (#251318).
66 * Thu Aug 02 2007 Chris Lumens <clumens@redhat.com> 1.6-1
67 - Fix a couple tracebacks in ksvalidator.
68 - Change --class to --dhcpclass (#248912).
70 * Thu Jul 19 2007 Chris Lumens <clumens@redhat.com> 1.5-2
71 - Require rhpl (#248953).
73 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.5-1
74 - Fix traceback when calling preprocessKickstart.
76 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.4-1
77 - Add methods to handle the %ksappend directive.
78 - Fix ignoredisk --disks.
80 * Wed Jul 11 2007 Chris Lumens <clumens@redhat.com> - 1.3-1
81 - Add support for ignoredisk --only-use.
82 - Fix traceback in raid command printing method (#246709).
84 * Fri Jun 08 2007 Chris Lumens <clumens@redhat.com> - 1.2-2
85 - Fix package review problems (#226334).
87 * Mon Jun 04 2007 Chris Lumens <clumens@redhat.com> - 1.2-1
88 - Fix harddrive install method error checking (#232492).
89 - Set authentication information from the input line to preserve quoting
90 (#241657).
91 - Allow included files to be given by URL.
92 - Fix typo in user --iscrypted option.
94 * Mon May 14 2007 Chris Lumens <clumens@redhat.com> - 1.1-1
95 - Better regexes for splitting version strings into family and version.
96 - Add basic support for RHEL3.
97 - Update translations.
99 * Fri Apr 13 2007 Chris Lumens <clumens@redhat.com> - 1.0-1
100 - Update documentation.
101 - Update translations.
103 * Mon Mar 19 2007 Chris Lumens <clumens@redhat.com> - 0.100-1
104 - bootloader should be written out after upgrade/install.
105 - Treat class names as unicode strings (#231053).
107 * Wed Mar 07 2007 Chris Lumens <clumens@redhat.com> - 0.99-1
108 - The timezone command didn't recognize --isUtc before FC6 (#231189).
109 - Recognize %ksappend lines in ksvalidator.
110 - Don't set default values in some command __init__ methods.
111 - Added an updates command.
112 - Add support for RAID10.
114 * Mon Feb 26 2007 Chris Lumens <clumens@redhat.com> - 0.98-1
115 - Fix device command syntax to match anaconda.
116 - Fix __call__ on method command.
118 * Wed Feb 21 2007 Chris Lumens <clumens@redhat.com> - 0.97-1
119 - Fix traceback when not overriding default mappings (#229505).
121 * Tue Feb 20 2007 Chris Lumens <clumens@redhat.com> - 0.96-1
122 - Fix __str__ methods for langsupport and reboot commands.
123 - Renamed BaseHandler.empty to BaseHandler.maskAllExcept.
124 - Split command objects out into their own files in commands/.
125 - Rename command objects to start with Version_.
126 - Support extended group selection syntax.
128 * Wed Feb 14 2007 Chris Lumens <clumens@redhat.com> - 0.95-1
129 - KickstartParser no longer takes a version argument.
130 - Be more lenient in what strings stringToVersion accepts.
131 - Allow setting state on one data object from multiple files.
133 * Wed Feb 07 2007 Chris Lumens <clumens@redhat.com> - 0.94-1
134 - Add a newline to the end of the key command output.
135 - Use network bootproto constants (#197694).
136 - Fix tracebacks in subclass __str__ methods (#226734).
138 * Wed Jan 31 2007 Chris Lumens <clumens@redhat.com> - 0.93-2
139 - Make some minor spec file changes to get closer to the extras guidelines.
141 * Thu Jan 25 2007 Chris Lumens <clumens@redhat.com> - 0.93-1
142 - Add support for FC3, RHEL4, and RHEL5.
143 - The key command was not supported until after FC6.
144 - Accept more strings in stringToVersion.
146 * Fri Jan 19 2007 Chris Lumens <clumens@redhat.com> - 0.92-1
147 - Fix KickstartVersionError reporting.
148 - Add a version attribute to handler objects.
149 - Fix line number reporting on lots of commands.
150 - Add initial support for Fedora 7 and remove deprecated commands.
151 - Accept a --default argument to the %%packages header (#221305).
153 * Wed Jan 17 2007 Chris Lumens <clumens@redhat.com> - 0.91-1
154 - Add a method to read kickstart files from strings.
156 * Tue Jan 16 2007 Chris Lumens <clumens@redhat.com> - 0.90-1
157 - Support multiple versions of kickstart syntax from one code base
158 (#189348).
159 - Fix inconsistency between Script parser and writer (#222877).
161 * Fri Dec 15 2006 Chris Lumens <clumens@redhat.com> - 0.43-1
162 - Pull in new translations (#216620).
164 * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.42-2
165 - rebuild against python 2.5
167 * Tue Dec 05 2006 Chris Lumens <clumens@redhat.com> - 0.42-1
168 - Fix traceback when writing out repo command (#218274).
170 * Fri Dec 01 2006 Chris Lumens <clumens@redhat.com> - 0.41-1
171 - Fix traceback when using deprecated commands (#218047, #218059).
173 * Thu Nov 30 2006 Chris Lumens <clumens@redhat.com> - 0.40-1
174 - Pull in new translations (#216620).
175 - Add --level argument to logging command writer.
177 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-2
178 - Fix release number.
180 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-1
181 - Add writer for --key (#211997).
183 * Tue Oct 17 2006 Jeremy Katz <katzj@redhat.com> - 0.38-1
184 - allow --skip for installation number as well (#207029)
186 * Mon Oct 16 2006 Jeremy Katz <katzj@redhat.com> - 0.37-1
187 - support for installation numbers (#207029)
189 * Fri Oct 13 2006 Bill Nottingham <notting@redhat.com> - 0.36-1
190 - use valid charsets in translations (#210720)
192 * Fri Sep 29 2006 Chris Lumens <clumens@redhat.com> - 0.35-1
193 - Fix traceback in harddrive command (#208557).
195 * Mon Sep 25 2006 Chris Lumens <clumens@redhat.com> - 0.34-1
196 - Add support for --biospart option to harddrive (#207585).
197 - Update writer for syntax changes.
199 * Wed Sep 20 2006 Jeremy Katz <katzj@redhat.com> - 0.33-1
200 - improved iscsi syntax
201 - allow multiple zfcp devs
203 * Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 0.32-1
204 - Limit --bootproto to what anaconda supports.
205 - Add --noipv4 and --noipv6 network options.
207 * Tue Jun 20 2006 Chris Lumens <clumens@redhat.com> 0.31-1
208 - Handle nfs --opts (katzj).
209 - RAID devices should be integers instead of strings (#176537).
210 - Add initial support for iscsi (katzj).
212 * Tue Jun 06 2006 Chris Lumens <clumens@redhat.com> 0.30-2
213 - Add BuildRequires to fix building under mock (#194156, Joost Soeterbroek
214 <fedora AT soeterbroek.com>).
216 * Thu May 25 2006 Chris Lumens <clumens@redhat.com> 0.30-1
217 - Change order of LVM-related writing functions (#193073).
218 - Require urlgrabber.
219 - Return a more useful error message on unknown commands.
220 - Fix logvol writing typo.
221 - Make ksvalidator validate from a URL in addition to a file.
222 - Don't write out an empty packages section (#192851).
224 * Tue May 23 2006 Chris Lumens <clumens@redhat.com> 0.29-1
225 - Add multipath command, handlers, and data objects (pjones).
226 - Rename --ports to --port in writer.
228 * Mon May 15 2006 Chris Lumens <clumens@redhat.com> 0.28-1
229 - Support --mtu for the network command (#191328).
230 - Accept --isUtc for backwards compatibility.
232 * Wed May 04 2006 Chris Lumens <clumens@redhat.com> 0.27-1
233 - Output formatting fixes.
234 - Added commands for managing users and services.
236 * Mon Apr 17 2006 Chris Lumens <clumens@redhat.com> 0.26-1
237 - Ignore spaces before group names (#188095).
238 - Added some translations.
239 - Add options for repo command.
240 - Reorder %%packages section output.
241 - Output %%packages header options.
242 - Initialize RAID and volume group members to empty lists.
244 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.25-1
245 - Add support for the logging command.
247 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.24-1
248 - Don't write out a blank xconfig line.
249 - Reorder output handlers to group like commands together.
250 - Mark strings for translation.
252 * Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 0.23-1
253 - Backwards compatibility support for options to zerombr.
255 * Fri Feb 24 2006 Chris Lumens <clumens@redhat.com> 0.22-1
256 - Get ignoredisk working again (#182934).
258 * Fri Feb 17 2006 Chris Lumens <clumens@redhat.com> 0.21-1
259 - Provide an option to not traceback on missing include files (#181760).
260 - Update programming documentation.
262 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.20-1
263 - Correctly set --noformat and --useexisting on lvm and raid.
265 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.19-1
266 - --onboot requires a value (#180987).
267 - Be more strict about commands that don't take arguments.
269 * Thu Feb 09 2006 Chris Lumens <clumens@redhat.com> 0.18-1
270 - Fix some errors pychecker caught.
271 - Allow exceptions to not be fatal so ksvalidator can spot more errors in
272 a single pass (#179894).
274 * Wed Feb 01 2006 Chris Lumens <clumens@redhat.com> 0.17-1
275 - Don't set a default port for vnc.
277 * Tue Jan 31 2006 Chris Lumens <clumens@redhat.com> 0.16-1
278 - Give dmraid string an initial value.
279 - Handle None on partition size.
281 * Tue Jan 31 2006 Peter Jones <pjones@redhat.com> 0.15-1
282 - Add dmraid support
284 * Mon Jan 30 2006 Chris Lumens <clumens@redhat.com> 0.14-1
285 - Fix VNC parameter parsing (#179209).
286 - Deprecate --connect. Add --host and --port instead.
288 * Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 0.13-1
289 - Recognize the --eject parameter to shutdown/halt.
290 - Store the exact post-installation action in ksdata.
292 * Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 0.12-1
293 - Clean up output quoting.
294 - Finish removing monitor-related stuff from xconfig.
296 * Mon Dec 12 2005 Chris Lumens <clumens@redhat.com> 0.11-1
297 - Deprecate monitor-related options to xconfig.
299 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
300 - Support --bytes-per-inode on raid
301 (Curtis Doty <Curtis at GreenKey.net> #175288).
303 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
304 - fixup network --onboot
306 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
307 - Default to SELINUX_ENFORCING.
308 - Default partition sizes to None for anaconda (#172378).
309 - Don't call shlex.split on anything inside a script (#172313).
311 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
312 - Fix clearpart --all.
313 - vnc command does not require --connect option (#172192).
314 - network --onboot does not take any option.
315 - Remove extra spaces from firewall --ports and --trust.
316 - Write out network --<service> options.
318 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
319 - Add --resolvedeps and --ignoredeps as deprecated options.
320 - Pass line number to header functions.
322 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
323 - Add line numbers to exception reporting.
324 - Added ksvalidator.
326 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
327 - Correct deprecated attribute on options.
328 - Added programming documentation.
330 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
331 - Correct python lib directory on 64-bit archs (#170621).
333 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
334 - Add a deprecated attribute to options.
335 - Add --card option back to xconfig and mark as deprecated.
336 - Throw a deprecation warning on mouse and langsupport commands.
337 - Rename Writer to KickstartWriter for consistency.
338 - Collapse scripts into a single list and add an attribute on Script to
339 differentiate.
341 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
342 - Rename module to pykickstart to avoid conflicts in anaconda.
343 - Rename data classes for consistency.
344 - Add default bytesPerInode settings.
346 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
347 - Created package from anaconda.