1 %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library
for manipulating kickstart files
5 Url
: http
://fedoraproject.org
/wiki
/pykickstart
8 # This is a Red Hat maintained package which is specific to
9 # our distribution. Thus the source is only available from
11 Source0: %{name}-%{version}.tar.gz
14 Group: System Environment
/Libraries
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n
)
17 BuildRequires
: python
-devel
, gettext
, python
-setuptools
-devel
18 BuildRequires
: transifex
-client
19 Requires: python
, python
-urlgrabber
22 The pykickstart package is a python library
for manipulating kickstart
33 make DESTDIR
=%{buildroot} install
39 %files -f
%{name}.lang
40 %defattr(-,root
,root
,-)
41 %doc README ChangeLog COPYING docs
/programmers
-guide
42 %doc docs
/kickstart
-docs.txt
44 %{_bindir}/ksvalidator
49 * Mon Jun
18 2012 Chris Lumens
<clumens@redhat.com
> - 1.99.12-1
50 - Add
--nontp option and a way to specify NTP servers to the timezone
command (vpodzime
)
51 - fix TypeError
in network.py with ipv6 static addresses
(wwoods
)
52 - Layouts may include spaces
, so put them
in quotes
(vpodzime
)
54 * Mon May
07 2012 Chris Lumens
<clumens@redhat.com
> - 1.99.11-1
55 - pylint doesn't like .setter syntax at all.
(clumens
)
56 - Modify keyboard
command to handle multiple layouts
(vpodzime
)
57 - Add support
for F18.
(vpodzime
)
58 - Fix traceback
if modules cannot be loaded when running tests
(vpodzime
)
60 * Mon Apr
02 2012 Chris Lumens
<clumens@redhat.com
> - 1.99.10-1
61 - Add resize option to partition and logvol commands.
(dlehman
)
62 - Add
--list
= mode to clearpart
for explicit list of partitions to remove.
(dlehman
)
64 * Thu Mar
22 2012 Chris Lumens
<clumens@redhat.com
> - 1.99.9-1
65 - Add __ne__ methods to every object with an __eq__ method.
(clumens
)
66 - Use the older exception syntax
for python
2.4 compatibility.
(clumens
)
67 - Add an __eq__ method to the method
command.
(clumens
)
69 * Wed Mar
14 2012 Chris Lumens
<clumens@redhat.com
> - 1.99.8-1
70 - Add support
for RHEL7
(#802369).
71 - Add a method to
set a
command back to its initial blank state.
72 - btrfs likes its raid levels
in lower
case.
(#799154) (dlehman)
73 - iscsi
: add support
for interface binding to F17
(rvykydal
)
74 - iscsi
: add support
for interface binding
(#500273) (rvykydal)
76 * Wed Jan
11 2012 Chris Lumens
<clumens@redhat.com
> - 1.99.7-1
77 - Add
--type option to autopart
command.
(dlehman
)
78 - Add btrfs
command.
(dlehman
)
80 * Tue Nov
15 2011 Chris Lumens
<clumens@redhat.com
> - 1.99.6-1
81 - Add
--boot
-drive option to bootloader
command to pick boot drive.
(dlehman
)
82 - Add support
for F17.
(clumens
)
83 - The guts of a script could include a line starting with a %
(#746928). (clumens)
85 * Wed Oct
19 2011 Chris Lumens
<clumens@redhat.com
> - 1.99.5-1
86 - Don't error out
if raid
--useexisting is given with no members
(#741728). (clumens)
87 - When
%end is missing
, include the unterminated section
in the error message.
(clumens
)
89 * Wed Sep
14 2011 Chris Lumens
<clumens@redhat.com
> - 1.99.4-1
90 - --reserved
-space and
--reserved
-percent should be checked on a callback.
(clumens
)
91 - Add a volgroup unit
test, and fix a bug it uncovered.
(clumens
)
92 - Add support
for reserved space
in volume group.
(dlehman
)
93 - Allow a
%include to come
in the middle of a section
(#733455). (clumens)
94 - Add a
test case for %include inside
%packages.
(clumens
)
96 * Mon Aug
22 2011 Chris Lumens
<clumens@redhat.com
> - 1.99.3-1
97 - Ignore reimport warnings.
(clumens
)
98 - Add support
for 'autopart
--nolvm'
(jlaska
)
99 - autopart
- Inherit error checking from base class
(jlaska
)
100 - Let's just use url.size instead. That's defined
for both FTP and HTTP.
(clumens
)
101 - It's url.hdr now
, not url.info.
(clumens
)
102 - Support end
-of
-line comments
in the
%packages section
(#728563). (clumens)
104 * Mon Jun
27 2011 Chris Lumens
<clumens@redhat.com
> - 1.99.2-1
105 - Don't
do "
make po
-pull" during installation.
(clumens
)
107 * Mon Jun
27 2011 Chris Lumens
<clumens@redhat.com
> - 1.99.1-1
108 - Fix a couple Makefile typos.
(clumens
)
109 - typo fix
(vpodzime
)
110 - option
for wpa wifi connection specification added
(vpodzime
)
111 - Update Makefiles to work with new translation system.
(clumens
)
112 - BuildRequires transifex
-client.
(clumens
)
113 - Ignore po
/*.po files.
(clumens
)
114 - Remove translation files.
(clumens
)
115 - Add transifex
-client configuration file.
(clumens
)
116 - Fix po files so "msgfmt
-c" passes and they can be uploaded to transifex.
(clumens
)
118 * Tue Jun
07 2011 Chris Lumens
<clumens@redhat.com
> 1.99.0-1
119 - Add a way to tell how often a section has been handled.
(clumens
)
120 - Add a NullSection that just ignores any section provided.
(clumens
)
121 - Add
test cases
for the parser itself.
(clumens
)
122 - Allow
for defining your own kickstart
%sections.
(clumens
)
123 - The docs need to be fetched from an HTTPS location now.
(clumens
)
124 - Write out
--onboot
=off
if it's False.
(clumens
)
126 * Fri Mar
25 2011 Chris Lumens
<clumens@redhat.com
> - 1.83-1
127 - Add kickstart network
--nodefroute option
(#668417) (rvykydal)
128 - Add support
for network
--bootproto ibft option
(#668417) (rvykydal)
129 - Add network
--activate option
(#668417) (rvykydal)
130 - Add support
for F16.
(clumens
)
132 * Fri Feb
18 2011 Chris Lumens
<clumens@redhat.com
> - 1.82-1
133 - Add support
for "logvol
--label
="
(#677571). (clumens)
135 * Wed Jan
19 2011 Chris Lumens
<clumens@redhat.com
> - 1.81-1
136 - Add support
for "raid
--label
="
(#670643). (clumens)
137 - --baseurl
/--mirrorlist are no longer required
for the repo
command.
(clumens
)
138 - Make use of the "interactive"
command an error.
(clumens
)
140 * Fri Dec
10 2010 Chris Lumens
<clumens@redhat.com
> - 1.80-1
141 - Remove preceededInclude
= support
(#639372). (clumens)
142 - support noverifyssl on the rhel6
-branch
(method
, repo
) (#660340). (akozumpl)
143 - l10n
: Added Low German translation
(ncfiedler
)
145 * Mon Nov
08 2010 Chris Lumens
<clumens@redhat.com
> 1.79-1
146 - Move from pychecker to pylint
, since the latter actually works.
147 - Lots of minor corrections
for pylint.
148 - Add bootloader
--iscrypted
(#554870).
149 - Add support
for F15.
151 * Fri Sep
10 2010 Chris Lumens
<clumens@redhat.com
> - 1.78-1
152 - Raise KickstartError instead of IOError
(#618002). (clumens)
153 - It's
--biospart
, not
--biosdisk
(#620855). (clumens)
154 - Translation updates.
156 * Tue Jul
20 2010 Chris Lumens
<clumens@redhat.com
> - 1.77-1
157 - Send the key
command down the memory hole.
(clumens
)
158 - Deprecate interactive kickstart mode.
(clumens
)
160 * Thu Jul
08 2010 Chris Lumens
<clumens@redhat.com
> - 1.76-1
161 - method
: new parameter '
--noverifyssl' after
--url.
(akozumpl
)
162 - repo
: new parameter '
--noverifyssl'.
(akozumpl
)
164 * Tue Jun
22 2010 Chris Lumens
<clumens@redhat.com
> - 1.75-1
165 - Update translation files.
(clumens
)
166 - Remove everything from pykickstart that's been deprecated forever.
(clumens
)
167 - Using the knowledge of what
command supports what option
, condense
test cases.
(clumens
)
168 - Add a method to list all supported options
for a
command being tested.
(clumens
)
169 - Add support
for F14.
(clumens
)
170 - The
%end at the end of a section is now required.
(clumens
)
172 * Thu Jun
10 2010 Chris Lumens
<clumens@redhat.com
> - 1.74-1
173 - If an option is deprecated
, do not care
if it takes a value
(#602303). (clumens)
174 - Don't compare the dest
("telnet"
) with the option string
("
--telnet"
).
(clumens
)
175 - The
--connect
= parameter wasn't really deprecated
in FC6.
(clumens
)
177 * Tue Jun
01 2010 Chris Lumens
<clumens@redhat.com
> - 1.73-1
178 - Allow "ignoredisk" to explicitly specify interactive usage
(#596804) (pjones)
180 * Fri Apr
23 2010 Chris Lumens
<clumens@redhat.com
> - 1.72-1
181 - Return non
-zero on error from ksvalidator
(#585284). (clumens)
183 * Wed Apr
14 2010 Chris Lumens
<clumens@redhat.com
> - 1.71-1
184 - Don't overwrite the excluded group list after every
%packages line
(#577334). (clumens)
185 - Add a bunch of
test cases
for the packages section.
(clumens
)
187 * Wed Mar
31 2010 Chris Lumens
<clumens@redhat.com
> - 1.70-1
188 - Add support
for RAID4
(#578514). (clumens)
189 - Escape percent signs
in the changelog.
(clumens
)
191 * Wed Mar
10 2010 Chris Lumens
<clumens@redhat.com
> - 1.69-1
192 - Add driverdisk
--biospart
= (#570437). (clumens)
193 - Fix IOError catching
in ksflatten
(jgregusk
, #558650).
195 * Thu Jan
14 2010 Chris Lumens
<clumens@redhat.com
> - 1.68-1
196 - Support removing groups that were included by a glob
(#554717). (clumens)
197 - Make sure that everything
in version.versionMap has a handler.
(clumens
)
198 - Add support
for RHEL6
(#552230). (clumens)
199 - Don't consider RHEL versions as developmental even
if they're latest.
(clumens
)
200 - Add lineno to BaseData and derived classes
(version
2) (hdegoede
)
201 - Give the non mandatory iscsi
--port argument a sane default
(hdegoede
)
202 - Change python_sitelib macro to use %
%global for new rpm
(hdegoede
)
203 - Fix typo
in iscsi parsing error message
(hdegoede
)
205 * Thu Dec
03 2009 Chris Lumens
<clumens@redhat.com
> - 1.67-1
206 - Don't use action
="append_const"
in firewall.py.
207 - Make "
make archive" depend on
test and check passing again.
208 - versionToString now works
in all cases we
test for.
209 - Fix the few pychecker errors outstanding
in options.py.
210 - Fix
make docs to
make docs dir before trying to download files there
(hdegoede
)
212 * Wed Nov
25 2009 Hans de Goede
<hdgoede@redhat.com
> - 1.66-1
213 - Add
--dcb option to fcoe
command (#513011)
214 - Remove rhpl from tests
215 - Port bootloader
--hvargs option added
in rhel5
216 - Ignore comments when looking
for %
%ksappend lines
(#525676)
217 - Use python
2.x exception syntax
219 * Thu Nov
12 2009 Chris Lumens
<clumens@redhat.com
> - 1.65-1
220 - Add additional arguments to BaseHandler.__init__
for better map control.
221 - Return the KickstartCommand
/KickstartData object from dispatcher.
222 - Add an "sshpw"
command for changing the passwords
in anaconda's env.
223 - Add
--proxy support to the url and repo commands.
224 - Add support
for F13. Is it really that
time already?
226 * Wed Sep
30 2009 Chris Lumens
<clumens@redhat.com
> - 1.64-1
227 - Update the zfcp
command for F12
(#526360).
228 - Move "
make" to %
%build (#524215).
230 * Wed Sep
16 2009 Chris Lumens
<clumens@redhat.com
> - 1.63-1
231 - Add encryption key escrow support
(mitr
, #508963).
232 - Fix the repo
test cases to expect quotes around the repo's name.
234 * Thu Sep
10 2009 Chris Lumens
<clumens@redhat.com
> - 1.62-1
235 - Support translated
help text
in optparse
(#479519).
236 - If the input kickstart file cannot be
read, raise IOError
(#519477).
238 * Thu Aug
27 2009 Chris Lumens
<clumens@redhat.com
> - 1.61-1
239 - Include the error messages from URLGrabError
in the exception
(#518443).
241 * Tue Aug
11 2009 Chris Lumens
<clumens@redhat.com
> - 1.60-1
242 - Put quotes around the repo's name
(Marc.Herbert@gmail.com
).
243 - Make duplicate entries warnings
, not errors
(#516338).
245 * Tue Jul
28 2009 Chris Lumens
<clumens@redhat.com
> - 1.59-1
246 - Handle a few more places where a urlgrabber error could happen
(#512951).
247 - Error out
if the same partition
/repo
/network is defined twice
(#512956).
248 - Call parent class tests first.
(jlaska
)
249 - Add KSOptionParser to FC3 upgrade
command.
(jlaska
)
250 - Correct missing
return stmt
in _getArgsAsStr
() (jlaska
)
252 * Fri Jul
17 2009 Chris Lumens
<clumens@redhat.com
> - 1.58-1
253 - Adjust writePriority to fix lvm
-on
-raid0
test cases
(jlaska
).
254 - Add F12 to the version number tests.
(clumens
)
255 - F12_User
test case.
(dcantrell
)
256 - Add
--gecos argument to the 'user'
command (dcantrell
)
257 - Convert user.py to use _getArgsAsStr
() (dcantrell
)
259 * Fri Jul
10 2009 Chris Lumens
<clumens@redhat.com
> - 1.57-1
260 - Another patch to
make the bootloader
test work
(jlaska
).
262 * Thu Jul
09 2009 Chris Lumens
<clumens@redhat.com
> - 1.56-1
263 - Make sure to import the gettext stuff
in fcoe.
(clumens
)
264 - Correctly deprecate bootloader
--lba32
(jlaska
).
265 - pykickstart
: fix zfcp
command writepriority
(hdegoede
)
266 - pykickstart
: Add fcoe
command (take
2) (hdegoede
)
267 - Add a
test case for RAID
(jlaska
).
269 * Thu Jul
02 2009 Chris Lumens
<clumens@redhat.com
> - 1.55-1
270 - Add support
for the group
command to F12
(#509119).
271 - RHEL5 now supports RAID
10.
272 - The f12 hander class should be called F12Handler.
(jgranado
)
273 - Remove bootloader
--lba32.
274 - Add a new version of the driverdisk
command without
--type=.
275 - Add initial support
for F12.
276 - Fetch the programmers
-guide from the wiki now.
278 * Mon May
18 2009 Chris Lumens
<clumens@redhat.com
> - 1.54-1
279 - Make sure the F11 handler gets used
for "partition" and "part"
(#501020).
281 * Wed Apr
29 2009 Chris Lumens
<clumens@redhat.com
> - 1.53-1
282 - Move lineno
= from KSOptionParser.__init__ to parse_args
(#497149). (clumens)
283 - Use the F11 version of the partition
command.
(clumens
)
284 - Remove the
--start and
--end options since anaconda no longer uses them.
(clumens
)
285 - Remove a broken
test case.
(clumens
)
287 * Wed Feb
18 2009 Chris Lumens
<clumens@redhat.com
> - 1.52-1
288 - Add lots more
test cases
(alindebe
, mgracik
, stickster
).
289 - Add a skip attribute on key to shut up pychecker.
290 - Only show autostep
command when requested
(jlaska
)
291 - Strip spaces from service names
, and require an option to be provided.
292 - Surround services lists
in double quotes.
293 - Remove the extra space from the services __str__ method.
294 - Fix output formatting bugs
in firewall
, partition
, and repo
(mgracik
).
295 - Specifying both or neither of
--drives and
--only
-use should be an error.
296 - Corrected newline char
in return value of FC6_Method.
(mgracik
)
297 - Make
--drives a required option
for FC3
, and catch no args on F8.
298 - Fix final printing of the rescue
command (mgracik
).
299 - Surround output strings
in double quotes.
300 - Fix a typo
in the deviceprobe
command.
301 - Revert the more strict option processing on displaymode.
302 - Properly handle erroring on extra args
, not just extra options.
303 - Don't use the logging class since it interferes with the logging
test.
304 - port without host should raise KickstartParseError
, not kickstartValueError.
305 - Add the
--key option to option processing
, since it's a valid argument.
306 - Fix
test cases that were failing due to the new use of KSOptionParser.
307 - Teach driverdisk.py
command to reject extra partitions
(stickster
).
308 - Add KSOptionParser to all commands ... enables more strick option checking
(jlaska
).
309 - Use KSOptionParser so we can catch bad
command options
(jlaska
).
311 * Thu Jan
29 2009 Chris Lumens
<clumens@redhat.com
> - 1.51-1
312 - Make a couple changes to how the logging
command is handled.
313 - Add a lot of
test cases
(clumens
, alindebe
, jlaska
, fcami
, adamwill
, pfrields
).
314 - Fix output formatting
for the rootpw
command.
315 - For commands that take exactly one argument
, check and error correctly.
316 - Surround module options
in quotes on the output side
(jlaska
).
317 - Set module opts
in the FC3 handler correctly.
318 - Fix newlines on the device
command output
(jlaska
).
319 - If
--autoscreenshot is not specified
, still output "autostep".
320 - Move the currentCmd and currentLine into getParser
().
(jlaska
)
321 - Write out an selinux line
if set to disabled
, but not
if None.
322 - F9_LogVolData should inherit from FC4_LogVolData
, not FC3_LogVolData
(jlaska
).
323 - Add unittest framework along with logvol and vnc unittests.
(jlaska
)
324 - Don't
set the KSOption.required attribute
in the constructor
(jlaska
).
326 * Sat Jan
10 2009 Chris Lumens
<clumens@redhat.com
> - 1.50-1
327 - Add a script to diff two versions of kickstart syntax.
328 - Add an option to ksvalidator to list all available syntax versions.
329 - Remove a couple extra newlines
in output formatting.
330 - Add documentation
for the new %
%include representation.
331 - Add support
%include to the pykickstart data objects.
333 * Thu Jan
08 2009 Chris Lumens
<clumens@redhat.com
> - 1.49-1
334 - Add upgrade
--root
-device
(atodorov
, #471232).
335 - Use python's
builtin set rather than the Sets module
(#477836, dcantrell).
337 * Tue Dec
23 2008 Chris Lumens
<clumens@redhat.com
> - 1.48-1
338 - Allow ignoring group metadata from repos
, using a '
--ignoregroups'
340 - Add initial support
for F11.
341 - Specify the
command versions
in the handlers instead of making copies.
342 - Remove empty and pointless __init__ methods.
343 - Pass arguments to superclasses via
*args and
**kwargs
, all the way up.
344 - Add removedKeywords and removedAttrs lists on Commands and Data.
345 - Fix version regexes to handle double digits and minor releases
(jlaska
).
347 * Thu Oct
30 2008 Chris Lumens
<clumens@redhat.com
> - 1.47-1
348 - Fix enabling services we specify by specific options.
350 * Mon Oct
27 2008 Chris Lumens
<clumens@redhat.com
> - 1.46-1
351 - Add support
for firewall
--service
(#467005).
353 * Tue Oct
14 2008 Chris Lumens
<clumens@redhat.com
> - 1.45-1
354 - Lots of translation updates.
355 - Remove use of string.partition
for python2.4
(atodorov
).
357 * Mon Sep
22 2008 Chris Lumens
<clumens@redhat.com
> - 1.44-1
358 - Add support
for reverse CHAP to the kickstart iscsi
command (hans
)
361 * Wed Sep
03 2008 Chris Lumens
<clumens@redhat.com
> - 1.43-1
362 - Revert "Do not include passphrases
for encrypted block devices
in
363 anaconda
-ks.cfg."
(dlehman
)
364 - yum doesn't like when mirrorlist is "".
(clumens
)
366 * Mon Aug
11 2008 Chris Lumens
<clumens@redhat.com
> - 1.42-1
367 - Add rescue
command to pykickstart
(atodorov
)
368 - Sort %
%packages output
(katzj
)
369 - Fix a typo
(atodorov
).
371 * Fri Aug
01 2008 Chris Lumens
<clumens@redhat.com
> - 1.41-1
372 - RHEL5 supports ignoredisk
--only
-use now too.
(clumens
)
373 - Do not include passphrases
for encrypted block devices
in
374 anaconda
-ks.cfg.
(dlehman
)
375 - Fix F9
,F10
,RHEL5 "part" commands to use the same class as
376 "partition".
(dlehman
)
377 - Add an apply method
() for commands and implement
for lang
(katzj
)
379 * Tue Jul
15 2008 Chris Lumens
<clumens@redhat.com
> - 1.40-1
380 - RHEL5_LogVolData should inherit from FC4
, not FC3.
381 Also fix FC9
->F9 typo.
(dlehman
)
382 - Support creation of encrypted block devices
in RHEL5.
(#449830) (dlehman)
383 - Use the right LogVolData objects
for RHEL3 and
4 (jlaska
).
(clumens
)
384 - We no longer use rhpl
for translations.
(clumens
)
385 - All the base classes should derive from object.
(clumens
)
387 * Fri Jun
13 2008 Chris Lumens
<clumens@redhat.com
> - 1.39-1
388 - It's helpful to
return the parser object.
(clumens
)
390 * Tue Jun
10 2008 Chris Lumens
<clumens@redhat.com
> - 1.38-1
391 - Fix loading the Handler object by looking
for a more specific
392 name
(#450740). (clumens)
394 * Sun Jun
08 2008 Chris Lumens
<clumens@redhat.com
> - 1.37-1
395 - XConfig is still used by other projects
, so just deprecate some
398 * Thu May
29 2008 Chris Lumens
<clumens@redhat.com
> - 1.36-1
399 - It should be repo
--cost
, not repo
--priority.
(clumens
)
401 * Fri May
23 2008 Chris Lumens
<clumens@redhat.com
> - 1.35-1
402 - Bring driverdisk
command in line with the docs.
(clumens
)
403 - Change RAID
command print priorities
(jlaska
).
404 - According to docs
, physvols are space delimited.
(jlaska
)
405 - Don't write the label out twice
(jlaska
).
406 - Deprecate monitor and xconfig commands.
(clumens
)
408 * Wed May
07 2008 Chris Lumens
<clumens@redhat.com
> - 1.34-1
409 - Load the handler module automatically.
(clumens
)
410 - Add support
for F10.
(clumens
)
411 - Initialize cmd.handler earlier
; fixes repo.methodToRepo
() (markmc
)
412 - Don't shadow
builtin function names.
(clumens
)
413 - Running check is now required before pykickstart can be packaged.
(clumens
)
414 - Reorganize code a little bit to pass pychecker.
(clumens
)
416 * Tue Apr
08 2008 Chris Lumens
<clumens@redhat.com
> - 1.33-1
417 - Fix whitespace when printing out the bootloader
command (pmeyers
).
418 - Fix the
type on bootloader
--timeout processing.
(clumens
)
420 * Wed Apr
02 2008 Chris Lumens
<clumens@redhat.com
> - 1.32-1
421 - Make the string reader act like the file reader upon EOF.
(clumens
)
422 - Add syntax
for encrypted logical volumes.
(clumens
)
424 * Tue Mar
25 2008 Chris Lumens
<clumens@redhat.com
> - 1.31-1
425 - Support end
-of
-line comments.
(clumens
)
426 - Lots of translation updates.
428 * Tue Feb
26 2008 Chris Lumens
<clumens@redhat.com
> - 1.30-1
429 - Reverse writePriorities of iscsi and iscsname
(#434965, jlaska).
430 - Fix printing of iscsiname
command (#434945, jlaska).
431 - Don't traceback on ENOENT.
(pnasrat
)
432 - Store the mouse name as a string
, not a list.
(clumens
)
433 - Update translations.
435 * Wed Jan
30 2008 Chris Lumens
<clumens@redhat.com
> - 1.29-1
436 - Renamed bootproto
=ask to bootproto
=query
, add to RHEL5 as well.
(clumens
)
438 * Wed Jan
23 2008 Chris Lumens
<clumens@redhat.com
> - 1.28-1
439 - Fix traceback on volgroup
command.
(clumens
)
441 * Thu Jan
17 2008 Chris Lumens
<clumens@redhat.com
> - 1.27-1
442 - The bootprotoList needs to be defined before it's used.
(clumens
)
444 * Thu Jan
17 2008 Chris Lumens
<clumens@redhat.com
> - 1.26-1
445 - Add support
for network
--bootproto
=ask.
(clumens
)
447 * Tue Jan
15 2008 Chris Lumens
<clumens@redhat.com
> - 1.25-1
448 - Add the version to the output ks file.
(clumens
)
449 - Add syntax
for encrypted partitions and raid devices.
(clumens
)
451 * Thu Jan
10 2008 Chris Lumens
<clumens@redhat.com
> - 1.24-1
452 - Make inheritance and overriding of %
%packages work
(#427768). (clumens)
453 - Add an option
for which languages should be installed.
(katzj
)
454 - Use the right name
for the iscsi
--target variable
(#418781). (clumens)
456 * Mon Dec
10 2007 Chris Lumens
<clumens@redhat.com
> - 1.23-1
457 - Take Makefile improvements from anaconda.
458 - Fix a traceback on F9 zerombr
command (#395431).
459 - Update to handle new Python eggs packaging.
461 * Tue Nov
20 2007 Chris Lumens
<clumens@redhat.com
> 1.22-1
462 - Don't process or write out vnc
--enabled
(jlaska AT redhat DOT com
).
463 - Fix a traceback
in the clearpart
command.
465 * Tue Nov
06 2007 Chris Lumens
<clumens@redhat.com
> 1.21-1
466 - Save script line numbers
for debugging.
467 - More internal cleanups.
469 * Wed Oct
31 2007 Chris Lumens
<clumens@redhat.com
> 1.20-1
470 - Pull wiki docs from the new location.
471 - Fix error messages
for options that have been removed after having been
472 previously deprecated.
473 - zerombr no longer takes any arguments.
474 - %
%packages --ignoredeps
--resolvedeps have been removed.
475 - firewall
--high
--medium have been removed.
476 - vnc
--connect has been removed.
477 - xconfig options from monitor have now been removed.
478 - --bytes
-per
-inode has been marked as deprecated.
480 - Add
--fsprofile option to disk commands
(pjones
).
481 - Add F9 support
(pjones
).
482 - Lots of internal fixes
(clumens
, pjones
).
484 * Tue Oct
23 2007 Chris Lumens
<clumens@redhat.com
> 1.19-1
485 - Fix a traceback on the cdrom method.
487 * Thu Oct
18 2007 Chris Lumens
<clumens@redhat.com
> 1.18-1
488 - Don't write out %
%end to packages and scripts
if the syntax version doesn't
490 - Remove obsolete translation
(#332221).
492 * Thu Oct
04 2007 Chris Lumens
<clumens@redhat.com
> 1.17-1
493 - Simplify argument processing and printing.
495 * Wed Oct
03 2007 Chris Lumens
<clumens@redhat.com
> 1.16-1
496 - Undeprecate %
%packages --excludedocs.
497 - Fix a traceback
in the device
command handling.
498 - Add bootloader
--timeout
(katzj
).
500 * Tue Oct
02 2007 Chris Lumens
<clumens@redhat.com
> 1.15-1
501 - Update translations
(#259121).
502 - The device
command no longer takes a
type argument.
504 * Fri Sep
28 2007 Chris Lumens
<clumens@redhat.com
> 1.14-1
505 - Fix output formatting
for packages section header
(#310211).
506 - Add a script to flatten kickstart files containing includes
(katzj
).
508 * Wed Sep
12 2007 Chris Lumens
<clumens@redhat.com
> 1.13-1
509 - Add a
function to convert
URL method strings into repo objects
511 - Writer formatting fixes.
512 - Add kickstart documentation from the Fedora Wiki.
514 * Tue Sep
04 2007 Chris Lumens
<clumens@redhat.com
> 1.12-1
515 - Fix lots of problems
in processing the bootloader
, device
, network
, and
517 - Add %
%end when writing out scripts and packages.
518 - Add a makefile target to run pychecker to cut down on errors
in
521 * Mon Sep
3 2007 Jeremy Katz
<katzj@redhat.com
> - 1.11-1
522 - fix a few tracebacks
524 * Fri Aug
31 2007 Chris Lumens
<clumens@redhat.com
> 1.10-1
525 - Add network
--ipv6
=.
527 * Fri Aug
24 2007 Chris Lumens
<clumens@redhat.com
> 1.9-1
528 - Add support
for the %
%end directive to be placed at the end of scripts
529 and packages sections. Deprecate old syntax.
530 - Clean up after ksvalidator
if pykickstart issues a traceback.
531 - Add support
for repo
--priority
--includepkgs
--excludepkgs.
532 - Fix newline at end of reboot
--eject output
(#253562).
534 * Mon Aug
13 2007 Chris Lumens
<clumens@redhat.com
> 1.8-1
535 - Fix
type checking of string values.
537 * Thu Aug
09 2007 Chris Lumens
<clumens@redhat.com
> 1.7-1
538 - Clarify license
in spec file and all
source files.
539 - Check string values to options to
make sure they're not other options
542 * Thu Aug
02 2007 Chris Lumens
<clumens@redhat.com
> 1.6-1
543 - Fix a couple tracebacks
in ksvalidator.
544 - Change
--class to
--dhcpclass
(#248912).
546 * Thu Jul
19 2007 Chris Lumens
<clumens@redhat.com
> 1.5-2
547 - Require rhpl
(#248953).
549 * Tue Jul
17 2007 Chris Lumens
<clumens@redhat.com
> 1.5-1
550 - Fix traceback when calling preprocessKickstart.
552 * Tue Jul
17 2007 Chris Lumens
<clumens@redhat.com
> 1.4-1
553 - Add methods to handle the %
%ksappend directive.
554 - Fix ignoredisk
--disks.
556 * Wed Jul
11 2007 Chris Lumens
<clumens@redhat.com
> - 1.3-1
557 - Add support
for ignoredisk
--only
-use.
558 - Fix traceback
in raid
command printing method
(#246709).
560 * Fri Jun
08 2007 Chris Lumens
<clumens@redhat.com
> - 1.2-2
561 - Fix package review problems
(#226334).
563 * Mon Jun
04 2007 Chris Lumens
<clumens@redhat.com
> - 1.2-1
564 - Fix harddrive
install method error checking
(#232492).
565 - Set authentication information from the input line to preserve quoting
567 - Allow included files to be given by
URL.
568 - Fix typo
in user
--iscrypted option.
570 * Mon May
14 2007 Chris Lumens
<clumens@redhat.com
> - 1.1-1
571 - Better regexes
for splitting version strings into family and version.
572 - Add basic support
for RHEL3.
573 - Update translations.
575 * Fri Apr
13 2007 Chris Lumens
<clumens@redhat.com
> - 1.0-1
576 - Update documentation.
577 - Update translations.
579 * Mon Mar
19 2007 Chris Lumens
<clumens@redhat.com
> - 0.100-1
580 - bootloader should be written out after upgrade
/install.
581 - Treat class names as unicode strings
(#231053).
583 * Wed Mar
07 2007 Chris Lumens
<clumens@redhat.com
> - 0.99-1
584 - The timezone
command didn't recognize
--isUtc before FC6
(#231189).
585 - Recognize %
%ksappend lines
in ksvalidator.
586 - Don't
set default values
in some
command __init__ methods.
587 - Added an updates
command.
588 - Add support
for RAID10.
590 * Mon Feb
26 2007 Chris Lumens
<clumens@redhat.com
> - 0.98-1
591 - Fix device
command syntax to match anaconda.
592 - Fix __call__ on method
command.
594 * Wed Feb
21 2007 Chris Lumens
<clumens@redhat.com
> - 0.97-1
595 - Fix traceback when not overriding default mappings
(#229505).
597 * Tue Feb
20 2007 Chris Lumens
<clumens@redhat.com
> - 0.96-1
598 - Fix __str__ methods
for langsupport and reboot commands.
599 - Renamed BaseHandler.empty to BaseHandler.maskAllExcept.
600 - Split
command objects out into their own files
in commands
/.
601 - Rename
command objects to start with Version_.
602 - Support extended group selection syntax.
604 * Wed Feb
14 2007 Chris Lumens
<clumens@redhat.com
> - 0.95-1
605 - KickstartParser no longer takes a version argument.
606 - Be more lenient
in what strings stringToVersion accepts.
607 - Allow setting state on one data object from multiple files.
609 * Wed Feb
07 2007 Chris Lumens
<clumens@redhat.com
> - 0.94-1
610 - Add a newline to the end of the key
command output.
611 - Use network bootproto constants
(#197694).
612 - Fix tracebacks
in subclass __str__ methods
(#226734).
614 * Wed Jan
31 2007 Chris Lumens
<clumens@redhat.com
> - 0.93-2
615 - Make some minor spec file changes to get closer to the extras guidelines.
617 * Thu Jan
25 2007 Chris Lumens
<clumens@redhat.com
> - 0.93-1
618 - Add support
for FC3
, RHEL4
, and RHEL5.
619 - The key
command was not supported
until after FC6.
620 - Accept more strings
in stringToVersion.
622 * Fri Jan
19 2007 Chris Lumens
<clumens@redhat.com
> - 0.92-1
623 - Fix KickstartVersionError reporting.
624 - Add a version attribute to handler objects.
625 - Fix line number reporting on lots of commands.
626 - Add initial support
for Fedora
7 and remove deprecated commands.
627 - Accept a
--default argument to the %
%packages header
(#221305).
629 * Wed Jan
17 2007 Chris Lumens
<clumens@redhat.com
> - 0.91-1
630 - Add a method to
read kickstart files from strings.
632 * Tue Jan
16 2007 Chris Lumens
<clumens@redhat.com
> - 0.90-1
633 - Support multiple versions of kickstart syntax from one code base
635 - Fix inconsistency between Script parser and writer
(#222877).
637 * Fri Dec
15 2006 Chris Lumens
<clumens@redhat.com
> - 0.43-1
638 - Pull
in new translations
(#216620).
640 * Thu Dec
7 2006 Jeremy Katz
<katzj@redhat.com
> - 0.42-2
641 - rebuild against python
2.5
643 * Tue Dec
05 2006 Chris Lumens
<clumens@redhat.com
> - 0.42-1
644 - Fix traceback when writing out repo
command (#218274).
646 * Fri Dec
01 2006 Chris Lumens
<clumens@redhat.com
> - 0.41-1
647 - Fix traceback when using deprecated commands
(#218047, #218059).
649 * Thu Nov
30 2006 Chris Lumens
<clumens@redhat.com
> - 0.40-1
650 - Pull
in new translations
(#216620).
651 - Add
--level argument to logging
command writer.
653 * Tue Oct
24 2006 Chris Lumens
<clumens@redhat.com
> - 0.39-2
654 - Fix release number.
656 * Tue Oct
24 2006 Chris Lumens
<clumens@redhat.com
> - 0.39-1
657 - Add writer
for --key
(#211997).
659 * Tue Oct
17 2006 Jeremy Katz
<katzj@redhat.com
> - 0.38-1
660 - allow
--skip
for installation number as well
(#207029)
662 * Mon Oct
16 2006 Jeremy Katz
<katzj@redhat.com
> - 0.37-1
663 - support
for installation numbers
(#207029)
665 * Fri Oct
13 2006 Bill Nottingham
<notting@redhat.com
> - 0.36-1
666 - use valid charsets
in translations
(#210720)
668 * Fri Sep
29 2006 Chris Lumens
<clumens@redhat.com
> - 0.35-1
669 - Fix traceback
in harddrive
command (#208557).
671 * Mon Sep
25 2006 Chris Lumens
<clumens@redhat.com
> - 0.34-1
672 - Add support
for --biospart option to harddrive
(#207585).
673 - Update writer
for syntax changes.
675 * Wed Sep
20 2006 Jeremy Katz
<katzj@redhat.com
> - 0.33-1
676 - improved iscsi syntax
677 - allow multiple zfcp devs
679 * Thu Jul
20 2006 Chris Lumens
<clumens@redhat.com
> 0.32-1
680 - Limit
--bootproto to what anaconda supports.
681 - Add
--noipv4 and
--noipv6 network options.
683 * Tue Jun
20 2006 Chris Lumens
<clumens@redhat.com
> 0.31-1
684 - Handle nfs
--opts
(katzj
).
685 - RAID devices should be integers instead of strings
(#176537).
686 - Add initial support
for iscsi
(katzj
).
688 * Tue Jun
06 2006 Chris Lumens
<clumens@redhat.com
> 0.30-2
689 - Add BuildRequires to fix building under mock
(#194156, Joost Soeterbroek
690 <fedora AT soeterbroek.com
>).
692 * Thu May
25 2006 Chris Lumens
<clumens@redhat.com
> 0.30-1
693 - Change order of LVM
-related writing functions
(#193073).
694 - Require urlgrabber.
695 - Return a more useful error message on unknown commands.
696 - Fix logvol writing typo.
697 - Make ksvalidator validate from a
URL in addition to a file.
698 - Don't write out an empty packages section
(#192851).
700 * Tue May
23 2006 Chris Lumens
<clumens@redhat.com
> 0.29-1
701 - Add multipath
command, handlers
, and data objects
(pjones
).
702 - Rename
--ports to
--port
in writer.
704 * Mon May
15 2006 Chris Lumens
<clumens@redhat.com
> 0.28-1
705 - Support
--mtu
for the network
command (#191328).
706 - Accept
--isUtc
for backwards compatibility.
708 * Wed May
04 2006 Chris Lumens
<clumens@redhat.com
> 0.27-1
709 - Output formatting fixes.
710 - Added commands
for managing users and services.
712 * Mon Apr
17 2006 Chris Lumens
<clumens@redhat.com
> 0.26-1
713 - Ignore spaces before group names
(#188095).
714 - Added some translations.
715 - Add options
for repo
command.
716 - Reorder %
%packages section output.
717 - Output %
%packages header options.
718 - Initialize RAID and volume group members to empty lists.
720 * Mon Mar
27 2006 Chris Lumens
<clumens@redhat.com
> 0.25-1
721 - Add support
for the logging
command.
723 * Mon Mar
27 2006 Chris Lumens
<clumens@redhat.com
> 0.24-1
724 - Don't write out a blank xconfig line.
725 - Reorder output handlers to group like commands together.
726 - Mark strings
for translation.
728 * Tue Mar
07 2006 Chris Lumens
<clumens@redhat.com
> 0.23-1
729 - Backwards compatibility support
for options to zerombr.
731 * Fri Feb
24 2006 Chris Lumens
<clumens@redhat.com
> 0.22-1
732 - Get ignoredisk working again
(#182934).
734 * Fri Feb
17 2006 Chris Lumens
<clumens@redhat.com
> 0.21-1
735 - Provide an option to not traceback on missing include files
(#181760).
736 - Update programming documentation.
738 * Mon Feb
13 2006 Chris Lumens
<clumens@redhat.com
> 0.20-1
739 - Correctly
set --noformat and
--useexisting on lvm and raid.
741 * Mon Feb
13 2006 Chris Lumens
<clumens@redhat.com
> 0.19-1
742 - --onboot requires a value
(#180987).
743 - Be more strict about commands that don't take arguments.
745 * Thu Feb
09 2006 Chris Lumens
<clumens@redhat.com
> 0.18-1
746 - Fix some errors pychecker caught.
747 - Allow exceptions to not be fatal so ksvalidator can spot more errors
in
748 a single pass
(#179894).
750 * Wed Feb
01 2006 Chris Lumens
<clumens@redhat.com
> 0.17-1
751 - Don't
set a default port
for vnc.
753 * Tue Jan
31 2006 Chris Lumens
<clumens@redhat.com
> 0.16-1
754 - Give dmraid string an initial value.
755 - Handle None on partition size.
757 * Tue Jan
31 2006 Peter Jones
<pjones@redhat.com
> 0.15-1
760 * Mon Jan
30 2006 Chris Lumens
<clumens@redhat.com
> 0.14-1
761 - Fix VNC parameter parsing
(#179209).
762 - Deprecate
--connect. Add
--host and
--port instead.
764 * Thu Jan
19 2006 Chris Lumens
<clumens@redhat.com
> 0.13-1
765 - Recognize the
--eject parameter to shutdown
/halt.
766 - Store the exact post
-installation action
in ksdata.
768 * Mon Jan
09 2006 Chris Lumens
<clumens@redhat.com
> 0.12-1
769 - Clean up output quoting.
770 - Finish removing monitor
-related stuff from xconfig.
772 * Mon Dec
12 2005 Chris Lumens
<clumens@redhat.com
> 0.11-1
773 - Deprecate monitor
-related options to xconfig.
775 * Thu Dec
08 2005 Chris Lumens
<clumens@redhat.com
> 0.10-1
776 - Support
--bytes
-per
-inode on raid
777 (Curtis Doty
<Curtis at GreenKey.net
> #175288).
779 * Wed Nov
16 2005 Jeremy Katz
<katzj@redhat.com
> - 0.9-1
780 - fixup network
--onboot
782 * Thu Nov
03 2005 Chris Lumens
<clumens@redhat.com
> 0.8-1
783 - Default to SELINUX_ENFORCING.
784 - Default partition sizes to None
for anaconda
(#172378).
785 - Don't call shlex.split on anything inside a script
(#172313).
787 * Tue Nov
01 2005 Chris Lumens
<clumens@redhat.com
> 0.7-1
788 - Fix clearpart
--all.
789 - vnc
command does not require
--connect option
(#172192).
790 - network
--onboot does not take any option.
791 - Remove extra spaces from firewall
--ports and
--trust.
792 - Write out network
--<service
> options.
794 * Fri Oct
28 2005 Chris Lumens
<clumens@redhat.com
> 0.6-1
795 - Add
--resolvedeps and
--ignoredeps as deprecated options.
796 - Pass line number to header functions.
798 * Mon Oct
24 2005 Chris Lumens
<clumens@redhat.com
> 0.5-1
799 - Add line numbers to exception reporting.
802 * Wed Oct
19 2005 Chris Lumens
<clumens@redhat.com
> 0.4-1
803 - Correct deprecated attribute on options.
804 - Added programming documentation.
806 * Thu Oct
13 2005 Chris Lumens
<clumens@redhat.com
> 0.3-2
807 - Correct python lib directory on
64-bit archs
(#170621).
809 * Fri Oct
07 2005 Chris Lumens
<clumens@redhat.com
> 0.3-1
810 - Add a deprecated attribute to options.
811 - Add
--card option back to xconfig and mark as deprecated.
812 - Throw a deprecation warning on mouse and langsupport commands.
813 - Rename Writer to KickstartWriter
for consistency.
814 - Collapse scripts into a single list and add an attribute on Script to
817 * Wed Oct
05 2005 Chris Lumens
<clumens@redhat.com
> 0.2-1
818 - Rename module to pykickstart to avoid conflicts
in anaconda.
819 - Rename data classes
for consistency.
820 - Add default bytesPerInode settings.
822 * Wed Oct
05 2005 Chris Lumens
<clumens@redhat.com
> 0.1-1
823 - Created package from anaconda.