Add --level.
[pykickstart.git] / pykickstart.spec
blobfe13ba4d0c6a1ab8342134073b4d0ba5cc7c633b
1 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Version: 0.39
6 Release: 2%{?dist}
7 Source0: %{name}-%{version}.tar.gz
8 License: GPL
9 Group: System Environment/Libraries
10 BuildArch: noarch
11 BuildRoot: %{_tmppath}/%{name}-root
12 BuildRequires: python-devel
13 BuildRequires: gettext
14 Requires: python >= %(%{__python} -c "import sys; print sys.version[:3]")
15 Requires: python-urlgrabber
17 %description
18 The pykickstart package is a python library for manipulating kickstart
19 files.
21 %prep
22 %setup -q
23 make
25 %build
27 %install
28 rm -rf $RPM_BUILD_ROOT
29 make DESTDIR=${RPM_BUILD_ROOT} install
31 %clean
32 rm -rf $RPM_BUILD_ROOT
34 %files
35 %defattr(-,root,root)
36 %doc README ChangeLog COPYING docs/programmers-guide
37 %{python_sitelib}/pykickstart
38 /usr/bin/ksvalidator
39 /usr/share/locale/*/*/*
41 %changelog
42 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-2
43 - Fix release number.
45 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-1
46 - Add writer for --key (#211997).
48 * Tue Oct 17 2006 Jeremy Katz <katzj@redhat.com> - 0.38-1
49 - allow --skip for installation number as well (#207029)
51 * Mon Oct 16 2006 Jeremy Katz <katzj@redhat.com> - 0.37-1
52 - support for installation numbers (#207029)
54 * Fri Oct 13 2006 Bill Nottingham <notting@redhat.com> - 0.36-1
55 - use valid charsets in translations (#210720)
57 * Fri Sep 29 2006 Chris Lumens <clumens@redhat.com> - 0.35-1
58 - Fix traceback in harddrive command (#208557).
60 * Mon Sep 25 2006 Chris Lumens <clumens@redhat.com> - 0.34-1
61 - Add support for --biospart option to harddrive (#207585).
62 - Update writer for syntax changes.
64 * Wed Sep 20 2006 Jeremy Katz <katzj@redhat.com> - 0.33-1
65 - improved iscsi syntax
66 - allow multiple zfcp devs
68 * Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 0.32-1
69 - Limit --bootproto to what anaconda supports.
70 - Add --noipv4 and --noipv6 network options.
72 * Tue Jun 20 2006 Chris Lumens <clumens@redhat.com> 0.31-1
73 - Handle nfs --opts (katzj).
74 - RAID devices should be integers instead of strings (#176537).
75 - Add initial support for iscsi (katzj).
77 * Tue Jun 06 2006 Chris Lumens <clumens@redhat.com> 0.30-2
78 - Add BuildRequires to fix building under mock (#194156, Joost Soeterbroek
79 <fedora AT soeterbroek.com>).
81 * Thu May 25 2006 Chris Lumens <clumens@redhat.com> 0.30-1
82 - Change order of LVM-related writing functions (#193073).
83 - Require urlgrabber.
84 - Return a more useful error message on unknown commands.
85 - Fix logvol writing typo.
86 - Make ksvalidator validate from a URL in addition to a file.
87 - Don't write out an empty packages section (#192851).
89 * Tue May 23 2006 Chris Lumens <clumens@redhat.com> 0.29-1
90 - Add multipath command, handlers, and data objects (pjones).
91 - Rename --ports to --port in writer.
93 * Mon May 15 2006 Chris Lumens <clumens@redhat.com> 0.28-1
94 - Support --mtu for the network command (#191328).
95 - Accept --isUtc for backwards compatibility.
97 * Wed May 04 2006 Chris Lumens <clumens@redhat.com> 0.27-1
98 - Output formatting fixes.
99 - Added commands for managing users and services.
101 * Mon Apr 17 2006 Chris Lumens <clumens@redhat.com> 0.26-1
102 - Ignore spaces before group names (#188095).
103 - Added some translations.
104 - Add options for repo command.
105 - Reorder %packages section output.
106 - Output %packages header options.
107 - Initialize RAID and volume group members to empty lists.
109 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.25-1
110 - Add support for the logging command.
112 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.24-1
113 - Don't write out a blank xconfig line.
114 - Reorder output handlers to group like commands together.
115 - Mark strings for translation.
117 * Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 0.23-1
118 - Backwards compatibility support for options to zerombr.
120 * Fri Feb 24 2006 Chris Lumens <clumens@redhat.com> 0.22-1
121 - Get ignoredisk working again (#182934).
123 * Fri Feb 17 2006 Chris Lumens <clumens@redhat.com> 0.21-1
124 - Provide an option to not traceback on missing include files (#181760).
125 - Update programming documentation.
127 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.20-1
128 - Correctly set --noformat and --useexisting on lvm and raid.
130 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.19-1
131 - --onboot requires a value (#180987).
132 - Be more strict about commands that don't take arguments.
134 * Thu Feb 09 2006 Chris Lumens <clumens@redhat.com> 0.18-1
135 - Fix some errors pychecker caught.
136 - Allow exceptions to not be fatal so ksvalidator can spot more errors in
137 a single pass (#179894).
139 * Wed Feb 01 2006 Chris Lumens <clumens@redhat.com> 0.17-1
140 - Don't set a default port for vnc.
142 * Tue Jan 31 2006 Chris Lumens <clumens@redhat.com> 0.16-1
143 - Give dmraid string an initial value.
144 - Handle None on partition size.
146 * Tue Jan 31 2006 Peter Jones <pjones@redhat.com> 0.15-1
147 - Add dmraid support
149 * Mon Jan 30 2006 Chris Lumens <clumens@redhat.com> 0.14-1
150 - Fix VNC parameter parsing (#179209).
151 - Deprecate --connect. Add --host and --port instead.
153 * Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 0.13-1
154 - Recognize the --eject parameter to shutdown/halt.
155 - Store the exact post-installation action in ksdata.
157 * Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 0.12-1
158 - Clean up output quoting.
159 - Finish removing monitor-related stuff from xconfig.
161 * Mon Dec 12 2005 Chris Lumens <clumens@redhat.com> 0.11-1
162 - Deprecate monitor-related options to xconfig.
164 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
165 - Support --bytes-per-inode on raid
166 (Curtis Doty <Curtis at GreenKey.net> #175288).
168 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
169 - fixup network --onboot
171 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
172 - Default to SELINUX_ENFORCING.
173 - Default partition sizes to None for anaconda (#172378).
174 - Don't call shlex.split on anything inside a script (#172313).
176 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
177 - Fix clearpart --all.
178 - vnc command does not require --connect option (#172192).
179 - network --onboot does not take any option.
180 - Remove extra spaces from firewall --ports and --trust.
181 - Write out network --<service> options.
183 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
184 - Add --resolvedeps and --ignoredeps as deprecated options.
185 - Pass line number to header functions.
187 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
188 - Add line numbers to exception reporting.
189 - Added ksvalidator.
191 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
192 - Correct deprecated attribute on options.
193 - Added programming documentation.
195 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
196 - Correct python lib directory on 64-bit archs (#170621).
198 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
199 - Add a deprecated attribute to options.
200 - Add --card option back to xconfig and mark as deprecated.
201 - Throw a deprecation warning on mouse and langsupport commands.
202 - Rename Writer to KickstartWriter for consistency.
203 - Collapse scripts into a single list and add an attribute on Script to
204 differentiate.
206 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
207 - Rename module to pykickstart to avoid conflicts in anaconda.
208 - Rename data classes for consistency.
209 - Add default bytesPerInode settings.
211 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
212 - Created package from anaconda.