Limit bootproto to options anaconda supports. Add --noipv4 and --noipv6.
[pykickstart.git] / pykickstart.spec
blob4aa39d56c21faa707e1a316f5fe346653b44ccdd
1 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Version: 0.31
6 Release: 1
7 Source0: %{name}-%{version}.tar.gz
8 License: GPL
9 Group: System Environment/Libraries
10 BuildArch: noarch
11 BuildRoot: %{_tmppath}/%{name}-root
12 BuildRequires: python-devel
13 BuildRequires: gettext
14 Requires: python >= %(%{__python} -c "import sys; print sys.version[:3]")
15 Requires: python-urlgrabber
17 %description
18 The pykickstart package is a python library for manipulating kickstart
19 files.
21 %prep
22 %setup -q
23 make
25 %build
27 %install
28 rm -rf $RPM_BUILD_ROOT
29 make DESTDIR=${RPM_BUILD_ROOT} install
31 %clean
32 rm -rf $RPM_BUILD_ROOT
34 %files
35 %defattr(-,root,root)
36 %doc README ChangeLog COPYING docs/programmers-guide
37 %{python_sitelib}/pykickstart
38 /usr/bin/ksvalidator
39 /usr/share/locale/*/*/*
41 %changelog
42 * Tue Jun 20 2006 Chris Lumens <clumens@redhat.com> 0.31-1
43 - Handle nfs --opts (katzj).
44 - RAID devices should be integers instead of strings (#176537).
45 - Add initial support for iscsi (katzj).
47 * Tue Jun 06 2006 Chris Lumens <clumens@redhat.com> 0.30-2
48 - Add BuildRequires to fix building under mock (#194156, Joost Soeterbroek
49 <fedora AT soeterbroek.com>).
51 * Thu May 25 2006 Chris Lumens <clumens@redhat.com> 0.30-1
52 - Change order of LVM-related writing functions (#193073).
53 - Require urlgrabber.
54 - Return a more useful error message on unknown commands.
55 - Fix logvol writing typo.
56 - Make ksvalidator validate from a URL in addition to a file.
57 - Don't write out an empty packages section (#192851).
59 * Tue May 23 2006 Chris Lumens <clumens@redhat.com> 0.29-1
60 - Add multipath command, handlers, and data objects (pjones).
61 - Rename --ports to --port in writer.
63 * Mon May 15 2006 Chris Lumens <clumens@redhat.com> 0.28-1
64 - Support --mtu for the network command (#191328).
65 - Accept --isUtc for backwards compatibility.
67 * Wed May 04 2006 Chris Lumens <clumens@redhat.com> 0.27-1
68 - Output formatting fixes.
69 - Added commands for managing users and services.
71 * Mon Apr 17 2006 Chris Lumens <clumens@redhat.com> 0.26-1
72 - Ignore spaces before group names (#188095).
73 - Added some translations.
74 - Add options for repo command.
75 - Reorder %packages section output.
76 - Output %packages header options.
77 - Initialize RAID and volume group members to empty lists.
79 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.25-1
80 - Add support for the logging command.
82 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.24-1
83 - Don't write out a blank xconfig line.
84 - Reorder output handlers to group like commands together.
85 - Mark strings for translation.
87 * Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 0.23-1
88 - Backwards compatibility support for options to zerombr.
90 * Fri Feb 24 2006 Chris Lumens <clumens@redhat.com> 0.22-1
91 - Get ignoredisk working again (#182934).
93 * Fri Feb 17 2006 Chris Lumens <clumens@redhat.com> 0.21-1
94 - Provide an option to not traceback on missing include files (#181760).
95 - Update programming documentation.
97 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.20-1
98 - Correctly set --noformat and --useexisting on lvm and raid.
100 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.19-1
101 - --onboot requires a value (#180987).
102 - Be more strict about commands that don't take arguments.
104 * Thu Feb 09 2006 Chris Lumens <clumens@redhat.com> 0.18-1
105 - Fix some errors pychecker caught.
106 - Allow exceptions to not be fatal so ksvalidator can spot more errors in
107 a single pass (#179894).
109 * Wed Feb 01 2006 Chris Lumens <clumens@redhat.com> 0.17-1
110 - Don't set a default port for vnc.
112 * Tue Jan 31 2006 Chris Lumens <clumens@redhat.com> 0.16-1
113 - Give dmraid string an initial value.
114 - Handle None on partition size.
116 * Tue Jan 31 2006 Peter Jones <pjones@redhat.com> 0.15-1
117 - Add dmraid support
119 * Mon Jan 30 2006 Chris Lumens <clumens@redhat.com> 0.14-1
120 - Fix VNC parameter parsing (#179209).
121 - Deprecate --connect. Add --host and --port instead.
123 * Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 0.13-1
124 - Recognize the --eject parameter to shutdown/halt.
125 - Store the exact post-installation action in ksdata.
127 * Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 0.12-1
128 - Clean up output quoting.
129 - Finish removing monitor-related stuff from xconfig.
131 * Mon Dec 12 2005 Chris Lumens <clumens@redhat.com> 0.11-1
132 - Deprecate monitor-related options to xconfig.
134 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
135 - Support --bytes-per-inode on raid
136 (Curtis Doty <Curtis at GreenKey.net> #175288).
138 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
139 - fixup network --onboot
141 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
142 - Default to SELINUX_ENFORCING.
143 - Default partition sizes to None for anaconda (#172378).
144 - Don't call shlex.split on anything inside a script (#172313).
146 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
147 - Fix clearpart --all.
148 - vnc command does not require --connect option (#172192).
149 - network --onboot does not take any option.
150 - Remove extra spaces from firewall --ports and --trust.
151 - Write out network --<service> options.
153 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
154 - Add --resolvedeps and --ignoredeps as deprecated options.
155 - Pass line number to header functions.
157 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
158 - Add line numbers to exception reporting.
159 - Added ksvalidator.
161 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
162 - Correct deprecated attribute on options.
163 - Added programming documentation.
165 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
166 - Correct python lib directory on 64-bit archs (#170621).
168 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
169 - Add a deprecated attribute to options.
170 - Add --card option back to xconfig and mark as deprecated.
171 - Throw a deprecation warning on mouse and langsupport commands.
172 - Rename Writer to KickstartWriter for consistency.
173 - Collapse scripts into a single list and add an attribute on Script to
174 differentiate.
176 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
177 - Rename module to pykickstart to avoid conflicts in anaconda.
178 - Rename data classes for consistency.
179 - Add default bytesPerInode settings.
181 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
182 - Created package from anaconda.