New version.
[pykickstart.git] / pykickstart.spec
blob11c45961c80b59cb2d6b256ed772f1c5b6c82b1b
1 %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Url: http://fedoraproject.org/wiki/pykickstart
6 Version: 1.99.17
7 Release: 1%{?dist}
8 # This is a Red Hat maintained package which is specific to
9 # our distribution. Thus the source is only available from
10 # within this srpm.
11 Source0: %{name}-%{version}.tar.gz
13 License: GPLv2
14 Group: System Environment/Libraries
15 BuildArch: noarch
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17 BuildRequires: python-devel, gettext, python-setuptools-devel
18 BuildRequires: transifex-client
19 Requires: python, python-urlgrabber
21 %description
22 The pykickstart package is a python library for manipulating kickstart
23 files.
25 %prep
26 %setup -q
28 %build
29 make
31 %install
32 rm -rf %{buildroot}
33 make DESTDIR=%{buildroot} install
34 %find_lang %{name}
36 %clean
37 rm -rf %{buildroot}
39 %files -f %{name}.lang
40 %defattr(-,root,root,-)
41 %doc README ChangeLog COPYING docs/programmers-guide
42 %doc docs/kickstart-docs.txt
43 %{python_sitelib}/*
44 %{_bindir}/ksvalidator
45 %{_bindir}/ksflatten
46 %{_bindir}/ksverdiff
48 %changelog
49 * Tue Aug 28 2012 Chris Lumens <clumens@redhat.com> - 1.99.17-1
50 - Add ksdata.network.hostname (readonly) property (rvykydal)
52 * Wed Aug 22 2012 Chris Lumens <clumens@redhat.com> - 1.99.16-1
53 - Add swap --hibernation to logvol command (vpodzime)
55 * Thu Aug 09 2012 Chris Lumens <clumens@redhat.com> - 1.99.15-1
56 - No argument needs to be given to rootpw if you're just locking the account. (clumens)
58 * Thu Jul 26 2012 Chris Lumens <clumens@redhat.com> - 1.99.14-1
59 - add reboot test (bcl)
60 - add correct halt command handling (bcl)
61 - return parsed object from assert_parse (bcl)
62 - The monitor command has been deprecated since F10. Get rid of it. (clumens)
63 - Add --hibernation option for swap size specification (vpodzime)
64 - Add leavebootorder test (hamzy)
66 * Tue Jun 19 2012 Chris Lumens <clumens@redhat.com> - 1.99.13-1
67 - Support bootloader --leavebootorder for F18 and RHEL7 (#824801) (pjones)
68 - Allow %include in %pre and %post (#827269) (bcl)
70 * Mon Jun 18 2012 Chris Lumens <clumens@redhat.com> - 1.99.12-1
71 - Add --nontp option and a way to specify NTP servers to the timezone command (vpodzime)
72 - fix TypeError in network.py with ipv6 static addresses (wwoods)
73 - Layouts may include spaces, so put them in quotes (vpodzime)
75 * Mon May 07 2012 Chris Lumens <clumens@redhat.com> - 1.99.11-1
76 - pylint doesn't like .setter syntax at all. (clumens)
77 - Modify keyboard command to handle multiple layouts (vpodzime)
78 - Add support for F18. (vpodzime)
79 - Fix traceback if modules cannot be loaded when running tests (vpodzime)
81 * Mon Apr 02 2012 Chris Lumens <clumens@redhat.com> - 1.99.10-1
82 - Add resize option to partition and logvol commands. (dlehman)
83 - Add --list= mode to clearpart for explicit list of partitions to remove. (dlehman)
85 * Thu Mar 22 2012 Chris Lumens <clumens@redhat.com> - 1.99.9-1
86 - Add __ne__ methods to every object with an __eq__ method. (clumens)
87 - Use the older exception syntax for python 2.4 compatibility. (clumens)
88 - Add an __eq__ method to the method command. (clumens)
90 * Wed Mar 14 2012 Chris Lumens <clumens@redhat.com> - 1.99.8-1
91 - Add support for RHEL7 (#802369).
92 - Add a method to set a command back to its initial blank state.
93 - btrfs likes its raid levels in lower case. (#799154) (dlehman)
94 - iscsi: add support for interface binding to F17 (rvykydal)
95 - iscsi: add support for interface binding (#500273) (rvykydal)
97 * Wed Jan 11 2012 Chris Lumens <clumens@redhat.com> - 1.99.7-1
98 - Add --type option to autopart command. (dlehman)
99 - Add btrfs command. (dlehman)
101 * Tue Nov 15 2011 Chris Lumens <clumens@redhat.com> - 1.99.6-1
102 - Add --boot-drive option to bootloader command to pick boot drive. (dlehman)
103 - Add support for F17. (clumens)
104 - The guts of a script could include a line starting with a % (#746928). (clumens)
106 * Wed Oct 19 2011 Chris Lumens <clumens@redhat.com> - 1.99.5-1
107 - Don't error out if raid --useexisting is given with no members (#741728). (clumens)
108 - When %end is missing, include the unterminated section in the error message. (clumens)
110 * Wed Sep 14 2011 Chris Lumens <clumens@redhat.com> - 1.99.4-1
111 - --reserved-space and --reserved-percent should be checked on a callback. (clumens)
112 - Add a volgroup unit test, and fix a bug it uncovered. (clumens)
113 - Add support for reserved space in volume group. (dlehman)
114 - Allow a %include to come in the middle of a section (#733455). (clumens)
115 - Add a test case for %include inside %packages. (clumens)
117 * Mon Aug 22 2011 Chris Lumens <clumens@redhat.com> - 1.99.3-1
118 - Ignore reimport warnings. (clumens)
119 - Add support for 'autopart --nolvm' (jlaska)
120 - autopart - Inherit error checking from base class (jlaska)
121 - Let's just use url.size instead. That's defined for both FTP and HTTP. (clumens)
122 - It's url.hdr now, not url.info. (clumens)
123 - Support end-of-line comments in the %packages section (#728563). (clumens)
125 * Mon Jun 27 2011 Chris Lumens <clumens@redhat.com> - 1.99.2-1
126 - Don't do "make po-pull" during installation. (clumens)
128 * Mon Jun 27 2011 Chris Lumens <clumens@redhat.com> - 1.99.1-1
129 - Fix a couple Makefile typos. (clumens)
130 - typo fix (vpodzime)
131 - option for wpa wifi connection specification added (vpodzime)
132 - Update Makefiles to work with new translation system. (clumens)
133 - BuildRequires transifex-client. (clumens)
134 - Ignore po/*.po files. (clumens)
135 - Remove translation files. (clumens)
136 - Add transifex-client configuration file. (clumens)
137 - Fix po files so "msgfmt -c" passes and they can be uploaded to transifex. (clumens)
139 * Tue Jun 07 2011 Chris Lumens <clumens@redhat.com> 1.99.0-1
140 - Add a way to tell how often a section has been handled. (clumens)
141 - Add a NullSection that just ignores any section provided. (clumens)
142 - Add test cases for the parser itself. (clumens)
143 - Allow for defining your own kickstart %sections. (clumens)
144 - The docs need to be fetched from an HTTPS location now. (clumens)
145 - Write out --onboot=off if it's False. (clumens)
147 * Fri Mar 25 2011 Chris Lumens <clumens@redhat.com> - 1.83-1
148 - Add kickstart network --nodefroute option (#668417) (rvykydal)
149 - Add support for network --bootproto ibft option (#668417) (rvykydal)
150 - Add network --activate option (#668417) (rvykydal)
151 - Add support for F16. (clumens)
153 * Fri Feb 18 2011 Chris Lumens <clumens@redhat.com> - 1.82-1
154 - Add support for "logvol --label=" (#677571). (clumens)
156 * Wed Jan 19 2011 Chris Lumens <clumens@redhat.com> - 1.81-1
157 - Add support for "raid --label=" (#670643). (clumens)
158 - --baseurl/--mirrorlist are no longer required for the repo command. (clumens)
159 - Make use of the "interactive" command an error. (clumens)
161 * Fri Dec 10 2010 Chris Lumens <clumens@redhat.com> - 1.80-1
162 - Remove preceededInclude= support (#639372). (clumens)
163 - support noverifyssl on the rhel6-branch (method, repo) (#660340). (akozumpl)
164 - l10n: Added Low German translation (ncfiedler)
166 * Mon Nov 08 2010 Chris Lumens <clumens@redhat.com> 1.79-1
167 - Move from pychecker to pylint, since the latter actually works.
168 - Lots of minor corrections for pylint.
169 - Add bootloader --iscrypted (#554870).
170 - Add support for F15.
172 * Fri Sep 10 2010 Chris Lumens <clumens@redhat.com> - 1.78-1
173 - Raise KickstartError instead of IOError (#618002). (clumens)
174 - It's --biospart, not --biosdisk (#620855). (clumens)
175 - Translation updates.
177 * Tue Jul 20 2010 Chris Lumens <clumens@redhat.com> - 1.77-1
178 - Send the key command down the memory hole. (clumens)
179 - Deprecate interactive kickstart mode. (clumens)
181 * Thu Jul 08 2010 Chris Lumens <clumens@redhat.com> - 1.76-1
182 - method: new parameter '--noverifyssl' after --url. (akozumpl)
183 - repo: new parameter '--noverifyssl'. (akozumpl)
185 * Tue Jun 22 2010 Chris Lumens <clumens@redhat.com> - 1.75-1
186 - Update translation files. (clumens)
187 - Remove everything from pykickstart that's been deprecated forever. (clumens)
188 - Using the knowledge of what command supports what option, condense test cases. (clumens)
189 - Add a method to list all supported options for a command being tested. (clumens)
190 - Add support for F14. (clumens)
191 - The %end at the end of a section is now required. (clumens)
193 * Thu Jun 10 2010 Chris Lumens <clumens@redhat.com> - 1.74-1
194 - If an option is deprecated, do not care if it takes a value (#602303). (clumens)
195 - Don't compare the dest ("telnet") with the option string ("--telnet"). (clumens)
196 - The --connect= parameter wasn't really deprecated in FC6. (clumens)
198 * Tue Jun 01 2010 Chris Lumens <clumens@redhat.com> - 1.73-1
199 - Allow "ignoredisk" to explicitly specify interactive usage (#596804) (pjones)
201 * Fri Apr 23 2010 Chris Lumens <clumens@redhat.com> - 1.72-1
202 - Return non-zero on error from ksvalidator (#585284). (clumens)
204 * Wed Apr 14 2010 Chris Lumens <clumens@redhat.com> - 1.71-1
205 - Don't overwrite the excluded group list after every %packages line (#577334). (clumens)
206 - Add a bunch of test cases for the packages section. (clumens)
208 * Wed Mar 31 2010 Chris Lumens <clumens@redhat.com> - 1.70-1
209 - Add support for RAID4 (#578514). (clumens)
210 - Escape percent signs in the changelog. (clumens)
212 * Wed Mar 10 2010 Chris Lumens <clumens@redhat.com> - 1.69-1
213 - Add driverdisk --biospart= (#570437). (clumens)
214 - Fix IOError catching in ksflatten (jgregusk, #558650).
216 * Thu Jan 14 2010 Chris Lumens <clumens@redhat.com> - 1.68-1
217 - Support removing groups that were included by a glob (#554717). (clumens)
218 - Make sure that everything in version.versionMap has a handler. (clumens)
219 - Add support for RHEL6 (#552230). (clumens)
220 - Don't consider RHEL versions as developmental even if they're latest. (clumens)
221 - Add lineno to BaseData and derived classes (version 2) (hdegoede)
222 - Give the non mandatory iscsi --port argument a sane default (hdegoede)
223 - Change python_sitelib macro to use %%global for new rpm (hdegoede)
224 - Fix typo in iscsi parsing error message (hdegoede)
226 * Thu Dec 03 2009 Chris Lumens <clumens@redhat.com> - 1.67-1
227 - Don't use action="append_const" in firewall.py.
228 - Make "make archive" depend on test and check passing again.
229 - versionToString now works in all cases we test for.
230 - Fix the few pychecker errors outstanding in options.py.
231 - Fix make docs to make docs dir before trying to download files there (hdegoede)
233 * Wed Nov 25 2009 Hans de Goede <hdgoede@redhat.com> - 1.66-1
234 - Add --dcb option to fcoe command (#513011)
235 - Remove rhpl from tests
236 - Port bootloader --hvargs option added in rhel5
237 - Ignore comments when looking for %%ksappend lines (#525676)
238 - Use python 2.x exception syntax
240 * Thu Nov 12 2009 Chris Lumens <clumens@redhat.com> - 1.65-1
241 - Add additional arguments to BaseHandler.__init__ for better map control.
242 - Return the KickstartCommand/KickstartData object from dispatcher.
243 - Add an "sshpw" command for changing the passwords in anaconda's env.
244 - Add --proxy support to the url and repo commands.
245 - Add support for F13. Is it really that time already?
247 * Wed Sep 30 2009 Chris Lumens <clumens@redhat.com> - 1.64-1
248 - Update the zfcp command for F12 (#526360).
249 - Move "make" to %%build (#524215).
251 * Wed Sep 16 2009 Chris Lumens <clumens@redhat.com> - 1.63-1
252 - Add encryption key escrow support (mitr, #508963).
253 - Fix the repo test cases to expect quotes around the repo's name.
255 * Thu Sep 10 2009 Chris Lumens <clumens@redhat.com> - 1.62-1
256 - Support translated help text in optparse (#479519).
257 - If the input kickstart file cannot be read, raise IOError (#519477).
259 * Thu Aug 27 2009 Chris Lumens <clumens@redhat.com> - 1.61-1
260 - Include the error messages from URLGrabError in the exception (#518443).
262 * Tue Aug 11 2009 Chris Lumens <clumens@redhat.com> - 1.60-1
263 - Put quotes around the repo's name (Marc.Herbert@gmail.com).
264 - Make duplicate entries warnings, not errors (#516338).
266 * Tue Jul 28 2009 Chris Lumens <clumens@redhat.com> - 1.59-1
267 - Handle a few more places where a urlgrabber error could happen (#512951).
268 - Error out if the same partition/repo/network is defined twice (#512956).
269 - Call parent class tests first. (jlaska)
270 - Add KSOptionParser to FC3 upgrade command. (jlaska)
271 - Correct missing return stmt in _getArgsAsStr() (jlaska)
273 * Fri Jul 17 2009 Chris Lumens <clumens@redhat.com> - 1.58-1
274 - Adjust writePriority to fix lvm-on-raid0 test cases (jlaska).
275 - Add F12 to the version number tests. (clumens)
276 - F12_User test case. (dcantrell)
277 - Add --gecos argument to the 'user' command (dcantrell)
278 - Convert user.py to use _getArgsAsStr() (dcantrell)
280 * Fri Jul 10 2009 Chris Lumens <clumens@redhat.com> - 1.57-1
281 - Another patch to make the bootloader test work (jlaska).
283 * Thu Jul 09 2009 Chris Lumens <clumens@redhat.com> - 1.56-1
284 - Make sure to import the gettext stuff in fcoe. (clumens)
285 - Correctly deprecate bootloader --lba32 (jlaska).
286 - pykickstart: fix zfcp command writepriority (hdegoede)
287 - pykickstart: Add fcoe command (take 2) (hdegoede)
288 - Add a test case for RAID (jlaska).
290 * Thu Jul 02 2009 Chris Lumens <clumens@redhat.com> - 1.55-1
291 - Add support for the group command to F12 (#509119).
292 - RHEL5 now supports RAID 10.
293 - The f12 hander class should be called F12Handler. (jgranado)
294 - Remove bootloader --lba32.
295 - Add a new version of the driverdisk command without --type=.
296 - Add initial support for F12.
297 - Fetch the programmers-guide from the wiki now.
299 * Mon May 18 2009 Chris Lumens <clumens@redhat.com> - 1.54-1
300 - Make sure the F11 handler gets used for "partition" and "part" (#501020).
302 * Wed Apr 29 2009 Chris Lumens <clumens@redhat.com> - 1.53-1
303 - Move lineno= from KSOptionParser.__init__ to parse_args (#497149). (clumens)
304 - Use the F11 version of the partition command. (clumens)
305 - Remove the --start and --end options since anaconda no longer uses them. (clumens)
306 - Remove a broken test case. (clumens)
308 * Wed Feb 18 2009 Chris Lumens <clumens@redhat.com> - 1.52-1
309 - Add lots more test cases (alindebe, mgracik, stickster).
310 - Add a skip attribute on key to shut up pychecker.
311 - Only show autostep command when requested (jlaska)
312 - Strip spaces from service names, and require an option to be provided.
313 - Surround services lists in double quotes.
314 - Remove the extra space from the services __str__ method.
315 - Fix output formatting bugs in firewall, partition, and repo (mgracik).
316 - Specifying both or neither of --drives and --only-use should be an error.
317 - Corrected newline char in return value of FC6_Method. (mgracik)
318 - Make --drives a required option for FC3, and catch no args on F8.
319 - Fix final printing of the rescue command (mgracik).
320 - Surround output strings in double quotes.
321 - Fix a typo in the deviceprobe command.
322 - Revert the more strict option processing on displaymode.
323 - Properly handle erroring on extra args, not just extra options.
324 - Don't use the logging class since it interferes with the logging test.
325 - port without host should raise KickstartParseError, not kickstartValueError.
326 - Add the --key option to option processing, since it's a valid argument.
327 - Fix test cases that were failing due to the new use of KSOptionParser.
328 - Teach driverdisk.py command to reject extra partitions (stickster).
329 - Add KSOptionParser to all commands ... enables more strick option checking (jlaska).
330 - Use KSOptionParser so we can catch bad command options (jlaska).
332 * Thu Jan 29 2009 Chris Lumens <clumens@redhat.com> - 1.51-1
333 - Make a couple changes to how the logging command is handled.
334 - Add a lot of test cases (clumens, alindebe, jlaska, fcami, adamwill, pfrields).
335 - Fix output formatting for the rootpw command.
336 - For commands that take exactly one argument, check and error correctly.
337 - Surround module options in quotes on the output side (jlaska).
338 - Set module opts in the FC3 handler correctly.
339 - Fix newlines on the device command output (jlaska).
340 - If --autoscreenshot is not specified, still output "autostep".
341 - Move the currentCmd and currentLine into getParser(). (jlaska)
342 - Write out an selinux line if set to disabled, but not if None.
343 - F9_LogVolData should inherit from FC4_LogVolData, not FC3_LogVolData (jlaska).
344 - Add unittest framework along with logvol and vnc unittests. (jlaska)
345 - Don't set the KSOption.required attribute in the constructor (jlaska).
347 * Sat Jan 10 2009 Chris Lumens <clumens@redhat.com> - 1.50-1
348 - Add a script to diff two versions of kickstart syntax.
349 - Add an option to ksvalidator to list all available syntax versions.
350 - Remove a couple extra newlines in output formatting.
351 - Add documentation for the new %%include representation.
352 - Add support %include to the pykickstart data objects.
354 * Thu Jan 08 2009 Chris Lumens <clumens@redhat.com> - 1.49-1
355 - Add upgrade --root-device (atodorov, #471232).
356 - Use python's builtin set rather than the Sets module (#477836, dcantrell).
358 * Tue Dec 23 2008 Chris Lumens <clumens@redhat.com> - 1.48-1
359 - Allow ignoring group metadata from repos, using a '--ignoregroups'
360 boolean. (notting)
361 - Add initial support for F11.
362 - Specify the command versions in the handlers instead of making copies.
363 - Remove empty and pointless __init__ methods.
364 - Pass arguments to superclasses via *args and **kwargs, all the way up.
365 - Add removedKeywords and removedAttrs lists on Commands and Data.
366 - Fix version regexes to handle double digits and minor releases (jlaska).
368 * Thu Oct 30 2008 Chris Lumens <clumens@redhat.com> - 1.47-1
369 - Fix enabling services we specify by specific options.
371 * Mon Oct 27 2008 Chris Lumens <clumens@redhat.com> - 1.46-1
372 - Add support for firewall --service (#467005).
374 * Tue Oct 14 2008 Chris Lumens <clumens@redhat.com> - 1.45-1
375 - Lots of translation updates.
376 - Remove use of string.partition for python2.4 (atodorov).
378 * Mon Sep 22 2008 Chris Lumens <clumens@redhat.com> - 1.44-1
379 - Add support for reverse CHAP to the kickstart iscsi command (hans)
380 - Fix typo (katzj)
382 * Wed Sep 03 2008 Chris Lumens <clumens@redhat.com> - 1.43-1
383 - Revert "Do not include passphrases for encrypted block devices in
384 anaconda-ks.cfg." (dlehman)
385 - yum doesn't like when mirrorlist is "". (clumens)
387 * Mon Aug 11 2008 Chris Lumens <clumens@redhat.com> - 1.42-1
388 - Add rescue command to pykickstart (atodorov)
389 - Sort %%packages output (katzj)
390 - Fix a typo (atodorov).
392 * Fri Aug 01 2008 Chris Lumens <clumens@redhat.com> - 1.41-1
393 - RHEL5 supports ignoredisk --only-use now too. (clumens)
394 - Do not include passphrases for encrypted block devices in
395 anaconda-ks.cfg. (dlehman)
396 - Fix F9,F10,RHEL5 "part" commands to use the same class as
397 "partition". (dlehman)
398 - Add an apply method() for commands and implement for lang (katzj)
400 * Tue Jul 15 2008 Chris Lumens <clumens@redhat.com> - 1.40-1
401 - RHEL5_LogVolData should inherit from FC4, not FC3.
402 Also fix FC9->F9 typo. (dlehman)
403 - Support creation of encrypted block devices in RHEL5. (#449830) (dlehman)
404 - Use the right LogVolData objects for RHEL3 and 4 (jlaska). (clumens)
405 - We no longer use rhpl for translations. (clumens)
406 - All the base classes should derive from object. (clumens)
408 * Fri Jun 13 2008 Chris Lumens <clumens@redhat.com> - 1.39-1
409 - It's helpful to return the parser object. (clumens)
411 * Tue Jun 10 2008 Chris Lumens <clumens@redhat.com> - 1.38-1
412 - Fix loading the Handler object by looking for a more specific
413 name (#450740). (clumens)
415 * Sun Jun 08 2008 Chris Lumens <clumens@redhat.com> - 1.37-1
416 - XConfig is still used by other projects, so just deprecate some
417 options. (clumens)
419 * Thu May 29 2008 Chris Lumens <clumens@redhat.com> - 1.36-1
420 - It should be repo --cost, not repo --priority. (clumens)
422 * Fri May 23 2008 Chris Lumens <clumens@redhat.com> - 1.35-1
423 - Bring driverdisk command in line with the docs. (clumens)
424 - Change RAID command print priorities (jlaska).
425 - According to docs, physvols are space delimited. (jlaska)
426 - Don't write the label out twice (jlaska).
427 - Deprecate monitor and xconfig commands. (clumens)
429 * Wed May 07 2008 Chris Lumens <clumens@redhat.com> - 1.34-1
430 - Load the handler module automatically. (clumens)
431 - Add support for F10. (clumens)
432 - Initialize cmd.handler earlier; fixes repo.methodToRepo() (markmc)
433 - Don't shadow builtin function names. (clumens)
434 - Running check is now required before pykickstart can be packaged. (clumens)
435 - Reorganize code a little bit to pass pychecker. (clumens)
437 * Tue Apr 08 2008 Chris Lumens <clumens@redhat.com> - 1.33-1
438 - Fix whitespace when printing out the bootloader command (pmeyers).
439 - Fix the type on bootloader --timeout processing. (clumens)
441 * Wed Apr 02 2008 Chris Lumens <clumens@redhat.com> - 1.32-1
442 - Make the string reader act like the file reader upon EOF. (clumens)
443 - Add syntax for encrypted logical volumes. (clumens)
445 * Tue Mar 25 2008 Chris Lumens <clumens@redhat.com> - 1.31-1
446 - Support end-of-line comments. (clumens)
447 - Lots of translation updates.
449 * Tue Feb 26 2008 Chris Lumens <clumens@redhat.com> - 1.30-1
450 - Reverse writePriorities of iscsi and iscsname (#434965, jlaska).
451 - Fix printing of iscsiname command (#434945, jlaska).
452 - Don't traceback on ENOENT. (pnasrat)
453 - Store the mouse name as a string, not a list. (clumens)
454 - Update translations.
456 * Wed Jan 30 2008 Chris Lumens <clumens@redhat.com> - 1.29-1
457 - Renamed bootproto=ask to bootproto=query, add to RHEL5 as well. (clumens)
459 * Wed Jan 23 2008 Chris Lumens <clumens@redhat.com> - 1.28-1
460 - Fix traceback on volgroup command. (clumens)
462 * Thu Jan 17 2008 Chris Lumens <clumens@redhat.com> - 1.27-1
463 - The bootprotoList needs to be defined before it's used. (clumens)
465 * Thu Jan 17 2008 Chris Lumens <clumens@redhat.com> - 1.26-1
466 - Add support for network --bootproto=ask. (clumens)
468 * Tue Jan 15 2008 Chris Lumens <clumens@redhat.com> - 1.25-1
469 - Add the version to the output ks file. (clumens)
470 - Add syntax for encrypted partitions and raid devices. (clumens)
472 * Thu Jan 10 2008 Chris Lumens <clumens@redhat.com> - 1.24-1
473 - Make inheritance and overriding of %%packages work (#427768). (clumens)
474 - Add an option for which languages should be installed. (katzj)
475 - Use the right name for the iscsi --target variable (#418781). (clumens)
477 * Mon Dec 10 2007 Chris Lumens <clumens@redhat.com> - 1.23-1
478 - Take Makefile improvements from anaconda.
479 - Fix a traceback on F9 zerombr command (#395431).
480 - Update to handle new Python eggs packaging.
482 * Tue Nov 20 2007 Chris Lumens <clumens@redhat.com> 1.22-1
483 - Don't process or write out vnc --enabled (jlaska AT redhat DOT com).
484 - Fix a traceback in the clearpart command.
486 * Tue Nov 06 2007 Chris Lumens <clumens@redhat.com> 1.21-1
487 - Save script line numbers for debugging.
488 - More internal cleanups.
490 * Wed Oct 31 2007 Chris Lumens <clumens@redhat.com> 1.20-1
491 - Pull wiki docs from the new location.
492 - Fix error messages for options that have been removed after having been
493 previously deprecated.
494 - zerombr no longer takes any arguments.
495 - %%packages --ignoredeps --resolvedeps have been removed.
496 - firewall --high --medium have been removed.
497 - vnc --connect has been removed.
498 - xconfig options from monitor have now been removed.
499 - --bytes-per-inode has been marked as deprecated.
500 - Fix typos.
501 - Add --fsprofile option to disk commands (pjones).
502 - Add F9 support (pjones).
503 - Lots of internal fixes (clumens, pjones).
505 * Tue Oct 23 2007 Chris Lumens <clumens@redhat.com> 1.19-1
506 - Fix a traceback on the cdrom method.
508 * Thu Oct 18 2007 Chris Lumens <clumens@redhat.com> 1.18-1
509 - Don't write out %%end to packages and scripts if the syntax version doesn't
510 support it.
511 - Remove obsolete translation (#332221).
513 * Thu Oct 04 2007 Chris Lumens <clumens@redhat.com> 1.17-1
514 - Simplify argument processing and printing.
516 * Wed Oct 03 2007 Chris Lumens <clumens@redhat.com> 1.16-1
517 - Undeprecate %%packages --excludedocs.
518 - Fix a traceback in the device command handling.
519 - Add bootloader --timeout (katzj).
521 * Tue Oct 02 2007 Chris Lumens <clumens@redhat.com> 1.15-1
522 - Update translations (#259121).
523 - The device command no longer takes a type argument.
525 * Fri Sep 28 2007 Chris Lumens <clumens@redhat.com> 1.14-1
526 - Fix output formatting for packages section header (#310211).
527 - Add a script to flatten kickstart files containing includes (katzj).
529 * Wed Sep 12 2007 Chris Lumens <clumens@redhat.com> 1.13-1
530 - Add a function to convert URL method strings into repo objects
531 (jkeating).
532 - Writer formatting fixes.
533 - Add kickstart documentation from the Fedora Wiki.
535 * Tue Sep 04 2007 Chris Lumens <clumens@redhat.com> 1.12-1
536 - Fix lots of problems in processing the bootloader, device, network, and
537 raid commands.
538 - Add %%end when writing out scripts and packages.
539 - Add a makefile target to run pychecker to cut down on errors in
540 releases.
542 * Mon Sep 3 2007 Jeremy Katz <katzj@redhat.com> - 1.11-1
543 - fix a few tracebacks
545 * Fri Aug 31 2007 Chris Lumens <clumens@redhat.com> 1.10-1
546 - Add network --ipv6=.
548 * Fri Aug 24 2007 Chris Lumens <clumens@redhat.com> 1.9-1
549 - Add support for the %%end directive to be placed at the end of scripts
550 and packages sections. Deprecate old syntax.
551 - Clean up after ksvalidator if pykickstart issues a traceback.
552 - Add support for repo --priority --includepkgs --excludepkgs.
553 - Fix newline at end of reboot --eject output (#253562).
555 * Mon Aug 13 2007 Chris Lumens <clumens@redhat.com> 1.8-1
556 - Fix type checking of string values.
558 * Thu Aug 09 2007 Chris Lumens <clumens@redhat.com> 1.7-1
559 - Clarify license in spec file and all source files.
560 - Check string values to options to make sure they're not other options
561 (#251318).
563 * Thu Aug 02 2007 Chris Lumens <clumens@redhat.com> 1.6-1
564 - Fix a couple tracebacks in ksvalidator.
565 - Change --class to --dhcpclass (#248912).
567 * Thu Jul 19 2007 Chris Lumens <clumens@redhat.com> 1.5-2
568 - Require rhpl (#248953).
570 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.5-1
571 - Fix traceback when calling preprocessKickstart.
573 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.4-1
574 - Add methods to handle the %%ksappend directive.
575 - Fix ignoredisk --disks.
577 * Wed Jul 11 2007 Chris Lumens <clumens@redhat.com> - 1.3-1
578 - Add support for ignoredisk --only-use.
579 - Fix traceback in raid command printing method (#246709).
581 * Fri Jun 08 2007 Chris Lumens <clumens@redhat.com> - 1.2-2
582 - Fix package review problems (#226334).
584 * Mon Jun 04 2007 Chris Lumens <clumens@redhat.com> - 1.2-1
585 - Fix harddrive install method error checking (#232492).
586 - Set authentication information from the input line to preserve quoting
587 (#241657).
588 - Allow included files to be given by URL.
589 - Fix typo in user --iscrypted option.
591 * Mon May 14 2007 Chris Lumens <clumens@redhat.com> - 1.1-1
592 - Better regexes for splitting version strings into family and version.
593 - Add basic support for RHEL3.
594 - Update translations.
596 * Fri Apr 13 2007 Chris Lumens <clumens@redhat.com> - 1.0-1
597 - Update documentation.
598 - Update translations.
600 * Mon Mar 19 2007 Chris Lumens <clumens@redhat.com> - 0.100-1
601 - bootloader should be written out after upgrade/install.
602 - Treat class names as unicode strings (#231053).
604 * Wed Mar 07 2007 Chris Lumens <clumens@redhat.com> - 0.99-1
605 - The timezone command didn't recognize --isUtc before FC6 (#231189).
606 - Recognize %%ksappend lines in ksvalidator.
607 - Don't set default values in some command __init__ methods.
608 - Added an updates command.
609 - Add support for RAID10.
611 * Mon Feb 26 2007 Chris Lumens <clumens@redhat.com> - 0.98-1
612 - Fix device command syntax to match anaconda.
613 - Fix __call__ on method command.
615 * Wed Feb 21 2007 Chris Lumens <clumens@redhat.com> - 0.97-1
616 - Fix traceback when not overriding default mappings (#229505).
618 * Tue Feb 20 2007 Chris Lumens <clumens@redhat.com> - 0.96-1
619 - Fix __str__ methods for langsupport and reboot commands.
620 - Renamed BaseHandler.empty to BaseHandler.maskAllExcept.
621 - Split command objects out into their own files in commands/.
622 - Rename command objects to start with Version_.
623 - Support extended group selection syntax.
625 * Wed Feb 14 2007 Chris Lumens <clumens@redhat.com> - 0.95-1
626 - KickstartParser no longer takes a version argument.
627 - Be more lenient in what strings stringToVersion accepts.
628 - Allow setting state on one data object from multiple files.
630 * Wed Feb 07 2007 Chris Lumens <clumens@redhat.com> - 0.94-1
631 - Add a newline to the end of the key command output.
632 - Use network bootproto constants (#197694).
633 - Fix tracebacks in subclass __str__ methods (#226734).
635 * Wed Jan 31 2007 Chris Lumens <clumens@redhat.com> - 0.93-2
636 - Make some minor spec file changes to get closer to the extras guidelines.
638 * Thu Jan 25 2007 Chris Lumens <clumens@redhat.com> - 0.93-1
639 - Add support for FC3, RHEL4, and RHEL5.
640 - The key command was not supported until after FC6.
641 - Accept more strings in stringToVersion.
643 * Fri Jan 19 2007 Chris Lumens <clumens@redhat.com> - 0.92-1
644 - Fix KickstartVersionError reporting.
645 - Add a version attribute to handler objects.
646 - Fix line number reporting on lots of commands.
647 - Add initial support for Fedora 7 and remove deprecated commands.
648 - Accept a --default argument to the %%packages header (#221305).
650 * Wed Jan 17 2007 Chris Lumens <clumens@redhat.com> - 0.91-1
651 - Add a method to read kickstart files from strings.
653 * Tue Jan 16 2007 Chris Lumens <clumens@redhat.com> - 0.90-1
654 - Support multiple versions of kickstart syntax from one code base
655 (#189348).
656 - Fix inconsistency between Script parser and writer (#222877).
658 * Fri Dec 15 2006 Chris Lumens <clumens@redhat.com> - 0.43-1
659 - Pull in new translations (#216620).
661 * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.42-2
662 - rebuild against python 2.5
664 * Tue Dec 05 2006 Chris Lumens <clumens@redhat.com> - 0.42-1
665 - Fix traceback when writing out repo command (#218274).
667 * Fri Dec 01 2006 Chris Lumens <clumens@redhat.com> - 0.41-1
668 - Fix traceback when using deprecated commands (#218047, #218059).
670 * Thu Nov 30 2006 Chris Lumens <clumens@redhat.com> - 0.40-1
671 - Pull in new translations (#216620).
672 - Add --level argument to logging command writer.
674 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-2
675 - Fix release number.
677 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-1
678 - Add writer for --key (#211997).
680 * Tue Oct 17 2006 Jeremy Katz <katzj@redhat.com> - 0.38-1
681 - allow --skip for installation number as well (#207029)
683 * Mon Oct 16 2006 Jeremy Katz <katzj@redhat.com> - 0.37-1
684 - support for installation numbers (#207029)
686 * Fri Oct 13 2006 Bill Nottingham <notting@redhat.com> - 0.36-1
687 - use valid charsets in translations (#210720)
689 * Fri Sep 29 2006 Chris Lumens <clumens@redhat.com> - 0.35-1
690 - Fix traceback in harddrive command (#208557).
692 * Mon Sep 25 2006 Chris Lumens <clumens@redhat.com> - 0.34-1
693 - Add support for --biospart option to harddrive (#207585).
694 - Update writer for syntax changes.
696 * Wed Sep 20 2006 Jeremy Katz <katzj@redhat.com> - 0.33-1
697 - improved iscsi syntax
698 - allow multiple zfcp devs
700 * Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 0.32-1
701 - Limit --bootproto to what anaconda supports.
702 - Add --noipv4 and --noipv6 network options.
704 * Tue Jun 20 2006 Chris Lumens <clumens@redhat.com> 0.31-1
705 - Handle nfs --opts (katzj).
706 - RAID devices should be integers instead of strings (#176537).
707 - Add initial support for iscsi (katzj).
709 * Tue Jun 06 2006 Chris Lumens <clumens@redhat.com> 0.30-2
710 - Add BuildRequires to fix building under mock (#194156, Joost Soeterbroek
711 <fedora AT soeterbroek.com>).
713 * Thu May 25 2006 Chris Lumens <clumens@redhat.com> 0.30-1
714 - Change order of LVM-related writing functions (#193073).
715 - Require urlgrabber.
716 - Return a more useful error message on unknown commands.
717 - Fix logvol writing typo.
718 - Make ksvalidator validate from a URL in addition to a file.
719 - Don't write out an empty packages section (#192851).
721 * Tue May 23 2006 Chris Lumens <clumens@redhat.com> 0.29-1
722 - Add multipath command, handlers, and data objects (pjones).
723 - Rename --ports to --port in writer.
725 * Mon May 15 2006 Chris Lumens <clumens@redhat.com> 0.28-1
726 - Support --mtu for the network command (#191328).
727 - Accept --isUtc for backwards compatibility.
729 * Wed May 04 2006 Chris Lumens <clumens@redhat.com> 0.27-1
730 - Output formatting fixes.
731 - Added commands for managing users and services.
733 * Mon Apr 17 2006 Chris Lumens <clumens@redhat.com> 0.26-1
734 - Ignore spaces before group names (#188095).
735 - Added some translations.
736 - Add options for repo command.
737 - Reorder %%packages section output.
738 - Output %%packages header options.
739 - Initialize RAID and volume group members to empty lists.
741 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.25-1
742 - Add support for the logging command.
744 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.24-1
745 - Don't write out a blank xconfig line.
746 - Reorder output handlers to group like commands together.
747 - Mark strings for translation.
749 * Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 0.23-1
750 - Backwards compatibility support for options to zerombr.
752 * Fri Feb 24 2006 Chris Lumens <clumens@redhat.com> 0.22-1
753 - Get ignoredisk working again (#182934).
755 * Fri Feb 17 2006 Chris Lumens <clumens@redhat.com> 0.21-1
756 - Provide an option to not traceback on missing include files (#181760).
757 - Update programming documentation.
759 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.20-1
760 - Correctly set --noformat and --useexisting on lvm and raid.
762 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.19-1
763 - --onboot requires a value (#180987).
764 - Be more strict about commands that don't take arguments.
766 * Thu Feb 09 2006 Chris Lumens <clumens@redhat.com> 0.18-1
767 - Fix some errors pychecker caught.
768 - Allow exceptions to not be fatal so ksvalidator can spot more errors in
769 a single pass (#179894).
771 * Wed Feb 01 2006 Chris Lumens <clumens@redhat.com> 0.17-1
772 - Don't set a default port for vnc.
774 * Tue Jan 31 2006 Chris Lumens <clumens@redhat.com> 0.16-1
775 - Give dmraid string an initial value.
776 - Handle None on partition size.
778 * Tue Jan 31 2006 Peter Jones <pjones@redhat.com> 0.15-1
779 - Add dmraid support
781 * Mon Jan 30 2006 Chris Lumens <clumens@redhat.com> 0.14-1
782 - Fix VNC parameter parsing (#179209).
783 - Deprecate --connect. Add --host and --port instead.
785 * Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 0.13-1
786 - Recognize the --eject parameter to shutdown/halt.
787 - Store the exact post-installation action in ksdata.
789 * Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 0.12-1
790 - Clean up output quoting.
791 - Finish removing monitor-related stuff from xconfig.
793 * Mon Dec 12 2005 Chris Lumens <clumens@redhat.com> 0.11-1
794 - Deprecate monitor-related options to xconfig.
796 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
797 - Support --bytes-per-inode on raid
798 (Curtis Doty <Curtis at GreenKey.net> #175288).
800 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
801 - fixup network --onboot
803 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
804 - Default to SELINUX_ENFORCING.
805 - Default partition sizes to None for anaconda (#172378).
806 - Don't call shlex.split on anything inside a script (#172313).
808 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
809 - Fix clearpart --all.
810 - vnc command does not require --connect option (#172192).
811 - network --onboot does not take any option.
812 - Remove extra spaces from firewall --ports and --trust.
813 - Write out network --<service> options.
815 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
816 - Add --resolvedeps and --ignoredeps as deprecated options.
817 - Pass line number to header functions.
819 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
820 - Add line numbers to exception reporting.
821 - Added ksvalidator.
823 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
824 - Correct deprecated attribute on options.
825 - Added programming documentation.
827 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
828 - Correct python lib directory on 64-bit archs (#170621).
830 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
831 - Add a deprecated attribute to options.
832 - Add --card option back to xconfig and mark as deprecated.
833 - Throw a deprecation warning on mouse and langsupport commands.
834 - Rename Writer to KickstartWriter for consistency.
835 - Collapse scripts into a single list and add an attribute on Script to
836 differentiate.
838 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
839 - Rename module to pykickstart to avoid conflicts in anaconda.
840 - Rename data classes for consistency.
841 - Add default bytesPerInode settings.
843 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
844 - Created package from anaconda.