New version.
[pykickstart.git] / pykickstart.spec
blob1b99d332bfea81098bb3c4ebd9391cad2798f00b
1 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Url: http://fedoraproject.org/wiki/pykickstart
6 Version: 1.59
7 Release: 1%{?dist}
8 # This is a Red Hat maintained package which is specific to
9 # our distribution. Thus the source is only available from
10 # within this srpm.
11 Source0: %{name}-%{version}.tar.gz
13 License: GPLv2
14 Group: System Environment/Libraries
15 BuildArch: noarch
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17 BuildRequires: python-devel, gettext, python-setuptools-devel
18 Requires: python, python-urlgrabber
20 %description
21 The pykickstart package is a python library for manipulating kickstart
22 files.
24 %prep
25 %setup -q
26 make
28 %build
30 %install
31 rm -rf %{buildroot}
32 make DESTDIR=%{buildroot} install
33 %find_lang %{name}
35 %clean
36 rm -rf %{buildroot}
38 %files -f %{name}.lang
39 %defattr(-,root,root,-)
40 %doc README ChangeLog COPYING docs/programmers-guide
41 %doc docs/kickstart-docs.txt
42 %{python_sitelib}/*
43 %{_bindir}/ksvalidator
44 %{_bindir}/ksflatten
45 %{_bindir}/ksverdiff
47 %changelog
48 * Tue Jul 28 2009 Chris Lumens <clumens@redhat.com> - 1.59-1
49 - Handle a few more places where a urlgrabber error could happen (#512951).
50 - Error out if the same partition/repo/network is defined twice (#512956).
51 - Call parent class tests first. (jlaska)
52 - Add KSOptionParser to FC3 upgrade command. (jlaska)
53 - Correct missing return stmt in _getArgsAsStr() (jlaska)
55 * Fri Jul 17 2009 Chris Lumens <clumens@redhat.com> - 1.58-1
56 - Adjust writePriority to fix lvm-on-raid0 test cases (jlaska).
57 - Add F12 to the version number tests. (clumens)
58 - F12_User test case. (dcantrell)
59 - Add --gecos argument to the 'user' command (dcantrell)
60 - Convert user.py to use _getArgsAsStr() (dcantrell)
62 * Fri Jul 10 2009 Chris Lumens <clumens@redhat.com> - 1.57-1
63 - Another patch to make the bootloader test work (jlaska).
65 * Thu Jul 09 2009 Chris Lumens <clumens@redhat.com> - 1.56-1
66 - Make sure to import the gettext stuff in fcoe. (clumens)
67 - Correctly deprecate bootloader --lba32 (jlaska).
68 - pykickstart: fix zfcp command writepriority (hdegoede)
69 - pykickstart: Add fcoe command (take 2) (hdegoede)
70 - Add a test case for RAID (jlaska).
72 * Thu Jul 02 2009 Chris Lumens <clumens@redhat.com> - 1.55-1
73 - Add support for the group command to F12 (#509119).
74 - RHEL5 now supports RAID 10.
75 - The f12 hander class should be called F12Handler. (jgranado)
76 - Remove bootloader --lba32.
77 - Add a new version of the driverdisk command without --type=.
78 - Add initial support for F12.
79 - Fetch the programmers-guide from the wiki now.
81 * Mon May 18 2009 Chris Lumens <clumens@redhat.com> - 1.54-1
82 - Make sure the F11 handler gets used for "partition" and "part" (#501020).
84 * Wed Apr 29 2009 Chris Lumens <clumens@redhat.com> - 1.53-1
85 - Move lineno= from KSOptionParser.__init__ to parse_args (#497149). (clumens)
86 - Use the F11 version of the partition command. (clumens)
87 - Remove the --start and --end options since anaconda no longer uses them. (clumens)
88 - Remove a broken test case. (clumens)
90 * Wed Feb 18 2009 Chris Lumens <clumens@redhat.com> - 1.52-1
91 - Add lots more test cases (alindebe, mgracik, stickster).
92 - Add a skip attribute on key to shut up pychecker.
93 - Only show autostep command when requested (jlaska)
94 - Strip spaces from service names, and require an option to be provided.
95 - Surround services lists in double quotes.
96 - Remove the extra space from the services __str__ method.
97 - Fix output formatting bugs in firewall, partition, and repo (mgracik).
98 - Specifying both or neither of --drives and --only-use should be an error.
99 - Corrected newline char in return value of FC6_Method. (mgracik)
100 - Make --drives a required option for FC3, and catch no args on F8.
101 - Fix final printing of the rescue command (mgracik).
102 - Surround output strings in double quotes.
103 - Fix a typo in the deviceprobe command.
104 - Revert the more strict option processing on displaymode.
105 - Properly handle erroring on extra args, not just extra options.
106 - Don't use the logging class since it interferes with the logging test.
107 - port without host should raise KickstartParseError, not kickstartValueError.
108 - Add the --key option to option processing, since it's a valid argument.
109 - Fix test cases that were failing due to the new use of KSOptionParser.
110 - Teach driverdisk.py command to reject extra partitions (stickster).
111 - Add KSOptionParser to all commands ... enables more strick option checking (jlaska).
112 - Use KSOptionParser so we can catch bad command options (jlaska).
114 * Thu Jan 29 2009 Chris Lumens <clumens@redhat.com> - 1.51-1
115 - Make a couple changes to how the logging command is handled.
116 - Add a lot of test cases (clumens, alindebe, jlaska, fcami, adamwill, pfrields).
117 - Fix output formatting for the rootpw command.
118 - For commands that take exactly one argument, check and error correctly.
119 - Surround module options in quotes on the output side (jlaska).
120 - Set module opts in the FC3 handler correctly.
121 - Fix newlines on the device command output (jlaska).
122 - If --autoscreenshot is not specified, still output "autostep".
123 - Move the currentCmd and currentLine into getParser(). (jlaska)
124 - Write out an selinux line if set to disabled, but not if None.
125 - F9_LogVolData should inherit from FC4_LogVolData, not FC3_LogVolData (jlaska).
126 - Add unittest framework along with logvol and vnc unittests. (jlaska)
127 - Don't set the KSOption.required attribute in the constructor (jlaska).
129 * Sat Jan 10 2009 Chris Lumens <clumens@redhat.com> - 1.50-1
130 - Add a script to diff two versions of kickstart syntax.
131 - Add an option to ksvalidator to list all available syntax versions.
132 - Remove a couple extra newlines in output formatting.
133 - Add documentation for the new %include representation.
134 - Add support %include to the pykickstart data objects.
136 * Thu Jan 08 2009 Chris Lumens <clumens@redhat.com> - 1.49-1
137 - Add upgrade --root-device (atodorov, #471232).
138 - Use python's builtin set rather than the Sets module (#477836, dcantrell).
140 * Tue Dec 23 2008 Chris Lumens <clumens@redhat.com> - 1.48-1
141 - Allow ignoring group metadata from repos, using a '--ignoregroups'
142 boolean. (notting)
143 - Add initial support for F11.
144 - Specify the command versions in the handlers instead of making copies.
145 - Remove empty and pointless __init__ methods.
146 - Pass arguments to superclasses via *args and **kwargs, all the way up.
147 - Add removedKeywords and removedAttrs lists on Commands and Data.
148 - Fix version regexes to handle double digits and minor releases (jlaska).
150 * Thu Oct 30 2008 Chris Lumens <clumens@redhat.com> - 1.47-1
151 - Fix enabling services we specify by specific options.
153 * Mon Oct 27 2008 Chris Lumens <clumens@redhat.com> - 1.46-1
154 - Add support for firewall --service (#467005).
156 * Tue Oct 14 2008 Chris Lumens <clumens@redhat.com> - 1.45-1
157 - Lots of translation updates.
158 - Remove use of string.partition for python2.4 (atodorov).
160 * Mon Sep 22 2008 Chris Lumens <clumens@redhat.com> - 1.44-1
161 - Add support for reverse CHAP to the kickstart iscsi command (hans)
162 - Fix typo (katzj)
164 * Wed Sep 03 2008 Chris Lumens <clumens@redhat.com> - 1.43-1
165 - Revert "Do not include passphrases for encrypted block devices in
166 anaconda-ks.cfg." (dlehman)
167 - yum doesn't like when mirrorlist is "". (clumens)
169 * Mon Aug 11 2008 Chris Lumens <clumens@redhat.com> - 1.42-1
170 - Add rescue command to pykickstart (atodorov)
171 - Sort %packages output (katzj)
172 - Fix a typo (atodorov).
174 * Fri Aug 01 2008 Chris Lumens <clumens@redhat.com> - 1.41-1
175 - RHEL5 supports ignoredisk --only-use now too. (clumens)
176 - Do not include passphrases for encrypted block devices in
177 anaconda-ks.cfg. (dlehman)
178 - Fix F9,F10,RHEL5 "part" commands to use the same class as
179 "partition". (dlehman)
180 - Add an apply method() for commands and implement for lang (katzj)
182 * Tue Jul 15 2008 Chris Lumens <clumens@redhat.com> - 1.40-1
183 - RHEL5_LogVolData should inherit from FC4, not FC3.
184 Also fix FC9->F9 typo. (dlehman)
185 - Support creation of encrypted block devices in RHEL5. (#449830) (dlehman)
186 - Use the right LogVolData objects for RHEL3 and 4 (jlaska). (clumens)
187 - We no longer use rhpl for translations. (clumens)
188 - All the base classes should derive from object. (clumens)
190 * Fri Jun 13 2008 Chris Lumens <clumens@redhat.com> - 1.39-1
191 - It's helpful to return the parser object. (clumens)
193 * Tue Jun 10 2008 Chris Lumens <clumens@redhat.com> - 1.38-1
194 - Fix loading the Handler object by looking for a more specific
195 name (#450740). (clumens)
197 * Sun Jun 08 2008 Chris Lumens <clumens@redhat.com> - 1.37-1
198 - XConfig is still used by other projects, so just deprecate some
199 options. (clumens)
201 * Thu May 29 2008 Chris Lumens <clumens@redhat.com> - 1.36-1
202 - It should be repo --cost, not repo --priority. (clumens)
204 * Fri May 23 2008 Chris Lumens <clumens@redhat.com> - 1.35-1
205 - Bring driverdisk command in line with the docs. (clumens)
206 - Change RAID command print priorities (jlaska).
207 - According to docs, physvols are space delimited. (jlaska)
208 - Don't write the label out twice (jlaska).
209 - Deprecate monitor and xconfig commands. (clumens)
211 * Wed May 07 2008 Chris Lumens <clumens@redhat.com> - 1.34-1
212 - Load the handler module automatically. (clumens)
213 - Add support for F10. (clumens)
214 - Initialize cmd.handler earlier; fixes repo.methodToRepo() (markmc)
215 - Don't shadow builtin function names. (clumens)
216 - Running check is now required before pykickstart can be packaged. (clumens)
217 - Reorganize code a little bit to pass pychecker. (clumens)
219 * Tue Apr 08 2008 Chris Lumens <clumens@redhat.com> - 1.33-1
220 - Fix whitespace when printing out the bootloader command (pmeyers).
221 - Fix the type on bootloader --timeout processing. (clumens)
223 * Wed Apr 02 2008 Chris Lumens <clumens@redhat.com> - 1.32-1
224 - Make the string reader act like the file reader upon EOF. (clumens)
225 - Add syntax for encrypted logical volumes. (clumens)
227 * Tue Mar 25 2008 Chris Lumens <clumens@redhat.com> - 1.31-1
228 - Support end-of-line comments. (clumens)
229 - Lots of translation updates.
231 * Tue Feb 26 2008 Chris Lumens <clumens@redhat.com> - 1.30-1
232 - Reverse writePriorities of iscsi and iscsname (#434965, jlaska).
233 - Fix printing of iscsiname command (#434945, jlaska).
234 - Don't traceback on ENOENT. (pnasrat)
235 - Store the mouse name as a string, not a list. (clumens)
236 - Update translations.
238 * Wed Jan 30 2008 Chris Lumens <clumens@redhat.com> - 1.29-1
239 - Renamed bootproto=ask to bootproto=query, add to RHEL5 as well. (clumens)
241 * Wed Jan 23 2008 Chris Lumens <clumens@redhat.com> - 1.28-1
242 - Fix traceback on volgroup command. (clumens)
244 * Thu Jan 17 2008 Chris Lumens <clumens@redhat.com> - 1.27-1
245 - The bootprotoList needs to be defined before it's used. (clumens)
247 * Thu Jan 17 2008 Chris Lumens <clumens@redhat.com> - 1.26-1
248 - Add support for network --bootproto=ask. (clumens)
250 * Tue Jan 15 2008 Chris Lumens <clumens@redhat.com> - 1.25-1
251 - Add the version to the output ks file. (clumens)
252 - Add syntax for encrypted partitions and raid devices. (clumens)
254 * Thu Jan 10 2008 Chris Lumens <clumens@redhat.com> - 1.24-1
255 - Make inheritance and overriding of %packages work (#427768). (clumens)
256 - Add an option for which languages should be installed. (katzj)
257 - Use the right name for the iscsi --target variable (#418781). (clumens)
259 * Mon Dec 10 2007 Chris Lumens <clumens@redhat.com> - 1.23-1
260 - Take Makefile improvements from anaconda.
261 - Fix a traceback on F9 zerombr command (#395431).
262 - Update to handle new Python eggs packaging.
264 * Tue Nov 20 2007 Chris Lumens <clumens@redhat.com> 1.22-1
265 - Don't process or write out vnc --enabled (jlaska AT redhat DOT com).
266 - Fix a traceback in the clearpart command.
268 * Tue Nov 06 2007 Chris Lumens <clumens@redhat.com> 1.21-1
269 - Save script line numbers for debugging.
270 - More internal cleanups.
272 * Wed Oct 31 2007 Chris Lumens <clumens@redhat.com> 1.20-1
273 - Pull wiki docs from the new location.
274 - Fix error messages for options that have been removed after having been
275 previously deprecated.
276 - zerombr no longer takes any arguments.
277 - %packages --ignoredeps --resolvedeps have been removed.
278 - firewall --high --medium have been removed.
279 - vnc --connect has been removed.
280 - xconfig options from monitor have now been removed.
281 - --bytes-per-inode has been marked as deprecated.
282 - Fix typos.
283 - Add --fsprofile option to disk commands (pjones).
284 - Add F9 support (pjones).
285 - Lots of internal fixes (clumens, pjones).
287 * Tue Oct 23 2007 Chris Lumens <clumens@redhat.com> 1.19-1
288 - Fix a traceback on the cdrom method.
290 * Thu Oct 18 2007 Chris Lumens <clumens@redhat.com> 1.18-1
291 - Don't write out %end to packages and scripts if the syntax version doesn't
292 support it.
293 - Remove obsolete translation (#332221).
295 * Thu Oct 04 2007 Chris Lumens <clumens@redhat.com> 1.17-1
296 - Simplify argument processing and printing.
298 * Wed Oct 03 2007 Chris Lumens <clumens@redhat.com> 1.16-1
299 - Undeprecate %packages --excludedocs.
300 - Fix a traceback in the device command handling.
301 - Add bootloader --timeout (katzj).
303 * Tue Oct 02 2007 Chris Lumens <clumens@redhat.com> 1.15-1
304 - Update translations (#259121).
305 - The device command no longer takes a type argument.
307 * Fri Sep 28 2007 Chris Lumens <clumens@redhat.com> 1.14-1
308 - Fix output formatting for packages section header (#310211).
309 - Add a script to flatten kickstart files containing includes (katzj).
311 * Wed Sep 12 2007 Chris Lumens <clumens@redhat.com> 1.13-1
312 - Add a function to convert URL method strings into repo objects
313 (jkeating).
314 - Writer formatting fixes.
315 - Add kickstart documentation from the Fedora Wiki.
317 * Tue Sep 04 2007 Chris Lumens <clumens@redhat.com> 1.12-1
318 - Fix lots of problems in processing the bootloader, device, network, and
319 raid commands.
320 - Add %end when writing out scripts and packages.
321 - Add a makefile target to run pychecker to cut down on errors in
322 releases.
324 * Mon Sep 3 2007 Jeremy Katz <katzj@redhat.com> - 1.11-1
325 - fix a few tracebacks
327 * Fri Aug 31 2007 Chris Lumens <clumens@redhat.com> 1.10-1
328 - Add network --ipv6=.
330 * Fri Aug 24 2007 Chris Lumens <clumens@redhat.com> 1.9-1
331 - Add support for the %end directive to be placed at the end of scripts
332 and packages sections. Deprecate old syntax.
333 - Clean up after ksvalidator if pykickstart issues a traceback.
334 - Add support for repo --priority --includepkgs --excludepkgs.
335 - Fix newline at end of reboot --eject output (#253562).
337 * Mon Aug 13 2007 Chris Lumens <clumens@redhat.com> 1.8-1
338 - Fix type checking of string values.
340 * Thu Aug 09 2007 Chris Lumens <clumens@redhat.com> 1.7-1
341 - Clarify license in spec file and all source files.
342 - Check string values to options to make sure they're not other options
343 (#251318).
345 * Thu Aug 02 2007 Chris Lumens <clumens@redhat.com> 1.6-1
346 - Fix a couple tracebacks in ksvalidator.
347 - Change --class to --dhcpclass (#248912).
349 * Thu Jul 19 2007 Chris Lumens <clumens@redhat.com> 1.5-2
350 - Require rhpl (#248953).
352 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.5-1
353 - Fix traceback when calling preprocessKickstart.
355 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.4-1
356 - Add methods to handle the %ksappend directive.
357 - Fix ignoredisk --disks.
359 * Wed Jul 11 2007 Chris Lumens <clumens@redhat.com> - 1.3-1
360 - Add support for ignoredisk --only-use.
361 - Fix traceback in raid command printing method (#246709).
363 * Fri Jun 08 2007 Chris Lumens <clumens@redhat.com> - 1.2-2
364 - Fix package review problems (#226334).
366 * Mon Jun 04 2007 Chris Lumens <clumens@redhat.com> - 1.2-1
367 - Fix harddrive install method error checking (#232492).
368 - Set authentication information from the input line to preserve quoting
369 (#241657).
370 - Allow included files to be given by URL.
371 - Fix typo in user --iscrypted option.
373 * Mon May 14 2007 Chris Lumens <clumens@redhat.com> - 1.1-1
374 - Better regexes for splitting version strings into family and version.
375 - Add basic support for RHEL3.
376 - Update translations.
378 * Fri Apr 13 2007 Chris Lumens <clumens@redhat.com> - 1.0-1
379 - Update documentation.
380 - Update translations.
382 * Mon Mar 19 2007 Chris Lumens <clumens@redhat.com> - 0.100-1
383 - bootloader should be written out after upgrade/install.
384 - Treat class names as unicode strings (#231053).
386 * Wed Mar 07 2007 Chris Lumens <clumens@redhat.com> - 0.99-1
387 - The timezone command didn't recognize --isUtc before FC6 (#231189).
388 - Recognize %ksappend lines in ksvalidator.
389 - Don't set default values in some command __init__ methods.
390 - Added an updates command.
391 - Add support for RAID10.
393 * Mon Feb 26 2007 Chris Lumens <clumens@redhat.com> - 0.98-1
394 - Fix device command syntax to match anaconda.
395 - Fix __call__ on method command.
397 * Wed Feb 21 2007 Chris Lumens <clumens@redhat.com> - 0.97-1
398 - Fix traceback when not overriding default mappings (#229505).
400 * Tue Feb 20 2007 Chris Lumens <clumens@redhat.com> - 0.96-1
401 - Fix __str__ methods for langsupport and reboot commands.
402 - Renamed BaseHandler.empty to BaseHandler.maskAllExcept.
403 - Split command objects out into their own files in commands/.
404 - Rename command objects to start with Version_.
405 - Support extended group selection syntax.
407 * Wed Feb 14 2007 Chris Lumens <clumens@redhat.com> - 0.95-1
408 - KickstartParser no longer takes a version argument.
409 - Be more lenient in what strings stringToVersion accepts.
410 - Allow setting state on one data object from multiple files.
412 * Wed Feb 07 2007 Chris Lumens <clumens@redhat.com> - 0.94-1
413 - Add a newline to the end of the key command output.
414 - Use network bootproto constants (#197694).
415 - Fix tracebacks in subclass __str__ methods (#226734).
417 * Wed Jan 31 2007 Chris Lumens <clumens@redhat.com> - 0.93-2
418 - Make some minor spec file changes to get closer to the extras guidelines.
420 * Thu Jan 25 2007 Chris Lumens <clumens@redhat.com> - 0.93-1
421 - Add support for FC3, RHEL4, and RHEL5.
422 - The key command was not supported until after FC6.
423 - Accept more strings in stringToVersion.
425 * Fri Jan 19 2007 Chris Lumens <clumens@redhat.com> - 0.92-1
426 - Fix KickstartVersionError reporting.
427 - Add a version attribute to handler objects.
428 - Fix line number reporting on lots of commands.
429 - Add initial support for Fedora 7 and remove deprecated commands.
430 - Accept a --default argument to the %%packages header (#221305).
432 * Wed Jan 17 2007 Chris Lumens <clumens@redhat.com> - 0.91-1
433 - Add a method to read kickstart files from strings.
435 * Tue Jan 16 2007 Chris Lumens <clumens@redhat.com> - 0.90-1
436 - Support multiple versions of kickstart syntax from one code base
437 (#189348).
438 - Fix inconsistency between Script parser and writer (#222877).
440 * Fri Dec 15 2006 Chris Lumens <clumens@redhat.com> - 0.43-1
441 - Pull in new translations (#216620).
443 * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.42-2
444 - rebuild against python 2.5
446 * Tue Dec 05 2006 Chris Lumens <clumens@redhat.com> - 0.42-1
447 - Fix traceback when writing out repo command (#218274).
449 * Fri Dec 01 2006 Chris Lumens <clumens@redhat.com> - 0.41-1
450 - Fix traceback when using deprecated commands (#218047, #218059).
452 * Thu Nov 30 2006 Chris Lumens <clumens@redhat.com> - 0.40-1
453 - Pull in new translations (#216620).
454 - Add --level argument to logging command writer.
456 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-2
457 - Fix release number.
459 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-1
460 - Add writer for --key (#211997).
462 * Tue Oct 17 2006 Jeremy Katz <katzj@redhat.com> - 0.38-1
463 - allow --skip for installation number as well (#207029)
465 * Mon Oct 16 2006 Jeremy Katz <katzj@redhat.com> - 0.37-1
466 - support for installation numbers (#207029)
468 * Fri Oct 13 2006 Bill Nottingham <notting@redhat.com> - 0.36-1
469 - use valid charsets in translations (#210720)
471 * Fri Sep 29 2006 Chris Lumens <clumens@redhat.com> - 0.35-1
472 - Fix traceback in harddrive command (#208557).
474 * Mon Sep 25 2006 Chris Lumens <clumens@redhat.com> - 0.34-1
475 - Add support for --biospart option to harddrive (#207585).
476 - Update writer for syntax changes.
478 * Wed Sep 20 2006 Jeremy Katz <katzj@redhat.com> - 0.33-1
479 - improved iscsi syntax
480 - allow multiple zfcp devs
482 * Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 0.32-1
483 - Limit --bootproto to what anaconda supports.
484 - Add --noipv4 and --noipv6 network options.
486 * Tue Jun 20 2006 Chris Lumens <clumens@redhat.com> 0.31-1
487 - Handle nfs --opts (katzj).
488 - RAID devices should be integers instead of strings (#176537).
489 - Add initial support for iscsi (katzj).
491 * Tue Jun 06 2006 Chris Lumens <clumens@redhat.com> 0.30-2
492 - Add BuildRequires to fix building under mock (#194156, Joost Soeterbroek
493 <fedora AT soeterbroek.com>).
495 * Thu May 25 2006 Chris Lumens <clumens@redhat.com> 0.30-1
496 - Change order of LVM-related writing functions (#193073).
497 - Require urlgrabber.
498 - Return a more useful error message on unknown commands.
499 - Fix logvol writing typo.
500 - Make ksvalidator validate from a URL in addition to a file.
501 - Don't write out an empty packages section (#192851).
503 * Tue May 23 2006 Chris Lumens <clumens@redhat.com> 0.29-1
504 - Add multipath command, handlers, and data objects (pjones).
505 - Rename --ports to --port in writer.
507 * Mon May 15 2006 Chris Lumens <clumens@redhat.com> 0.28-1
508 - Support --mtu for the network command (#191328).
509 - Accept --isUtc for backwards compatibility.
511 * Wed May 04 2006 Chris Lumens <clumens@redhat.com> 0.27-1
512 - Output formatting fixes.
513 - Added commands for managing users and services.
515 * Mon Apr 17 2006 Chris Lumens <clumens@redhat.com> 0.26-1
516 - Ignore spaces before group names (#188095).
517 - Added some translations.
518 - Add options for repo command.
519 - Reorder %%packages section output.
520 - Output %%packages header options.
521 - Initialize RAID and volume group members to empty lists.
523 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.25-1
524 - Add support for the logging command.
526 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.24-1
527 - Don't write out a blank xconfig line.
528 - Reorder output handlers to group like commands together.
529 - Mark strings for translation.
531 * Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 0.23-1
532 - Backwards compatibility support for options to zerombr.
534 * Fri Feb 24 2006 Chris Lumens <clumens@redhat.com> 0.22-1
535 - Get ignoredisk working again (#182934).
537 * Fri Feb 17 2006 Chris Lumens <clumens@redhat.com> 0.21-1
538 - Provide an option to not traceback on missing include files (#181760).
539 - Update programming documentation.
541 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.20-1
542 - Correctly set --noformat and --useexisting on lvm and raid.
544 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.19-1
545 - --onboot requires a value (#180987).
546 - Be more strict about commands that don't take arguments.
548 * Thu Feb 09 2006 Chris Lumens <clumens@redhat.com> 0.18-1
549 - Fix some errors pychecker caught.
550 - Allow exceptions to not be fatal so ksvalidator can spot more errors in
551 a single pass (#179894).
553 * Wed Feb 01 2006 Chris Lumens <clumens@redhat.com> 0.17-1
554 - Don't set a default port for vnc.
556 * Tue Jan 31 2006 Chris Lumens <clumens@redhat.com> 0.16-1
557 - Give dmraid string an initial value.
558 - Handle None on partition size.
560 * Tue Jan 31 2006 Peter Jones <pjones@redhat.com> 0.15-1
561 - Add dmraid support
563 * Mon Jan 30 2006 Chris Lumens <clumens@redhat.com> 0.14-1
564 - Fix VNC parameter parsing (#179209).
565 - Deprecate --connect. Add --host and --port instead.
567 * Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 0.13-1
568 - Recognize the --eject parameter to shutdown/halt.
569 - Store the exact post-installation action in ksdata.
571 * Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 0.12-1
572 - Clean up output quoting.
573 - Finish removing monitor-related stuff from xconfig.
575 * Mon Dec 12 2005 Chris Lumens <clumens@redhat.com> 0.11-1
576 - Deprecate monitor-related options to xconfig.
578 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
579 - Support --bytes-per-inode on raid
580 (Curtis Doty <Curtis at GreenKey.net> #175288).
582 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
583 - fixup network --onboot
585 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
586 - Default to SELINUX_ENFORCING.
587 - Default partition sizes to None for anaconda (#172378).
588 - Don't call shlex.split on anything inside a script (#172313).
590 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
591 - Fix clearpart --all.
592 - vnc command does not require --connect option (#172192).
593 - network --onboot does not take any option.
594 - Remove extra spaces from firewall --ports and --trust.
595 - Write out network --<service> options.
597 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
598 - Add --resolvedeps and --ignoredeps as deprecated options.
599 - Pass line number to header functions.
601 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
602 - Add line numbers to exception reporting.
603 - Added ksvalidator.
605 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
606 - Correct deprecated attribute on options.
607 - Added programming documentation.
609 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
610 - Correct python lib directory on 64-bit archs (#170621).
612 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
613 - Add a deprecated attribute to options.
614 - Add --card option back to xconfig and mark as deprecated.
615 - Throw a deprecation warning on mouse and langsupport commands.
616 - Rename Writer to KickstartWriter for consistency.
617 - Collapse scripts into a single list and add an attribute on Script to
618 differentiate.
620 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
621 - Rename module to pykickstart to avoid conflicts in anaconda.
622 - Rename data classes for consistency.
623 - Add default bytesPerInode settings.
625 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
626 - Created package from anaconda.