Add --resolvedeps and --includedeps as deprecated options to %packages.
[pykickstart.git] / pykickstart.spec
blob58d3fed4a071bbbd119d10bc60232f7589366b1e
1 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Version: 0.5
6 Release: 1
7 Source0: %{name}-%{version}.tar.gz
8 License: GPL
9 Group: System Environment/Libraries
10 BuildArch: noarch
11 BuildRoot: %{_tmppath}/%{name}-root
12 BuildRequires: python-devel
13 Requires: python >= %(%{__python} -c "import sys; print sys.version[:3]")
15 %description
16 The pykickstart package is a python library for manipulating kickstart
17 files.
19 %prep
20 %setup -q
21 make
23 %build
25 %install
26 rm -rf $RPM_BUILD_ROOT
27 python setup.py install --root=${RPM_BUILD_ROOT}
29 %clean
30 rm -rf $RPM_BUILD_ROOT
32 %files
33 %defattr(-,root,root)
34 %doc README ChangeLog COPYING docs/programmers-guide
35 %{python_sitelib}/pykickstart
36 /usr/bin/ksvalidator
38 %changelog
39 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
40 - Add line numbers to exception reporting.
41 - Added ksvalidator.
43 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
44 - Correct deprecated attribute on options.
45 - Added programming documentation.
47 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
48 - Correct python lib directory on 64-bit archs (#170621).
50 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
51 - Add a deprecated attribute to options.
52 - Add --card option back to xconfig and mark as deprecated.
53 - Throw a deprecation warning on mouse and langsupport commands.
54 - Rename Writer to KickstartWriter for consistency.
55 - Collapse scripts into a single list and add an attribute on Script to
56 differentiate.
58 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
59 - Rename module to pykickstart to avoid conflicts in anaconda.
60 - Rename data classes for consistency.
61 - Add default bytesPerInode settings.
63 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
64 - Created package from anaconda.