1 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library
for manipulating kickstart files
5 Url
: http
://fedoraproject.org
/wiki
/pykickstart
8 # This is a Red Hat maintained package which is specific to
9 # our distribution. Thus the source is only available from
11 Source0: %{name}-%{version}.tar.gz
14 Group: System Environment
/Libraries
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n
)
17 BuildRequires
: python
-devel
, gettext
, python
-setuptools
-devel
18 Requires: python
, python
-urlgrabber
21 The pykickstart package is a python library
for manipulating kickstart
32 make DESTDIR
=%{buildroot} install
38 %files -f
%{name}.lang
39 %defattr(-,root
,root
,-)
40 %doc README ChangeLog COPYING docs
/programmers
-guide
41 %doc docs
/kickstart
-docs.txt
43 %{_bindir}/ksvalidator
48 * Thu Sep
10 2009 Chris Lumens
<clumens@redhat.com
> - 1.62-1
49 - Support translated
help text
in optparse
(#479519).
50 - If the input kickstart file cannot be
read, raise IOError
(#519477).
52 * Thu Aug
27 2009 Chris Lumens
<clumens@redhat.com
> - 1.61-1
53 - Include the error messages from URLGrabError
in the exception
(#518443).
55 * Tue Aug
11 2009 Chris Lumens
<clumens@redhat.com
> - 1.60-1
56 - Put quotes around the repo's name
(Marc.Herbert@gmail.com
).
57 - Make duplicate entries warnings
, not errors
(#516338).
59 * Tue Jul
28 2009 Chris Lumens
<clumens@redhat.com
> - 1.59-1
60 - Handle a few more places where a urlgrabber error could happen
(#512951).
61 - Error out
if the same partition
/repo
/network is defined twice
(#512956).
62 - Call parent class tests first.
(jlaska
)
63 - Add KSOptionParser to FC3 upgrade
command.
(jlaska
)
64 - Correct missing
return stmt
in _getArgsAsStr
() (jlaska
)
66 * Fri Jul
17 2009 Chris Lumens
<clumens@redhat.com
> - 1.58-1
67 - Adjust writePriority to fix lvm
-on
-raid0
test cases
(jlaska
).
68 - Add F12 to the version number tests.
(clumens
)
69 - F12_User
test case.
(dcantrell
)
70 - Add
--gecos argument to the 'user'
command (dcantrell
)
71 - Convert user.py to use _getArgsAsStr
() (dcantrell
)
73 * Fri Jul
10 2009 Chris Lumens
<clumens@redhat.com
> - 1.57-1
74 - Another patch to
make the bootloader
test work
(jlaska
).
76 * Thu Jul
09 2009 Chris Lumens
<clumens@redhat.com
> - 1.56-1
77 - Make sure to import the gettext stuff
in fcoe.
(clumens
)
78 - Correctly deprecate bootloader
--lba32
(jlaska
).
79 - pykickstart
: fix zfcp
command writepriority
(hdegoede
)
80 - pykickstart
: Add fcoe
command (take
2) (hdegoede
)
81 - Add a
test case for RAID
(jlaska
).
83 * Thu Jul
02 2009 Chris Lumens
<clumens@redhat.com
> - 1.55-1
84 - Add support
for the group
command to F12
(#509119).
85 - RHEL5 now supports RAID
10.
86 - The f12 hander class should be called F12Handler.
(jgranado
)
87 - Remove bootloader
--lba32.
88 - Add a new version of the driverdisk
command without
--type=.
89 - Add initial support
for F12.
90 - Fetch the programmers
-guide from the wiki now.
92 * Mon May
18 2009 Chris Lumens
<clumens@redhat.com
> - 1.54-1
93 - Make sure the F11 handler gets used
for "partition" and "part"
(#501020).
95 * Wed Apr
29 2009 Chris Lumens
<clumens@redhat.com
> - 1.53-1
96 - Move lineno
= from KSOptionParser.__init__ to parse_args
(#497149). (clumens)
97 - Use the F11 version of the partition
command.
(clumens
)
98 - Remove the
--start and
--end options since anaconda no longer uses them.
(clumens
)
99 - Remove a broken
test case.
(clumens
)
101 * Wed Feb
18 2009 Chris Lumens
<clumens@redhat.com
> - 1.52-1
102 - Add lots more
test cases
(alindebe
, mgracik
, stickster
).
103 - Add a skip attribute on key to shut up pychecker.
104 - Only show autostep
command when requested
(jlaska
)
105 - Strip spaces from service names
, and require an option to be provided.
106 - Surround services lists
in double quotes.
107 - Remove the extra space from the services __str__ method.
108 - Fix output formatting bugs
in firewall
, partition
, and repo
(mgracik
).
109 - Specifying both or neither of
--drives and
--only
-use should be an error.
110 - Corrected newline char
in return value of FC6_Method.
(mgracik
)
111 - Make
--drives a required option
for FC3
, and catch no args on F8.
112 - Fix final printing of the rescue
command (mgracik
).
113 - Surround output strings
in double quotes.
114 - Fix a typo
in the deviceprobe
command.
115 - Revert the more strict option processing on displaymode.
116 - Properly handle erroring on extra args
, not just extra options.
117 - Don't use the logging class since it interferes with the logging
test.
118 - port without host should raise KickstartParseError
, not kickstartValueError.
119 - Add the
--key option to option processing
, since it's a valid argument.
120 - Fix
test cases that were failing due to the new use of KSOptionParser.
121 - Teach driverdisk.py
command to reject extra partitions
(stickster
).
122 - Add KSOptionParser to all commands ... enables more strick option checking
(jlaska
).
123 - Use KSOptionParser so we can catch bad
command options
(jlaska
).
125 * Thu Jan
29 2009 Chris Lumens
<clumens@redhat.com
> - 1.51-1
126 - Make a couple changes to how the logging
command is handled.
127 - Add a lot of
test cases
(clumens
, alindebe
, jlaska
, fcami
, adamwill
, pfrields
).
128 - Fix output formatting
for the rootpw
command.
129 - For commands that take exactly one argument
, check and error correctly.
130 - Surround module options
in quotes on the output side
(jlaska
).
131 - Set module opts
in the FC3 handler correctly.
132 - Fix newlines on the device
command output
(jlaska
).
133 - If
--autoscreenshot is not specified
, still output "autostep".
134 - Move the currentCmd and currentLine into getParser
().
(jlaska
)
135 - Write out an selinux line
if set to disabled
, but not
if None.
136 - F9_LogVolData should inherit from FC4_LogVolData
, not FC3_LogVolData
(jlaska
).
137 - Add unittest framework along with logvol and vnc unittests.
(jlaska
)
138 - Don't
set the KSOption.required attribute
in the constructor
(jlaska
).
140 * Sat Jan
10 2009 Chris Lumens
<clumens@redhat.com
> - 1.50-1
141 - Add a script to diff two versions of kickstart syntax.
142 - Add an option to ksvalidator to list all available syntax versions.
143 - Remove a couple extra newlines
in output formatting.
144 - Add documentation
for the new
%include representation.
145 - Add support
%include to the pykickstart data objects.
147 * Thu Jan
08 2009 Chris Lumens
<clumens@redhat.com
> - 1.49-1
148 - Add upgrade
--root
-device
(atodorov
, #471232).
149 - Use python's
builtin set rather than the Sets module
(#477836, dcantrell).
151 * Tue Dec
23 2008 Chris Lumens
<clumens@redhat.com
> - 1.48-1
152 - Allow ignoring group metadata from repos
, using a '
--ignoregroups'
154 - Add initial support
for F11.
155 - Specify the
command versions
in the handlers instead of making copies.
156 - Remove empty and pointless __init__ methods.
157 - Pass arguments to superclasses via
*args and
**kwargs
, all the way up.
158 - Add removedKeywords and removedAttrs lists on Commands and Data.
159 - Fix version regexes to handle double digits and minor releases
(jlaska
).
161 * Thu Oct
30 2008 Chris Lumens
<clumens@redhat.com
> - 1.47-1
162 - Fix enabling services we specify by specific options.
164 * Mon Oct
27 2008 Chris Lumens
<clumens@redhat.com
> - 1.46-1
165 - Add support
for firewall
--service
(#467005).
167 * Tue Oct
14 2008 Chris Lumens
<clumens@redhat.com
> - 1.45-1
168 - Lots of translation updates.
169 - Remove use of string.partition
for python2.4
(atodorov
).
171 * Mon Sep
22 2008 Chris Lumens
<clumens@redhat.com
> - 1.44-1
172 - Add support
for reverse CHAP to the kickstart iscsi
command (hans
)
175 * Wed Sep
03 2008 Chris Lumens
<clumens@redhat.com
> - 1.43-1
176 - Revert "Do not include passphrases
for encrypted block devices
in
177 anaconda
-ks.cfg."
(dlehman
)
178 - yum doesn't like when mirrorlist is "".
(clumens
)
180 * Mon Aug
11 2008 Chris Lumens
<clumens@redhat.com
> - 1.42-1
181 - Add rescue
command to pykickstart
(atodorov
)
182 - Sort
%packages output
(katzj
)
183 - Fix a typo
(atodorov
).
185 * Fri Aug
01 2008 Chris Lumens
<clumens@redhat.com
> - 1.41-1
186 - RHEL5 supports ignoredisk
--only
-use now too.
(clumens
)
187 - Do not include passphrases
for encrypted block devices
in
188 anaconda
-ks.cfg.
(dlehman
)
189 - Fix F9
,F10
,RHEL5 "part" commands to use the same class as
190 "partition".
(dlehman
)
191 - Add an apply method
() for commands and implement
for lang
(katzj
)
193 * Tue Jul
15 2008 Chris Lumens
<clumens@redhat.com
> - 1.40-1
194 - RHEL5_LogVolData should inherit from FC4
, not FC3.
195 Also fix FC9
->F9 typo.
(dlehman
)
196 - Support creation of encrypted block devices
in RHEL5.
(#449830) (dlehman)
197 - Use the right LogVolData objects
for RHEL3 and
4 (jlaska
).
(clumens
)
198 - We no longer use rhpl
for translations.
(clumens
)
199 - All the base classes should derive from object.
(clumens
)
201 * Fri Jun
13 2008 Chris Lumens
<clumens@redhat.com
> - 1.39-1
202 - It's helpful to
return the parser object.
(clumens
)
204 * Tue Jun
10 2008 Chris Lumens
<clumens@redhat.com
> - 1.38-1
205 - Fix loading the Handler object by looking
for a more specific
206 name
(#450740). (clumens)
208 * Sun Jun
08 2008 Chris Lumens
<clumens@redhat.com
> - 1.37-1
209 - XConfig is still used by other projects
, so just deprecate some
212 * Thu May
29 2008 Chris Lumens
<clumens@redhat.com
> - 1.36-1
213 - It should be repo
--cost
, not repo
--priority.
(clumens
)
215 * Fri May
23 2008 Chris Lumens
<clumens@redhat.com
> - 1.35-1
216 - Bring driverdisk
command in line with the docs.
(clumens
)
217 - Change RAID
command print priorities
(jlaska
).
218 - According to docs
, physvols are space delimited.
(jlaska
)
219 - Don't write the label out twice
(jlaska
).
220 - Deprecate monitor and xconfig commands.
(clumens
)
222 * Wed May
07 2008 Chris Lumens
<clumens@redhat.com
> - 1.34-1
223 - Load the handler module automatically.
(clumens
)
224 - Add support
for F10.
(clumens
)
225 - Initialize cmd.handler earlier
; fixes repo.methodToRepo
() (markmc
)
226 - Don't shadow
builtin function names.
(clumens
)
227 - Running check is now required before pykickstart can be packaged.
(clumens
)
228 - Reorganize code a little bit to pass pychecker.
(clumens
)
230 * Tue Apr
08 2008 Chris Lumens
<clumens@redhat.com
> - 1.33-1
231 - Fix whitespace when printing out the bootloader
command (pmeyers
).
232 - Fix the
type on bootloader
--timeout processing.
(clumens
)
234 * Wed Apr
02 2008 Chris Lumens
<clumens@redhat.com
> - 1.32-1
235 - Make the string reader act like the file reader upon EOF.
(clumens
)
236 - Add syntax
for encrypted logical volumes.
(clumens
)
238 * Tue Mar
25 2008 Chris Lumens
<clumens@redhat.com
> - 1.31-1
239 - Support end
-of
-line comments.
(clumens
)
240 - Lots of translation updates.
242 * Tue Feb
26 2008 Chris Lumens
<clumens@redhat.com
> - 1.30-1
243 - Reverse writePriorities of iscsi and iscsname
(#434965, jlaska).
244 - Fix printing of iscsiname
command (#434945, jlaska).
245 - Don't traceback on ENOENT.
(pnasrat
)
246 - Store the mouse name as a string
, not a list.
(clumens
)
247 - Update translations.
249 * Wed Jan
30 2008 Chris Lumens
<clumens@redhat.com
> - 1.29-1
250 - Renamed bootproto
=ask to bootproto
=query
, add to RHEL5 as well.
(clumens
)
252 * Wed Jan
23 2008 Chris Lumens
<clumens@redhat.com
> - 1.28-1
253 - Fix traceback on volgroup
command.
(clumens
)
255 * Thu Jan
17 2008 Chris Lumens
<clumens@redhat.com
> - 1.27-1
256 - The bootprotoList needs to be defined before it's used.
(clumens
)
258 * Thu Jan
17 2008 Chris Lumens
<clumens@redhat.com
> - 1.26-1
259 - Add support
for network
--bootproto
=ask.
(clumens
)
261 * Tue Jan
15 2008 Chris Lumens
<clumens@redhat.com
> - 1.25-1
262 - Add the version to the output ks file.
(clumens
)
263 - Add syntax
for encrypted partitions and raid devices.
(clumens
)
265 * Thu Jan
10 2008 Chris Lumens
<clumens@redhat.com
> - 1.24-1
266 - Make inheritance and overriding of
%packages work
(#427768). (clumens)
267 - Add an option
for which languages should be installed.
(katzj
)
268 - Use the right name
for the iscsi
--target variable
(#418781). (clumens)
270 * Mon Dec
10 2007 Chris Lumens
<clumens@redhat.com
> - 1.23-1
271 - Take Makefile improvements from anaconda.
272 - Fix a traceback on F9 zerombr
command (#395431).
273 - Update to handle new Python eggs packaging.
275 * Tue Nov
20 2007 Chris Lumens
<clumens@redhat.com
> 1.22-1
276 - Don't process or write out vnc
--enabled
(jlaska AT redhat DOT com
).
277 - Fix a traceback
in the clearpart
command.
279 * Tue Nov
06 2007 Chris Lumens
<clumens@redhat.com
> 1.21-1
280 - Save script line numbers
for debugging.
281 - More internal cleanups.
283 * Wed Oct
31 2007 Chris Lumens
<clumens@redhat.com
> 1.20-1
284 - Pull wiki docs from the new location.
285 - Fix error messages
for options that have been removed after having been
286 previously deprecated.
287 - zerombr no longer takes any arguments.
288 - %packages --ignoredeps
--resolvedeps have been removed.
289 - firewall
--high
--medium have been removed.
290 - vnc
--connect has been removed.
291 - xconfig options from monitor have now been removed.
292 - --bytes
-per
-inode has been marked as deprecated.
294 - Add
--fsprofile option to disk commands
(pjones
).
295 - Add F9 support
(pjones
).
296 - Lots of internal fixes
(clumens
, pjones
).
298 * Tue Oct
23 2007 Chris Lumens
<clumens@redhat.com
> 1.19-1
299 - Fix a traceback on the cdrom method.
301 * Thu Oct
18 2007 Chris Lumens
<clumens@redhat.com
> 1.18-1
302 - Don't write out
%end to packages and scripts
if the syntax version doesn't
304 - Remove obsolete translation
(#332221).
306 * Thu Oct
04 2007 Chris Lumens
<clumens@redhat.com
> 1.17-1
307 - Simplify argument processing and printing.
309 * Wed Oct
03 2007 Chris Lumens
<clumens@redhat.com
> 1.16-1
310 - Undeprecate
%packages --excludedocs.
311 - Fix a traceback
in the device
command handling.
312 - Add bootloader
--timeout
(katzj
).
314 * Tue Oct
02 2007 Chris Lumens
<clumens@redhat.com
> 1.15-1
315 - Update translations
(#259121).
316 - The device
command no longer takes a
type argument.
318 * Fri Sep
28 2007 Chris Lumens
<clumens@redhat.com
> 1.14-1
319 - Fix output formatting
for packages section header
(#310211).
320 - Add a script to flatten kickstart files containing includes
(katzj
).
322 * Wed Sep
12 2007 Chris Lumens
<clumens@redhat.com
> 1.13-1
323 - Add a
function to convert
URL method strings into repo objects
325 - Writer formatting fixes.
326 - Add kickstart documentation from the Fedora Wiki.
328 * Tue Sep
04 2007 Chris Lumens
<clumens@redhat.com
> 1.12-1
329 - Fix lots of problems
in processing the bootloader
, device
, network
, and
331 - Add
%end when writing out scripts and packages.
332 - Add a makefile target to run pychecker to cut down on errors
in
335 * Mon Sep
3 2007 Jeremy Katz
<katzj@redhat.com
> - 1.11-1
336 - fix a few tracebacks
338 * Fri Aug
31 2007 Chris Lumens
<clumens@redhat.com
> 1.10-1
339 - Add network
--ipv6
=.
341 * Fri Aug
24 2007 Chris Lumens
<clumens@redhat.com
> 1.9-1
342 - Add support
for the
%end directive to be placed at the end of scripts
343 and packages sections. Deprecate old syntax.
344 - Clean up after ksvalidator
if pykickstart issues a traceback.
345 - Add support
for repo
--priority
--includepkgs
--excludepkgs.
346 - Fix newline at end of reboot
--eject output
(#253562).
348 * Mon Aug
13 2007 Chris Lumens
<clumens@redhat.com
> 1.8-1
349 - Fix
type checking of string values.
351 * Thu Aug
09 2007 Chris Lumens
<clumens@redhat.com
> 1.7-1
352 - Clarify license
in spec file and all
source files.
353 - Check string values to options to
make sure they're not other options
356 * Thu Aug
02 2007 Chris Lumens
<clumens@redhat.com
> 1.6-1
357 - Fix a couple tracebacks
in ksvalidator.
358 - Change
--class to
--dhcpclass
(#248912).
360 * Thu Jul
19 2007 Chris Lumens
<clumens@redhat.com
> 1.5-2
361 - Require rhpl
(#248953).
363 * Tue Jul
17 2007 Chris Lumens
<clumens@redhat.com
> 1.5-1
364 - Fix traceback when calling preprocessKickstart.
366 * Tue Jul
17 2007 Chris Lumens
<clumens@redhat.com
> 1.4-1
367 - Add methods to handle the
%ksappend directive.
368 - Fix ignoredisk
--disks.
370 * Wed Jul
11 2007 Chris Lumens
<clumens@redhat.com
> - 1.3-1
371 - Add support
for ignoredisk
--only
-use.
372 - Fix traceback
in raid
command printing method
(#246709).
374 * Fri Jun
08 2007 Chris Lumens
<clumens@redhat.com
> - 1.2-2
375 - Fix package review problems
(#226334).
377 * Mon Jun
04 2007 Chris Lumens
<clumens@redhat.com
> - 1.2-1
378 - Fix harddrive
install method error checking
(#232492).
379 - Set authentication information from the input line to preserve quoting
381 - Allow included files to be given by
URL.
382 - Fix typo
in user
--iscrypted option.
384 * Mon May
14 2007 Chris Lumens
<clumens@redhat.com
> - 1.1-1
385 - Better regexes
for splitting version strings into family and version.
386 - Add basic support
for RHEL3.
387 - Update translations.
389 * Fri Apr
13 2007 Chris Lumens
<clumens@redhat.com
> - 1.0-1
390 - Update documentation.
391 - Update translations.
393 * Mon Mar
19 2007 Chris Lumens
<clumens@redhat.com
> - 0.100-1
394 - bootloader should be written out after upgrade
/install.
395 - Treat class names as unicode strings
(#231053).
397 * Wed Mar
07 2007 Chris Lumens
<clumens@redhat.com
> - 0.99-1
398 - The timezone
command didn't recognize
--isUtc before FC6
(#231189).
399 - Recognize
%ksappend lines
in ksvalidator.
400 - Don't
set default values
in some
command __init__ methods.
401 - Added an updates
command.
402 - Add support
for RAID10.
404 * Mon Feb
26 2007 Chris Lumens
<clumens@redhat.com
> - 0.98-1
405 - Fix device
command syntax to match anaconda.
406 - Fix __call__ on method
command.
408 * Wed Feb
21 2007 Chris Lumens
<clumens@redhat.com
> - 0.97-1
409 - Fix traceback when not overriding default mappings
(#229505).
411 * Tue Feb
20 2007 Chris Lumens
<clumens@redhat.com
> - 0.96-1
412 - Fix __str__ methods
for langsupport and reboot commands.
413 - Renamed BaseHandler.empty to BaseHandler.maskAllExcept.
414 - Split
command objects out into their own files
in commands
/.
415 - Rename
command objects to start with Version_.
416 - Support extended group selection syntax.
418 * Wed Feb
14 2007 Chris Lumens
<clumens@redhat.com
> - 0.95-1
419 - KickstartParser no longer takes a version argument.
420 - Be more lenient
in what strings stringToVersion accepts.
421 - Allow setting state on one data object from multiple files.
423 * Wed Feb
07 2007 Chris Lumens
<clumens@redhat.com
> - 0.94-1
424 - Add a newline to the end of the key
command output.
425 - Use network bootproto constants
(#197694).
426 - Fix tracebacks
in subclass __str__ methods
(#226734).
428 * Wed Jan
31 2007 Chris Lumens
<clumens@redhat.com
> - 0.93-2
429 - Make some minor spec file changes to get closer to the extras guidelines.
431 * Thu Jan
25 2007 Chris Lumens
<clumens@redhat.com
> - 0.93-1
432 - Add support
for FC3
, RHEL4
, and RHEL5.
433 - The key
command was not supported
until after FC6.
434 - Accept more strings
in stringToVersion.
436 * Fri Jan
19 2007 Chris Lumens
<clumens@redhat.com
> - 0.92-1
437 - Fix KickstartVersionError reporting.
438 - Add a version attribute to handler objects.
439 - Fix line number reporting on lots of commands.
440 - Add initial support
for Fedora
7 and remove deprecated commands.
441 - Accept a
--default argument to the %
%packages header
(#221305).
443 * Wed Jan
17 2007 Chris Lumens
<clumens@redhat.com
> - 0.91-1
444 - Add a method to
read kickstart files from strings.
446 * Tue Jan
16 2007 Chris Lumens
<clumens@redhat.com
> - 0.90-1
447 - Support multiple versions of kickstart syntax from one code base
449 - Fix inconsistency between Script parser and writer
(#222877).
451 * Fri Dec
15 2006 Chris Lumens
<clumens@redhat.com
> - 0.43-1
452 - Pull
in new translations
(#216620).
454 * Thu Dec
7 2006 Jeremy Katz
<katzj@redhat.com
> - 0.42-2
455 - rebuild against python
2.5
457 * Tue Dec
05 2006 Chris Lumens
<clumens@redhat.com
> - 0.42-1
458 - Fix traceback when writing out repo
command (#218274).
460 * Fri Dec
01 2006 Chris Lumens
<clumens@redhat.com
> - 0.41-1
461 - Fix traceback when using deprecated commands
(#218047, #218059).
463 * Thu Nov
30 2006 Chris Lumens
<clumens@redhat.com
> - 0.40-1
464 - Pull
in new translations
(#216620).
465 - Add
--level argument to logging
command writer.
467 * Tue Oct
24 2006 Chris Lumens
<clumens@redhat.com
> - 0.39-2
468 - Fix release number.
470 * Tue Oct
24 2006 Chris Lumens
<clumens@redhat.com
> - 0.39-1
471 - Add writer
for --key
(#211997).
473 * Tue Oct
17 2006 Jeremy Katz
<katzj@redhat.com
> - 0.38-1
474 - allow
--skip
for installation number as well
(#207029)
476 * Mon Oct
16 2006 Jeremy Katz
<katzj@redhat.com
> - 0.37-1
477 - support
for installation numbers
(#207029)
479 * Fri Oct
13 2006 Bill Nottingham
<notting@redhat.com
> - 0.36-1
480 - use valid charsets
in translations
(#210720)
482 * Fri Sep
29 2006 Chris Lumens
<clumens@redhat.com
> - 0.35-1
483 - Fix traceback
in harddrive
command (#208557).
485 * Mon Sep
25 2006 Chris Lumens
<clumens@redhat.com
> - 0.34-1
486 - Add support
for --biospart option to harddrive
(#207585).
487 - Update writer
for syntax changes.
489 * Wed Sep
20 2006 Jeremy Katz
<katzj@redhat.com
> - 0.33-1
490 - improved iscsi syntax
491 - allow multiple zfcp devs
493 * Thu Jul
20 2006 Chris Lumens
<clumens@redhat.com
> 0.32-1
494 - Limit
--bootproto to what anaconda supports.
495 - Add
--noipv4 and
--noipv6 network options.
497 * Tue Jun
20 2006 Chris Lumens
<clumens@redhat.com
> 0.31-1
498 - Handle nfs
--opts
(katzj
).
499 - RAID devices should be integers instead of strings
(#176537).
500 - Add initial support
for iscsi
(katzj
).
502 * Tue Jun
06 2006 Chris Lumens
<clumens@redhat.com
> 0.30-2
503 - Add BuildRequires to fix building under mock
(#194156, Joost Soeterbroek
504 <fedora AT soeterbroek.com
>).
506 * Thu May
25 2006 Chris Lumens
<clumens@redhat.com
> 0.30-1
507 - Change order of LVM
-related writing functions
(#193073).
508 - Require urlgrabber.
509 - Return a more useful error message on unknown commands.
510 - Fix logvol writing typo.
511 - Make ksvalidator validate from a
URL in addition to a file.
512 - Don't write out an empty packages section
(#192851).
514 * Tue May
23 2006 Chris Lumens
<clumens@redhat.com
> 0.29-1
515 - Add multipath
command, handlers
, and data objects
(pjones
).
516 - Rename
--ports to
--port
in writer.
518 * Mon May
15 2006 Chris Lumens
<clumens@redhat.com
> 0.28-1
519 - Support
--mtu
for the network
command (#191328).
520 - Accept
--isUtc
for backwards compatibility.
522 * Wed May
04 2006 Chris Lumens
<clumens@redhat.com
> 0.27-1
523 - Output formatting fixes.
524 - Added commands
for managing users and services.
526 * Mon Apr
17 2006 Chris Lumens
<clumens@redhat.com
> 0.26-1
527 - Ignore spaces before group names
(#188095).
528 - Added some translations.
529 - Add options
for repo
command.
530 - Reorder %
%packages section output.
531 - Output %
%packages header options.
532 - Initialize RAID and volume group members to empty lists.
534 * Mon Mar
27 2006 Chris Lumens
<clumens@redhat.com
> 0.25-1
535 - Add support
for the logging
command.
537 * Mon Mar
27 2006 Chris Lumens
<clumens@redhat.com
> 0.24-1
538 - Don't write out a blank xconfig line.
539 - Reorder output handlers to group like commands together.
540 - Mark strings
for translation.
542 * Tue Mar
07 2006 Chris Lumens
<clumens@redhat.com
> 0.23-1
543 - Backwards compatibility support
for options to zerombr.
545 * Fri Feb
24 2006 Chris Lumens
<clumens@redhat.com
> 0.22-1
546 - Get ignoredisk working again
(#182934).
548 * Fri Feb
17 2006 Chris Lumens
<clumens@redhat.com
> 0.21-1
549 - Provide an option to not traceback on missing include files
(#181760).
550 - Update programming documentation.
552 * Mon Feb
13 2006 Chris Lumens
<clumens@redhat.com
> 0.20-1
553 - Correctly
set --noformat and
--useexisting on lvm and raid.
555 * Mon Feb
13 2006 Chris Lumens
<clumens@redhat.com
> 0.19-1
556 - --onboot requires a value
(#180987).
557 - Be more strict about commands that don't take arguments.
559 * Thu Feb
09 2006 Chris Lumens
<clumens@redhat.com
> 0.18-1
560 - Fix some errors pychecker caught.
561 - Allow exceptions to not be fatal so ksvalidator can spot more errors
in
562 a single pass
(#179894).
564 * Wed Feb
01 2006 Chris Lumens
<clumens@redhat.com
> 0.17-1
565 - Don't
set a default port
for vnc.
567 * Tue Jan
31 2006 Chris Lumens
<clumens@redhat.com
> 0.16-1
568 - Give dmraid string an initial value.
569 - Handle None on partition size.
571 * Tue Jan
31 2006 Peter Jones
<pjones@redhat.com
> 0.15-1
574 * Mon Jan
30 2006 Chris Lumens
<clumens@redhat.com
> 0.14-1
575 - Fix VNC parameter parsing
(#179209).
576 - Deprecate
--connect. Add
--host and
--port instead.
578 * Thu Jan
19 2006 Chris Lumens
<clumens@redhat.com
> 0.13-1
579 - Recognize the
--eject parameter to shutdown
/halt.
580 - Store the exact post
-installation action
in ksdata.
582 * Mon Jan
09 2006 Chris Lumens
<clumens@redhat.com
> 0.12-1
583 - Clean up output quoting.
584 - Finish removing monitor
-related stuff from xconfig.
586 * Mon Dec
12 2005 Chris Lumens
<clumens@redhat.com
> 0.11-1
587 - Deprecate monitor
-related options to xconfig.
589 * Thu Dec
08 2005 Chris Lumens
<clumens@redhat.com
> 0.10-1
590 - Support
--bytes
-per
-inode on raid
591 (Curtis Doty
<Curtis at GreenKey.net
> #175288).
593 * Wed Nov
16 2005 Jeremy Katz
<katzj@redhat.com
> - 0.9-1
594 - fixup network
--onboot
596 * Thu Nov
03 2005 Chris Lumens
<clumens@redhat.com
> 0.8-1
597 - Default to SELINUX_ENFORCING.
598 - Default partition sizes to None
for anaconda
(#172378).
599 - Don't call shlex.split on anything inside a script
(#172313).
601 * Tue Nov
01 2005 Chris Lumens
<clumens@redhat.com
> 0.7-1
602 - Fix clearpart
--all.
603 - vnc
command does not require
--connect option
(#172192).
604 - network
--onboot does not take any option.
605 - Remove extra spaces from firewall
--ports and
--trust.
606 - Write out network
--<service
> options.
608 * Fri Oct
28 2005 Chris Lumens
<clumens@redhat.com
> 0.6-1
609 - Add
--resolvedeps and
--ignoredeps as deprecated options.
610 - Pass line number to header functions.
612 * Mon Oct
24 2005 Chris Lumens
<clumens@redhat.com
> 0.5-1
613 - Add line numbers to exception reporting.
616 * Wed Oct
19 2005 Chris Lumens
<clumens@redhat.com
> 0.4-1
617 - Correct deprecated attribute on options.
618 - Added programming documentation.
620 * Thu Oct
13 2005 Chris Lumens
<clumens@redhat.com
> 0.3-2
621 - Correct python lib directory on
64-bit archs
(#170621).
623 * Fri Oct
07 2005 Chris Lumens
<clumens@redhat.com
> 0.3-1
624 - Add a deprecated attribute to options.
625 - Add
--card option back to xconfig and mark as deprecated.
626 - Throw a deprecation warning on mouse and langsupport commands.
627 - Rename Writer to KickstartWriter
for consistency.
628 - Collapse scripts into a single list and add an attribute on Script to
631 * Wed Oct
05 2005 Chris Lumens
<clumens@redhat.com
> 0.2-1
632 - Rename module to pykickstart to avoid conflicts
in anaconda.
633 - Rename data classes
for consistency.
634 - Add default bytesPerInode settings.
636 * Wed Oct
05 2005 Chris Lumens
<clumens@redhat.com
> 0.1-1
637 - Created package from anaconda.