Allow passing a command mapping to BaseHandler.__init__ for overriding
[pykickstart.git] / pykickstart.spec
blobfc4fbd7b8b1ba9e7f012c8fa05979fa03ccf7d0a
1 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Url: http://fedoraproject.org/wiki/pykickstart
6 Version: 0.95
7 Release: 1%{?dist}
8 Source0: %{name}-%{version}.tar.gz
9 License: GPL
10 Group: System Environment/Libraries
11 BuildArch: noarch
12 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13 BuildRequires: python-devel, gettext
14 Requires: python, python-urlgrabber
16 %description
17 The pykickstart package is a python library for manipulating kickstart
18 files.
20 %prep
21 %setup -q
22 make
24 %build
26 %install
27 rm -rf %{buildroot}
28 make DESTDIR=%{buildroot} install
29 %find_lang %{name}
31 %clean
32 rm -rf %{buildroot}
34 %files -f %{name}.lang
35 %defattr(-,root,root,-)
36 %doc README ChangeLog COPYING docs/programmers-guide
37 %{python_sitelib}/pykickstart
38 %{_bindir}/ksvalidator
40 %changelog
41 * Wed Feb 14 2007 Chris Lumens <clumens@redhat.com> - 0.95-1
42 - KickstartParser no longer takes a version argument.
43 - Be more lenient in what strings stringToVersion accepts.
44 - Allow setting state on one data object from multiple files.
46 * Wed Feb 07 2007 Chris Lumens <clumens@redhat.com> - 0.94-1
47 - Add a newline to the end of the key command output.
48 - Use network bootproto constants (#197694).
49 - Fix tracebacks in subclass __str__ methods (#226734).
51 * Wed Jan 31 2007 Chris Lumens <clumens@redhat.com> - 0.93-2
52 - Make some minor spec file changes to get closer to the extras guidelines.
54 * Thu Jan 25 2007 Chris Lumens <clumens@redhat.com> - 0.93-1
55 - Add support for FC3, RHEL4, and RHEL5.
56 - The key command was not supported until after FC6.
57 - Accept more strings in stringToVersion.
59 * Fri Jan 19 2007 Chris Lumens <clumens@redhat.com> - 0.92-1
60 - Fix KickstartVersionError reporting.
61 - Add a version attribute to handler objects.
62 - Fix line number reporting on lots of commands.
63 - Add initial support for Fedora 7 and remove deprecated commands.
64 - Accept a --default argument to the %%packages header (#221305).
66 * Wed Jan 17 2007 Chris Lumens <clumens@redhat.com> - 0.91-1
67 - Add a method to read kickstart files from strings.
69 * Tue Jan 16 2007 Chris Lumens <clumens@redhat.com> - 0.90-1
70 - Support multiple versions of kickstart syntax from one code base
71 (#189348).
72 - Fix inconsistency between Script parser and writer (#222877).
74 * Fri Dec 15 2006 Chris Lumens <clumens@redhat.com> - 0.43-1
75 - Pull in new translations (#216620).
77 * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.42-2
78 - rebuild against python 2.5
80 * Tue Dec 05 2006 Chris Lumens <clumens@redhat.com> - 0.42-1
81 - Fix traceback when writing out repo command (#218274).
83 * Fri Dec 01 2006 Chris Lumens <clumens@redhat.com> - 0.41-1
84 - Fix traceback when using deprecated commands (#218047, #218059).
86 * Thu Nov 30 2006 Chris Lumens <clumens@redhat.com> - 0.40-1
87 - Pull in new translations (#216620).
88 - Add --level argument to logging command writer.
90 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-2
91 - Fix release number.
93 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-1
94 - Add writer for --key (#211997).
96 * Tue Oct 17 2006 Jeremy Katz <katzj@redhat.com> - 0.38-1
97 - allow --skip for installation number as well (#207029)
99 * Mon Oct 16 2006 Jeremy Katz <katzj@redhat.com> - 0.37-1
100 - support for installation numbers (#207029)
102 * Fri Oct 13 2006 Bill Nottingham <notting@redhat.com> - 0.36-1
103 - use valid charsets in translations (#210720)
105 * Fri Sep 29 2006 Chris Lumens <clumens@redhat.com> - 0.35-1
106 - Fix traceback in harddrive command (#208557).
108 * Mon Sep 25 2006 Chris Lumens <clumens@redhat.com> - 0.34-1
109 - Add support for --biospart option to harddrive (#207585).
110 - Update writer for syntax changes.
112 * Wed Sep 20 2006 Jeremy Katz <katzj@redhat.com> - 0.33-1
113 - improved iscsi syntax
114 - allow multiple zfcp devs
116 * Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 0.32-1
117 - Limit --bootproto to what anaconda supports.
118 - Add --noipv4 and --noipv6 network options.
120 * Tue Jun 20 2006 Chris Lumens <clumens@redhat.com> 0.31-1
121 - Handle nfs --opts (katzj).
122 - RAID devices should be integers instead of strings (#176537).
123 - Add initial support for iscsi (katzj).
125 * Tue Jun 06 2006 Chris Lumens <clumens@redhat.com> 0.30-2
126 - Add BuildRequires to fix building under mock (#194156, Joost Soeterbroek
127 <fedora AT soeterbroek.com>).
129 * Thu May 25 2006 Chris Lumens <clumens@redhat.com> 0.30-1
130 - Change order of LVM-related writing functions (#193073).
131 - Require urlgrabber.
132 - Return a more useful error message on unknown commands.
133 - Fix logvol writing typo.
134 - Make ksvalidator validate from a URL in addition to a file.
135 - Don't write out an empty packages section (#192851).
137 * Tue May 23 2006 Chris Lumens <clumens@redhat.com> 0.29-1
138 - Add multipath command, handlers, and data objects (pjones).
139 - Rename --ports to --port in writer.
141 * Mon May 15 2006 Chris Lumens <clumens@redhat.com> 0.28-1
142 - Support --mtu for the network command (#191328).
143 - Accept --isUtc for backwards compatibility.
145 * Wed May 04 2006 Chris Lumens <clumens@redhat.com> 0.27-1
146 - Output formatting fixes.
147 - Added commands for managing users and services.
149 * Mon Apr 17 2006 Chris Lumens <clumens@redhat.com> 0.26-1
150 - Ignore spaces before group names (#188095).
151 - Added some translations.
152 - Add options for repo command.
153 - Reorder %%packages section output.
154 - Output %%packages header options.
155 - Initialize RAID and volume group members to empty lists.
157 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.25-1
158 - Add support for the logging command.
160 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.24-1
161 - Don't write out a blank xconfig line.
162 - Reorder output handlers to group like commands together.
163 - Mark strings for translation.
165 * Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 0.23-1
166 - Backwards compatibility support for options to zerombr.
168 * Fri Feb 24 2006 Chris Lumens <clumens@redhat.com> 0.22-1
169 - Get ignoredisk working again (#182934).
171 * Fri Feb 17 2006 Chris Lumens <clumens@redhat.com> 0.21-1
172 - Provide an option to not traceback on missing include files (#181760).
173 - Update programming documentation.
175 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.20-1
176 - Correctly set --noformat and --useexisting on lvm and raid.
178 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.19-1
179 - --onboot requires a value (#180987).
180 - Be more strict about commands that don't take arguments.
182 * Thu Feb 09 2006 Chris Lumens <clumens@redhat.com> 0.18-1
183 - Fix some errors pychecker caught.
184 - Allow exceptions to not be fatal so ksvalidator can spot more errors in
185 a single pass (#179894).
187 * Wed Feb 01 2006 Chris Lumens <clumens@redhat.com> 0.17-1
188 - Don't set a default port for vnc.
190 * Tue Jan 31 2006 Chris Lumens <clumens@redhat.com> 0.16-1
191 - Give dmraid string an initial value.
192 - Handle None on partition size.
194 * Tue Jan 31 2006 Peter Jones <pjones@redhat.com> 0.15-1
195 - Add dmraid support
197 * Mon Jan 30 2006 Chris Lumens <clumens@redhat.com> 0.14-1
198 - Fix VNC parameter parsing (#179209).
199 - Deprecate --connect. Add --host and --port instead.
201 * Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 0.13-1
202 - Recognize the --eject parameter to shutdown/halt.
203 - Store the exact post-installation action in ksdata.
205 * Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 0.12-1
206 - Clean up output quoting.
207 - Finish removing monitor-related stuff from xconfig.
209 * Mon Dec 12 2005 Chris Lumens <clumens@redhat.com> 0.11-1
210 - Deprecate monitor-related options to xconfig.
212 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
213 - Support --bytes-per-inode on raid
214 (Curtis Doty <Curtis at GreenKey.net> #175288).
216 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
217 - fixup network --onboot
219 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
220 - Default to SELINUX_ENFORCING.
221 - Default partition sizes to None for anaconda (#172378).
222 - Don't call shlex.split on anything inside a script (#172313).
224 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
225 - Fix clearpart --all.
226 - vnc command does not require --connect option (#172192).
227 - network --onboot does not take any option.
228 - Remove extra spaces from firewall --ports and --trust.
229 - Write out network --<service> options.
231 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
232 - Add --resolvedeps and --ignoredeps as deprecated options.
233 - Pass line number to header functions.
235 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
236 - Add line numbers to exception reporting.
237 - Added ksvalidator.
239 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
240 - Correct deprecated attribute on options.
241 - Added programming documentation.
243 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
244 - Correct python lib directory on 64-bit archs (#170621).
246 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
247 - Add a deprecated attribute to options.
248 - Add --card option back to xconfig and mark as deprecated.
249 - Throw a deprecation warning on mouse and langsupport commands.
250 - Rename Writer to KickstartWriter for consistency.
251 - Collapse scripts into a single list and add an attribute on Script to
252 differentiate.
254 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
255 - Rename module to pykickstart to avoid conflicts in anaconda.
256 - Rename data classes for consistency.
257 - Add default bytesPerInode settings.
259 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
260 - Created package from anaconda.