1 %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library
for manipulating kickstart files
5 Url
: http
://fedoraproject.org
/wiki
/pykickstart
8 # This is a Red Hat maintained package which is specific to
9 # our distribution. Thus the source is only available from
11 Source0: %{name}-%{version}.tar.gz
14 Group: System Environment
/Libraries
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n
)
17 BuildRequires
: python
-devel
, gettext
, python
-setuptools
-devel
18 Requires: python
, python
-urlgrabber
21 The pykickstart package is a python library
for manipulating kickstart
32 make DESTDIR
=%{buildroot} install
38 %files -f
%{name}.lang
39 %defattr(-,root
,root
,-)
40 %doc README ChangeLog COPYING docs
/programmers
-guide
41 %doc docs
/kickstart
-docs.txt
43 %{_bindir}/ksvalidator
48 * Wed Mar
31 2010 Chris Lumens
<clumens@redhat.com
> - 1.70-1
49 - Add support
for RAID4
(#578514). (clumens)
50 - Escape percent signs
in the changelog.
(clumens
)
52 * Wed Mar
10 2010 Chris Lumens
<clumens@redhat.com
> - 1.69-1
53 - Add driverdisk
--biospart
= (#570437). (clumens)
54 - Fix IOError catching
in ksflatten
(jgregusk
, #558650).
56 * Thu Jan
14 2010 Chris Lumens
<clumens@redhat.com
> - 1.68-1
57 - Support removing groups that were included by a glob
(#554717). (clumens)
58 - Make sure that everything
in version.versionMap has a handler.
(clumens
)
59 - Add support
for RHEL6
(#552230). (clumens)
60 - Don't consider RHEL versions as developmental even
if they're latest.
(clumens
)
61 - Add lineno to BaseData and derived classes
(version
2) (hdegoede
)
62 - Give the non mandatory iscsi
--port argument a sane default
(hdegoede
)
63 - Change python_sitelib macro to use %
%global for new rpm
(hdegoede
)
64 - Fix typo
in iscsi parsing error message
(hdegoede
)
66 * Thu Dec
03 2009 Chris Lumens
<clumens@redhat.com
> - 1.67-1
67 - Don't use action
="append_const"
in firewall.py.
68 - Make "
make archive" depend on
test and check passing again.
69 - versionToString now works
in all cases we
test for.
70 - Fix the few pychecker errors outstanding
in options.py.
71 - Fix
make docs to
make docs dir before trying to download files there
(hdegoede
)
73 * Wed Nov
25 2009 Hans de Goede
<hdgoede@redhat.com
> - 1.66-1
74 - Add
--dcb option to fcoe
command (#513011)
75 - Remove rhpl from tests
76 - Port bootloader
--hvargs option added
in rhel5
77 - Ignore comments when looking
for %
%ksappend lines
(#525676)
78 - Use python
2.x exception syntax
80 * Thu Nov
12 2009 Chris Lumens
<clumens@redhat.com
> - 1.65-1
81 - Add additional arguments to BaseHandler.__init__
for better map control.
82 - Return the KickstartCommand
/KickstartData object from dispatcher.
83 - Add an "sshpw"
command for changing the passwords
in anaconda's env.
84 - Add
--proxy support to the url and repo commands.
85 - Add support
for F13. Is it really that
time already?
87 * Wed Sep
30 2009 Chris Lumens
<clumens@redhat.com
> - 1.64-1
88 - Update the zfcp
command for F12
(#526360).
89 - Move "
make" to %
%build (#524215).
91 * Wed Sep
16 2009 Chris Lumens
<clumens@redhat.com
> - 1.63-1
92 - Add encryption key escrow support
(mitr
, #508963).
93 - Fix the repo
test cases to expect quotes around the repo's name.
95 * Thu Sep
10 2009 Chris Lumens
<clumens@redhat.com
> - 1.62-1
96 - Support translated
help text
in optparse
(#479519).
97 - If the input kickstart file cannot be
read, raise IOError
(#519477).
99 * Thu Aug
27 2009 Chris Lumens
<clumens@redhat.com
> - 1.61-1
100 - Include the error messages from URLGrabError
in the exception
(#518443).
102 * Tue Aug
11 2009 Chris Lumens
<clumens@redhat.com
> - 1.60-1
103 - Put quotes around the repo's name
(Marc.Herbert@gmail.com
).
104 - Make duplicate entries warnings
, not errors
(#516338).
106 * Tue Jul
28 2009 Chris Lumens
<clumens@redhat.com
> - 1.59-1
107 - Handle a few more places where a urlgrabber error could happen
(#512951).
108 - Error out
if the same partition
/repo
/network is defined twice
(#512956).
109 - Call parent class tests first.
(jlaska
)
110 - Add KSOptionParser to FC3 upgrade
command.
(jlaska
)
111 - Correct missing
return stmt
in _getArgsAsStr
() (jlaska
)
113 * Fri Jul
17 2009 Chris Lumens
<clumens@redhat.com
> - 1.58-1
114 - Adjust writePriority to fix lvm
-on
-raid0
test cases
(jlaska
).
115 - Add F12 to the version number tests.
(clumens
)
116 - F12_User
test case.
(dcantrell
)
117 - Add
--gecos argument to the 'user'
command (dcantrell
)
118 - Convert user.py to use _getArgsAsStr
() (dcantrell
)
120 * Fri Jul
10 2009 Chris Lumens
<clumens@redhat.com
> - 1.57-1
121 - Another patch to
make the bootloader
test work
(jlaska
).
123 * Thu Jul
09 2009 Chris Lumens
<clumens@redhat.com
> - 1.56-1
124 - Make sure to import the gettext stuff
in fcoe.
(clumens
)
125 - Correctly deprecate bootloader
--lba32
(jlaska
).
126 - pykickstart
: fix zfcp
command writepriority
(hdegoede
)
127 - pykickstart
: Add fcoe
command (take
2) (hdegoede
)
128 - Add a
test case for RAID
(jlaska
).
130 * Thu Jul
02 2009 Chris Lumens
<clumens@redhat.com
> - 1.55-1
131 - Add support
for the group
command to F12
(#509119).
132 - RHEL5 now supports RAID
10.
133 - The f12 hander class should be called F12Handler.
(jgranado
)
134 - Remove bootloader
--lba32.
135 - Add a new version of the driverdisk
command without
--type=.
136 - Add initial support
for F12.
137 - Fetch the programmers
-guide from the wiki now.
139 * Mon May
18 2009 Chris Lumens
<clumens@redhat.com
> - 1.54-1
140 - Make sure the F11 handler gets used
for "partition" and "part"
(#501020).
142 * Wed Apr
29 2009 Chris Lumens
<clumens@redhat.com
> - 1.53-1
143 - Move lineno
= from KSOptionParser.__init__ to parse_args
(#497149). (clumens)
144 - Use the F11 version of the partition
command.
(clumens
)
145 - Remove the
--start and
--end options since anaconda no longer uses them.
(clumens
)
146 - Remove a broken
test case.
(clumens
)
148 * Wed Feb
18 2009 Chris Lumens
<clumens@redhat.com
> - 1.52-1
149 - Add lots more
test cases
(alindebe
, mgracik
, stickster
).
150 - Add a skip attribute on key to shut up pychecker.
151 - Only show autostep
command when requested
(jlaska
)
152 - Strip spaces from service names
, and require an option to be provided.
153 - Surround services lists
in double quotes.
154 - Remove the extra space from the services __str__ method.
155 - Fix output formatting bugs
in firewall
, partition
, and repo
(mgracik
).
156 - Specifying both or neither of
--drives and
--only
-use should be an error.
157 - Corrected newline char
in return value of FC6_Method.
(mgracik
)
158 - Make
--drives a required option
for FC3
, and catch no args on F8.
159 - Fix final printing of the rescue
command (mgracik
).
160 - Surround output strings
in double quotes.
161 - Fix a typo
in the deviceprobe
command.
162 - Revert the more strict option processing on displaymode.
163 - Properly handle erroring on extra args
, not just extra options.
164 - Don't use the logging class since it interferes with the logging
test.
165 - port without host should raise KickstartParseError
, not kickstartValueError.
166 - Add the
--key option to option processing
, since it's a valid argument.
167 - Fix
test cases that were failing due to the new use of KSOptionParser.
168 - Teach driverdisk.py
command to reject extra partitions
(stickster
).
169 - Add KSOptionParser to all commands ... enables more strick option checking
(jlaska
).
170 - Use KSOptionParser so we can catch bad
command options
(jlaska
).
172 * Thu Jan
29 2009 Chris Lumens
<clumens@redhat.com
> - 1.51-1
173 - Make a couple changes to how the logging
command is handled.
174 - Add a lot of
test cases
(clumens
, alindebe
, jlaska
, fcami
, adamwill
, pfrields
).
175 - Fix output formatting
for the rootpw
command.
176 - For commands that take exactly one argument
, check and error correctly.
177 - Surround module options
in quotes on the output side
(jlaska
).
178 - Set module opts
in the FC3 handler correctly.
179 - Fix newlines on the device
command output
(jlaska
).
180 - If
--autoscreenshot is not specified
, still output "autostep".
181 - Move the currentCmd and currentLine into getParser
().
(jlaska
)
182 - Write out an selinux line
if set to disabled
, but not
if None.
183 - F9_LogVolData should inherit from FC4_LogVolData
, not FC3_LogVolData
(jlaska
).
184 - Add unittest framework along with logvol and vnc unittests.
(jlaska
)
185 - Don't
set the KSOption.required attribute
in the constructor
(jlaska
).
187 * Sat Jan
10 2009 Chris Lumens
<clumens@redhat.com
> - 1.50-1
188 - Add a script to diff two versions of kickstart syntax.
189 - Add an option to ksvalidator to list all available syntax versions.
190 - Remove a couple extra newlines
in output formatting.
191 - Add documentation
for the new %
%include representation.
192 - Add support
%include to the pykickstart data objects.
194 * Thu Jan
08 2009 Chris Lumens
<clumens@redhat.com
> - 1.49-1
195 - Add upgrade
--root
-device
(atodorov
, #471232).
196 - Use python's
builtin set rather than the Sets module
(#477836, dcantrell).
198 * Tue Dec
23 2008 Chris Lumens
<clumens@redhat.com
> - 1.48-1
199 - Allow ignoring group metadata from repos
, using a '
--ignoregroups'
201 - Add initial support
for F11.
202 - Specify the
command versions
in the handlers instead of making copies.
203 - Remove empty and pointless __init__ methods.
204 - Pass arguments to superclasses via
*args and
**kwargs
, all the way up.
205 - Add removedKeywords and removedAttrs lists on Commands and Data.
206 - Fix version regexes to handle double digits and minor releases
(jlaska
).
208 * Thu Oct
30 2008 Chris Lumens
<clumens@redhat.com
> - 1.47-1
209 - Fix enabling services we specify by specific options.
211 * Mon Oct
27 2008 Chris Lumens
<clumens@redhat.com
> - 1.46-1
212 - Add support
for firewall
--service
(#467005).
214 * Tue Oct
14 2008 Chris Lumens
<clumens@redhat.com
> - 1.45-1
215 - Lots of translation updates.
216 - Remove use of string.partition
for python2.4
(atodorov
).
218 * Mon Sep
22 2008 Chris Lumens
<clumens@redhat.com
> - 1.44-1
219 - Add support
for reverse CHAP to the kickstart iscsi
command (hans
)
222 * Wed Sep
03 2008 Chris Lumens
<clumens@redhat.com
> - 1.43-1
223 - Revert "Do not include passphrases
for encrypted block devices
in
224 anaconda
-ks.cfg."
(dlehman
)
225 - yum doesn't like when mirrorlist is "".
(clumens
)
227 * Mon Aug
11 2008 Chris Lumens
<clumens@redhat.com
> - 1.42-1
228 - Add rescue
command to pykickstart
(atodorov
)
229 - Sort %
%packages output
(katzj
)
230 - Fix a typo
(atodorov
).
232 * Fri Aug
01 2008 Chris Lumens
<clumens@redhat.com
> - 1.41-1
233 - RHEL5 supports ignoredisk
--only
-use now too.
(clumens
)
234 - Do not include passphrases
for encrypted block devices
in
235 anaconda
-ks.cfg.
(dlehman
)
236 - Fix F9
,F10
,RHEL5 "part" commands to use the same class as
237 "partition".
(dlehman
)
238 - Add an apply method
() for commands and implement
for lang
(katzj
)
240 * Tue Jul
15 2008 Chris Lumens
<clumens@redhat.com
> - 1.40-1
241 - RHEL5_LogVolData should inherit from FC4
, not FC3.
242 Also fix FC9
->F9 typo.
(dlehman
)
243 - Support creation of encrypted block devices
in RHEL5.
(#449830) (dlehman)
244 - Use the right LogVolData objects
for RHEL3 and
4 (jlaska
).
(clumens
)
245 - We no longer use rhpl
for translations.
(clumens
)
246 - All the base classes should derive from object.
(clumens
)
248 * Fri Jun
13 2008 Chris Lumens
<clumens@redhat.com
> - 1.39-1
249 - It's helpful to
return the parser object.
(clumens
)
251 * Tue Jun
10 2008 Chris Lumens
<clumens@redhat.com
> - 1.38-1
252 - Fix loading the Handler object by looking
for a more specific
253 name
(#450740). (clumens)
255 * Sun Jun
08 2008 Chris Lumens
<clumens@redhat.com
> - 1.37-1
256 - XConfig is still used by other projects
, so just deprecate some
259 * Thu May
29 2008 Chris Lumens
<clumens@redhat.com
> - 1.36-1
260 - It should be repo
--cost
, not repo
--priority.
(clumens
)
262 * Fri May
23 2008 Chris Lumens
<clumens@redhat.com
> - 1.35-1
263 - Bring driverdisk
command in line with the docs.
(clumens
)
264 - Change RAID
command print priorities
(jlaska
).
265 - According to docs
, physvols are space delimited.
(jlaska
)
266 - Don't write the label out twice
(jlaska
).
267 - Deprecate monitor and xconfig commands.
(clumens
)
269 * Wed May
07 2008 Chris Lumens
<clumens@redhat.com
> - 1.34-1
270 - Load the handler module automatically.
(clumens
)
271 - Add support
for F10.
(clumens
)
272 - Initialize cmd.handler earlier
; fixes repo.methodToRepo
() (markmc
)
273 - Don't shadow
builtin function names.
(clumens
)
274 - Running check is now required before pykickstart can be packaged.
(clumens
)
275 - Reorganize code a little bit to pass pychecker.
(clumens
)
277 * Tue Apr
08 2008 Chris Lumens
<clumens@redhat.com
> - 1.33-1
278 - Fix whitespace when printing out the bootloader
command (pmeyers
).
279 - Fix the
type on bootloader
--timeout processing.
(clumens
)
281 * Wed Apr
02 2008 Chris Lumens
<clumens@redhat.com
> - 1.32-1
282 - Make the string reader act like the file reader upon EOF.
(clumens
)
283 - Add syntax
for encrypted logical volumes.
(clumens
)
285 * Tue Mar
25 2008 Chris Lumens
<clumens@redhat.com
> - 1.31-1
286 - Support end
-of
-line comments.
(clumens
)
287 - Lots of translation updates.
289 * Tue Feb
26 2008 Chris Lumens
<clumens@redhat.com
> - 1.30-1
290 - Reverse writePriorities of iscsi and iscsname
(#434965, jlaska).
291 - Fix printing of iscsiname
command (#434945, jlaska).
292 - Don't traceback on ENOENT.
(pnasrat
)
293 - Store the mouse name as a string
, not a list.
(clumens
)
294 - Update translations.
296 * Wed Jan
30 2008 Chris Lumens
<clumens@redhat.com
> - 1.29-1
297 - Renamed bootproto
=ask to bootproto
=query
, add to RHEL5 as well.
(clumens
)
299 * Wed Jan
23 2008 Chris Lumens
<clumens@redhat.com
> - 1.28-1
300 - Fix traceback on volgroup
command.
(clumens
)
302 * Thu Jan
17 2008 Chris Lumens
<clumens@redhat.com
> - 1.27-1
303 - The bootprotoList needs to be defined before it's used.
(clumens
)
305 * Thu Jan
17 2008 Chris Lumens
<clumens@redhat.com
> - 1.26-1
306 - Add support
for network
--bootproto
=ask.
(clumens
)
308 * Tue Jan
15 2008 Chris Lumens
<clumens@redhat.com
> - 1.25-1
309 - Add the version to the output ks file.
(clumens
)
310 - Add syntax
for encrypted partitions and raid devices.
(clumens
)
312 * Thu Jan
10 2008 Chris Lumens
<clumens@redhat.com
> - 1.24-1
313 - Make inheritance and overriding of %
%packages work
(#427768). (clumens)
314 - Add an option
for which languages should be installed.
(katzj
)
315 - Use the right name
for the iscsi
--target variable
(#418781). (clumens)
317 * Mon Dec
10 2007 Chris Lumens
<clumens@redhat.com
> - 1.23-1
318 - Take Makefile improvements from anaconda.
319 - Fix a traceback on F9 zerombr
command (#395431).
320 - Update to handle new Python eggs packaging.
322 * Tue Nov
20 2007 Chris Lumens
<clumens@redhat.com
> 1.22-1
323 - Don't process or write out vnc
--enabled
(jlaska AT redhat DOT com
).
324 - Fix a traceback
in the clearpart
command.
326 * Tue Nov
06 2007 Chris Lumens
<clumens@redhat.com
> 1.21-1
327 - Save script line numbers
for debugging.
328 - More internal cleanups.
330 * Wed Oct
31 2007 Chris Lumens
<clumens@redhat.com
> 1.20-1
331 - Pull wiki docs from the new location.
332 - Fix error messages
for options that have been removed after having been
333 previously deprecated.
334 - zerombr no longer takes any arguments.
335 - %
%packages --ignoredeps
--resolvedeps have been removed.
336 - firewall
--high
--medium have been removed.
337 - vnc
--connect has been removed.
338 - xconfig options from monitor have now been removed.
339 - --bytes
-per
-inode has been marked as deprecated.
341 - Add
--fsprofile option to disk commands
(pjones
).
342 - Add F9 support
(pjones
).
343 - Lots of internal fixes
(clumens
, pjones
).
345 * Tue Oct
23 2007 Chris Lumens
<clumens@redhat.com
> 1.19-1
346 - Fix a traceback on the cdrom method.
348 * Thu Oct
18 2007 Chris Lumens
<clumens@redhat.com
> 1.18-1
349 - Don't write out %
%end to packages and scripts
if the syntax version doesn't
351 - Remove obsolete translation
(#332221).
353 * Thu Oct
04 2007 Chris Lumens
<clumens@redhat.com
> 1.17-1
354 - Simplify argument processing and printing.
356 * Wed Oct
03 2007 Chris Lumens
<clumens@redhat.com
> 1.16-1
357 - Undeprecate %
%packages --excludedocs.
358 - Fix a traceback
in the device
command handling.
359 - Add bootloader
--timeout
(katzj
).
361 * Tue Oct
02 2007 Chris Lumens
<clumens@redhat.com
> 1.15-1
362 - Update translations
(#259121).
363 - The device
command no longer takes a
type argument.
365 * Fri Sep
28 2007 Chris Lumens
<clumens@redhat.com
> 1.14-1
366 - Fix output formatting
for packages section header
(#310211).
367 - Add a script to flatten kickstart files containing includes
(katzj
).
369 * Wed Sep
12 2007 Chris Lumens
<clumens@redhat.com
> 1.13-1
370 - Add a
function to convert
URL method strings into repo objects
372 - Writer formatting fixes.
373 - Add kickstart documentation from the Fedora Wiki.
375 * Tue Sep
04 2007 Chris Lumens
<clumens@redhat.com
> 1.12-1
376 - Fix lots of problems
in processing the bootloader
, device
, network
, and
378 - Add %
%end when writing out scripts and packages.
379 - Add a makefile target to run pychecker to cut down on errors
in
382 * Mon Sep
3 2007 Jeremy Katz
<katzj@redhat.com
> - 1.11-1
383 - fix a few tracebacks
385 * Fri Aug
31 2007 Chris Lumens
<clumens@redhat.com
> 1.10-1
386 - Add network
--ipv6
=.
388 * Fri Aug
24 2007 Chris Lumens
<clumens@redhat.com
> 1.9-1
389 - Add support
for the %
%end directive to be placed at the end of scripts
390 and packages sections. Deprecate old syntax.
391 - Clean up after ksvalidator
if pykickstart issues a traceback.
392 - Add support
for repo
--priority
--includepkgs
--excludepkgs.
393 - Fix newline at end of reboot
--eject output
(#253562).
395 * Mon Aug
13 2007 Chris Lumens
<clumens@redhat.com
> 1.8-1
396 - Fix
type checking of string values.
398 * Thu Aug
09 2007 Chris Lumens
<clumens@redhat.com
> 1.7-1
399 - Clarify license
in spec file and all
source files.
400 - Check string values to options to
make sure they're not other options
403 * Thu Aug
02 2007 Chris Lumens
<clumens@redhat.com
> 1.6-1
404 - Fix a couple tracebacks
in ksvalidator.
405 - Change
--class to
--dhcpclass
(#248912).
407 * Thu Jul
19 2007 Chris Lumens
<clumens@redhat.com
> 1.5-2
408 - Require rhpl
(#248953).
410 * Tue Jul
17 2007 Chris Lumens
<clumens@redhat.com
> 1.5-1
411 - Fix traceback when calling preprocessKickstart.
413 * Tue Jul
17 2007 Chris Lumens
<clumens@redhat.com
> 1.4-1
414 - Add methods to handle the %
%ksappend directive.
415 - Fix ignoredisk
--disks.
417 * Wed Jul
11 2007 Chris Lumens
<clumens@redhat.com
> - 1.3-1
418 - Add support
for ignoredisk
--only
-use.
419 - Fix traceback
in raid
command printing method
(#246709).
421 * Fri Jun
08 2007 Chris Lumens
<clumens@redhat.com
> - 1.2-2
422 - Fix package review problems
(#226334).
424 * Mon Jun
04 2007 Chris Lumens
<clumens@redhat.com
> - 1.2-1
425 - Fix harddrive
install method error checking
(#232492).
426 - Set authentication information from the input line to preserve quoting
428 - Allow included files to be given by
URL.
429 - Fix typo
in user
--iscrypted option.
431 * Mon May
14 2007 Chris Lumens
<clumens@redhat.com
> - 1.1-1
432 - Better regexes
for splitting version strings into family and version.
433 - Add basic support
for RHEL3.
434 - Update translations.
436 * Fri Apr
13 2007 Chris Lumens
<clumens@redhat.com
> - 1.0-1
437 - Update documentation.
438 - Update translations.
440 * Mon Mar
19 2007 Chris Lumens
<clumens@redhat.com
> - 0.100-1
441 - bootloader should be written out after upgrade
/install.
442 - Treat class names as unicode strings
(#231053).
444 * Wed Mar
07 2007 Chris Lumens
<clumens@redhat.com
> - 0.99-1
445 - The timezone
command didn't recognize
--isUtc before FC6
(#231189).
446 - Recognize %
%ksappend lines
in ksvalidator.
447 - Don't
set default values
in some
command __init__ methods.
448 - Added an updates
command.
449 - Add support
for RAID10.
451 * Mon Feb
26 2007 Chris Lumens
<clumens@redhat.com
> - 0.98-1
452 - Fix device
command syntax to match anaconda.
453 - Fix __call__ on method
command.
455 * Wed Feb
21 2007 Chris Lumens
<clumens@redhat.com
> - 0.97-1
456 - Fix traceback when not overriding default mappings
(#229505).
458 * Tue Feb
20 2007 Chris Lumens
<clumens@redhat.com
> - 0.96-1
459 - Fix __str__ methods
for langsupport and reboot commands.
460 - Renamed BaseHandler.empty to BaseHandler.maskAllExcept.
461 - Split
command objects out into their own files
in commands
/.
462 - Rename
command objects to start with Version_.
463 - Support extended group selection syntax.
465 * Wed Feb
14 2007 Chris Lumens
<clumens@redhat.com
> - 0.95-1
466 - KickstartParser no longer takes a version argument.
467 - Be more lenient
in what strings stringToVersion accepts.
468 - Allow setting state on one data object from multiple files.
470 * Wed Feb
07 2007 Chris Lumens
<clumens@redhat.com
> - 0.94-1
471 - Add a newline to the end of the key
command output.
472 - Use network bootproto constants
(#197694).
473 - Fix tracebacks
in subclass __str__ methods
(#226734).
475 * Wed Jan
31 2007 Chris Lumens
<clumens@redhat.com
> - 0.93-2
476 - Make some minor spec file changes to get closer to the extras guidelines.
478 * Thu Jan
25 2007 Chris Lumens
<clumens@redhat.com
> - 0.93-1
479 - Add support
for FC3
, RHEL4
, and RHEL5.
480 - The key
command was not supported
until after FC6.
481 - Accept more strings
in stringToVersion.
483 * Fri Jan
19 2007 Chris Lumens
<clumens@redhat.com
> - 0.92-1
484 - Fix KickstartVersionError reporting.
485 - Add a version attribute to handler objects.
486 - Fix line number reporting on lots of commands.
487 - Add initial support
for Fedora
7 and remove deprecated commands.
488 - Accept a
--default argument to the %
%packages header
(#221305).
490 * Wed Jan
17 2007 Chris Lumens
<clumens@redhat.com
> - 0.91-1
491 - Add a method to
read kickstart files from strings.
493 * Tue Jan
16 2007 Chris Lumens
<clumens@redhat.com
> - 0.90-1
494 - Support multiple versions of kickstart syntax from one code base
496 - Fix inconsistency between Script parser and writer
(#222877).
498 * Fri Dec
15 2006 Chris Lumens
<clumens@redhat.com
> - 0.43-1
499 - Pull
in new translations
(#216620).
501 * Thu Dec
7 2006 Jeremy Katz
<katzj@redhat.com
> - 0.42-2
502 - rebuild against python
2.5
504 * Tue Dec
05 2006 Chris Lumens
<clumens@redhat.com
> - 0.42-1
505 - Fix traceback when writing out repo
command (#218274).
507 * Fri Dec
01 2006 Chris Lumens
<clumens@redhat.com
> - 0.41-1
508 - Fix traceback when using deprecated commands
(#218047, #218059).
510 * Thu Nov
30 2006 Chris Lumens
<clumens@redhat.com
> - 0.40-1
511 - Pull
in new translations
(#216620).
512 - Add
--level argument to logging
command writer.
514 * Tue Oct
24 2006 Chris Lumens
<clumens@redhat.com
> - 0.39-2
515 - Fix release number.
517 * Tue Oct
24 2006 Chris Lumens
<clumens@redhat.com
> - 0.39-1
518 - Add writer
for --key
(#211997).
520 * Tue Oct
17 2006 Jeremy Katz
<katzj@redhat.com
> - 0.38-1
521 - allow
--skip
for installation number as well
(#207029)
523 * Mon Oct
16 2006 Jeremy Katz
<katzj@redhat.com
> - 0.37-1
524 - support
for installation numbers
(#207029)
526 * Fri Oct
13 2006 Bill Nottingham
<notting@redhat.com
> - 0.36-1
527 - use valid charsets
in translations
(#210720)
529 * Fri Sep
29 2006 Chris Lumens
<clumens@redhat.com
> - 0.35-1
530 - Fix traceback
in harddrive
command (#208557).
532 * Mon Sep
25 2006 Chris Lumens
<clumens@redhat.com
> - 0.34-1
533 - Add support
for --biospart option to harddrive
(#207585).
534 - Update writer
for syntax changes.
536 * Wed Sep
20 2006 Jeremy Katz
<katzj@redhat.com
> - 0.33-1
537 - improved iscsi syntax
538 - allow multiple zfcp devs
540 * Thu Jul
20 2006 Chris Lumens
<clumens@redhat.com
> 0.32-1
541 - Limit
--bootproto to what anaconda supports.
542 - Add
--noipv4 and
--noipv6 network options.
544 * Tue Jun
20 2006 Chris Lumens
<clumens@redhat.com
> 0.31-1
545 - Handle nfs
--opts
(katzj
).
546 - RAID devices should be integers instead of strings
(#176537).
547 - Add initial support
for iscsi
(katzj
).
549 * Tue Jun
06 2006 Chris Lumens
<clumens@redhat.com
> 0.30-2
550 - Add BuildRequires to fix building under mock
(#194156, Joost Soeterbroek
551 <fedora AT soeterbroek.com
>).
553 * Thu May
25 2006 Chris Lumens
<clumens@redhat.com
> 0.30-1
554 - Change order of LVM
-related writing functions
(#193073).
555 - Require urlgrabber.
556 - Return a more useful error message on unknown commands.
557 - Fix logvol writing typo.
558 - Make ksvalidator validate from a
URL in addition to a file.
559 - Don't write out an empty packages section
(#192851).
561 * Tue May
23 2006 Chris Lumens
<clumens@redhat.com
> 0.29-1
562 - Add multipath
command, handlers
, and data objects
(pjones
).
563 - Rename
--ports to
--port
in writer.
565 * Mon May
15 2006 Chris Lumens
<clumens@redhat.com
> 0.28-1
566 - Support
--mtu
for the network
command (#191328).
567 - Accept
--isUtc
for backwards compatibility.
569 * Wed May
04 2006 Chris Lumens
<clumens@redhat.com
> 0.27-1
570 - Output formatting fixes.
571 - Added commands
for managing users and services.
573 * Mon Apr
17 2006 Chris Lumens
<clumens@redhat.com
> 0.26-1
574 - Ignore spaces before group names
(#188095).
575 - Added some translations.
576 - Add options
for repo
command.
577 - Reorder %
%packages section output.
578 - Output %
%packages header options.
579 - Initialize RAID and volume group members to empty lists.
581 * Mon Mar
27 2006 Chris Lumens
<clumens@redhat.com
> 0.25-1
582 - Add support
for the logging
command.
584 * Mon Mar
27 2006 Chris Lumens
<clumens@redhat.com
> 0.24-1
585 - Don't write out a blank xconfig line.
586 - Reorder output handlers to group like commands together.
587 - Mark strings
for translation.
589 * Tue Mar
07 2006 Chris Lumens
<clumens@redhat.com
> 0.23-1
590 - Backwards compatibility support
for options to zerombr.
592 * Fri Feb
24 2006 Chris Lumens
<clumens@redhat.com
> 0.22-1
593 - Get ignoredisk working again
(#182934).
595 * Fri Feb
17 2006 Chris Lumens
<clumens@redhat.com
> 0.21-1
596 - Provide an option to not traceback on missing include files
(#181760).
597 - Update programming documentation.
599 * Mon Feb
13 2006 Chris Lumens
<clumens@redhat.com
> 0.20-1
600 - Correctly
set --noformat and
--useexisting on lvm and raid.
602 * Mon Feb
13 2006 Chris Lumens
<clumens@redhat.com
> 0.19-1
603 - --onboot requires a value
(#180987).
604 - Be more strict about commands that don't take arguments.
606 * Thu Feb
09 2006 Chris Lumens
<clumens@redhat.com
> 0.18-1
607 - Fix some errors pychecker caught.
608 - Allow exceptions to not be fatal so ksvalidator can spot more errors
in
609 a single pass
(#179894).
611 * Wed Feb
01 2006 Chris Lumens
<clumens@redhat.com
> 0.17-1
612 - Don't
set a default port
for vnc.
614 * Tue Jan
31 2006 Chris Lumens
<clumens@redhat.com
> 0.16-1
615 - Give dmraid string an initial value.
616 - Handle None on partition size.
618 * Tue Jan
31 2006 Peter Jones
<pjones@redhat.com
> 0.15-1
621 * Mon Jan
30 2006 Chris Lumens
<clumens@redhat.com
> 0.14-1
622 - Fix VNC parameter parsing
(#179209).
623 - Deprecate
--connect. Add
--host and
--port instead.
625 * Thu Jan
19 2006 Chris Lumens
<clumens@redhat.com
> 0.13-1
626 - Recognize the
--eject parameter to shutdown
/halt.
627 - Store the exact post
-installation action
in ksdata.
629 * Mon Jan
09 2006 Chris Lumens
<clumens@redhat.com
> 0.12-1
630 - Clean up output quoting.
631 - Finish removing monitor
-related stuff from xconfig.
633 * Mon Dec
12 2005 Chris Lumens
<clumens@redhat.com
> 0.11-1
634 - Deprecate monitor
-related options to xconfig.
636 * Thu Dec
08 2005 Chris Lumens
<clumens@redhat.com
> 0.10-1
637 - Support
--bytes
-per
-inode on raid
638 (Curtis Doty
<Curtis at GreenKey.net
> #175288).
640 * Wed Nov
16 2005 Jeremy Katz
<katzj@redhat.com
> - 0.9-1
641 - fixup network
--onboot
643 * Thu Nov
03 2005 Chris Lumens
<clumens@redhat.com
> 0.8-1
644 - Default to SELINUX_ENFORCING.
645 - Default partition sizes to None
for anaconda
(#172378).
646 - Don't call shlex.split on anything inside a script
(#172313).
648 * Tue Nov
01 2005 Chris Lumens
<clumens@redhat.com
> 0.7-1
649 - Fix clearpart
--all.
650 - vnc
command does not require
--connect option
(#172192).
651 - network
--onboot does not take any option.
652 - Remove extra spaces from firewall
--ports and
--trust.
653 - Write out network
--<service
> options.
655 * Fri Oct
28 2005 Chris Lumens
<clumens@redhat.com
> 0.6-1
656 - Add
--resolvedeps and
--ignoredeps as deprecated options.
657 - Pass line number to header functions.
659 * Mon Oct
24 2005 Chris Lumens
<clumens@redhat.com
> 0.5-1
660 - Add line numbers to exception reporting.
663 * Wed Oct
19 2005 Chris Lumens
<clumens@redhat.com
> 0.4-1
664 - Correct deprecated attribute on options.
665 - Added programming documentation.
667 * Thu Oct
13 2005 Chris Lumens
<clumens@redhat.com
> 0.3-2
668 - Correct python lib directory on
64-bit archs
(#170621).
670 * Fri Oct
07 2005 Chris Lumens
<clumens@redhat.com
> 0.3-1
671 - Add a deprecated attribute to options.
672 - Add
--card option back to xconfig and mark as deprecated.
673 - Throw a deprecation warning on mouse and langsupport commands.
674 - Rename Writer to KickstartWriter
for consistency.
675 - Collapse scripts into a single list and add an attribute on Script to
678 * Wed Oct
05 2005 Chris Lumens
<clumens@redhat.com
> 0.2-1
679 - Rename module to pykickstart to avoid conflicts
in anaconda.
680 - Rename data classes
for consistency.
681 - Add default bytesPerInode settings.
683 * Wed Oct
05 2005 Chris Lumens
<clumens@redhat.com
> 0.1-1
684 - Created package from anaconda.