New version.
[pykickstart.git] / pykickstart.spec
blobea155242cdba99c00b775a87a49b7a2f059ac57a
1 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Url: http://fedoraproject.org/wiki/pykickstart
6 Version: 1.4
7 Release: 1%{?dist}
8 # This is a Red Hat maintained package which is specific to
9 # our distribution. Thus the source is only available from
10 # within this srpm.
11 Source0: %{name}-%{version}.tar.gz
13 License: GPL
14 Group: System Environment/Libraries
15 BuildArch: noarch
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17 BuildRequires: python-devel, gettext
18 Requires: python, python-urlgrabber
20 %description
21 The pykickstart package is a python library for manipulating kickstart
22 files.
24 %prep
25 %setup -q
26 make
28 %build
30 %install
31 rm -rf %{buildroot}
32 make DESTDIR=%{buildroot} install
33 %find_lang %{name}
35 %clean
36 rm -rf %{buildroot}
38 %files -f %{name}.lang
39 %defattr(-,root,root,-)
40 %doc README ChangeLog COPYING docs/programmers-guide
41 %{python_sitelib}/pykickstart
42 %{_bindir}/ksvalidator
44 %changelog
45 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.4-1
46 - Add methods to handle the %ksappend directive.
47 - Fix ignoredisk --disks.
49 * Wed Jul 11 2007 Chris Lumens <clumens@redhat.com> - 1.3-1
50 - Add support for ignoredisk --only-use.
51 - Fix traceback in raid command printing method (#246709).
53 * Fri Jun 08 2007 Chris Lumens <clumens@redhat.com> - 1.2-2
54 - Fix package review problems (#226334).
56 * Mon Jun 04 2007 Chris Lumens <clumens@redhat.com> - 1.2-1
57 - Fix harddrive install method error checking (#232492).
58 - Set authentication information from the input line to preserve quoting
59 (#241657).
60 - Allow included files to be given by URL.
61 - Fix typo in user --iscrypted option.
63 * Mon May 14 2007 Chris Lumens <clumens@redhat.com> - 1.1-1
64 - Better regexes for splitting version strings into family and version.
65 - Add basic support for RHEL3.
66 - Update translations.
68 * Fri Apr 13 2007 Chris Lumens <clumens@redhat.com> - 1.0-1
69 - Update documentation.
70 - Update translations.
72 * Mon Mar 19 2007 Chris Lumens <clumens@redhat.com> - 0.100-1
73 - bootloader should be written out after upgrade/install.
74 - Treat class names as unicode strings (#231053).
76 * Wed Mar 07 2007 Chris Lumens <clumens@redhat.com> - 0.99-1
77 - The timezone command didn't recognize --isUtc before FC6 (#231189).
78 - Recognize %ksappend lines in ksvalidator.
79 - Don't set default values in some command __init__ methods.
80 - Added an updates command.
81 - Add support for RAID10.
83 * Mon Feb 26 2007 Chris Lumens <clumens@redhat.com> - 0.98-1
84 - Fix device command syntax to match anaconda.
85 - Fix __call__ on method command.
87 * Wed Feb 21 2007 Chris Lumens <clumens@redhat.com> - 0.97-1
88 - Fix traceback when not overriding default mappings (#229505).
90 * Tue Feb 20 2007 Chris Lumens <clumens@redhat.com> - 0.96-1
91 - Fix __str__ methods for langsupport and reboot commands.
92 - Renamed BaseHandler.empty to BaseHandler.maskAllExcept.
93 - Split command objects out into their own files in commands/.
94 - Rename command objects to start with Version_.
95 - Support extended group selection syntax.
97 * Wed Feb 14 2007 Chris Lumens <clumens@redhat.com> - 0.95-1
98 - KickstartParser no longer takes a version argument.
99 - Be more lenient in what strings stringToVersion accepts.
100 - Allow setting state on one data object from multiple files.
102 * Wed Feb 07 2007 Chris Lumens <clumens@redhat.com> - 0.94-1
103 - Add a newline to the end of the key command output.
104 - Use network bootproto constants (#197694).
105 - Fix tracebacks in subclass __str__ methods (#226734).
107 * Wed Jan 31 2007 Chris Lumens <clumens@redhat.com> - 0.93-2
108 - Make some minor spec file changes to get closer to the extras guidelines.
110 * Thu Jan 25 2007 Chris Lumens <clumens@redhat.com> - 0.93-1
111 - Add support for FC3, RHEL4, and RHEL5.
112 - The key command was not supported until after FC6.
113 - Accept more strings in stringToVersion.
115 * Fri Jan 19 2007 Chris Lumens <clumens@redhat.com> - 0.92-1
116 - Fix KickstartVersionError reporting.
117 - Add a version attribute to handler objects.
118 - Fix line number reporting on lots of commands.
119 - Add initial support for Fedora 7 and remove deprecated commands.
120 - Accept a --default argument to the %%packages header (#221305).
122 * Wed Jan 17 2007 Chris Lumens <clumens@redhat.com> - 0.91-1
123 - Add a method to read kickstart files from strings.
125 * Tue Jan 16 2007 Chris Lumens <clumens@redhat.com> - 0.90-1
126 - Support multiple versions of kickstart syntax from one code base
127 (#189348).
128 - Fix inconsistency between Script parser and writer (#222877).
130 * Fri Dec 15 2006 Chris Lumens <clumens@redhat.com> - 0.43-1
131 - Pull in new translations (#216620).
133 * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.42-2
134 - rebuild against python 2.5
136 * Tue Dec 05 2006 Chris Lumens <clumens@redhat.com> - 0.42-1
137 - Fix traceback when writing out repo command (#218274).
139 * Fri Dec 01 2006 Chris Lumens <clumens@redhat.com> - 0.41-1
140 - Fix traceback when using deprecated commands (#218047, #218059).
142 * Thu Nov 30 2006 Chris Lumens <clumens@redhat.com> - 0.40-1
143 - Pull in new translations (#216620).
144 - Add --level argument to logging command writer.
146 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-2
147 - Fix release number.
149 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-1
150 - Add writer for --key (#211997).
152 * Tue Oct 17 2006 Jeremy Katz <katzj@redhat.com> - 0.38-1
153 - allow --skip for installation number as well (#207029)
155 * Mon Oct 16 2006 Jeremy Katz <katzj@redhat.com> - 0.37-1
156 - support for installation numbers (#207029)
158 * Fri Oct 13 2006 Bill Nottingham <notting@redhat.com> - 0.36-1
159 - use valid charsets in translations (#210720)
161 * Fri Sep 29 2006 Chris Lumens <clumens@redhat.com> - 0.35-1
162 - Fix traceback in harddrive command (#208557).
164 * Mon Sep 25 2006 Chris Lumens <clumens@redhat.com> - 0.34-1
165 - Add support for --biospart option to harddrive (#207585).
166 - Update writer for syntax changes.
168 * Wed Sep 20 2006 Jeremy Katz <katzj@redhat.com> - 0.33-1
169 - improved iscsi syntax
170 - allow multiple zfcp devs
172 * Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 0.32-1
173 - Limit --bootproto to what anaconda supports.
174 - Add --noipv4 and --noipv6 network options.
176 * Tue Jun 20 2006 Chris Lumens <clumens@redhat.com> 0.31-1
177 - Handle nfs --opts (katzj).
178 - RAID devices should be integers instead of strings (#176537).
179 - Add initial support for iscsi (katzj).
181 * Tue Jun 06 2006 Chris Lumens <clumens@redhat.com> 0.30-2
182 - Add BuildRequires to fix building under mock (#194156, Joost Soeterbroek
183 <fedora AT soeterbroek.com>).
185 * Thu May 25 2006 Chris Lumens <clumens@redhat.com> 0.30-1
186 - Change order of LVM-related writing functions (#193073).
187 - Require urlgrabber.
188 - Return a more useful error message on unknown commands.
189 - Fix logvol writing typo.
190 - Make ksvalidator validate from a URL in addition to a file.
191 - Don't write out an empty packages section (#192851).
193 * Tue May 23 2006 Chris Lumens <clumens@redhat.com> 0.29-1
194 - Add multipath command, handlers, and data objects (pjones).
195 - Rename --ports to --port in writer.
197 * Mon May 15 2006 Chris Lumens <clumens@redhat.com> 0.28-1
198 - Support --mtu for the network command (#191328).
199 - Accept --isUtc for backwards compatibility.
201 * Wed May 04 2006 Chris Lumens <clumens@redhat.com> 0.27-1
202 - Output formatting fixes.
203 - Added commands for managing users and services.
205 * Mon Apr 17 2006 Chris Lumens <clumens@redhat.com> 0.26-1
206 - Ignore spaces before group names (#188095).
207 - Added some translations.
208 - Add options for repo command.
209 - Reorder %%packages section output.
210 - Output %%packages header options.
211 - Initialize RAID and volume group members to empty lists.
213 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.25-1
214 - Add support for the logging command.
216 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.24-1
217 - Don't write out a blank xconfig line.
218 - Reorder output handlers to group like commands together.
219 - Mark strings for translation.
221 * Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 0.23-1
222 - Backwards compatibility support for options to zerombr.
224 * Fri Feb 24 2006 Chris Lumens <clumens@redhat.com> 0.22-1
225 - Get ignoredisk working again (#182934).
227 * Fri Feb 17 2006 Chris Lumens <clumens@redhat.com> 0.21-1
228 - Provide an option to not traceback on missing include files (#181760).
229 - Update programming documentation.
231 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.20-1
232 - Correctly set --noformat and --useexisting on lvm and raid.
234 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.19-1
235 - --onboot requires a value (#180987).
236 - Be more strict about commands that don't take arguments.
238 * Thu Feb 09 2006 Chris Lumens <clumens@redhat.com> 0.18-1
239 - Fix some errors pychecker caught.
240 - Allow exceptions to not be fatal so ksvalidator can spot more errors in
241 a single pass (#179894).
243 * Wed Feb 01 2006 Chris Lumens <clumens@redhat.com> 0.17-1
244 - Don't set a default port for vnc.
246 * Tue Jan 31 2006 Chris Lumens <clumens@redhat.com> 0.16-1
247 - Give dmraid string an initial value.
248 - Handle None on partition size.
250 * Tue Jan 31 2006 Peter Jones <pjones@redhat.com> 0.15-1
251 - Add dmraid support
253 * Mon Jan 30 2006 Chris Lumens <clumens@redhat.com> 0.14-1
254 - Fix VNC parameter parsing (#179209).
255 - Deprecate --connect. Add --host and --port instead.
257 * Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 0.13-1
258 - Recognize the --eject parameter to shutdown/halt.
259 - Store the exact post-installation action in ksdata.
261 * Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 0.12-1
262 - Clean up output quoting.
263 - Finish removing monitor-related stuff from xconfig.
265 * Mon Dec 12 2005 Chris Lumens <clumens@redhat.com> 0.11-1
266 - Deprecate monitor-related options to xconfig.
268 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
269 - Support --bytes-per-inode on raid
270 (Curtis Doty <Curtis at GreenKey.net> #175288).
272 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
273 - fixup network --onboot
275 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
276 - Default to SELINUX_ENFORCING.
277 - Default partition sizes to None for anaconda (#172378).
278 - Don't call shlex.split on anything inside a script (#172313).
280 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
281 - Fix clearpart --all.
282 - vnc command does not require --connect option (#172192).
283 - network --onboot does not take any option.
284 - Remove extra spaces from firewall --ports and --trust.
285 - Write out network --<service> options.
287 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
288 - Add --resolvedeps and --ignoredeps as deprecated options.
289 - Pass line number to header functions.
291 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
292 - Add line numbers to exception reporting.
293 - Added ksvalidator.
295 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
296 - Correct deprecated attribute on options.
297 - Added programming documentation.
299 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
300 - Correct python lib directory on 64-bit archs (#170621).
302 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
303 - Add a deprecated attribute to options.
304 - Add --card option back to xconfig and mark as deprecated.
305 - Throw a deprecation warning on mouse and langsupport commands.
306 - Rename Writer to KickstartWriter for consistency.
307 - Collapse scripts into a single list and add an attribute on Script to
308 differentiate.
310 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
311 - Rename module to pykickstart to avoid conflicts in anaconda.
312 - Rename data classes for consistency.
313 - Add default bytesPerInode settings.
315 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
316 - Created package from anaconda.