Allow processing multiple kickstart files with the same handler object for
[pykickstart.git] / pykickstart.spec
blob29c3d5549ea9119ce2b16d20103f8e84ffcdb740
1 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Url: http://fedoraproject.org/wiki/pykickstart
6 Version: 0.94
7 Release: 1%{?dist}
8 Source0: %{name}-%{version}.tar.gz
9 License: GPL
10 Group: System Environment/Libraries
11 BuildArch: noarch
12 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13 BuildRequires: python-devel, gettext
14 Requires: python, python-urlgrabber
16 %description
17 The pykickstart package is a python library for manipulating kickstart
18 files.
20 %prep
21 %setup -q
22 make
24 %build
26 %install
27 rm -rf %{buildroot}
28 make DESTDIR=%{buildroot} install
29 %find_lang %{name}
31 %clean
32 rm -rf %{buildroot}
34 %files -f %{name}.lang
35 %defattr(-,root,root,-)
36 %doc README ChangeLog COPYING docs/programmers-guide
37 %{python_sitelib}/pykickstart
38 %{_bindir}/ksvalidator
40 %changelog
41 * Wed Feb 07 2007 Chris Lumens <clumens@redhat.com> - 0.94-1
42 - Add a newline to the end of the key command output.
43 - Use network bootproto constants (#197694).
44 - Fix tracebacks in subclass __str__ methods (#226734).
46 * Wed Jan 31 2007 Chris Lumens <clumens@redhat.com> - 0.93-2
47 - Make some minor spec file changes to get closer to the extras guidelines.
49 * Thu Jan 25 2007 Chris Lumens <clumens@redhat.com> - 0.93-1
50 - Add support for FC3, RHEL4, and RHEL5.
51 - The key command was not supported until after FC6.
52 - Accept more strings in stringToVersion.
54 * Fri Jan 19 2007 Chris Lumens <clumens@redhat.com> - 0.92-1
55 - Fix KickstartVersionError reporting.
56 - Add a version attribute to handler objects.
57 - Fix line number reporting on lots of commands.
58 - Add initial support for Fedora 7 and remove deprecated commands.
59 - Accept a --default argument to the %%packages header (#221305).
61 * Wed Jan 17 2007 Chris Lumens <clumens@redhat.com> - 0.91-1
62 - Add a method to read kickstart files from strings.
64 * Tue Jan 16 2007 Chris Lumens <clumens@redhat.com> - 0.90-1
65 - Support multiple versions of kickstart syntax from one code base
66 (#189348).
67 - Fix inconsistency between Script parser and writer (#222877).
69 * Fri Dec 15 2006 Chris Lumens <clumens@redhat.com> - 0.43-1
70 - Pull in new translations (#216620).
72 * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.42-2
73 - rebuild against python 2.5
75 * Tue Dec 05 2006 Chris Lumens <clumens@redhat.com> - 0.42-1
76 - Fix traceback when writing out repo command (#218274).
78 * Fri Dec 01 2006 Chris Lumens <clumens@redhat.com> - 0.41-1
79 - Fix traceback when using deprecated commands (#218047, #218059).
81 * Thu Nov 30 2006 Chris Lumens <clumens@redhat.com> - 0.40-1
82 - Pull in new translations (#216620).
83 - Add --level argument to logging command writer.
85 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-2
86 - Fix release number.
88 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-1
89 - Add writer for --key (#211997).
91 * Tue Oct 17 2006 Jeremy Katz <katzj@redhat.com> - 0.38-1
92 - allow --skip for installation number as well (#207029)
94 * Mon Oct 16 2006 Jeremy Katz <katzj@redhat.com> - 0.37-1
95 - support for installation numbers (#207029)
97 * Fri Oct 13 2006 Bill Nottingham <notting@redhat.com> - 0.36-1
98 - use valid charsets in translations (#210720)
100 * Fri Sep 29 2006 Chris Lumens <clumens@redhat.com> - 0.35-1
101 - Fix traceback in harddrive command (#208557).
103 * Mon Sep 25 2006 Chris Lumens <clumens@redhat.com> - 0.34-1
104 - Add support for --biospart option to harddrive (#207585).
105 - Update writer for syntax changes.
107 * Wed Sep 20 2006 Jeremy Katz <katzj@redhat.com> - 0.33-1
108 - improved iscsi syntax
109 - allow multiple zfcp devs
111 * Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 0.32-1
112 - Limit --bootproto to what anaconda supports.
113 - Add --noipv4 and --noipv6 network options.
115 * Tue Jun 20 2006 Chris Lumens <clumens@redhat.com> 0.31-1
116 - Handle nfs --opts (katzj).
117 - RAID devices should be integers instead of strings (#176537).
118 - Add initial support for iscsi (katzj).
120 * Tue Jun 06 2006 Chris Lumens <clumens@redhat.com> 0.30-2
121 - Add BuildRequires to fix building under mock (#194156, Joost Soeterbroek
122 <fedora AT soeterbroek.com>).
124 * Thu May 25 2006 Chris Lumens <clumens@redhat.com> 0.30-1
125 - Change order of LVM-related writing functions (#193073).
126 - Require urlgrabber.
127 - Return a more useful error message on unknown commands.
128 - Fix logvol writing typo.
129 - Make ksvalidator validate from a URL in addition to a file.
130 - Don't write out an empty packages section (#192851).
132 * Tue May 23 2006 Chris Lumens <clumens@redhat.com> 0.29-1
133 - Add multipath command, handlers, and data objects (pjones).
134 - Rename --ports to --port in writer.
136 * Mon May 15 2006 Chris Lumens <clumens@redhat.com> 0.28-1
137 - Support --mtu for the network command (#191328).
138 - Accept --isUtc for backwards compatibility.
140 * Wed May 04 2006 Chris Lumens <clumens@redhat.com> 0.27-1
141 - Output formatting fixes.
142 - Added commands for managing users and services.
144 * Mon Apr 17 2006 Chris Lumens <clumens@redhat.com> 0.26-1
145 - Ignore spaces before group names (#188095).
146 - Added some translations.
147 - Add options for repo command.
148 - Reorder %%packages section output.
149 - Output %%packages header options.
150 - Initialize RAID and volume group members to empty lists.
152 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.25-1
153 - Add support for the logging command.
155 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.24-1
156 - Don't write out a blank xconfig line.
157 - Reorder output handlers to group like commands together.
158 - Mark strings for translation.
160 * Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 0.23-1
161 - Backwards compatibility support for options to zerombr.
163 * Fri Feb 24 2006 Chris Lumens <clumens@redhat.com> 0.22-1
164 - Get ignoredisk working again (#182934).
166 * Fri Feb 17 2006 Chris Lumens <clumens@redhat.com> 0.21-1
167 - Provide an option to not traceback on missing include files (#181760).
168 - Update programming documentation.
170 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.20-1
171 - Correctly set --noformat and --useexisting on lvm and raid.
173 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.19-1
174 - --onboot requires a value (#180987).
175 - Be more strict about commands that don't take arguments.
177 * Thu Feb 09 2006 Chris Lumens <clumens@redhat.com> 0.18-1
178 - Fix some errors pychecker caught.
179 - Allow exceptions to not be fatal so ksvalidator can spot more errors in
180 a single pass (#179894).
182 * Wed Feb 01 2006 Chris Lumens <clumens@redhat.com> 0.17-1
183 - Don't set a default port for vnc.
185 * Tue Jan 31 2006 Chris Lumens <clumens@redhat.com> 0.16-1
186 - Give dmraid string an initial value.
187 - Handle None on partition size.
189 * Tue Jan 31 2006 Peter Jones <pjones@redhat.com> 0.15-1
190 - Add dmraid support
192 * Mon Jan 30 2006 Chris Lumens <clumens@redhat.com> 0.14-1
193 - Fix VNC parameter parsing (#179209).
194 - Deprecate --connect. Add --host and --port instead.
196 * Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 0.13-1
197 - Recognize the --eject parameter to shutdown/halt.
198 - Store the exact post-installation action in ksdata.
200 * Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 0.12-1
201 - Clean up output quoting.
202 - Finish removing monitor-related stuff from xconfig.
204 * Mon Dec 12 2005 Chris Lumens <clumens@redhat.com> 0.11-1
205 - Deprecate monitor-related options to xconfig.
207 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
208 - Support --bytes-per-inode on raid
209 (Curtis Doty <Curtis at GreenKey.net> #175288).
211 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
212 - fixup network --onboot
214 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
215 - Default to SELINUX_ENFORCING.
216 - Default partition sizes to None for anaconda (#172378).
217 - Don't call shlex.split on anything inside a script (#172313).
219 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
220 - Fix clearpart --all.
221 - vnc command does not require --connect option (#172192).
222 - network --onboot does not take any option.
223 - Remove extra spaces from firewall --ports and --trust.
224 - Write out network --<service> options.
226 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
227 - Add --resolvedeps and --ignoredeps as deprecated options.
228 - Pass line number to header functions.
230 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
231 - Add line numbers to exception reporting.
232 - Added ksvalidator.
234 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
235 - Correct deprecated attribute on options.
236 - Added programming documentation.
238 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
239 - Correct python lib directory on 64-bit archs (#170621).
241 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
242 - Add a deprecated attribute to options.
243 - Add --card option back to xconfig and mark as deprecated.
244 - Throw a deprecation warning on mouse and langsupport commands.
245 - Rename Writer to KickstartWriter for consistency.
246 - Collapse scripts into a single list and add an attribute on Script to
247 differentiate.
249 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
250 - Rename module to pykickstart to avoid conflicts in anaconda.
251 - Rename data classes for consistency.
252 - Add default bytesPerInode settings.
254 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
255 - Created package from anaconda.