Fix typo.
[pykickstart.git] / pykickstart.spec
blobf70b6a0c706dd49aa5d0be2c88b35d114b434c48
1 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Url: http://fedoraproject.org/wiki/pykickstart
6 Version: 0.98
7 Release: 1%{?dist}
8 Source0: %{name}-%{version}.tar.gz
9 License: GPL
10 Group: System Environment/Libraries
11 BuildArch: noarch
12 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13 BuildRequires: python-devel, gettext
14 Requires: python, python-urlgrabber
16 %description
17 The pykickstart package is a python library for manipulating kickstart
18 files.
20 %prep
21 %setup -q
22 make
24 %build
26 %install
27 rm -rf %{buildroot}
28 make DESTDIR=%{buildroot} install
29 %find_lang %{name}
31 %clean
32 rm -rf %{buildroot}
34 %files -f %{name}.lang
35 %defattr(-,root,root,-)
36 %doc README ChangeLog COPYING docs/programmers-guide
37 %{python_sitelib}/pykickstart
38 %{_bindir}/ksvalidator
40 %changelog
41 * Mon Feb 26 2007 Chris Lumens <clumens@redhat.com> - 0.98-1
42 - Fix device command syntax to match anaconda.
43 - Fix __call__ on method command.
45 * Wed Feb 21 2007 Chris Lumens <clumens@redhat.com> - 0.97-1
46 - Fix traceback when not overriding default mappings (#229505).
48 * Tue Feb 20 2007 Chris Lumens <clumens@redhat.com> - 0.96-1
49 - Fix __str__ methods for langsupport and reboot commands.
50 - Renamed BaseHandler.empty to BaseHandler.maskAllExcept.
51 - Split command objects out into their own files in commands/.
52 - Rename command objects to start with Version_.
53 - Support extended group selection syntax.
55 * Wed Feb 14 2007 Chris Lumens <clumens@redhat.com> - 0.95-1
56 - KickstartParser no longer takes a version argument.
57 - Be more lenient in what strings stringToVersion accepts.
58 - Allow setting state on one data object from multiple files.
60 * Wed Feb 07 2007 Chris Lumens <clumens@redhat.com> - 0.94-1
61 - Add a newline to the end of the key command output.
62 - Use network bootproto constants (#197694).
63 - Fix tracebacks in subclass __str__ methods (#226734).
65 * Wed Jan 31 2007 Chris Lumens <clumens@redhat.com> - 0.93-2
66 - Make some minor spec file changes to get closer to the extras guidelines.
68 * Thu Jan 25 2007 Chris Lumens <clumens@redhat.com> - 0.93-1
69 - Add support for FC3, RHEL4, and RHEL5.
70 - The key command was not supported until after FC6.
71 - Accept more strings in stringToVersion.
73 * Fri Jan 19 2007 Chris Lumens <clumens@redhat.com> - 0.92-1
74 - Fix KickstartVersionError reporting.
75 - Add a version attribute to handler objects.
76 - Fix line number reporting on lots of commands.
77 - Add initial support for Fedora 7 and remove deprecated commands.
78 - Accept a --default argument to the %%packages header (#221305).
80 * Wed Jan 17 2007 Chris Lumens <clumens@redhat.com> - 0.91-1
81 - Add a method to read kickstart files from strings.
83 * Tue Jan 16 2007 Chris Lumens <clumens@redhat.com> - 0.90-1
84 - Support multiple versions of kickstart syntax from one code base
85 (#189348).
86 - Fix inconsistency between Script parser and writer (#222877).
88 * Fri Dec 15 2006 Chris Lumens <clumens@redhat.com> - 0.43-1
89 - Pull in new translations (#216620).
91 * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.42-2
92 - rebuild against python 2.5
94 * Tue Dec 05 2006 Chris Lumens <clumens@redhat.com> - 0.42-1
95 - Fix traceback when writing out repo command (#218274).
97 * Fri Dec 01 2006 Chris Lumens <clumens@redhat.com> - 0.41-1
98 - Fix traceback when using deprecated commands (#218047, #218059).
100 * Thu Nov 30 2006 Chris Lumens <clumens@redhat.com> - 0.40-1
101 - Pull in new translations (#216620).
102 - Add --level argument to logging command writer.
104 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-2
105 - Fix release number.
107 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-1
108 - Add writer for --key (#211997).
110 * Tue Oct 17 2006 Jeremy Katz <katzj@redhat.com> - 0.38-1
111 - allow --skip for installation number as well (#207029)
113 * Mon Oct 16 2006 Jeremy Katz <katzj@redhat.com> - 0.37-1
114 - support for installation numbers (#207029)
116 * Fri Oct 13 2006 Bill Nottingham <notting@redhat.com> - 0.36-1
117 - use valid charsets in translations (#210720)
119 * Fri Sep 29 2006 Chris Lumens <clumens@redhat.com> - 0.35-1
120 - Fix traceback in harddrive command (#208557).
122 * Mon Sep 25 2006 Chris Lumens <clumens@redhat.com> - 0.34-1
123 - Add support for --biospart option to harddrive (#207585).
124 - Update writer for syntax changes.
126 * Wed Sep 20 2006 Jeremy Katz <katzj@redhat.com> - 0.33-1
127 - improved iscsi syntax
128 - allow multiple zfcp devs
130 * Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 0.32-1
131 - Limit --bootproto to what anaconda supports.
132 - Add --noipv4 and --noipv6 network options.
134 * Tue Jun 20 2006 Chris Lumens <clumens@redhat.com> 0.31-1
135 - Handle nfs --opts (katzj).
136 - RAID devices should be integers instead of strings (#176537).
137 - Add initial support for iscsi (katzj).
139 * Tue Jun 06 2006 Chris Lumens <clumens@redhat.com> 0.30-2
140 - Add BuildRequires to fix building under mock (#194156, Joost Soeterbroek
141 <fedora AT soeterbroek.com>).
143 * Thu May 25 2006 Chris Lumens <clumens@redhat.com> 0.30-1
144 - Change order of LVM-related writing functions (#193073).
145 - Require urlgrabber.
146 - Return a more useful error message on unknown commands.
147 - Fix logvol writing typo.
148 - Make ksvalidator validate from a URL in addition to a file.
149 - Don't write out an empty packages section (#192851).
151 * Tue May 23 2006 Chris Lumens <clumens@redhat.com> 0.29-1
152 - Add multipath command, handlers, and data objects (pjones).
153 - Rename --ports to --port in writer.
155 * Mon May 15 2006 Chris Lumens <clumens@redhat.com> 0.28-1
156 - Support --mtu for the network command (#191328).
157 - Accept --isUtc for backwards compatibility.
159 * Wed May 04 2006 Chris Lumens <clumens@redhat.com> 0.27-1
160 - Output formatting fixes.
161 - Added commands for managing users and services.
163 * Mon Apr 17 2006 Chris Lumens <clumens@redhat.com> 0.26-1
164 - Ignore spaces before group names (#188095).
165 - Added some translations.
166 - Add options for repo command.
167 - Reorder %%packages section output.
168 - Output %%packages header options.
169 - Initialize RAID and volume group members to empty lists.
171 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.25-1
172 - Add support for the logging command.
174 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.24-1
175 - Don't write out a blank xconfig line.
176 - Reorder output handlers to group like commands together.
177 - Mark strings for translation.
179 * Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 0.23-1
180 - Backwards compatibility support for options to zerombr.
182 * Fri Feb 24 2006 Chris Lumens <clumens@redhat.com> 0.22-1
183 - Get ignoredisk working again (#182934).
185 * Fri Feb 17 2006 Chris Lumens <clumens@redhat.com> 0.21-1
186 - Provide an option to not traceback on missing include files (#181760).
187 - Update programming documentation.
189 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.20-1
190 - Correctly set --noformat and --useexisting on lvm and raid.
192 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.19-1
193 - --onboot requires a value (#180987).
194 - Be more strict about commands that don't take arguments.
196 * Thu Feb 09 2006 Chris Lumens <clumens@redhat.com> 0.18-1
197 - Fix some errors pychecker caught.
198 - Allow exceptions to not be fatal so ksvalidator can spot more errors in
199 a single pass (#179894).
201 * Wed Feb 01 2006 Chris Lumens <clumens@redhat.com> 0.17-1
202 - Don't set a default port for vnc.
204 * Tue Jan 31 2006 Chris Lumens <clumens@redhat.com> 0.16-1
205 - Give dmraid string an initial value.
206 - Handle None on partition size.
208 * Tue Jan 31 2006 Peter Jones <pjones@redhat.com> 0.15-1
209 - Add dmraid support
211 * Mon Jan 30 2006 Chris Lumens <clumens@redhat.com> 0.14-1
212 - Fix VNC parameter parsing (#179209).
213 - Deprecate --connect. Add --host and --port instead.
215 * Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 0.13-1
216 - Recognize the --eject parameter to shutdown/halt.
217 - Store the exact post-installation action in ksdata.
219 * Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 0.12-1
220 - Clean up output quoting.
221 - Finish removing monitor-related stuff from xconfig.
223 * Mon Dec 12 2005 Chris Lumens <clumens@redhat.com> 0.11-1
224 - Deprecate monitor-related options to xconfig.
226 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
227 - Support --bytes-per-inode on raid
228 (Curtis Doty <Curtis at GreenKey.net> #175288).
230 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
231 - fixup network --onboot
233 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
234 - Default to SELINUX_ENFORCING.
235 - Default partition sizes to None for anaconda (#172378).
236 - Don't call shlex.split on anything inside a script (#172313).
238 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
239 - Fix clearpart --all.
240 - vnc command does not require --connect option (#172192).
241 - network --onboot does not take any option.
242 - Remove extra spaces from firewall --ports and --trust.
243 - Write out network --<service> options.
245 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
246 - Add --resolvedeps and --ignoredeps as deprecated options.
247 - Pass line number to header functions.
249 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
250 - Add line numbers to exception reporting.
251 - Added ksvalidator.
253 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
254 - Correct deprecated attribute on options.
255 - Added programming documentation.
257 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
258 - Correct python lib directory on 64-bit archs (#170621).
260 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
261 - Add a deprecated attribute to options.
262 - Add --card option back to xconfig and mark as deprecated.
263 - Throw a deprecation warning on mouse and langsupport commands.
264 - Rename Writer to KickstartWriter for consistency.
265 - Collapse scripts into a single list and add an attribute on Script to
266 differentiate.
268 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
269 - Rename module to pykickstart to avoid conflicts in anaconda.
270 - Rename data classes for consistency.
271 - Add default bytesPerInode settings.
273 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
274 - Created package from anaconda.