corrected the SQLGraph iterator methods and improved its code for determing column...
[pygr.git] / misc / pygr-VER.ebuild
blob54f2eefdd10d6f9965eb0d99d8148e074e462e2d
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 NEED_PYTHON=2.3
7 inherit distutils
9 DESCRIPTION="A Python graph-database toolkit oriented primarily on bioinformatics applications"
10 HOMEPAGE="http://code.google.com/p/pygr/"
11 SRC_URI="http://pygr.googlecode.com/files/${P}.tar.gz"
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="doc mysql sqlite"
18 DEPEND="doc? ( dev-python/sphinx )"
19 RDEPEND="mysql? ( dev-python/mysql-python )
20 sqlite? ( || ( dev-python/pysqlite >=dev-lang/python-2.5 ) )"
22 src_install() {
23 distutils_src_install
25 dodoc README COPYING pygrrc.example
26 if use doc; then
27 cd doc
28 emake newdoc
29 dohtml -r html_new/*
33 src_test() {
34 "${python}" tests/runtest.py -b || die "Running tests failed"