* lib/Parrot/Pmc2c/MethodEmitter.pm:
[parrot.git] / parrot.spec
blob7b816602e8db44a301dd64ca5cb566886cb060f6
1 Name: parrot
2 Version: 0.6.2
3 Release: 1%{?dist}
4 Summary: Parrot Virtual Machine
5 License: Artistic 2.0
6 Group: Development/Libraries
7 URL: http://www.parrotcode.org/
8 Source0: http://www.cpan.org/authors/id/P/PM/PMIC/parrot-%{version}.tar.gz
9 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
10 BuildRequires: readline-devel
11 BuildRequires: ncurses-devel
12 BuildRequires: gmp-devel
13 BuildRequires: gdbm-devel
14 BuildRequires: /usr/bin/perldoc
15 BuildRequires: bc
16 BuildRequires: m4
17 BuildRequires: libicu-devel
19 %package devel
20 Summary: Parrot Virtual Machine development headers and libraries
21 License: Artistic 2.0
22 Group: Development/Libraries
23 Requires: %{name} = %{version}-%{release}
24 Requires: %{_libdir}/pkgconfig
26 %description
27 Parrot is a virtual machine designed to efficiently compile and execute
28 bytecode for dynamic languages. Parrot is a target for the Perl 6 compiler, and
29 is already usable as a backend for Pugs, as well as variety of other languages.
31 %description devel
32 Parrot Virtual Machine development headers and libraries.
34 %prep
35 %setup -q
37 %{__perl} -pi -e 's,"lib/,"%{_lib}/, if (/CONST_STRING\(interp,/)' \
38 src/library.c
39 %{__perl} -pi -e "s,'/usr/lib','%{_libdir}',;s,runtime/lib/,runtime/%{_lib}/," \
40 tools/dev/install_files.pl \
41 tools/dev/mk_manifests.pl
43 %build
44 %{__perl} Configure.pl \
45 --prefix=%{_usr} \
46 --libdir=%{_libdir} \
47 --sysconfdir=%{_sysconfdir} \
48 --infodir=%{_datadir}/info \
49 --mandir=%{_mandir} \
50 --cc=%{__cc} \
51 --cxx=%{__cxx} \
52 --optimize="$RPM_OPT_FLAGS -maccumulate-outgoing-args" \
53 --parrot_is_shared \
54 --lex=/usr/bin/flex \
55 --yacc=/usr/bin/yacc \
56 --libs='-lcurses -lm'
58 export LD_LIBRARY_PATH=$( pwd )/blib/lib
59 make
61 %install
62 rm -rf $RPM_BUILD_ROOT
64 export LD_LIBRARY_PATH=$( pwd )/blib/lib
65 make reallyinstall DESTDIR=$RPM_BUILD_ROOT
67 # Drop the docs so rpm can pick them up itself.
68 rm -rf $RPM_BUILD_ROOT/%{_docdir}/parrot
70 # Force permissions on doc directories.
71 find docs examples -type d -exec chmod 755 {} \;
72 find docs examples -type f -exec chmod 644 {} \;
74 # Force permissions on shared libs so they get stripped.
75 find $RPM_BUILD_ROOT%{_libdir} -type f \( -name '*.so' -o -name '*.so.*' \) \
76 -exec chmod 755 {} \;
78 # These files *probably* aren't needed.
79 rm -rf $RPM_BUILD_ROOT%{_usr}/compilers \
80 $RPM_BUILD_ROOT%{_usr}/config \
81 $RPM_BUILD_ROOT%{_includedir}/src \
82 $RPM_BUILD_ROOT%{_usr}/src \
83 $RPM_BUILD_ROOT%{_usr}/tools
85 %check
86 export LD_LIBRARY_PATH=$( pwd )/blib/lib
87 # make test < /dev/null
88 # %{?_with_fulltest:make fulltest < /dev/null}
89 # make test || :
90 # %{?_with_fulltest:make fulltest || :}
92 %clean
93 rm -rf $RPM_BUILD_ROOT
95 %post -p /sbin/ldconfig
97 %postun -p /sbin/ldconfig
99 %files
100 %defattr(-,root,root,-)
101 %doc ChangeLog CREDITS NEWS PBC_COMPAT PLATFORMS README
102 %doc RESPONSIBLE_PARTIES TODO
103 %doc docs examples
104 %exclude %{_bindir}/parrot-config
105 %{_bindir}/*
106 %{_libdir}/parrot
107 %{_libdir}/libparrot.so.*
109 %files devel
110 %defattr(-,root,root,-)
111 %{_bindir}/parrot-config
112 %{_includedir}/parrot
113 %{_libdir}/libparrot.so
114 %{_libdir}/libparrot.a
115 %{_libdir}/pkgconfig/*
117 %changelog
118 * Tue May 20 2008 chromatic <chromatic@wgz.org 0.6.2
119 - updated to 0.6.2
121 * Mon Apr 28 2008 chromatic <chromatic@wgz.org> 0.6.1
122 - minor fixes; tested with Fedora 7, 8, and 9-beta
124 * Tue Mar 18 2008 Bernhard Schmalhofer <Bernhard.Schmalhofer@gmx.de> 0.6.0
125 - Update to 0.5.3.
127 * Wed Feb 20 2008 Patrick Michaud <pmichaud@pobox.com> 0.5.3
128 - Update to 0.5.3.
130 * Tue Jan 15 2008 Bob Rogers <rogers@rgrjr.dyndns.org> 0.5.2
131 - Update to 0.5.2.
133 * Tue Dec 18 2007 Jonathan Worthington <jnthn@jnthn.net> 0.5.1
134 - Update to 0.5.1.
136 * Tue Nov 20 2007 chromatic <chromatic@wgz.org> 0.5.0
137 - Update to 0.5.0.
139 * Fri May 25 2007 David Fetter <david@fetter.org> 0.4.12-1
140 - Update to 0.4.12.
142 * Wed Apr 18 2007 Steven Pritchard <steve@kspei.com> 0.4.11-1
143 - Update to 0.4.11.
145 * Wed Mar 21 2007 Steven Pritchard <steve@kspei.com> 0.4.10-1
146 - Update to 0.4.10.
148 * Sat Mar 10 2007 Steven Pritchard <steve@kspei.com> 0.4.9-1
149 - Update to 0.4.9.
150 - BR ncurses-devel.
151 - For some reason now I need to force -lm too.
152 - Remove some files/directories that shouldn't be included.
154 * Wed Jan 17 2007 Steven Pritchard <steve@kspei.com> 0.4.8-1
155 - Attempt update to 0.4.8.
157 * Fri Jun 30 2006 Steven Pritchard <steve@kspei.com> 0.4.5-5
158 - Override lib_dir and make various substitutions to try to fix multilib.
159 - Remove rpath use from Makefile.
160 - Fix a pod error in src/ops/experimental.ops.
161 - Enable "make test" since t/doc/pod.t won't fail now.
163 * Wed Jun 28 2006 Steven Pritchard <steve@kspei.com> 0.4.5-4
164 - Force permissions on shared libraries so rpmbuild strips them.
166 * Wed Jun 28 2006 Steven Pritchard <steve@kspei.com> 0.4.5-3
167 - Fix URL, description, summary, etc.
168 - Add post/postun.
169 - Move parrot-config to the devel sub-package.
170 - Force permissions on the doc directories.
172 * Tue Jun 27 2006 Steven Pritchard <steve@kspei.com> 0.4.5-2
173 - Add -lcurses to get readline detection to work.
174 - BR libicu-devel.
176 * Tue Jun 27 2006 Steven Pritchard <steve@kspei.com> 0.4.5-1
177 - Initial packaging attempt.
179 * Tue Mar 18 2003 Steve Fink <sfink@foxglove.localdomain> 0.0.11
180 - first .spec file created