makepkg: use double brackets
[pacman-ng.git] / PKGBUILD-split.proto
blobd7f1de1b9a1c8b3565922336e1f1c122522bf119
1 # This is an example of a PKGBUILD for splitting packages. Use this as a
2 # start to creating your own, and remove these comments. For more information,
3 # see 'man PKGBUILD'. NOTE: Please fill out the license field for your package!
4 # If it is unknown, then please put 'unknown'.
6 # Maintainer: Your Name <youremail@domain.com>
7 pkgname=('pkg1' 'pkg2')
8 pkgbase=BASE
9 pkgver=VERSION
10 pkgrel=1
11 pkgdesc=""
12 arch=()
13 url=""
14 license=('GPL')
15 groups=()
16 depends=()
17 makedepends=()
18 provides=()
19 conflicts=()
20 replaces=()
21 backup=()
22 options=()
23 install=
24 changelog=
25 source=($pkgbase-$pkgver.tar.gz)
26 noextract=()
27 md5sums=() #generate with 'makepkg -g'
29 build() {
30   cd "$srcdir/$pkgbase-$pkgver"
31   ./configure --prefix=/usr
32   make
35 package_pkg1() {
36   # options and directives that can be overridden
37   pkgver=
38   pkgrel=
39   pkgdesc=""
40   arch=()
41   license=()
42   groups=()
43   depends=()
44   optdepends=()
45   provides=()
46   conflicts=()
47   replaces=()
48   backup=()
49   options=()
50   install=
51   changelog=
53   cd "$srcdir/$pkgbase-$pkgver"
54   make DESTDIR="$pkgdir/" install-pkg1
57 package_pkg2() {
58   # options and directives overrides
59   pkgdesc=""
61   cd "$srcdir/$pkgbase-$pkgver"
62   make DESTDIR="$pkgdir/" install-pkg2