2 vim:set ts=4 sw=4 syntax=asciidoc noet:
9 PKGBUILD - Arch Linux package build description file
19 This manual page is meant to describe general rules about PKGBUILDs. Once a
20 PKGBUILD is written, the actual package is built using makepkg and installed
23 NOTE: An example PKGBUILD, useful for reference, is located in '{pkgdatadir}'.
24 Also located there are other example files such as a ChangeLog and an install
25 script. You can copy the provided PKGBUILD.proto file to a new package build
26 directory and make customizations to suit your needs.
29 Options and Directives
30 ----------------------
31 The following is a list of standard options and directives available for use
32 in a PKGBUILD. These are all understood and interpreted by makepkg, and most
33 will be directly transferred to the built package.
35 If you need to create any custom variables for use in your build process, it is
36 recommended to name your custom variables with an '_' (underscore) prefix.
37 This will prevent any possible name clashes with internal makepkg variables.
38 For example, to store the base kernel version in a variable, use something
39 similar to `$_basekernver`.
42 The name of the package. This has be a unix-friendly name as it will be
43 used in the package filename. Members of the array are not allowed to start
47 The version of the software as released from the author (e.g. '2.7.1').
48 The variable is not allowed to contain hyphens.
51 This is the release number specific to the Arch Linux release. This
52 allows package maintainers to make updates to the package's configure
53 flags, for example. A pkgrel of '1' is typically used for each upstream
54 software release and is incremented for intermediate PKGBUILD updates. The
55 variable is not allowed to contain hyphens.
58 This should be a brief description of the package and its functionality.
59 Try to keep the description to one line of text.
62 Used to force the package to be seen as newer than any previous versions
63 with a lower epoch, even if the version number would normally not trigger
64 such an upgrade. This value is required to be a positive integer; the
65 default value if left unspecified is '0'. This is useful when the version
66 numbering scheme of a package changes (or is alphanumeric), breaking normal
67 version comparison logic. See linkman:pacman[8] for more information on
71 This field contains a URL that is associated with the software being
72 packaged. This is typically the project's website.
75 This field specifies the license(s) that apply to the package.
76 Commonly-used licenses are found in '/usr/share/licenses/common'. If you
77 see the package's license there, simply reference it in the license
78 field (e.g. `license=('GPL')`). If the package provides a license not
79 found in '/usr/share/licenses/common', then you should include the license
80 in the package itself and set `license=('custom')` or
81 `license=('custom:LicenseName')`. The license should be placed in
82 '$pkgdir/usr/share/licenses/$pkgname' when building the package. If
83 multiple licenses are applicable for a package, list all of them:
84 `license=('GPL' 'FDL')`.
87 Specifies a special install script that is to be included in the package.
88 This file should reside in the same directory as the PKGBUILD, and will
89 be copied into the package by makepkg. It does not need to be included
90 in the source array (e.g. `install=pkgname.install`).
93 Specifies a changelog file that is to be included in the package.
94 This file should reside in the same directory as the PKGBUILD, and will
95 be copied into the package by makepkg. It does not need to be included
96 in the source array (e.g. `changelog=$pkgname.changelog`).
99 An array of source files required to build the package. Source files
100 must either reside in the same directory as the PKGBUILD file, or be a
101 fully-qualified URL that makepkg will use to download the file. In order
102 to make the PKGBUILD as useful as possible, use the $pkgname and $pkgver
103 variables if possible when specifying the download location. Any files
104 that are compressed will automatically be extracted, unless found in
105 the noextract array listed below.
107 It is also possible to specify an optional filename, which is helpful
108 with weird URLs and for handling multiple source files with the same
109 name. The syntax is: `source=('filename::url')`.
111 *noextract (array)*::
112 An array of filenames corresponding to those from the source array. Files
113 listed here will not be extracted with the rest of the source files. This
114 is useful for packages which use compressed data which is downloaded but
115 not necessary to uncompress.
118 This array contains an MD5 hash for every source file specified in the
119 source array (in the same order). makepkg will use this to verify source
120 file integrity during subsequent builds. To easily generate md5sums, run
121 ``makepkg -g >> PKGBUILD''. If desired, move the md5sums line to an
122 appropriate location.
124 *sha1sums, sha256sums, sha384sums, sha512sums (arrays)*::
125 Alternative integrity checks that makepkg supports; these all behave
126 similar to the md5sums option described above. To enable use and generation
127 of these checksums, be sure to set up the `INTEGRITY_CHECK` option in
128 linkman:makepkg.conf[5].
131 An array of symbolic names that represent groups of packages, allowing
132 you to install multiple packages by requesting a single target. For
133 example, one could install all KDE packages by installing the 'kde' group.
136 Defines on which architectures the given package is available (e.g.
137 `arch=('i686' 'x86_64')`). Packages that contain no architecture specific
138 files may use arch=('any').
141 A space-delimited array of filenames, without preceding slashes, that
142 should be backed up if the package is removed or upgraded. This is
143 commonly used for packages placing configuration files in /etc. See
144 Handling Config Files in linkman:pacman[8] for more information.
147 An array of packages that this package depends on to run. Packages in
148 this list should be surrounded with single quotes and contain at least
149 the package name. Entries can also include a version requirement of the
150 form 'name<>version', where <> is one of five comparisons: >= (greater
151 than or equal to), <= (less than or equal to), = (equal to), > (greater
152 than), or < (less than).
154 *makedepends (array)*::
155 An array of packages that this package depends on to build, but are not
156 needed at runtime. Packages in this list follow the same format as
159 *checkdepends (array)*::
160 An array of packages that this package depends on to run its test suite,
161 but are not needed at runtime. Packages in this list follow the same
162 format as depends. These dependencies are only considered when the
163 check() function is present and is to be run by makepkg.
165 *optdepends (array)*::
166 An array of packages (and accompanying reasons) that are not essential for
167 base functionality, but may be necessary to make full use of the contents
168 of this package. optdepends are currently for informational purposes only
169 and are not utilized by pacman during dependency resolution. The format
170 for specifying optdepends is:
172 optdepends=('fakeroot: for makepkg usage as normal user')
174 *conflicts (array)*::
175 An array of packages that will conflict with this package (i.e. they
176 cannot both be installed at the same time). This directive follows the
177 same format as depends. Versioned conflicts are also supported.
180 An array of ``virtual provisions'' that this package provides. This allows
181 a package to provide dependencies other than its own package name. For
182 example, the dcron package can provide 'cron', which allows packages to
183 depend on 'cron' rather than 'dcron OR fcron'.
184 Versioned provisions are also possible, in the 'name=version' format.
185 For example, dcron can provide 'cron=2.0' to satisfy the 'cron>=2.0'
186 dependency of other packages. Provisions involving the '>' and '<'
187 operators are invalid as only specific versions of a package may be
191 An array of packages that this package should replace, and can be used
192 to handle renamed/combined packages. For example, if the 'j2re' package
193 is renamed to 'jre', this directive allows future upgrades to continue
194 as expected even though the package has moved. Sysupgrade is currently
195 the only pacman operation that utilizes this field, a normal sync will
199 This array allows you to override some of makepkg's default behavior
200 when building packages. To set an option, just include the option name
201 in the options array. To reverse the default behavior, place an ``!'' at
202 the front of the option. Only specify the options you specifically want
203 to override, the rest will be taken from linkman:makepkg.conf[5].
204 *NOTE:* 'force' is a now-removed option in favor of the top level 'epoch'
208 Strip symbols from binaries and libraries. If you frequently
209 use a debugger on programs or libraries, it may be helpful to
213 Save doc directories. If you wish to delete doc directories,
214 specify `!docs` in the array.
217 Leave libtool (.la) files in packages. Specify `!libtool` to
221 Leave empty directories in packages.
224 Compress man and info pages with gzip.
227 Allow the use of ccache during build. More useful in its negative
228 form `!ccache` with select packages that have problems building
232 Allow the use of distcc during build. More useful in its negative
233 form `!distcc` with select packages that have problems building
237 Allow the use of user-specific buildflags (CFLAGS, CXXFLAGS, LDFLAGS)
238 during build as specified in linkman:makepkg.conf[5]. More useful in
239 its negative form `!buildflags` with select packages that have problems
240 building with custom buildflags.
243 Allow the use of user-specific makeflags during build as specified
244 in linkman:makepkg.conf[5]. More useful in its negative form
245 `!makeflags` with select packages that have problems building with
246 custom makeflags such as `-j2` (or higher).
251 In addition to the above directives, the optional build() bash function usually
252 comprises the remainder of the PKGBUILD. This is directly sourced and executed
253 by makepkg, so anything that bash or the system has available is available for
254 use here. The function is run in `bash -e` mode, meaning any command that exits
255 with a non-zero status will cause the function to exit. Be sure any exotic
256 commands used are covered by `makedepends`.
258 All of the above variables such as `pkgname` and `pkgver` are available for use
259 in the build function. In addition, makepkg defines three variables for your
260 use during the build and install process. These three variables are as follows:
263 This contains the absolute path to the directory where the PKGBUILD was
264 located, which is usually the output of `$(pwd)` when makepkg is started.
267 This points to the directory where makepkg extracts or copies all source
271 This points to the directory where makepkg bundles the installed package
272 (this directory will become the root directory of your built package).
274 If you create any variables of your own in the build function, it is
275 recommended to use the bash `local` keyword to scope the variable to inside
280 An optional check() function can be specified in which a packages test-suite
281 may be run. This function is run between the build() and package() functions.
282 The function is run in `bash -e` mode, meaning any command that exits with a
283 non-zero status will cause the function to exit. Be sure any exotic commands
284 used are covered by `checkdepends`.
288 An optional package() function can be specified in addition to the build()
289 function. This function is run after the build() and check() functions. The
290 function is run in `bash -e` mode, meaning any command that exits with a
291 non-zero status will cause the function to exit. When specified in combination
292 with the fakeroot BUILDENV option in linkman:makepkg.conf[5], fakeroot usage
293 will be limited to running the packaging stage. An existing build() function
294 will be run as the user calling makepkg.
298 makepkg supports building multiple packages from a single PKGBUILD. This is
299 achieved by assigning an array of package names to the `pkgname` directive.
300 Each split package uses a corresponding packaging function with name
301 `package_foo()`, where `foo` is the name of the split package.
303 All options and directives for the split packages default to the global values
304 given within the PKGBUILD. However, some of these can be overridden within each
305 split package's packaging function. The following variables can be overridden:
306 `pkgver`, `pkgrel`, `pkgdesc`, `arch`, `license`, `groups`, `depends`,
307 `optdepends`, `provides`, `conflicts`, `replaces`, `backup`, `options`,
308 `install` and `changelog`.
310 An optional global directive is available when building a split package:
313 The name used to refer to the group of packages in the output of makepkg
314 and in the naming of source-only tarballs. If not specified, the first
315 element in the `pkgname` array is used. The variable is not allowed to
318 Install/Upgrade/Remove Scripting
319 --------------------------------
320 Pacman has the ability to store and execute a package-specific script when it
321 installs, removes, or upgrades a package. This allows a package to configure
322 itself after installation and perform an opposite action upon removal.
324 The exact time the script is run varies with each operation:
327 script is run right before files are extracted. One argument is passed:
331 script is run right after files are extracted. One argument is passed:
335 script is run right before files are extracted. Two arguments are passed
336 in the following order: new package version, old package version.
339 script is run after files are extracted. Two arguments are passed
340 in the following order: new package version, old package version.
343 script is run right before files are removed. One argument is passed:
347 script is run right after files are removed. One argument is passed:
350 To use this feature, create a file such as 'pkgname.install' and put it in the
351 same directory as the PKGBUILD script. Then use the install directive:
353 install=pkgname.install
355 The install script does not need to be specified in the source array. A
356 template install file is available in '{pkgdatadir}' as 'proto.install' for
357 reference with all of the available functions defined.
360 Development Directives
361 ----------------------
362 makepkg supports building development versions of packages without having to
363 manually update the pkgver in the PKGBUILD. This was formerly done using the
364 separate utility 'versionpkg'. In order to utilize this functionality, your
365 PKGBUILD must use correct variable names depending on the SCM being fetched
369 The generated pkgver will be the date the package is built.
372 The root of the CVS repository.
375 The CVS module to fetch.
378 The generated pkgver will be the latest SVN revision number.
381 The trunk of the SVN repository.
384 The SVN module to fetch.
387 The generated pkgver will be one formatted by the 'git-describe'
388 command, with '-' characters converted to '_' characters.
391 The URL (all protocols supported) to the GIT repository.
394 GIT tag or branch to use.
397 The generated pkgver will be the hg tip revision number.
400 The URL of the mercurial repository.
403 The repository to follow.
406 The generated pkgver will be the date the package is built.
409 URL to the repository trunk.
415 The generated pkgver will be the latest Bazaar revision number (revno).
418 URL to the bazaar repository.
421 Bazaar module to use.
426 The following is an example PKGBUILD for the 'patch' package. For more
427 examples, look through the build files of your distribution's packages. For
428 those using Arch Linux, consult the ABS tree.
431 -------------------------------
432 include::PKGBUILD-example.txt[]
433 -------------------------------
437 linkman:makepkg[8], linkman:pacman[8], linkman:makepkg.conf[5]
439 include::footer.txt[]