makepkg: unset errexit when sourcing /etc/profile
[pacman-ng.git] / doc / PKGBUILD.5.txt
blob60d8e53b8fc36768e489967f08e21b97ab49c788
1 /////
2 vim:set ts=4 sw=4 syntax=asciidoc noet spell spelllang=en_us:
3 /////
4 PKGBUILD(5)
5 ===========
7 Name
8 ----
9 PKGBUILD - Arch Linux package build description file
12 Synopsis
13 --------
14 PKGBUILD
17 Description
18 -----------
19 This manual page describes general rules about PKGBUILDs. Once a
20 PKGBUILD is written, the actual package is built using makepkg and installed
21 with pacman.
23 NOTE: An example PKGBUILD, useful for reference, is located in '{pkgdatadir}'
24 along with other example files such as a ChangeLog and an install
25 script. You can copy the provided PKGBUILD.proto file to a new package build
26 directory and make customizations to suit your needs.
29 Options and Directives
30 ----------------------
31 The following is a list of standard options and directives available for use
32 in a PKGBUILD. These are all understood and interpreted by makepkg, and most
33 of them will be directly transferred to the built package.
35 If you need to create any custom variables for use in your build process, it is
36 recommended to prefix their name with an '_' (underscore).
37 This will prevent any possible name clashes with internal makepkg variables.
38 For example, to store the base kernel version in a variable, use something
39 similar to `$_basekernver`.
41 *pkgname (array)*::
42         Either the name of the package or an array of names for split packages.
43         Because it will be used in the package filename, this has to be unix-friendly.
44         Members of the array are not allowed to start with hyphens.
46 *pkgver*::
47         The version of the software as released from the author (e.g., '2.7.1').
48         The variable is not allowed to contain colons or hyphens.
50 *pkgrel*::
51         This is the release number specific to the Arch Linux release. This
52         allows package maintainers to make updates to the package's configure
53         flags, for example. This is typically set to '1' for each new upstream
54         software release and incremented for intermediate PKGBUILD updates. The
55         variable is not allowed to contain hyphens.
57 *pkgdesc*::
58         This should be a brief description of the package and its functionality.
59         Try to keep the description to one line of text and not use the package's name.
61 *epoch*::
62         Used to force the package to be seen as newer than any previous versions
63         with a lower epoch, even if the version number would normally not trigger
64         such an upgrade. This value is required to be a positive integer; the
65         default value if left unspecified is '0'. This is useful when the version
66         numbering scheme of a package changes (or is alphanumeric), breaking normal
67         version comparison logic. See linkman:pacman[8] for more information on
68         version comparisons.
70 *url*::
71         This field contains a URL that is associated with the software being
72         packaged. Typically the project's website.
74 *license (array)*::
75         This field specifies the license(s) that apply to the package.
76         Commonly used licenses can be found in '/usr/share/licenses/common'. If you
77         see the package's license there, simply reference it in the license
78         field (e.g., `license=('GPL')`). If the package provides a license not
79         available in '/usr/share/licenses/common', then you should include it
80         in the package itself and set `license=('custom')` or
81         `license=('custom:LicenseName')`. The license should be placed in
82         '$pkgdir/usr/share/licenses/$pkgname/' when building the package. If
83         multiple licenses are applicable, list all of them:
84         `license=('GPL' 'FDL')`.
86 *install*::
87         Specifies a special install script that is to be included in the package.
88         This file should reside in the same directory as the PKGBUILD, and will
89         be copied into the package by makepkg. It does not need to be included
90         in the source array (e.g., `install=pkgname.install`).
92 *changelog*::
93         Specifies a changelog file that is to be included in the package.
94         This file should reside in the same directory as the PKGBUILD, and will
95         be copied into the package by makepkg. It does not need to be included
96         in the source array (e.g., `changelog=$pkgname.changelog`).
98 *source (array)*::
99         An array of source files required to build the package. Source files
100         must either reside in the same directory as the PKGBUILD, or be a
101         fully-qualified URL that makepkg can use to download the file.
102         To make the PKGBUILD as useful as possible, use the `$pkgname` and `$pkgver`
103         variables if possible when specifying the download location. Compressed files
104         will be extracted automatically unless found in
105         the noextract array described below.
107 It is also possible to change the name of the downloaded file, which is helpful
108 with weird URLs and for handling multiple source files with the same
109 name. The syntax is: `source=('filename::url')`.
111 *noextract (array)*::
112         An array of filenames corresponding to those from the source array. Files
113         listed here will not be extracted with the rest of the source files. This
114         is useful for packages that use compressed data directly.
116 *md5sums (array)*::
117         This array contains an MD5 hash for every source file specified in the
118         source array (in the same order). makepkg will use this to verify source
119         file integrity during subsequent builds. To easily generate md5sums, run
120         `makepkg -g >> PKGBUILD`. If desired, move the md5sums line to an
121         appropriate location.
123 *sha1sums, sha256sums, sha384sums, sha512sums (arrays)*::
124         Alternative integrity checks that makepkg supports; these all behave
125         similar to the md5sums option described above. To enable use and generation
126         of these checksums, be sure to set up the `INTEGRITY_CHECK` option in
127         linkman:makepkg.conf[5].
129 *groups (array)*::
130         An array of symbolic names that represent groups of packages, allowing
131         you to install multiple packages by requesting a single target. For
132         example, one could install all KDE packages by installing the 'kde' group.
134 *arch (array)*::
135         Defines on which architectures the given package is available (e.g.,
136         `arch=('i686' 'x86_64')`). Packages that contain no architecture specific
137         files should use `arch=('any')`.
139 *backup (array)*::
140         An array of filenames, without preceding slashes, that
141         should be backed up if the package is removed or upgraded. This is
142         commonly used for packages placing configuration files in /etc. See
143         Handling Config Files in linkman:pacman[8] for more information.
145 *depends (array)*::
146         An array of packages this package depends on to run. Entries in
147         this list should be surrounded with single quotes and contain at least
148         the package name. Entries can also include a version requirement of the
149         form 'name<>version', where `<>` is one of five comparisons: `>=` (greater
150         than or equal to), `<=` (less than or equal to), `=` (equal to), `>`
151         (greater than), or `<` (less than).
153 If the dependency name appears to be a library (ends with .so), makepkg will
154 try to find a binary that depends on the library in the built package and
155 append the version needed by the binary. Appending the version yourself
156 disables auto detection.
158 *makedepends (array)*::
159         An array of packages this package depends on to build but are not
160         needed at runtime. Packages in this list follow the same format as
161         depends.
163 *checkdepends (array)*::
164         An array of packages this package depends on to run its test suite
165         but are not needed at runtime. Packages in this list follow the same
166         format as depends. These dependencies are only considered when the
167         check() function is present and is to be run by makepkg.
169 *optdepends (array)*::
170         An array of packages (and accompanying reasons) that are not essential for
171         base functionality, but may be necessary to make full use of the contents
172         of this package. optdepends are currently for informational purposes only
173         and are not utilized by pacman during dependency resolution. The format
174         for specifying optdepends is:
176         optdepends=('fakeroot: for makepkg usage as normal user')
178 *conflicts (array)*::
179         An array of packages that will conflict with this package (i.e. they
180         cannot both be installed at the same time). This directive follows the
181         same format as depends. Versioned conflicts are supported using the
182         operators as described in `depends`.
184 *provides (array)*::
185         An array of ``virtual provisions'' this package provides. This allows
186         a package to provide dependencies other than its own package name. For
187         example, the dcron package can provide 'cron', which allows packages to
188         depend on 'cron' rather than 'dcron OR fcron'.
190 Versioned provisions are also possible, in the 'name=version' format. For
191 example, dcron can provide 'cron=2.0' to satisfy the 'cron>=2.0' dependency of
192 other packages. Provisions involving the `>` and `<` operators are invalid as
193 only specific versions of a package may be provided.
195 If the provision name appears to be a library (ends with .so), makepkg will
196 try to find the library in the built package and append the correct
197 version. Appending the version yourself disables auto detection.
199 *replaces (array)*::
200         An array of packages this package should replace. This can be used
201         to handle renamed/combined packages. For example, if the 'j2re' package
202         is renamed to 'jre', this directive allows future upgrades to continue
203         as expected even though the package has moved. Versioned replaces are
204         supported using the operators as described in `depends`.
206 Sysupgrade is currently the only pacman operation that utilizes this field.
207 A normal sync or upgrade will not use its value.
209 *options (array)*::
210         This array allows you to override some of makepkg's default behavior
211         when building packages. To set an option, just include the option name
212         in the options array. To reverse the default behavior, place an ``!'' at
213         the front of the option. Only specify the options you specifically want
214         to override, the rest will be taken from linkman:makepkg.conf[5].
215         *NOTE:* 'force' is a now-removed option in favor of the top level 'epoch'
216         variable.
218         *strip*;;
219                 Strip symbols from binaries and libraries. If you frequently
220                 use a debugger on programs or libraries, it may be helpful to
221                 disable this option.
223         *docs*;;
224                 Save doc directories. If you wish to delete doc directories,
225                 specify `!docs` in the array.
227         *libtool*;;
228                 Leave libtool (.la) files in packages. Specify `!libtool` to
229                 remove them.
231         *emptydirs*;;
232                 Leave empty directories in packages.
234         *zipman*;;
235                 Compress man and info pages with gzip.
237         *upx*;;
238                 Compress binary executable files using UPX.
240         *ccache*;;
241                 Allow the use of ccache during build. More useful in its negative
242                 form `!ccache` with select packages that have problems building
243                 with ccache.
245         *distcc*;;
246                 Allow the use of distcc during build. More useful in its negative
247                 form `!distcc` with select packages that have problems building
248                 with distcc.
250         *buildflags*;;
251                 Allow the use of user-specific buildflags (CFLAGS, CXXFLAGS, LDFLAGS)
252                 during build as specified in linkman:makepkg.conf[5]. More useful in
253                 its negative form `!buildflags` with select packages that have problems
254                 building with custom buildflags.
256         *makeflags*;;
257                 Allow the use of user-specific makeflags during build as specified
258                 in linkman:makepkg.conf[5]. More useful in its negative form
259                 `!makeflags` with select packages that have problems building with
260                 custom makeflags such as `-j2` (or higher).
263 build() Function
264 ----------------
265 In addition to the above directives, the optional build() function usually
266 comprises the remainder of the PKGBUILD. This is directly sourced and executed
267 by makepkg, so anything that bash or the system has available is available for
268 use here. The function is run in `bash -e` mode, meaning any command that exits
269 with a non-zero status will cause the function to exit. Be sure any exotic
270 commands used are covered by `makedepends`.
272 All of the above variables such as `$pkgname` and `$pkgver` are available for use
273 in the build function. In addition, makepkg defines the following three
274 variables for use during the build and install process:
276 *startdir*::
277         This contains the absolute path to the directory where the PKGBUILD is
278         located, which is usually the output of `$(pwd)` when makepkg is started.
279         Use of this variable is deprecated and strongly discouraged.
281 *srcdir*::
282         This contains the directory where makepkg extracts, or copies, all source
283         files.
285 *pkgdir*::
286         This contains the directory where makepkg bundles the installed package
287         (this directory will become the root directory of your built package).
289 If you create any variables of your own in the build function, it is
290 recommended to use the bash `local` keyword to scope the variable to inside
291 the build function.
293 check() Function
294 ----------------
295 An optional check() function can be specified in which a packages test-suite
296 may be run. This function is run between the build() and package() functions.
297 The function is run in `bash -e` mode, meaning any command that exits with a
298 non-zero status will cause the function to exit. Be sure any exotic commands
299 used are covered by `checkdepends`.
301 package() Function
302 ------------------
303 An optional package() function can be specified in addition to the build()
304 function. This function is run after the build() and check() functions. The
305 function is run in `bash -e` mode, meaning any command that exits with a
306 non-zero status will cause the function to exit. When specified in combination
307 with the fakeroot BUILDENV option in linkman:makepkg.conf[5], fakeroot usage
308 will be limited to running the packaging stage. An existing build() function
309 will be run as the user calling makepkg.
311 Package Splitting
312 -----------------
313 makepkg supports building multiple packages from a single PKGBUILD. This is
314 achieved by assigning an array of package names to the `pkgname` directive.
315 Each split package uses a corresponding packaging function with name
316 `package_foo()`, where `foo` is the name of the split package.
318 All options and directives for the split packages default to the global values
319 given in the PKGBUILD. Nevertheless, the following ones can be overridden within
320 each split package's packaging function:
321 `pkgver`, `pkgrel`, `epoch`, `pkgdesc`, `arch`, `license`, `groups`, `depends`,
322 `optdepends`, `provides`, `conflicts`, `replaces`, `backup`, `options`,
323 `install` and `changelog`.
325 An optional global directive is available when building a split package:
327 *pkgbase*::
328         The name used to refer to the group of packages in the output of makepkg
329         and in the naming of source-only tarballs.  If not specified, the first
330         element in the `pkgname` array is used.  The variable is not allowed to
331         begin with a hyphen.
333 Install/Upgrade/Remove Scripting
334 --------------------------------
335 Pacman has the ability to store and execute a package-specific script when it
336 installs, removes, or upgrades a package. This allows a package to configure
337 itself after installation and perform an opposite action upon removal.
339 The exact time the script is run varies with each operation, and should be
340 self-explanatory. Note that during an upgrade operation, none of the install
341 or remove scripts will be called.
343 Scripts are passed either one or two ``full version strings'', where a full
344 version string is either 'pkgver-pkgrel' or 'epoch:pkgver-pkgrel' if epoch is
345 non-zero.
347 *pre_install*::
348         Run right before files are extracted. One argument is passed:
349         new package full version string.
351 *post_install*::
352         Run right after files are extracted. One argument is passed:
353         new package full version string.
355 *pre_upgrade*::
356         Run right before files are extracted. Two arguments are passed in this
357         order: new package full version string, old package full version string.
359 *post_upgrade*::
360         Run after files are extracted. Two arguments are passed in this order:
361         new package full version string, old package full version string.
363 *pre_remove*::
364         Run right before files are removed. One argument is passed:
365         old package full version string.
367 *post_remove*::
368         Run right after files are removed. One argument is passed:
369         old package full version string.
371 To use this feature, create a file such as 'pkgname.install' and put it in the
372 same directory as the PKGBUILD script. Then use the install directive:
374         install=pkgname.install
376 The install script does not need to be specified in the source array. A
377 template install file is available in '{pkgdatadir}' as 'proto.install' for
378 reference with all of the available functions defined.
381 Development Directives
382 ----------------------
383 makepkg supports building development versions of packages without having to
384 manually update the pkgver in the PKGBUILD. This was formerly done using the
385 separate utility 'versionpkg'. In order to utilize this functionality, your
386 PKGBUILD must use correct variable names depending on the SCM being fetched
387 from (e.g., 'makepkg-git', 'mplayer-svn').
389 *CVS*::
390         The generated pkgver will be the date the package is built.
392         *_cvsroot*;;
393                 The root of the CVS repository.
395         *_cvsmod*;;
396                 The CVS module to fetch.
398 *SVN*::
399         The generated pkgver will be the latest SVN revision number.
401         *_svntrunk*;;
402                 The trunk of the SVN repository.
404         *_svnmod*;;
405                 The SVN module to fetch.
407 *Git*::
408         The generated pkgver will be the date the package is built.
410         *_gitroot*;;
411                 The URL (all protocols supported) to the GIT repository.
413         *_gitname*;;
414                 GIT tag or branch to use.
416 *Mercurial*::
417         The generated pkgver will be the hg tip revision number.
419         *_hgroot*;;
420                 The URL of the mercurial repository.
422         *_hgrepo*;;
423                 The repository to follow.
425 *Darcs*::
426         The generated pkgver will be the date the package is built.
428         *_darcstrunk*;;
429                 URL to the repository trunk.
431         *_darcsmod*;;
432                 Darcs module to use.
434 *Bazaar*::
435         The generated pkgver will be the latest Bazaar revision number (revno).
437         *_bzrtrunk*;;
438                 URL to the bazaar repository.
440         *_bzrmod*;;
441                 Bazaar module to use.
444 Example
445 -------
446 The following is an example PKGBUILD for the 'patch' package. For more
447 examples, look through the build files of your distribution's packages. For
448 those using Arch Linux, consult the ABS tree.
450 [source,sh]
451 -------------------------------
452 include::PKGBUILD-example.txt[]
453 -------------------------------
455 See Also
456 --------
457 linkman:makepkg[8], linkman:pacman[8], linkman:makepkg.conf[5]
459 include::footer.txt[]