Rename pmdelta_t to alpm_delta_t
[pacman-ng.git] / PKGBUILD.proto
blob98172d8db8b1f606100e20c1b710b2575ce5ab9b
1 # This is an example PKGBUILD file. Use this as a start to creating your own,
2 # and remove these comments. For more information, see 'man PKGBUILD'.
3 # NOTE: Please fill out the license field for your package! If it is unknown,
4 # then please put 'unknown'.
6 # Maintainer: Your Name <youremail@domain.com>
7 pkgname=NAME
8 pkgver=VERSION
9 pkgrel=1
10 epoch=
11 pkgdesc=""
12 arch=()
13 url=""
14 license=('GPL')
15 groups=()
16 depends=()
17 makedepends=()
18 checkdepends=()
19 optdepends=()
20 provides=()
21 conflicts=()
22 replaces=()
23 backup=()
24 options=()
25 install=
26 changelog=
27 source=($pkgname-$pkgver.tar.gz)
28 noextract=()
29 md5sums=() #generate with 'makepkg -g'
31 build() {
32   cd "$srcdir/$pkgname-$pkgver"
33   ./configure --prefix=/usr
34   make
37 check() {
38   cd "$srcdir/$pkgname-$pkgver"
39   make -k check
42 package() {
43   cd "$srcdir/$pkgname-$pkgver"
44   make DESTDIR="$pkgdir/" install
47 # vim:set ts=2 sw=2 et: