Prototype disk space checking functionality
[pacman-ng.git] / PKGBUILD-split.proto
blobf5114ab76703c2ff22449e8316ac27b2df9ac547
1 # This is an example of a PKGBUILD for splitting packages. Use this as a
2 # start to creating your own, and remove these comments. For more information,
3 # see 'man PKGBUILD'. NOTE: Please fill out the license field for your package!
4 # If it is unknown, then please put 'unknown'.
6 # Maintainer: Your Name <youremail@domain.com>
7 pkgname=('pkg1' 'pkg2')
8 pkgbase=BASE
9 pkgver=VERSION
10 pkgrel=1
11 epoch=
12 pkgdesc=""
13 arch=()
14 url=""
15 license=('GPL')
16 groups=()
17 depends=()
18 makedepends=()
19 provides=()
20 conflicts=()
21 replaces=()
22 backup=()
23 options=()
24 install=
25 changelog=
26 source=($pkgbase-$pkgver.tar.gz)
27 noextract=()
28 md5sums=() #generate with 'makepkg -g'
30 build() {
31   cd "$srcdir/$pkgbase-$pkgver"
32   ./configure --prefix=/usr
33   make
36 package_pkg1() {
37   # options and directives that can be overridden
38   pkgver=
39   pkgrel=
40   pkgdesc=""
41   arch=()
42   license=()
43   groups=()
44   depends=()
45   optdepends=()
46   provides=()
47   conflicts=()
48   replaces=()
49   backup=()
50   options=()
51   install=
52   changelog=
54   cd "$srcdir/$pkgbase-$pkgver"
55   make DESTDIR="$pkgdir/" install-pkg1
58 package_pkg2() {
59   # options and directives overrides
60   pkgdesc=""
62   cd "$srcdir/$pkgbase-$pkgver"
63   make DESTDIR="$pkgdir/" install-pkg2