Always specify arguement type in function delcarations
[pacman-ng.git] / PKGBUILD.proto
blob71dbc14d568414c23c2c81963507291e3ca280df
1 # This is an example PKGBUILD file. Use this as a start to creating your own,
2 # and remove these comments. For more information, see 'man PKGBUILD'.
3 # NOTE: Please fill out the license field for your package! If it is unknown,
4 # then please put 'unknown'.
6 # Maintainer: Your Name <youremail@domain.com>
7 pkgname=NAME
8 pkgver=VERSION
9 pkgrel=1
10 epoch=
11 pkgdesc=""
12 arch=()
13 url=""
14 license=('GPL')
15 groups=()
16 depends=()
17 makedepends=()
18 optdepends=()
19 provides=()
20 conflicts=()
21 replaces=()
22 backup=()
23 options=()
24 install=
25 changelog=
26 source=($pkgname-$pkgver.tar.gz)
27 noextract=()
28 md5sums=() #generate with 'makepkg -g'
30 build() {
31   cd "$srcdir/$pkgname-$pkgver"
33   ./configure --prefix=/usr
34   make
37 package() {
38   cd "$srcdir/$pkgname-$pkgver"
40   make DESTDIR="$pkgdir/" install
43 # vim:set ts=2 sw=2 et: