Update pactest to use hashlib
[pacman-ng.git] / PKGBUILD-split.proto
blob35fb22b906eb4e7d6c26857340f6780ecf0ffbad
1 # This is an example of a PKGBUILD for splitting packages. Use this as a
2 # start to creating your own, and remove these comments. For more information,
3 # see 'man PKGBUILD'. NOTE: Please fill out the license field for your package!
4 # If it is unknown, then please put 'unknown'.
6 # Contributor: Your Name <youremail@domain.com>
7 pkgname=('pkg1' 'pkg2')
8 pkgver=VERSION
9 pkgrel=1
10 pkgdesc=""
11 arch=()
12 url=""
13 license=('GPL')
14 groups=()
15 depends=()
16 makedepends=()
17 provides=()
18 conflicts=()
19 replaces=()
20 backup=()
21 options=()
22 install=
23 source=($pkgname-$pkgver.tar.gz)
24 noextract=()
25 md5sums=() #generate with 'makepkg -g'
27 build() {
28   cd "$srcdir/$pkgname-$pkgver"
29   ./configure --prefix=/usr
30   make || return 1
33 package_pkg1() {
34   # options and directives that can be overridden
35   pkgdesc=""
36   license=()
37   groups=()
38   depends=()
39   optdepends=()
40   provides=()
41   conflicts=()
42   replaces=()
43   backup=()
44   options=()
45   install=
47   make DESTDIR="$pkgdir/" install-pkg1
50 package_pkg2() {
51   # options and directives overrides
52   pkgdesc=""
54   make DESTDIR="$pkgdir/" install-pkg2