doc/PKGBUILD: document libdeps
[pacman-ng.git] / doc / PKGBUILD.5.txt
blobb9b7855bde7e48d52eace594c098223148a6af05
1 /////
2 vim:set ts=4 sw=4 syntax=asciidoc noet:
3 /////
4 PKGBUILD(5)
5 ===========
7 Name
8 ----
9 PKGBUILD - Arch Linux package build description file
12 Synopsis
13 --------
14 PKGBUILD
17 Description
18 -----------
19 This manual page is meant to describe general rules about PKGBUILDs. Once a
20 PKGBUILD is written, the actual package is built using makepkg and installed
21 with pacman.
23 NOTE: An example PKGBUILD, useful for reference, is located in '{pkgdatadir}'.
24 Also located there are other example files such as a ChangeLog and an install
25 script. You can copy the provided PKGBUILD.proto file to a new package build
26 directory and make customizations to suit your needs.
29 Options and Directives
30 ----------------------
31 The following is a list of standard options and directives available for use
32 in a PKGBUILD. These are all understood and interpreted by makepkg, and most
33 will be directly transferred to the built package.
35 If you need to create any custom variables for use in your build process, it is
36 recommended to name your custom variables with an '_' (underscore) prefix.
37 This will prevent any possible name clashes with internal makepkg variables.
38 For example, to store the base kernel version in a variable, use something
39 similar to `$_basekernver`.
41 *pkgname (array)*::
42         The name of the package. This has be a unix-friendly name as it will be
43         used in the package filename. Members of the array are not allowed to start
44         with hyphens.
46 *pkgver*::
47         The version of the software as released from the author (e.g. '2.7.1').
48         The variable is not allowed to contain colons or hyphens.
50 *pkgrel*::
51         This is the release number specific to the Arch Linux release. This
52         allows package maintainers to make updates to the package's configure
53         flags, for example. A pkgrel of '1' is typically used for each upstream
54         software release and is incremented for intermediate PKGBUILD updates. The
55         variable is not allowed to contain hyphens.
57 *pkgdesc*::
58         This should be a brief description of the package and its functionality.
59         Try to keep the description to one line of text.
61 *epoch*::
62         Used to force the package to be seen as newer than any previous versions
63         with a lower epoch, even if the version number would normally not trigger
64         such an upgrade. This value is required to be a positive integer; the
65         default value if left unspecified is '0'. This is useful when the version
66         numbering scheme of a package changes (or is alphanumeric), breaking normal
67         version comparison logic. See linkman:pacman[8] for more information on
68         version comparisons.
70 *url*::
71         This field contains a URL that is associated with the software being
72         packaged. This is typically the project's website.
74 *license (array)*::
75         This field specifies the license(s) that apply to the package.
76         Commonly-used licenses are found in '/usr/share/licenses/common'. If you
77         see the package's license there, simply reference it in the license
78         field (e.g. `license=('GPL')`). If the package provides a license not
79         found in '/usr/share/licenses/common', then you should include the license
80         in the package itself and set `license=('custom')` or
81         `license=('custom:LicenseName')`. The license should be placed in
82         '$pkgdir/usr/share/licenses/$pkgname' when building the package. If
83         multiple licenses are applicable for a package, list all of them:
84         `license=('GPL' 'FDL')`.
86 *install*::
87         Specifies a special install script that is to be included in the package.
88         This file should reside in the same directory as the PKGBUILD, and will
89         be copied into the package by makepkg. It does not need to be included
90         in the source array (e.g. `install=pkgname.install`).
92 *changelog*::
93         Specifies a changelog file that is to be included in the package.
94         This file should reside in the same directory as the PKGBUILD, and will
95         be copied into the package by makepkg. It does not need to be included
96         in the source array (e.g. `changelog=$pkgname.changelog`).
98 *source (array)*::
99         An array of source files required to build the package. Source files
100         must either reside in the same directory as the PKGBUILD file, or be a
101         fully-qualified URL that makepkg will use to download the file. In order
102         to make the PKGBUILD as useful as possible, use the $pkgname and $pkgver
103         variables if possible when specifying the download location. Any files
104         that are compressed will automatically be extracted, unless found in
105         the noextract array listed below.
107 It is also possible to specify an optional filename, which is helpful
108 with weird URLs and for handling multiple source files with the same
109 name. The syntax is: `source=('filename::url')`.
111 *noextract (array)*::
112         An array of filenames corresponding to those from the source array. Files
113         listed here will not be extracted with the rest of the source files. This
114         is useful for packages which use compressed data which is downloaded but
115         not necessary to uncompress.
117 *md5sums (array)*::
118         This array contains an MD5 hash for every source file specified in the
119         source array (in the same order). makepkg will use this to verify source
120         file integrity during subsequent builds. To easily generate md5sums, run
121         ``makepkg -g >> PKGBUILD''. If desired, move the md5sums line to an
122         appropriate location.
124 *sha1sums, sha256sums, sha384sums, sha512sums (arrays)*::
125         Alternative integrity checks that makepkg supports; these all behave
126         similar to the md5sums option described above. To enable use and generation
127         of these checksums, be sure to set up the `INTEGRITY_CHECK` option in
128         linkman:makepkg.conf[5].
130 *groups (array)*::
131         An array of symbolic names that represent groups of packages, allowing
132         you to install multiple packages by requesting a single target. For
133         example, one could install all KDE packages by installing the 'kde' group.
135 *arch (array)*::
136         Defines on which architectures the given package is available (e.g.
137         `arch=('i686' 'x86_64')`). Packages that contain no architecture specific
138         files may use arch=('any').
140 *backup (array)*::
141         A space-delimited array of filenames, without preceding slashes, that
142         should be backed up if the package is removed or upgraded. This is
143         commonly used for packages placing configuration files in /etc. See
144         Handling Config Files in linkman:pacman[8] for more information.
146 *depends (array)*::
147         An array of packages that this package depends on to run. Packages in
148         this list should be surrounded with single quotes and contain at least
149         the package name. Entries can also include a version requirement of the
150         form 'name<>version', where <> is one of five comparisons: >= (greater
151         than or equal to), <= (less than or equal to), = (equal to), > (greater
152         than), or < (less than).
154 If the dependency name appears to be a library (ends with .so), makepkg will
155 try to find a binary that depends on the library in the built package and
156 append the version needed by the binary. Appending the version yourself
157 disables auto detection.
159 *makedepends (array)*::
160         An array of packages that this package depends on to build, but are not
161         needed at runtime. Packages in this list follow the same format as
162         depends.
164 *checkdepends (array)*::
165         An array of packages that this package depends on to run its test suite,
166         but are not needed at runtime. Packages in this list follow the same
167         format as depends. These dependencies are only considered when the
168         check() function is present and is to be run by makepkg.
170 *optdepends (array)*::
171         An array of packages (and accompanying reasons) that are not essential for
172         base functionality, but may be necessary to make full use of the contents
173         of this package. optdepends are currently for informational purposes only
174         and are not utilized by pacman during dependency resolution. The format
175         for specifying optdepends is:
177         optdepends=('fakeroot: for makepkg usage as normal user')
179 *conflicts (array)*::
180         An array of packages that will conflict with this package (i.e. they
181         cannot both be installed at the same time). This directive follows the
182         same format as depends. Versioned conflicts are also supported.
184 *provides (array)*::
185         An array of ``virtual provisions'' that this package provides. This allows
186         a package to provide dependencies other than its own package name. For
187         example, the dcron package can provide 'cron', which allows packages to
188         depend on 'cron' rather than 'dcron OR fcron'.
189         Versioned provisions are also possible, in the 'name=version' format.
190         For example, dcron can provide 'cron=2.0' to satisfy the 'cron>=2.0'
191         dependency of other packages. Provisions involving the '>' and '<'
192         operators are invalid as only specific versions of a package may be
193         provided.
195 If the provision name appears to be a library (ends with .so), makepkg will
196 try to find the library in the built package and append the correct
197 version. Appending the version yourself disables auto detection.
199 *replaces (array)*::
200         An array of packages that this package should replace, and can be used
201         to handle renamed/combined packages. For example, if the 'j2re' package
202         is renamed to 'jre', this directive allows future upgrades to continue
203         as expected even though the package has moved. Sysupgrade is currently
204         the only pacman operation that utilizes this field, a normal sync will
205         not use its value.
207 *options (array)*::
208         This array allows you to override some of makepkg's default behavior
209         when building packages. To set an option, just include the option name
210         in the options array. To reverse the default behavior, place an ``!'' at
211         the front of the option. Only specify the options you specifically want
212         to override, the rest will be taken from linkman:makepkg.conf[5].
213         *NOTE:* 'force' is a now-removed option in favor of the top level 'epoch'
214         variable.
216         *strip*;;
217                 Strip symbols from binaries and libraries. If you frequently
218                 use a debugger on programs or libraries, it may be helpful to
219                 disable this option.
221         *docs*;;
222                 Save doc directories. If you wish to delete doc directories,
223                 specify `!docs` in the array.
225         *libtool*;;
226                 Leave libtool (.la) files in packages. Specify `!libtool` to
227                 remove them.
229         *emptydirs*;;
230                 Leave empty directories in packages.
232         *zipman*;;
233                 Compress man and info pages with gzip.
235         *ccache*;;
236                 Allow the use of ccache during build. More useful in its negative
237                 form `!ccache` with select packages that have problems building
238                 with ccache.
240         *distcc*;;
241                 Allow the use of distcc during build. More useful in its negative
242                 form `!distcc` with select packages that have problems building
243                 with distcc.
245         *buildflags*;;
246                 Allow the use of user-specific buildflags (CFLAGS, CXXFLAGS, LDFLAGS)
247                 during build as specified in linkman:makepkg.conf[5]. More useful in
248                 its negative form `!buildflags` with select packages that have problems
249                 building with custom buildflags.
251         *makeflags*;;
252                 Allow the use of user-specific makeflags during build as specified
253                 in linkman:makepkg.conf[5]. More useful in its negative form
254                 `!makeflags` with select packages that have problems building with
255                 custom makeflags such as `-j2` (or higher).
258 build() Function
259 ----------------
260 In addition to the above directives, the optional build() bash function usually
261 comprises the remainder of the PKGBUILD. This is directly sourced and executed
262 by makepkg, so anything that bash or the system has available is available for
263 use here. The function is run in `bash -e` mode, meaning any command that exits
264 with a non-zero status will cause the function to exit. Be sure any exotic
265 commands used are covered by `makedepends`.
267 All of the above variables such as `pkgname` and `pkgver` are available for use
268 in the build function. In addition, makepkg defines three variables for your
269 use during the build and install process. These three variables are as follows:
271 *startdir*::
272         This contains the absolute path to the directory where the PKGBUILD was
273         located, which is usually the output of `$(pwd)` when makepkg is started.
275 *srcdir*::
276         This points to the directory where makepkg extracts or copies all source
277         files.
279 *pkgdir*::
280         This points to the directory where makepkg bundles the installed package
281         (this directory will become the root directory of your built package).
283 If you create any variables of your own in the build function, it is
284 recommended to use the bash `local` keyword to scope the variable to inside
285 the build function.
287 check() Function
288 ----------------
289 An optional check() function can be specified in which a packages test-suite
290 may be run. This function is run between the build() and package() functions.
291 The function is run in `bash -e` mode, meaning any command that exits with a
292 non-zero status will cause the function to exit. Be sure any exotic commands
293 used are covered by `checkdepends`.
295 package() Function
296 ------------------
297 An optional package() function can be specified in addition to the build()
298 function. This function is run after the build() and check() functions. The
299 function is run in `bash -e` mode, meaning any command that exits with a
300 non-zero status will cause the function to exit. When specified in combination
301 with the fakeroot BUILDENV option in linkman:makepkg.conf[5], fakeroot usage
302 will be limited to running the packaging stage. An existing build() function
303 will be run as the user calling makepkg.
305 Package Splitting
306 -----------------
307 makepkg supports building multiple packages from a single PKGBUILD. This is
308 achieved by assigning an array of package names to the `pkgname` directive.
309 Each split package uses a corresponding packaging function with name
310 `package_foo()`, where `foo` is the name of the split package.
312 All options and directives for the split packages default to the global values
313 given within the PKGBUILD. However, some of these can be overridden within each
314 split package's packaging function. The following variables can be overridden:
315 `pkgver`, `pkgrel`, `pkgdesc`, `arch`, `license`, `groups`, `depends`,
316 `optdepends`, `provides`, `conflicts`, `replaces`, `backup`, `options`,
317 `install` and `changelog`.
319 An optional global directive is available when building a split package:
321 *pkgbase*::
322         The name used to refer to the group of packages in the output of makepkg
323         and in the naming of source-only tarballs.  If not specified, the first
324         element in the `pkgname` array is used.  The variable is not allowed to
325         begin with a hyphen.
327 Install/Upgrade/Remove Scripting
328 --------------------------------
329 Pacman has the ability to store and execute a package-specific script when it
330 installs, removes, or upgrades a package. This allows a package to configure
331 itself after installation and perform an opposite action upon removal.
333 The exact time the script is run varies with each operation:
335 *pre_install*::
336         script is run right before files are extracted. One argument is passed:
337         new package version.
339 *post_install*::
340         script is run right after files are extracted. One argument is passed:
341         new package version.
343 *pre_upgrade*::
344         script is run right before files are extracted. Two arguments are passed
345         in the following order: new package version, old package version.
347 *post_upgrade*::
348         script is run after files are extracted. Two arguments are passed
349         in the following order: new package version, old package version.
351 *pre_remove*::
352         script is run right before files are removed. One argument is passed:
353         old package version.
355 *post_remove*::
356         script is run right after files are removed. One argument is passed:
357         old package version.
359 To use this feature, create a file such as 'pkgname.install' and put it in the
360 same directory as the PKGBUILD script. Then use the install directive:
362         install=pkgname.install
364 The install script does not need to be specified in the source array. A
365 template install file is available in '{pkgdatadir}' as 'proto.install' for
366 reference with all of the available functions defined.
369 Development Directives
370 ----------------------
371 makepkg supports building development versions of packages without having to
372 manually update the pkgver in the PKGBUILD. This was formerly done using the
373 separate utility 'versionpkg'. In order to utilize this functionality, your
374 PKGBUILD must use correct variable names depending on the SCM being fetched
375 from.
377 *CVS*::
378         The generated pkgver will be the date the package is built.
380         *_cvsroot*;;
381                 The root of the CVS repository.
383         *_cvsmod*;;
384                 The CVS module to fetch.
386 *SVN*::
387         The generated pkgver will be the latest SVN revision number.
389         *_svntrunk*;;
390                 The trunk of the SVN repository.
392         *_svnmod*;;
393                 The SVN module to fetch.
395 *Git*::
396         The generated pkgver will be one formatted by the 'git-describe'
397         command, with '-' characters converted to '_' characters.
399         *_gitroot*;;
400                 The URL (all protocols supported) to the GIT repository.
402         *_gitname*;;
403                 GIT tag or branch to use.
405 *Mercurial*::
406         The generated pkgver will be the hg tip revision number.
408         *_hgroot*;;
409                 The URL of the mercurial repository.
411         *_hgrepo*;;
412                 The repository to follow.
414 *Darcs*::
415         The generated pkgver will be the date the package is built.
417         *_darcstrunk*;;
418                 URL to the repository trunk.
420         *_darcsmod*;;
421                 Darcs module to use.
423 *Bazaar*::
424         The generated pkgver will be the latest Bazaar revision number (revno).
426         *_bzrtrunk*;;
427                 URL to the bazaar repository.
429         *_bzrmod*;;
430                 Bazaar module to use.
433 Example
434 -------
435 The following is an example PKGBUILD for the 'patch' package. For more
436 examples, look through the build files of your distribution's packages. For
437 those using Arch Linux, consult the ABS tree.
439 [source,sh]
440 -------------------------------
441 include::PKGBUILD-example.txt[]
442 -------------------------------
444 See Also
445 --------
446 linkman:makepkg[8], linkman:pacman[8], linkman:makepkg.conf[5]
448 include::footer.txt[]