makepkg: run tidy_install with no package() function
[pacman-ng.git] / PKGBUILD.proto
blobeddcf7599d4cb1f14f5743543bfacffe5fbebc6b
1 # This is an example PKGBUILD file. Use this as a start to creating your own,
2 # and remove these comments. For more information, see 'man PKGBUILD'.
3 # NOTE: Please fill out the license field for your package! If it is unknown,
4 # then please put 'unknown'.
6 # Contributor: Your Name <youremail@domain.com>
7 pkgname=NAME
8 pkgver=VERSION
9 pkgrel=1
10 pkgdesc=""
11 arch=()
12 url=""
13 license=('GPL')
14 groups=()
15 depends=()
16 makedepends=()
17 optdepends=()
18 provides=()
19 conflicts=()
20 replaces=()
21 backup=()
22 options=()
23 install=
24 source=($pkgname-$pkgver.tar.gz)
25 noextract=()
26 md5sums=() #generate with 'makepkg -g'
28 build() {
29   cd "$srcdir/$pkgname-$pkgver"
31   ./configure --prefix=/usr
32   make || return 1
33   make DESTDIR="$pkgdir/" install
36 # vim:set ts=2 sw=2 et: