Rename pmgrp_t to alpm_group_t
[pacman-ng.git] / PKGBUILD-split.proto
blob52aacc545576360028f1e562ef1f31c9cba65d4b
1 # This is an example of a PKGBUILD for splitting packages. Use this as a
2 # start to creating your own, and remove these comments. For more information,
3 # see 'man PKGBUILD'. NOTE: Please fill out the license field for your package!
4 # If it is unknown, then please put 'unknown'.
6 # Maintainer: Your Name <youremail@domain.com>
7 pkgname=('pkg1' 'pkg2')
8 pkgbase=BASE
9 pkgver=VERSION
10 pkgrel=1
11 epoch=
12 pkgdesc=""
13 arch=()
14 url=""
15 license=('GPL')
16 groups=()
17 depends=()
18 makedepends=()
19 checkdepends=()
20 provides=()
21 conflicts=()
22 replaces=()
23 backup=()
24 options=()
25 install=
26 changelog=
27 source=($pkgbase-$pkgver.tar.gz)
28 noextract=()
29 md5sums=() #generate with 'makepkg -g'
31 build() {
32   cd "$srcdir/$pkgbase-$pkgver"
33   ./configure --prefix=/usr
34   make
37 check() {
38   cd "$srcdir/$pkgname-$pkgver"
39   make -k check
42 package_pkg1() {
43   # options and directives that can be overridden
44   pkgver=
45   pkgrel=
46   pkgdesc=""
47   arch=()
48   license=()
49   groups=()
50   depends=()
51   optdepends=()
52   provides=()
53   conflicts=()
54   replaces=()
55   backup=()
56   options=()
57   install=
58   changelog=
60   cd "$srcdir/$pkgbase-$pkgver"
61   make DESTDIR="$pkgdir/" install-pkg1
64 package_pkg2() {
65   # options and directives overrides
66   pkgdesc=""
68   cd "$srcdir/$pkgbase-$pkgver"
69   make DESTDIR="$pkgdir/" install-pkg2