net-dialup/wvdial/files/wvdial-1.60-glibc-2.10.1.patch: fix patch
[otih-overlay.git] / net-dialup / wvdial / wvdial-1.60-r1.ebuild
blob448c97e49a198bdabeb2dc073352b396a1ffc6a5
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/net-dialup/wvdial/wvdial-1.60.ebuild,v 1.8 2008/12/14 16:33:50 loki_val Exp $
5 inherit eutils
7 DESCRIPTION="Excellent program to automatically configure PPP sessions"
8 HOMEPAGE="http://alumnit.ca/wiki/?WvDial"
9 SRC_URI="http://alumnit.ca/download/${P}.tar.gz"
11 LICENSE="LGPL-2"
12 SLOT="0"
13 KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
14 IUSE=""
16 COMMON_DEPEND=">=net-libs/wvstreams-4.4"
17 DEPEND="${COMMON_DEPEND}
18 dev-util/pkgconfig"
19 RDEPEND="${COMMON_DEPEND}
20 net-dialup/ppp"
22 src_unpack() {
23 unpack ${A}
24 cd "${S}"
25 epatch "${FILESDIR}/${P}-destdir.patch"
26 epatch "${FILESDIR}/${P}-as-needed.patch"
27 epatch "${FILESDIR}/${P}-glibc-2.10.1.patch"
30 src_install() {
31 make "DESTDIR=${D}" install || die "make install failed"
33 dodoc CHANGES FAQ MENUS README TODO
36 pkg_postinst() {
37 elog
38 elog "Use wvdialconf to automagically generate a configuration file."
39 elog
40 elog "Users have to be member of the dialout AND the uucp group"
41 elog "to use wvdial!"
42 elog