ThirdParty: Add gcc 4.6.4. Switch to cmake 2.8.11
[openfoam-extend-OpenFOAM-1.6-ext.git] / ThirdParty / rpmBuild / SPECS / mpc-1.0.1.spec
blob34be899a020c629e22eda4621c428730e548f4df
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | OpenFOAM: The Open Source CFD Toolbox
4 # \\ / O peration |
5 # \\ / A nd | Copyright held by original author
6 # \\/ M anipulation |
7 #------------------------------------------------------------------------------
8 # License
9 # This file is part of OpenFOAM.
11 # OpenFOAM is free software; you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation; either version 2 of the License, or (at your
14 # option) any later version.
16 # OpenFOAM is distributed in the hope that it will be useful, but WITHOUT
17 # ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
18 # FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
19 # for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with OpenFOAM; if not, write to the Free Software Foundation,
23 # Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
25 # Script
26 # RPM spec file for mpc-1.0.1
28 # Description
29 # RPM spec file for creating a relocatable RPM
31 # Author:
32 # Martin Beaudoin, Hydro-Quebec, (2010)
34 #------------------------------------------------------------------------------
36 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
37 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
38 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
40 # Disable the generation of debuginfo packages
41 %define debug_package %{nil}
43 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
44 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
45 %define _tmppath %{_topdir}/tmp
47 # Will install the package directly $WM_THIRD_PARTY_DIR
48 # Some comments about package relocation:
49 # By using this prefix for the Prefix: parameter in thi file, you will make this
50 # package relocatable.
52 # This is fine, as long as your software is itself relocatable.
54 # Simply take note that libraries built with libtool are not relocatable because the
55 # prefix we specify will be hard-coded in the library .la files.
56 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
58 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
59 # not be able to reutilize this RPM, even though it is relocatable. You will need to
60 # regenerate the RPM.
62 %define _prefix %{_WM_THIRD_PARTY_DIR}
64 %define name mpc
65 %define release %{_WM_OPTIONS}
66 %define version 1.0.1
68 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
70 BuildRoot: %{buildroot}
71 Summary: mpc
72 License: Unkown
73 Name: %{name}
74 Version: %{version}
75 Release: %{release}
76 URL: http://www.multiprecision.org/mpc/download/
77 Source: %url/%{name}-%{version}.tar.gz
78 Prefix: %{_prefix}
79 Group: Development/Tools
82 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
84 %description
85 %{summary}
87 %prep
88 %setup -q
90 %build
91 # export WM settings in a form that GNU configure recognizes
92 [ -n "$WM_CC" ] && export CC="$WM_CC"
93 [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
94 [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
95 [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
96 [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
98 GMP_VERSION=gmp-5.1.2
99 MPFR_VERSION=mpfr-3.1.2
101 ./configure \
102 --prefix=%{_installPrefix} \
103 --with-gmp=$WM_THIRD_PARTY_DIR/packages/$GMP_VERSION/platforms/$WM_OPTIONS \
104 --with-mpfr=$WM_THIRD_PARTY_DIR/packages/$MPFR_VERSION/platforms/$WM_OPTIONS
106 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
107 make -j $WM_NCOMPPROCS
109 %install
110 make install DESTDIR=$RPM_BUILD_ROOT
112 # Creation of OpenFOAM specific .csh and .sh files"
114 echo ""
115 echo "Generating OpenFOAM specific .csh and .sh files for the package %{name}-%{version}"
116 echo ""
118 # Generate package specific .sh file for OpenFOAM
120 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
121 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
122 # Load %{name}-%{version} libraries and binaries if available
123 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
125 export MPC_DIR=\$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
127 [ -d \$MPC_DIR/lib ] && _foamAddLib \$MPC_DIR/lib
129 # Enable access to the package applications if present
130 [ -d \$MPC_DIR/bin ] && _foamAddPath \$MPC_DIR/bin
131 DOT_SH_EOF
134 # Generate package specific .csh file for OpenFOAM
136 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
137 # Load %{name}-%{version} libraries and binaries if available
138 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
139 setenv MPC_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
141 if ( -e \$MPC_DIR/lib ) then
142 _foamAddLib \$MPC_DIR/lib
143 endif
145 if ( -e \$MPC_DIR/bin ) then
146 _foamAddPath \$MPC_DIR/bin
147 endif
148 DOT_CSH_EOF
150 #finally, generate a .tgz file for systems where using rpm for installing packages
151 # as a non-root user might be a problem.
152 (mkdir -p %{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
155 %clean
156 rm -rf %{buildroot}
158 %files
159 %defattr(-,root,root)
160 %{_installPrefix}/etc
161 %{_installPrefix}/include
162 %{_installPrefix}/lib
163 %{_installPrefix}/share