Fixes for gcc-4.5.1
[openfoam-extend-OpenFOAM-1.6-ext.git] / ThirdParty / rpmBuild / SPECS / gcc-4.5.1.spec
blob89e946098262e5b6c72d27359d760dc3bd7a216f
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | OpenFOAM: The Open Source CFD Toolbox
4 # \\ / O peration |
5 # \\ / A nd | Copyright held by original author
6 # \\/ M anipulation |
7 #------------------------------------------------------------------------------
8 # License
9 # This file is part of OpenFOAM.
11 # OpenFOAM is free software; you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation; either version 2 of the License, or (at your
14 # option) any later version.
16 # OpenFOAM is distributed in the hope that it will be useful, but WITHOUT
17 # ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
18 # FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
19 # for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with OpenFOAM; if not, write to the Free Software Foundation,
23 # Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
25 # Script
26 # RPM spec file for gcc-4.5.1
28 # Description
29 # RPM spec file for creating a relocatable RPM
31 # Author:
32 # Martin Beaudoin, Hydro-Quebec, (2010)
34 #------------------------------------------------------------------------------
36 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
37 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
38 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
40 # Disable the generation of debuginfo packages
41 %define debug_package %{nil}
43 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
44 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
45 %define _tmppath %{_topdir}/tmp
47 # Will install the package directly $WM_THIRD_PARTY_DIR
48 # Some comments about package relocation:
49 # By using this prefix for the Prefix: parameter in thi file, you will make this
50 # package relocatable.
52 # This is fine, as long as your software is itself relocatable.
54 # Simply take note that libraries built with libtool are not relocatable because the
55 # prefix we specify will be hard-coded in the library .la files.
56 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
58 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
59 # not be able to reutilize this RPM, even though it is relocatable. You will need to
60 # regenerate the RPM.
62 %define _prefix %{_WM_THIRD_PARTY_DIR}
64 %define name gcc
65 %define release %{_WM_OPTIONS}
66 %define version 4.5.1
68 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
70 BuildRoot: %{buildroot}
71 Summary: gcc
72 License: Unkown
73 Name: %{name}
74 Version: %{version}
75 Release: %{release}
76 URL: ftp://ftp.gnu.org/gnu/gcc/gcc-4.5.1
77 Source: %url/%{name}-%{version}.tar.gz
78 Prefix: %{_prefix}
79 Group: Development/Tools
82 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
84 %description
85 %{summary}
87 %prep
88 %setup -q
90 %build
91 # export WM settings in a form that GNU configure recognizes
92 [ -n "$WM_CC" ] && export CC="$WM_CC"
93 [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
94 [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
95 [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
96 [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
98 GMP_VERSION=gmp-5.0.1
99 MPFR_VERSION=mpfr-3.0.1
100 MPC_VERSION=mpc-0.8.2
102 mkdir ./objBuildDir
103 cd ./objBuildDir
105 ../configure \
106 --prefix=%{_installPrefix} \
107 --enable-languages=c,c++ \
108 --enable-shared \
109 --disable-multilib \
110 --with-mpc=$WM_THIRD_PARTY_DIR/packages/$MPC_VERSION/platforms/$WM_OPTIONS \
111 --with-gmp=$WM_THIRD_PARTY_DIR/packages/$GMP_VERSION/platforms/$WM_OPTIONS \
112 --with-mpfr=$WM_THIRD_PARTY_DIR/packages/$MPFR_VERSION/platforms/$WM_OPTIONS
114 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
115 make -j $WM_NCOMPPROCS
117 %install
118 cd ./objBuildDir
119 make install DESTDIR=$RPM_BUILD_ROOT
121 # Creation of OpenFOAM specific .csh and .sh files"
123 echo ""
124 echo "Generating OpenFOAM specific .csh and .sh files for the package %{name}-%{version}"
125 echo ""
127 # Generate package specific .sh file for OpenFOAM
129 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
130 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
131 # Load %{name}-%{version} libraries and binaries if available
132 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
134 export GCC_DIR=\$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
136 [ -d \$GCC_DIR/lib ] && _foamAddLib \$GCC_DIR/lib
138 # Enable access to the package applications if present
139 [ -d \$GCC_DIR/bin ] && _foamAddPath \$GCC_DIR/bin
140 DOT_SH_EOF
143 # Generate package specific .csh file for OpenFOAM
145 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
146 # Load %{name}-%{version} libraries and binaries if available
147 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
148 setenv GCC_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
150 if ( -e \$GCC_DIR/lib ) then
151 _foamAddLib \$GCC_DIR/lib
152 endif
154 if ( -e \$GCC_DIR/bin ) then
155 _foamAddPath \$GCC_DIR/bin
156 endif
157 DOT_CSH_EOF
159 #finally, generate a .tgz file for systems where using rpm for installing packages
160 # as a non-root user might be a problem.
161 (mkdir -p %{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
164 %clean
165 rm -rf %{buildroot}
167 %files
168 %defattr(-,root,root)
169 %{_installPrefix}