MINI2440: Added support for u-boot git
[openembedded/mini2440.git] / recipes / u-boot / u-boot_git.bb
blob4f9777e797dd3efa6ec54f409947c5fbaccf515a
1 require u-boot.inc
2 PR ="r30"
4 FILESPATHPKG =. "u-boot-git:"
6 SRC_URI = "git://www.denx.de/git/u-boot.git;protocol=git "
7 SRCREV_davinci-sffsdr = "4b50cd12a3b3c644153c4cf393f4a4c12289e5aa"
8 SRCREV_akita = "9bf86baaa3b35b25baa2d664e2f7f6cafad689ee"
9 SRCREV_spitz = "9bf86baaa3b35b25baa2d664e2f7f6cafad689ee"
10 SRCREV_c7x0 = "9bf86baaa3b35b25baa2d664e2f7f6cafad689ee"
11 SRCREV_afeb9260 = "6b8edfde22acc574b5532e9f086e6a7287a9bc78"
12 SRCREV_afeb9260-180 = "6b8edfde22acc574b5532e9f086e6a7287a9bc78"
13 SRC_URI_append_afeb9260 = " file://AFEB9260-network-fix.patch;patch=1"
14 SRC_URI_append_afeb9260-180 = " file://AFEB9260-network-fix.patch;patch=1"
16 SRC_URI_beagleboard = "git://gitorious.org/u-boot-omap3/mainline.git;branch=omap3-dev;protocol=git \
17 file://fw-env.patch;patch=1 \
18 file://dss2.patch;patch=1 \
19 file://new-pinmux.patch;patch=1 \
21 SRCREV_beagleboard = "d363f9cb0918a1b6b92e2e20d01543d0c4f53274"
22 PV_beagleboard = "2009.05+${PR}+gitr${SRCREV}"
24 SRC_URI_omap3-touchbook = "git://gitorious.org/u-boot-omap3/mainline.git;branch=omap3-dev;protocol=git \
25 file://fw-env.patch;patch=1 \
26 file://dss2.patch;patch=1 \
27 file://spi3.patch;patch=1 \
28 file://spi4.patch;patch=1 \
29 file://headphone.patch;patch=1 \
31 SRCREV_omap3-touchbook = "d363f9cb0918a1b6b92e2e20d01543d0c4f53274"
32 PV_omap3-touchbook = "2009.05+${PR}+gitr${SRCREV}"
35 SRC_URI_omap3evm = "git://gitorious.org/u-boot-omap3/mainline.git;branch=omap3-dev;protocol=git"
36 SRCREV_omap3evm = "2dea1db2a3b7c12ed70bbf8ee50755089c5e5170"
37 PV_omap3evm = "2009.03+${PR}+gitr${SRCREV}"
40 SRCREV_omap3517-evm = "e60beb13cf0"
41 SRC_URI_append_omap3517-evm = " \
42 file://omap3evm/0001-Changes-for-making-a-NAND-build.patch;patch=1 \
43 file://omap3evm/0002-Fix-for-NFS-boot-for-OMAP3-EVM.patch;patch=1 \
44 file://omap3evm/0003-OMAP3-timer-handling-to-1ms-tick-and-CONFIG_SYS_HZ-t.patch;patch=1 \
45 file://omap3evm/0004-Reverse-patch-for-NFS-boot-to-fix-comments-provided.patch;patch=1 \
46 file://omap3evm/0005-SMC911x-driver-fixed-for-NFS-boot.patch;patch=1 \
47 file://omap3evm/0006-Added-OMAP3517-3505-support.patch;patch=1 \
48 file://omap3evm/0007-OMAP3517TEB-validated-on-OMAP3517TEB-board.patch;patch=1 \
49 file://omap3evm/0008-OMAP3517PRE-ALPHA-validated-on-OMAP3517PRE_ALPHA-bo.patch;patch=1 \
50 file://omap3evm/0009-OMAP3517PRE-ALPHA-DDR-size-issue-fixed.patch;patch=1 \
51 file://omap3evm/0010-OMAP3517PRE-ALPHA-Mux-configuration-for-MMC-CD-and.patch;patch=1 \
52 file://omap3evm/0011-Ethernet-driver-functional-no-need-for-time-delay.patch;patch=1 \
53 file://omap3evm/0012-EMAC-driver-Implement-GPIO-driven-PHY-reset.patch;patch=1 \
54 file://omap3evm/0013-Cleaned-up-during-EVM-hang-issue.patch;patch=1 \
55 file://omap3evm/0014-EMAC-driver-cleanup-removed-debug-prints.patch;patch=1 \
56 file://omap3evm/0015-EMAC-driver-Check-for-link-status-in-packet-send-lo.patch;patch=1 \
57 file://omap3evm/0016-Config-option-and-name-changed-to-omap3517_evm.patch;patch=1 \
59 PV_omap3517-evm = "2009.03+${PR}+gitr${SRCREV}"
61 SRC_URI_omapzoom = "git://www.sakoman.net/git/u-boot-omap3.git;branch=omap3-dev;protocol=git"
62 SRCREV_omapzoom = "d691b424f1f5bf7eea3a4131dfc578d272e8f335"
63 PV_omapzoom = "2009.01+${PR}+gitr${SRCREV}"
65 SRCREV_omapzoom2 = "3672cd5c3b53d219d33345eebad4e25ad5bf6d52"
66 PV_omapzoom2 = "2009.05+${PR}+gitr${SRCREV}"
68 SRC_URI_overo = "git://gitorious.org/u-boot-omap3/mainline.git;branch=omap3-dev;protocol=git \
69 file://fw-env.patch;patch=1 \
70 file://dss2.patch;patch=1 \
72 SRCREV_overo = "2dea1db2a3b7c12ed70bbf8ee50755089c5e5170"
73 PV_overo = "2009.03+${PR}+gitr${SRCREV}"
75 SRC_URI_dm6446-evm = "git://arago-project.org/git/projects/u-boot-davinci.git;protocol=git"
76 SRCREV_dm6446-evm = "f8d047c84137ab331c0ee2c3e94c3f1ec4228298"
77 PV_dm6446-evm = "2009.05+2009.06-rc0+gitr${SRCREV}"
79 SRC_URI_dm355-evm = "git://arago-project.org/git/projects/u-boot-davinci.git;protocol=git"
80 SRCREV_dm355-evm = "5ae613482c9468386872cedd46f8fb389f19859d"
81 PV_dm355-evm = "2009.08+gitr${SRCREV}"
83 SRC_URI_dm365-evm = "git://arago-project.org/git/projects/u-boot-davinci.git;protocol=git"
84 SRCREV_dm365-evm = "5ae613482c9468386872cedd46f8fb389f19859d"
85 PV_dm365-evm = "2009.08+gitr${SRCREV}"
87 SRC_URI_dm6467-evm = "git://arago-project.org/git/people/hemant/u-boot-dm646x.git;protocol=git"
88 SRCREV_dm6467-evm = "3da7475ae13445ba89c77ea563ccdfb9df540bb7"
89 PV_dm6467-evm = "2009.08+gitr${SRCREV}"
91 SRC_URI_dm6467t-evm = "git://arago-project.org/git/people/hemant/u-boot-dm646x.git;protocol=git"
92 SRCREV_dm6467t-evm = "3da7475ae13445ba89c77ea563ccdfb9df540bb7"
93 PV_dm6467t-evm = "2009.08+gitr${SRCREV}"
95 SRC_URI_da830-omapl137-evm = "git://arago-project.org/git/people/sekhar/u-boot-omapl1.git;protocol=git;branch=wakeup"
96 SRCREV_da830-omapl137-evm = "04a03bb477ad842b84c61b29f11422089ad0088d"
97 PV_da830-omapl137-evm = "2009.01+gitr${SRCREV}"
99 SRC_URI_da850-omapl138-evm = "git://arago-project.org/git/people/sekhar/u-boot-omapl1.git;protocol=git;branch=wakeup"
100 SRCREV_da850-omapl138-evm = "04a03bb477ad842b84c61b29f11422089ad0088d"
101 PV_da850-omapl138-evm = "2009.01+gitr${SRCREV}"
103 SRC_URI_dm355-leopard = "git://www.denx.de/git/u-boot-arm.git;protocol=git;branch=next \
104 file://leopardboard-support.patch;patch=1 \
106 SRCREV_dm355-leopard = "86d5c98d3d97d631b1d3a5f5e6a17e87c99b42cf"
107 PV_dm355-leopard = "2009.05+2009.06-rc2+gitr${SRCREV}"
109 SRC_URI_neuros-osd2 = "git://github.com/neuros/u-boot.git;protocol=git;branch=neuros"
110 SRCREV_neuros-osd2 = "8de979d346624c0e4cfe2e5c0f08ce20ca4b5d14"
112 SRC_URI_sequoia = "git://www.denx.de/git/u-boot.git;protocol=git"
113 SRCREV_sequoa = "cf3b41e0c1111dbb865b6e34e9f3c3d3145a6093"
115 SRC_URI_sequoia = "git://www.denx.de/git/u-boot.git;protocol=git;tag=cf3b41e0c1111dbb865b6e34e9f3c3d3145a6093 "
117 SRC_URI_mini2440 = "git://repo.or.cz/u-boot-openmoko/mini2440.git;protocol=git;branch=dev-mini2440-stable"
118 SRCREV_mini2440 = "294b4782963f4b50074d2e8cf386b1bb9afd1c51"
120 SRC_URI_micro2440 = "git://repo.or.cz/u-boot-openmoko/mini2440.git;protocol=git;branch=dev-mini2440-stable"
121 SRCREV_micro2440 = "3516c35fb777ca959e5cadf2156a792ca10e1cff"
123 SRC_URI_neuros-osd2 += "file://Makefile-fix.patch;patch=1"
124 SRC_URI_append_akita = "file://pdaXrom-u-boot.patch;patch=1 \
125 file://uboot-eabi-fix-HACK2.patch;patch=1 \
126 file://akita-standard-partitioning.patch;patch=1 \
128 SRC_URI_append_spitz = "file://pdaXrom-u-boot.patch;patch=1 \
129 file://uboot-eabi-fix-HACK2.patch;patch=1 \
130 file://spitz-standard-partitioning.patch;patch=1 \
132 SRC_URI_append_c7x0 = "file://pdaXrom-u-boot.patch;patch=1 \
133 file://uboot-eabi-fix-HACK2.patch;patch=1 \
134 file://corgi-standard-partitioning.patch;patch=1 \
136 S = "${WORKDIR}/git"
139 do_configure_prepend_akita() {
140 sed -i s:ROOT_FLASH_SIZE:${ROOT_FLASH_SIZE}:g ${S}/include/configs/akita.h
143 do_configure_prepend_spitz() {
144 sed -i s:ROOT_FLASH_SIZE:${ROOT_FLASH_SIZE}:g ${S}/include/configs/akita.h
147 do_configure_prepend_c7x0() {
148 sed -i s:ROOT_FLASH_SIZE:${ROOT_FLASH_SIZE}:g ${S}/include/configs/corgi.h
151 do_deploy_prepend_mini2440() {
152 cp ${S}/u-boot-nand2k.bin ${S}/u-boot.bin
155 do_deploy_prepend_micro2440() {
156 cp ${S}/u-boot-nand16k.bin ${S}/u-boot.bin