nbd: Recipe for 2.9.11
[openembedded/mini2440.git] / recipes / subversion / subversion_1.4.5.bb
blobd4f290590fee19c24b4e70c2ec0e98001be23b81
1 DESCRIPTION = "The Subversion (svn) client"
2 SECTION = "console/network"
3 DEPENDS = "apr-util neon"
4 RDEPENDS = "neon"
5 LICENSE = "Apache BSD"
6 HOMEPAGE = "http://subversion.tigris.org"
8 PR = "r0"
10 SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
11 file://disable-revision-install.patch;patch=1 \
12 file://neon-detection.patch;patch=1"
14 EXTRA_OECONF = "--with-neon=${STAGING_EXECPREFIXDIR} \
15 --without-berkeley-db --without-apxs --without-apache \
16 --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
17 --with-apr-util=${STAGING_BINDIR_CROSS}"
20 inherit autotools
22 export LDFLAGS += " -L${STAGING_LIBDIR} "
24 acpaths = "-I build/ -I build/ac-macros/"
26 do_stage() {
27 autotools_stage_all