nbd: Recipe for 2.9.11
[openembedded/mini2440.git] / recipes / subversion / subversion_1.4.3.bb
blob4871674cc8bf731cec8875715f81d5fb3a920a55
1 DESCRIPTION = "The Subversion (svn) client"
2 SECTION = "console/network"
3 DEPENDS = "apr-util neon"
4 RDEPENDS = "neon"
5 LICENSE = "Apache BSD"
6 HOMEPAGE = "http://subversion.tigris.org"
8 PR = "r1"
10 SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
11 file://disable-revision-install.patch;patch=1 \
12 file://neon-detection.patch;patch=1"
14 EXTRA_OECONF = "--with-neon=${STAGING_EXECPREFIXDIR} \
15 --without-berkeley-db --without-apxs --without-apache \
16 --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
17 --with-apr-util=${STAGING_BINDIR_CROSS}"
20 inherit autotools
22 export LDFLAGS += " -L${STAGING_LIBDIR} "
24 do_configure() {
25 gnu-configize
26 libtoolize --force
27 aclocal -I build/ -I build/ac-macros/ && autoconf
28 oe_runconf
31 do_stage() {
32 autotools_stage_all