nbd: Recipe for 2.9.11
[openembedded/mini2440.git] / recipes / subversion / subversion_1.4.0.bb
blob305b13c6a48bebcf67970bd8069d6fe0e7355f7a
1 DESCRIPTION = "The Subversion (svn) client"
2 SECTION = "console/network"
3 DEPENDS = "apr-util neon"
4 RDEPENDS = "neon"
5 LICENSE = "Apache BSD"
6 HOMEPAGE = "http://subversion.tigris.org"
7 PR = "r1"
9 SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
10 file://disable-revision-install.patch;patch=1 \
11 file://neon-detection.patch;patch=1"
13 EXTRA_OECONF = "--with-neon=${STAGING_EXECPREFIXDIR} \
14 --without-berkeley-db --without-apxs --without-apache \
15 --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
16 --with-apr-util=${STAGING_BINDIR_CROSS}"
19 inherit autotools
21 export LDFLAGS += " -L${STAGING_LIBDIR} "
23 do_configure() {
24 gnu-configize
25 libtoolize --force
26 aclocal -I build/ -I build/ac-macros/ && autoconf
27 oe_runconf