nbd: Recipe for 2.9.11
[openembedded/mini2440.git] / recipes / perl / perl_5.8.4.bb
blob10a871c8dd12d507e78bac5d94c51226c0e94011
1 require perl.inc
3 PR = "r5"
5 SRC_URI += "file://uclibc.patch;patch=1 \
6 file://config.sh-mipsel-linux \
7 file://config.sh-i686-linux"
9 do_configure() {
10 ln -sf ${HOSTPERL} ${STAGING_BINDIR_NATIVE}/hostperl
11 cp ${HOSTPERL} hostperl
12 cd Cross
13 rm -f Makefile.SH.patch
14 cp ${WORKDIR}/Makefile.SH.patch .
15 cp ${WORKDIR}/config.sh-mipsel-linux .
16 cp ${WORKDIR}/config.sh-i686-linux .
17 cat config.sh-arm-linux | sed -e "s,arm-linux,armeb-linux,g" > config.sh-armeb-linux
18 for i in config.sh-*-linux; do
19 a="`echo $i|sed -e 's,^config.sh-,,; s,-linux$,,'`"
20 newfile="`echo $i|sed -e 's,-linux$,-linux-uclibc,g'`"
21 cat $i | sed -e "s,${a}-linux,${a}-linux-uclibc,g; \
22 s,d_sockatmark='define',d_sockatmark='undef',g;" > $newfile
23 done
24 sed -i -e 's,./install_me_here,${D},g' config.sh-${TARGET_ARCH}-${TARGET_OS}
25 rm -f config
26 echo "ARCH = ${TARGET_ARCH}" > config
27 echo "OS = ${TARGET_OS}" >> config
28 oe_runmake patch