nbd: Recipe for 2.9.11
[openembedded/mini2440.git] / recipes / perl / perl-native_5.8.7.bb
blobebb10e5580177efe644af320f083d498371cf8cf
1 DESCRIPTION = "Perl is a popular scripting language."
2 HOMEPAGE = "http://www.perl.org/"
3 LICENSE = "Artistic|GPL"
4 PR = "r5"
6 SECTION = "libs"
7 inherit native
9 DEPENDS = "virtual/db-native gdbm-native"
11 SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
12 file://perl-5.8.8-gcc-4.2.patch;patch=1 \
13 file://Configure-multilib.patch;patch=1"
14 S = "${WORKDIR}/perl-${PV}"
16 #perl is not parallel_make safe
17 PARALLEL_MAKE = ""
19 do_configure () {
20 ./Configure \
21 -Dcc="${CC}" \
22 -Dcflags="${CFLAGS}" \
23 -Dldflags="$LDFLAGS}" \
24 -Dusethreads \
25 -Duselargefiles \
26 -Dprefix=${prefix} \
27 -Dvendorprefix=${prefix} \
28 -Dsiteprefix=${prefix}/local \
29 -Dman1ext=1 \
30 -Dman3ext=3perl \
31 -Uafs \
32 -Ud_csh \
33 -Uusesfio \
34 -Uusenm -des
35 sed 's!${STAGING_DIR}/bin!${STAGING_BINDIR}!;
36 s!${STAGING_DIR}/lib!${STAGING_LIBDIR}!' < config.sh > config.sh.new
37 mv config.sh.new config.sh