nbd: Recipe for 2.9.11
[openembedded/mini2440.git] / recipes / perl / perl-native_5.8.4.bb
blob69555e0fac3ae8ebce8b2aafd961eb580b8b2628
1 DESCRIPTION = "Perl is a popular scripting language."
2 HOMEPAGE = "http://www.perl.org/"
3 LICENSE = "Artistic|GPL"
4 PR = "r3"
6 SECTION = "libs"
7 inherit native
9 DEPENDS = "virtual/db-native gdbm-native"
11 SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz"
12 S = "${WORKDIR}/perl-${PV}"
14 do_configure () {
15 ./Configure \
16 -Dcc="${CC}" \
17 -Dcflags="${CFLAGS}" \
18 -Dldflags="${LDFLAGS}" \
19 -Dusethreads \
20 -Duselargefiles \
21 -Dprefix=${prefix} \
22 -Dvendorprefix=${prefix} \
23 -Dsiteprefix=${prefix}/local \
24 -Dman1ext=1 \
25 -Dman3ext=3perl \
26 -Uafs \
27 -Ud_csh \
28 -Uusesfio \
29 -Uusenm -des
30 sed 's!${STAGING_DIR}/bin!${STAGING_BINDIR}!;
31 s!${STAGING_DIR}/lib!${STAGING_LIBDIR}!' < config.sh > config.sh.new
32 mv config.sh.new config.sh