nbd: Recipe for 2.9.11
[openembedded/mini2440.git] / recipes / perl / libhtml-mason-perl_1.35.bb
blob71e96005e8ebfe738c0864ce0e4d923c915cf8da
1 SECTION = "libs"
2 LICENSE = "Artistic|GPL"
3 DEPENDS = "libexception-class-perl-native libparams-validate-perl-native \
4 libcache-cache-perl-native libclass-container-perl-native"
5 RDEPENDS_${PN} = "libexception-class-perl libparams-validate-perl \
6 libcache-cache-perl libclass-container-perl perl-module-strict \
7 perl-module-warnings perl-module-file-basename perl-module-file-path \
8 perl-module-file-spec perl-module-file-spec-unix perl-module-file-temp \
9 perl-module-carp-heavy perl-module-io-handle perl-module-io \
10 perl-module-exporter-heavy perl-module-cwd perl-module-scalar-util \
11 perl-module-list-util perl-module-bytes perl-module-file-glob \
12 perl-module-data-dumper"
13 PR = "r1"
15 SRC_URI = "http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/HTML-Mason-${PV}.tar.gz"
17 S = "${WORKDIR}/HTML-Mason-${PV}"
19 inherit cpan_build
21 do_install_append () {
22 # Fix up paths to the perl interpreter
23 for i in ${D}${bindir}/*.pl; do
24 sed -i -e "s#${STAGING_BINDIR}/perl#${bindir}/perl#g" $i
25 done
27 # Install the html documentation and example files
28 install -m 0755 -d ${D}${docdir}/${PN}/html \
29 ${D}${docdir}/${PN}/examples/samples \
30 ${D}${docdir}/${PN}/examples/eg
31 cp -pRP ${S}/htdocs ${D}${docdir}/${PN}/html
32 cp -pRP ${S}/eg ${D}${docdir}/${PN}/examples/eg
33 cp -pRP ${S}/samples ${D}${docdir}/${PN}/examples/samples