nbd: Recipe for 2.9.11
[openembedded/mini2440.git] / recipes / dosfstools / dosfstools-native_2.10.bb
blob0aae86beb93206013fb296012d5d443983d8e49b
1 # dosfstools-native OE build file
2 # Copyright (C) 2004-2006, Advanced Micro Devices, Inc. All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
5 require dosfstools_${PV}.bb
6 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dosfstools-${PV}"
8 S="${WORKDIR}/dosfstools-${PV}"
10 PR ="r4"
12 SRC_URI = "ftp://ftp.uni-erlangen.de/pub/Linux/LOCAL/dosfstools/dosfstools-${PV}.src.tar.gz \
13 file://mkdosfs-bootcode.patch;patch=1 \
14 file://mkdosfs-dir.patch;patch=1 \
15 file://alignment_hack.patch;patch=1 \
16 file://dosfstools-2.10-kernel-2.6.patch;patch=1 \
17 file://msdos_fat12_undefined.patch;patch=1 \
18 file://dosfstools-msdos_fs-types.patch;patch=1 \
19 file://include-linux-types.patch;patch=1 \
20 file://2.6.20-syscall.patch;patch=1"
22 inherit native
24 do_stage() {
25 install -m 755 ${S}/mkdosfs/mkdosfs ${STAGING_BINDIR}/mkdosfs
26 install -m 755 ${S}/dosfsck/dosfsck ${STAGING_BINDIR}/dosfsck