tinc: Added git repository backport from -dev
[openembedded/mini2440.git] / recipes / lockstat / lockstat_1.4.10.bb
blobef7254eab387c2150bdbb4aed540b11fd8321e57
1 SECTION = "console/utils"
2 DESCRIPTION = "A tool for retrieving kernel spinlock metering information."
3 DEPENDS = "virtual/kernel"
5 SRC_URI = "ftp://oss.sgi.com/projects/lockmeter/download/lockstat-${PV}.tar.gz"
6 S = "${WORKDIR}/lockstat"
8 export KERNEL_VERSION = "${@base_read_file('${STAGING_KERNEL_DIR}/kernel-abiversion')}"
9 export KERNEL_SOURCE = "${@base_read_file('${STAGING_KERNEL_DIR}/kernel-source')}"
10 CFLAGS += " -I${KERNEL_SOURCE}/include"
12 python () {
13 # NOTE: any target machines with kernels supporting spinlock metering should
14 # check the MACHINE variable here to prevent the SkipPackage.
15 raise bb.parse.SkipPackage("The target machine's kernel does not appear able to use spinlock metering.")
18 do_compile () {
19 oe_runmake
22 do_install () {
23 install -d ${D}${sbindir}
24 install -m 0755 lockstat ${D}${sbindir}/