libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / xorg-xserver / xserver-xorg_1.7.4.bb
blob34247848055c2c023e8b53376e926115b0383151
1 require xorg-xserver-common.inc
3 DESCRIPTION = "the X.Org X server"
4 DEPENDS += "pixman libpciaccess openssl dri2proto glproto xorg-minimal-fonts"
5 PE = "2"
6 PR = "${INC_PR}.1"
8 SRC_URI += "file://sysroot_fix.patch;patch=1 \
9 file://dolt-fix-1.7.0.patch;patch=1 \
10 file://randr-support-1.7.0.patch;patch=1 \
11 file://hack-fbdev-ignore-return-mode.patch;patch=1 \
14 SRC_URI_append_angstrom = " file://hack-assume-pixman-supports-overlapped-blt.patch;patch=1"
15 SRC_URI_append_shr = " file://hack-assume-pixman-supports-overlapped-blt.patch;patch=1"
17 do_install_prepend() {
18 mkdir -p ${D}/${libdir}/X11/fonts
21 # The NVidia driver requires Xinerama support in the X server. Ion uses it.
22 PACKAGE_ARCH_ion = "${MACHINE_ARCH}"
23 XINERAMA = "${@['--disable-xinerama','--enable-xinerama'][bb.data.getVar('MACHINE',d) in ['ion']]}"
25 EXTRA_OECONF += " ${CONFIG_MANAGER_OPTION} ${XINERAMA} --disable-kdrive --disable-xephyr --disable-xsdl --disable-xfake --disable-xfbdev --disable-dmx"
26 EXTRA_OECONF += " --disable-glx-tls --enable-dri2 --disable-unit-tests "
28 export LDFLAGS += " -ldl "
30 SRC_URI[archive.md5sum] = "75d27c3a1c12293f620a2d6518fcbdfa"
31 SRC_URI[archive.sha256sum] = "b8ec11b3f2c6f84c21e8cd9804672ba6e27fda3e913d58dd947205ea253e33f8"